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Introduction

Using AViCAD® is part of an integrated documentation set that includes this manual 
and a comprehensive collection of help resources to give you the information you 
need to create drawings in AViCAD.

This manual is organized into chapters that parallel how you work in AViCAD, 
according to the tasks you might perform; also as it refer to all AViCAD's versions, 
some of the features are available only in the full version.

Specific release's features are available on www.AViCAD.com.

Topics in this chapter

About AViCAD and other CAD software ............................................................... 3

Using AutoCAD commands with AViCAD ...................................................... 5

Comparing AViCAD and CAD to manual drafting .......................................... 5

Using advanced CAD features............................................................................ 13

Getting more information .................................................................................... 14
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Introduction: Chapter 1  An overview of the key features of AViCAD plus basic con-
cepts of computer-aided design (CAD) as they apply to AViCAD.

Getting started: Chapter 2  Installing AViCAD, starting and exiting AViCAD, working 
with toolbars, and selecting commands. 

Working with drawings: Chapter 3  Opening an existing drawing and starting a new 
drawing. Using Drawing Settings to establish paper size, scale factors, and text 
height. Working with colors in your drawings. Using drawing aids such as entity 
snaps and orthogonal mode to draw accurately.

Creating entities: Chapters 4–5  Working with simple entities such as lines, circles, and 
arcs and with complex entities such as polygons, spline curves, planes, wipeouts, 
boundary hatches, and more.

Viewing your drawing: Chapter 6  Moving around in the drawing, changing its magnifi-
cation, creating multiple views, and saving arrangements of windows of the drawing.

Working with coordinates: Chapter 7  Working with Cartesian coordinate systems, 
specifying two-dimensional and three-dimensional coordinates, and defining your 
own user coordinate systems.

Working with the AViCAD Explorer: Chapter 8  Using the AViCAD Explorer to manage 
your drawings: controlling layers, linetypes, text styles, coordinate systems, views, 
and blocks and copying information between drawings.

Getting drawing information: Chapter 9  Working with the additional information in 
AViCAD drawings, calculating areas and distances, and displaying other drawing 
information.

Modifying entities: Chapter 10  Selecting, copying, rearranging, resizing, and editing 
entities.

Annotating and dimensioning your drawing: Chapters 11–12  Using text to annotate 
drawings; using dimensions to annotate the measurement of entities.

Working with blocks, attributes, and external references: Chapter 13  Using blocks and 
external references to combine entities and data for reuse; creating attribute informa-
tion to extract for use in other programs.

Printing drawings: Chapter 14  Combining drawings into finished layouts and printing 
copies.

Drawing in three dimensions: Chapter 15  Creating and editing three-dimensional enti-
ties. Also visualizing them using hidden line removal, shading, and photo-realistic 
rendering.

Render: Chapter 16  Creating a photo-realistic image of your model, complete with 
light sources, shadows, surface material properties, and reflections.

Google Earth: Chapter 17  You can import the current Google Earth view into 
AViCAD and use this raster image as a background for a drawing or to give a geo-
graphical reference of your DWG model position on the earth’s surface. 
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Working with other programs: Chapter 18  Sharing drawings and data with other users, 
documents, and programs.

Image: Chapter 19  Modifying and viewing raster images.

Customizing AViCAD: Chapter 20  Customizing the appearance and operation of the 
program to suit your needs.

Understanding AutoCAD compatibility: Appendix  Describes similarities and differences 
between AViCAD and AutoCAD.

About AViCAD and other CAD software

AViCAD is designed for anyone who wants a fast and efficient CAD program with 
all the power and versatility of standard programs such as AutoCAD by Autodesk, 
Inc., or MicroStation by Bentley Systems, Inc., at an affordable price. Using today’s 
advanced technology, AViCAD integrates the Microsoft Windows interface with a 
powerful CAD engine. 

AViCAD provides unparalleled compatibility with AutoCAD, using most of the 
same file formats including those for drawings (.dwg files), commands, linetypes, 
hatch patterns, and text styles. You can also use AutoCAD menu files and run 
AutoLISP by Autodesk programs. If you have written your own ADS (AutoCAD 
Development System by Autodesk) programs, simply recompile them to link with the 
AViCAD libraries provided on your compact disc. Many third-party ADS programs 
already support AViCAD. If you have a program that is not already supported, ask 
your software vendor to provide an AViCAD-compatible version of the program.

AViCAD is more compatible with the AutoCAD program than any other CAD prod-
uct, delivers additional tools with advanced CAD features, and has a seamless 
Microsoft Windows integration. This powerful program provides a superb combina-
tion of features for CAD users like architects, engineers, and designers.

AViCAD incorporates all the standard features found in other CAD programs, along 
with features and capabilities you won’t find anywhere else. Its multiple-document 
interface (MDI) lets you open and work with several drawings at the same time. You 
can easily copy drawing entities between drawings. In addition, the powerful 
AViCAD Explorer lets you manage information and settings and quickly copy layers, 
linetypes, and other information between drawings.

Using AutoCAD legacy drawings
AViCAD fully supports AutoCAD legacy drawings. AViCAD reads and writes 
DWG files in their native format without any loss of data, from AutoCAD 11 to the 
last versions of AutoCAD, including AutoCAD LT®. Because AViCAD uses DWG 
as its native file format, no translation is required. 
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AViCAD provides you with the appropriate tools for your experience level—whether 
you are a beginner, intermediate, or advanced CAD user. If you are just starting out 
with CAD, you may want to use the beginner level, which provides toolbars contain-
ing the basic tools such as lines, arcs, and circles. As you become more experienced, 
you can move to the intermediate level and then to the advanced level, which gives 
you access to more than 300 commands through toolbars, menus, and keyboard 
entries. When you install the program, the default setting is the advanced level; you 
can change it from the Options dialog box on the Tools menu.

AViCAD supports three-dimensional wireframes with surfaces and solids entities. 
Three-dimensional drawings can be displayed in wireframe, hidden-line view, and 
surface shading and rendering. Full version of AViCAD also support creating and 
editing 3D ACIS solids; all versions display 3D solids, along with limited editing fea-
tures.

Full version of AViCAD support displaying and working with raster images in your 
drawings. However, AViCAD does not display images located inside of blocks and 
externally referenced drawings (xrefs). 

When you open a drawing containing proxy entities will be shown a dialog box with 
a warning message. 
Moreover you can choose:

•   View the proxy entities without editing them

•   Convert them in blocks

•   Convert only the proxy entities text
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It’s easy to customize AViCAD. You can modify menus and toolbars, create custom 
menus, dialog boxes, command aliases, and scripts, and add custom programs written 
in any of several programming languages, including LISP (the program’s Autodesk 
AutoLISP-compatible language), SDS™ (Solutions Development System™, the pro-
gram’s Autodesk ADS-compatible language), and Microsoft Visual Basic for Appli-
cations (VBA).

You can run existing Autodesk AutoLISP applications in AViCAD with little or no 
modification. AViCAD uses the appload command so you can easily load LISP pro-
grams. AViCAD reads files that contain dialog control language (DCL) statements as 
well, which makes AViCAD compatible with dialog boxes created for AutoCAD.

Using AutoCAD commands with AViCAD

Because AViCAD supports hundreds of AutoCAD commands, you use the com-
mands you already know. For example, to draw a circle, use the circle command. To 
copy a circle, use the copy command.

When you press Enter or the spacebar, you activate the command—just like in 
AutoCAD. AViCAD accepts the special characters used by AutoCAD, such as point 
filters (for example, .xy), relative coordinates (the @ symbol), and the apostrophe 
(the ‘ prefix) for transparent commands. AViCAD function keys are also similar to 
those used in AutoCAD. 

Because you do not need to learn a new set of commands, you are immediately pro-
ductive with AViCAD. 

Comparing AViCAD and CAD to manual drafting

AViCAD greatly reduces the time and effort it takes to create and revise drawings. 
Not only can you produce accurate drawings faster, you can also reuse the informa-
tion in your drawings. These are the primary reasons for making the transition to 
CAD from traditional, manual drafting on paper.

As with any tool, however, to use it effectively, you need to be familiar with some of 
the special features, functions, and concepts of CAD. If you are familiar with manual 
drafting, you’ll find some conceptual similarities in CAD as well as some differences.
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Drawing to scale
In traditional, manual drafting, you usually determine the scale of the drawing before 
you even start to draw, because you are working with a sheet of paper of a fixed size. 
You may have to reduce or enlarge the entity you are drawing to fit within the con-
fines of the paper.

When you create a drawing in AViCAD, you draw everything full-size. You deter-
mine the type of units in which your drawing is measured. If you are drawing a build-
ing, 1 drawing unit might equal 1 inch. If you are drawing a map, 1 drawing unit 
might equal 1 mile. Your drawing environment and the CAD drawing file itself are 
not limited to the size of a particular sheet of paper.  

As you draw, you can use commands such as Pan and Zoom to work on different por-
tions of the drawing and to magnify the display of the drawing to view small details. 
These commands have no effect on the actual size of the entities in your drawing; 
they affect only the way the drawing is displayed on your screen. Only when you 
print or plot your drawing do you need to set the scale so that the printed drawing fits 
within a specific paper size.

Using tools
In manual drafting, you use tools such as pencils, rulers, T-squares, templates, eras-
ers, and so on. When you create a drawing in AViCAD, you use a mouse instead of a 
pencil, and you use the mouse to select other tools—commands you select from a 
menu or a toolbar.

You use some tools to create basic entities, such as lines, circles, and arcs, and other 
tools to modify existing entities (for example, to copy or move them or to change 
properties such as color and linetype).

1 drawing unit equals 1 inch. 1 drawing unit equals 1 foot.
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Organizing information
In traditional drafting, you often separate elements such as walls, dimensions, struc-
tural steel members, and electrical plans onto separate, translucent overlays. When 
you want to print the working drawings, you can create several different drawings by 
combining different overlays.

When you create a drawing in AViCAD, you use layers to organize elements in a 
similar manner. However, the layers feature in CAD offers numerous advantages 
over physical transparencies. The number of overlays you can combine to print a 
manually drafted drawing is limited by the printing process. There is no such limita-
tion in CAD. With AViCAD, you can define an unlimited number of layers, any of 
which can be visible or invisible at any time. You can name each layer and assign 
each its own color and linetype. You can also lock individual layers to ensure that 
information on those layers isn’t altered accidentally.  

Use layers to organize drawing information.
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Drawing accurately
When you create a manual drawing, ensuring accuracy typically requires a lot of 
measuring and rechecking. By contrast, AViCAD offers a number of drawing aids 
that ensure accuracy from the start. For example, you create and modify entities 
based on an underlying Cartesian coordinate system. Every location in the drawing 
has its own x,y,z-coordinates. You can also display a grid as a visual reference to 
your coordinate system.      

Settings such as snap and entity snap allow you to draw accurately without specifying 
coordinates. The snap setting forces the selected points to adhere to the grid incre-
ment or to any other increment you set. Entity snaps let you snap to precise geometric 
points on existing entities—for example, the endpoint of a line or the center of a cir-
cle. Another setting, orthogonal, constrains lines so that they are drawn parallel to the 
vertical and horizontal axes. 

Every location in the drawing has its own x,y,z-coordinates within the underlying Cartesian coordinate 
system. Point 5,2,0 is 5 units to the right (along the x-axis), 2 units up (along the y-axis), and 0 units (along 
the z-axis) from the origin (the 0,0,0 point).
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Drawing efficiently
In paper-based, manual drafting, you often have to redraw the same entity several 
times at different scales or from different vantage points. You may also need to 
redraw the border and title block on each new sheet.

One of the most powerful features of AViCAD is that when you create a drawing, 
you can reuse individual entities, borders, and title blocks as often as you want. You 
need draw an entity only once; the final printed drawing can show the entity at sev-
eral different scales and viewpoints.

AViCAD provides two drawing environments, or workspaces: model space and 
paper space. You usually begin working in model space, creating the drawing (a floor 
plan, a map, or a three-dimensional part) without regard to the final layout on paper. 
When you are ready to print your drawing, you have the option to switch to paper 
space, where you lay out the drawing as you want it to appear on a sheet of paper. For 
example, you can insert a drawing file that contains the standard border and title 
block that you created. You can define and arrange multiple views of the drawing at 
appropriate scales and with specific portions visible or invisible—again, without hav-
ing to redraw the border and title block for each view. 

Paper-based drawings lack the high degree of accuracy possible when using CAD. Lines often overlap or fail 
to meet adjacent lines.

Snap and entity snap force the cursor to adhere to a specified increment or attach to key geometric points on 
existing entities. You can also constrain lines to vertical and horizontal axes.
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You create the basic drawing in model space.

When you’re ready to print or plot your drawing, you can switch to paper space, where you 
arrange the drawing as you want it to appear on a sheet of paper.
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Reusing CAD drawings and entities
When you create a paper drawing manually, you can draw repetitive symbols by trac-
ing a plastic template. After you draw a symbol in AViCAD, you can reuse that sym-
bol without having to redraw it. You simply save the symbol as a block. You can then 
insert copies of that block anywhere in your drawing. You can also save the symbol 
as a separate drawing for use in other drawings.  

In addition, you can reuse entire drawings and insert individual drawings into other 
drawings. You can also use an external reference, which acts as a pointer to another 
drawing rather than a copy of the entire drawing. Using an external reference has an 
added advantage: when you update the externally referenced drawing, each drawing 
that references it can be automatically updated.

Making changes
To make changes to a paper drawing, you erase and then redraw. With AViCAD, you 
use commands to modify entities in the drawing. You can move, rotate, stretch, or 
change the scale of entities. When you want to remove an entity, you can delete it 
with a single click of the mouse. If you make a mistake while creating or modifying 
your drawing, you can easily reverse your actions.

You can draw a symbol one time, save it as a block, and then insert multiple copies of that symbol anywhere 
in your drawing.
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Working with other data and programs
Traditional paper drawings serve only as a means of communicating information 
between the person who created the drawing and the person viewing the drawing. The 
drawings contain no more information than what is visually imparted by the creator 
and seen by the viewer.

AViCAD offers rich possibilities for analyzing drawings and attaching additional 
data to them. For instance, although it may be impractical to count entities in a com-
plex paper drawing, this task is simple in CAD. AViCAD can calculate the number of 
entities in a drawing and compute area and distance.

CAD drawings can also contain information in addition to visible entities. You can 
attach invisible database information to visible drawing entities and extract the infor-
mation for analysis in a database or spreadsheet. (Working with information in a data-
base requires a program from a third-party vendor, or you can create your own means 
of exporting the data in LISP, SDS, or VBA.)

You can easily change an entity using commands such as move, rotate, stretch, and scale 
instead of redrawing the entity.
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AViCAD provides in-place editing of Microsoft objects, such as those created in 
Microsoft Word and Microsoft Excel software programs. In-place editing makes it 
easy to share data with other users and programs. For example, you can include 
AViCAD drawings in files created using Microsoft Word, and you can insert files 
created using Microsoft Word into your AViCAD drawings.

Using advanced CAD features

In addition to being compatible with AutoCAD, AViCAD goes several steps further 
by providing you with innovative features to increase your productivity.

You can extract information stored in the drawing as 
visible or invisible attributes…

…and use that data for analysis in a database or 
spreadsheet.
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Using the AViCAD Explorer
The AViCAD Explorer has an interface similar to the Windows Explorer, allowing 
you to view and manage the elements of multiple, open drawings, such as layers, 
blocks, linetypes, views, user coordinate systems, and text styles. 

Editing multiple documents simultaneously
With AViCAD, you can open and edit multiple drawings simultaneously. You can 
also copy and paste elements between open drawings. 

Editing multiple entities
AViCAD allows you to change most of the properties of all selected entities using a 
single, tabbed dialog box. 

Using the Customize dialog box
AViCAD has a single, tabbed dialog box for changing toolbars, menus, keyboard 
shortcuts, and command aliases. You can also use the drag-and-drop method to cus-
tomize toolbars, including flyouts. The simple, point-and-click action lets you easily 
create new menu items and keyboard shortcuts—no programming or manual text 
editing required.

Performing unlimited undo and redo
AViCAD increases your power with unlimited undo and redo of editing actions.

Getting more information

In addition to this user’s guide, much of the assistance you need as you use AViCAD 
is specific to the commands you work with on the screen. To obtain immediate infor-
mation as you work, use these additional sources of information:

ToolTips To find out what a specific tool on a toolbar does, pause the cursor over it for 
a moment. A ToolTip appears on the screen.

Status bar To find out more detailed information about a tool when you pause the cur-
sor over it, look on the status bar at the bottom of the screen.

Online help AViCAD online help is available on the screen when you press F1, 
choose a command from the Help menu, or click the question mark in a dialog box. 
The online help also presents information that does not appear in this manual, includ-
ing a programming reference that describes how to program in LISP, SDS and DIE-
SEL. The programming reference also describes programming in VBA

AViCAD web site: www.AViCAD.com.
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Getting started

This chapter helps you get started using AViCAD® software by explaining how to 
install it and providing basic information about how to use it.

NOTE This user’s guide assumes that you have used other Microsoft Windows-
based programs and are familiar with Windows terminology and techniques.
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System requirements

You need the following software and hardware to install and run AViCAD: 

• Microsoft® Windows 7, Windows Vista®, Windows XP Professional, Windows 
XP Professional x64 Edition, Windows XP Home Edition.

• Intel Pentium (or faster) processor recommended (single or dual processor)

• 1 gigabyte (GB) of RAM minimum for Windows Vista or later, 512 megabytes 
(MB) of RAM minimum for Windows XP.

• 1.5 GB of free hard disk space recommended; 300 MB is required for a full instal-
lation, including sample files, electronic documentation, and online Help

• Super VGA (800 x 600) or higher resolution, video adapter, and monitor

• Keyboard and mouse, or other pointing device

• CD-ROM or DVD drive for installation, if installing from a CD or DVD

ATTENTION The requirements above specified are meant to be the minimum needed.  
A proper management of all kind of drawings processed it’s not guarantee anyway. 
In relation to the type of works that are dealt with, it could be necessary to update the 
system upgrading Ram and processor.

Starting AViCAD

To start AViCAD, double click on the icon created by the installation of the operative 
system on the desktop or on the drawing file to be opened.

Each time you start AViCAD, a Tip of the Day appears on your screen. To display 
the Tip of the Day dialog box at any time, choose Help > Tip of the Day. To prevent 
the Tip of the Day dialog box from being displayed, click the check box for Show 
Tips On StartUp to clear it.

Working in AViCAD

You can work with the AViCAD window and its elements in a variety of ways. For 
example, you can display and rearrange the toolbars, display the command bar, and 
enable the status bar. The toolbars and command bar can also be floated anywhere on 
the screen or docked to the edges of the main AViCAD window.  
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A You can customize the menu bar at the top of the window.

B You can customize the toolbars, changing the appearance and 
arrangement of tools and adding your own commands and macros.

C Your drawings are displayed in the drawing window.

D The user coordinate system (UCS) icon indicates the orientation of the 
drawing in three-dimensional space. 

E Click a tab to switch between the drawing of your model and a printed 
layout.

F You can type commands in the command bar. To reposition the 
command bar, drag it to another location on your screen.

G The status bar displays information such as the name or purpose 
of a tool, the current cursor coordinates, layer name, and mode 
settings.

H You can move and dock the toolbars to any location on your 
screen. 

C

D

E

H

G

A

B

F
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Displaying commands on a shortcut menu
Right clicking the mouse in the graphical area opens the right click context menu. 
The default options settings enable the context menu on the right button click both 
when entities are selected and when no entity is selected. You can disable these 
options and use the right button of the mouse only as Enter.

To disable the right button menu

1 Do one of the following:

• Select Tools > Options.

• Type options and press Enter

2 In the tab General activate/deactivate Enable Context menu on Right click when 
an entity is selected  and Enable Context menu on Right click with no entities 
selected.

3 Confirm with the OK button.

 

Right click menus are context dependent  and their relative options vary when an 
entity is selected or when no entity is selected  and in terms of the type of object is 
selected. 
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In general right click menus include different options to perform operations listed 
below: 

• Repeat last command

• Cancel current command 

• Cut, copy and paste from Notepad 

• Select a different option of the command 

• Display a dialog box, such as Options or Customize 

• Cancel last command

In case no object is selected, most common operations are displayed in the right click 
menu.  

When objects are selected, for example some dimension, options relative to the 
selected object will appear in the right click menu.
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Displaying and hiding toolbars
When you start AViCAD the first time, the Standard, Draw, Modify, Draw Order, 
Style and Entity Properties toolbars are displayed. AViCAD provides about a dozen 
toolbars, which you can customize by adding and deleting tools. You can also move 
and resize toolbars, and you can create new toolbars. You can use a shortcut menu to 
display or hide toolbars. 

You can also choose whether toolbars are displayed large or small and in color. You 
can choose to display or hide ToolTips, which provide descriptions of tools that dis-
play when you pause the cursor over them. Go to Tools > Customize > Toolbar to 
make these selections.

Toolbars are either docked or floating. A floating toolbar has a title bar and a Close 
box, can be located anywhere on the screen, and can be resized. A docked toolbar 
does not display a title or Close box, cannot be resized, and is attached along one of 
the edges of the drawing window.

• To dock a toolbar, drag it to the perimeter of your drawing; to undock it, drag it 
away from the perimeter.

• To position a toolbar in a docking area without docking it, press Ctrl while you 
drag it.

• To move a toolbar, drag it to a new location.
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• To resize a toolbar, move your cursor to the edge until it changes to a resize arrow, 
and then drag.

To choose which toolbars to display

1 Do one of the following:

• Choose View > Toolbars.

• Right-click anywhere on a docked toolbar to display the toolbar shortcut menu.

2 Select the toolbars you want displayed.

3 If the toolbar does not appear in the shortcut menu, choose Toolbars.

4 In the Select Toolbars dialog box, choose the toolbars you want displayed, and 
then click OK.

Using the command bar
The command bar is a dockable window in which you type AViCAD commands and 
view prompts and other program messages. To display the command bar, choose 
View > Display > Command Bar. When initially displayed, the command bar is 
docked between the toolbars and the drawing. It displays the three most recent lines 
of prompts. You can move the command bar by dragging it.

When the command bar is floating, you can drag the top or bottom of the window to 
change the number of lines of text it displays. You can dock the command bar at the 
top or bottom of the drawing. 

Select the check boxes for the toolbars you want to display.
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Using the status bar
If you elect not to use the command bar, the status bar displays information about the 
selected command or tool. It also displays the current cursor coordinates, the name of 
the current layer, mode settings, and other information about current settings.          

To change the items that display on the status bar

1 Right-click an empty area of the status bar.

2 Select an item to add or remove it.

To change the setting of an item on the status bar

1 Do one of the following:

• Click the status bar item.

• Right-click the status bar item you want to change, and then select the desired 
setting.

To display or hide the status bar

1 Do one of the following:

• Choose View > Display >  Status Bar.

• Type statbar, press Enter and then choose on or off mode.

Drawing tabs
 When you have several AViCAD drawings open at a time, you can quickly pass 
from one file to another clicking on the tab references placed right above the drawing 
area. 

A Information about the current command.

B Cursor coordinates (x,y,z).

C Layer name. Click to change layers.

D Drawing color. Click to change colors.

E Linetype. By default, the linetype is BYLAYER. 
Click to change linetypes.

F Lineweight. By default, the lineweight is 
BYLAYER. Click to change lineweights.

G Text style. Click to change text styles.

H Dimension style. Click to change dimension 
styles.

I Print style. Click to change print styles. (Available 
only for drawings that use named print style 
tables.)

J Snap setting. Click to toggle on or off.

K Grid setting. Click to toggle on or off.

L Orthogonal setting. Click to toggle on or off.

M Entity snap setting. Click to select entity snaps. 

N Lineweight display. Click to toggle on or off.

O Model space or paper space. Click to toggle 
between model space and paper space. 

P Digitizer mode. Click to toggle on or off.

Q Etrack mode. Click to toggle on or off.

R Polar mode. Click to toggle on or off.

A B C D E F G H I J K L M N O P Q R



G E T T I N G  S T A R T E D    23

If you right click the tabs, a context menu will appear where you can choose options 
relative to the window, these options can also be found in the corresponding menu 
Window. 

 

Drawing tabs also allow you to speed up commands performance from one file to 
another, for example to copy objects from Drawing 1 to Drawing 2. 
Choose the Copy command in Drawing 1 and select the objects you want to copy and 
indicate the base point. When you are asked for a displacement point, click on the tab 
of Drawing 2 and indicate the points for the objects copies.

To activate or deactivate drawing tabs display

1 Do one of the following:

• Choose View > Display > Drawing Tab 

• Right click one of the docked bars to display the context toolbar menu and 
choose Drawing Tabs.
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Using prompt boxes
AViCAD commands often provide several options. These options appear in the status 
bar or command bar and also in a prompt box (called a context menu in Autodesk 
AutoCAD) initially displayed in the upper right corner of the screen. You can move 
the prompt box by dragging it; future prompt boxes will appear where you last placed 
it. The options appear as menu selections. Choose the appropriate option by selecting 
it in the prompt box. To close a prompt box, click the Close box.   

The prompt box isn’t displayed by default. To turn on the display of prompt boxes, 
choose Tools > Options, click the Display tab, and then click the Display Prompt 
Boxes check box.

   Command options appear in a prompt box.
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 Selecting commands

Select commands using any of these methods:

• Choose a command from a menu.

• Click a tool in a toolbar.

• Type the command in the command bar.

Some commands remain active until you end them, so you can repeat an action with-
out having to select a command repeatedly. You can end a command by clicking 
Done in the prompt box or by pressing Esc.

The AViCAD user interface..
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Using commands
You can use most commands while another command is active. For example, while 
drawing a line, you may want to use the Pan command to move the drawing across 
the screen to select the endpoint of the line. You can also change the settings of draw-
ing aids such as snap or grid while other commands are active.

Starting commands using toolbars
To start a command from a toolbar, click a tool and respond to the prompts. 

NOTE The available toolbars depend on the experience level that is set. To change 
the current experience level, choose Tools > Options, and then click the General tab.

Some tools, such as Line or Arc, contain flyouts, which are options either for using 
the basic tool with different methods or that contain other, related tools. Flyouts are 
indicated by a small triangle in the lower right corner of a tool. To display a flyout, 
click the tool and hold down the mouse button. To select a tool from a flyout, point to 
the tool you want and then release the mouse button. The tool you select on the flyout 
becomes the default tool on the toolbar.

Starting commands using menus
To start a command from a menu, choose it from the list of menu options available.

The available menu options depend on the experience level that is set. The advanced 
experience level is the default. Menu selections shown in this guide are based on the 
advanced experience level unless otherwise noted. To change the current experience 
level, choose Tools > Options, and then click the General tab.

Starting commands using the command bar
Type a command, and then press Enter. If the command bar is displayed, the com-
mand you typed appears there. If the command bar is not displayed, the command 
you typed appears in the status bar.

TIP Quickly start commands using the command bar by copying, cutting, and past-
ing text. In the command bar or Prompt History window, right-click to select various 
cut,copy, and paste commands.

Repeating a command
You can repeat a command you used previously without having to reselect it.
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To repeat the command you just used

1 Do one of the following:

• Press the spacebar.

• Press Enter.

• Click the right mouse button in the drawing and choose Repeat last command.

To repeat commands you used previously

1 Do one of the following:

• In the command bar or Prompt History window, right-click, choose Recent 
Commands, and then choose the desired command.

• Press Ctrl + K, repeat until you get back to the desired command, and then press 
Enter. Press Ctrl + L to move forward to the desired command, and then press 
Enter.

• Use the Up and Down arrows to display previously used commands, if Use Up/
Down Arrows for Command History Navigation is selected in Tools > Options 
Display tab.

NOTE If you are using the command bar to type commands, you can type multiple 
before starting some commands (Circle, Arc, and Rectangle, for example) to repeat a 
command indefinitely. When you are done with a command, press Esc.

Nesting a command
If you are working in the command bar, you can use another command from within a 
command, called nesting. To use a command inside an active command, type an 
apostrophe before you type the command, such as ‘zoom . You can nest commands 
indefinitely in AViCAD. Many menu and toolbar macros work this way by default; 
for example, select color, reference grid, zoom, and snap. When you have finished 
with the nested command, the original command resumes. 

Modifying a command
If you are working in the command bar, there are special ways that you can modify a 
command as you work. You can modify the active command using any of the follow-
ing options:

• Entity snaps — Type an entity snap command, such as nearest or midpoint, to 
enable a one-time entity snap for a single selection. You can also use a one-time 
entity snap to override a running entity snap.

• Extension snaps — Type int after selecting a command, such as Line or Circle, to 
enable a one-time snap to the logical location where two entities would intersect if 
they were of infinite length. Type app to enable a similar one-time snap if the 
extensions would not intersect in three-dimensional space but would intersect in 
the current view.



28   C H A P T E R  2

• Midpoint snaps — Type m2p or mtp to enable a one-time snap to the midpoint of 
two points that you specify.

Using the Prompt History window
The Prompt History window displays a history of the commands and prompts issued 
since you started the current session of AViCAD. By default, the program tracks up 
to 256 command lines. There is no limit to the number of command lines you can 
track, but program performance may be degraded if you choose to track an exces-
sively high number of lines.

To display or close the Prompt History window 

• Press F2. 

To view entries in the Prompt History window 

1 Do one of the following:

• Use the scroll bars.

• Press Ctrl + K to browse backward; press Ctrl + L to browse forward.

• Use the Up and Down arrows to display previously used commands, if Use Up/
Down Arrows for Command History Navigation is selected in Tools > Options 
Display tab.

To copy or paste text in the Prompt History window 

1 If copying text, do one of the following: 

• Highlight text using your mouse.

• Press Ctrl + Shift + arrow keys to highlight text.

2 Right-click and choose whether to copy or paste.

TIP You can also copy the entire command history by choosing Copy History or 
copy the last command line by choosing Copy Last Line.

To change the number of command lines to track

1 Do one of the following:

• Choose Tools > Options, and then click the Display tab.

• Type options and then press Enter. Click the Display tab.

2 In the Command Lines To Track field, type the number of command lines you 
want to display, and then click OK.
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Using mouse shortcuts
You can use your mouse, often combined with the keyboard, to start commands and 
perform other actions.  

Using scripts
The AViCAD Script Recorder captures and saves many of your actions so you can 
play them back. After you enable the Script Recorder, all commands and options that 
you type in the command bar are recorded until you type a command to stop 
recording. When you run the script, the program carries out the recorded commands 
in succession.

Correcting mistakes

AViCAD tracks the commands you use and the changes you make. If you change 
your mind or make a mistake, you can undo, or reverse, the last action or several pre-
vious actions. You can also redo any actions that you reversed.  

Mouse shortcuts

Shortcut Action

Ctrl + Shift + Hold and drag left mouse button Real-Time Zoom command

Ctrl + Shift + Hold and drag right mouse button Real-Time Pan command

Ctrl + Hold and drag left mouse button Real-Time Sphere command

Ctrl + Hold and drag right mouse button Real-Time Z command

Shift + Left-click mouse Deselect entities

Shift + Right-click mouse Entity snap shortcut menu

Hold and drag left mouse button Move selected entities

Ctrl + Hold and drag left mouse button Copy and move selected entities

Right-click mouse Display shortcut menu for the selected entity

Rotate mouse wheel Zoom In and Zoom Out commands

Hold mouse wheel, and then move mouse Pan command

A Click the Undo tool to reverse the last action.

B Click the Redo tool to reverse the previous undos.

A B
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You can undo multiple actions by typing undo and specifying the number of actions 
to undo. 

Customizing AViCAD

You can tailor many aspects of AViCAD to better suit your needs. For example, you 
can easily create and modify toolbars by simply dragging and dropping icons. 
AViCAD stores your customized settings in the Windows registry rather than in a 
separate file.

AViCAD supports the most important AutoCAD customization files, including 
linetypes, hatch patterns, text fonts, the unit conversion file, menus, toolbars, and 
aliases. In addition, AViCAD unifies four AutoCAD customization functions with a 
single customize command: command aliases, keyboard shortcuts, menus, and 
toolbars.

You can also add custom programs written in any of several programming languages, 
including the following:

• LISP (the program’s Autodesk AutoLISP-compatible language)

• SDS (the program’s Autodesk ADS-compatible language)

• DIESEL

• VBA (Microsoft Visual Basic for Applications) 

Getting online Help

AViCAD includes online Help. It contains some information that does not appear in 
this book, including a programming language reference.

You can display online Help in any of these ways:

• On the Standard toolbar, click Help ( ).

• Press F1.

• Choose a command from the Help menu.

• Click the question mark in a dialog box.

• Type help in the command bar.
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Saving your drawing

You can save your drawing at any time.

To save a drawing, use one of the following methods:

• On the Standard toolbar, click Save ( ).

• Choose File > Save.

• Type save and then press Enter.

NOTE When you save a drawing the first time, the program displays the Save Draw-
ing As dialog box so that you can choose a directory and type a name for the draw-
ing. To save the drawing later using another name, choose File > Save As and type 
the new name.

Exiting AViCAD

When you have finished working in AViCAD, choose File > Exit. 
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Working with drawings

CAD drawings help you organize information for greater efficiency. With 
AViCAD®, you can draw entities representing different types of information on vari-
ous layers and use those layers to control color, linetype, and visibility. AViCAD also 
includes drawing aids that help you draw accurately.

This section explains setting up drawings and using built-in drawing aids, including 
how to:

• Create new drawings, open existing drawings, and save changes to drawings.

• Use aids such as the grid, snap, and orthogonal settings to draw accurately.

Topics in this chapter

Creating a new drawing ...................................................................................... 34

Opening a drawing.............................................................................................. 37

Setting up a drawing ........................................................................................... 40

Working with colors............................................................................................. 57

Using the grid, snap alignment and cursor restriction ........................................ 65

Using entity snaps .............................................................................................. 70

Using fly-over snapping ...................................................................................... 79

Etrack Snap tracking........................................................................................... 81

Polar Snap tracking............................................................................................. 82

Saving your drawing ........................................................................................... 84
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Creating a new drawing    

At the opening of AViCAD it is shown a mask in which is possible to decide the type 
of operation to undertake. In relation to the button selected in the Start mask, the 
access to several functions it’s allowed. Hereby follows the description starting from 
the key on the extreme left:

• Start from Scratch Choose if start by creating a new drawing with Metric set-
ting rather then English (Feet or inches). The drawing created is empty and con-
tains only the setting of the unit of measures chosen.

• Use a Template It’s supplied with a series of templates, pre-configured drawings 
as examples to start with for the creation of a new drawing. The templates contain 
cartouches, some in the template space and some other in the paper space with dif-
ferent dimensions and orientation. It’s possible to replace them with others per-
sonalized in according to specific needs. To chance the path in which the 
templates are created it’s enough to click on the button Select and choose the path 
with the new templates. In case we would have to occasionally choose a prototype 
it will be enough to act on Browse.
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• Use a Wizard If the intention is to specify the different characteristics that the 
starting drawing will have to have, it’s possible to use that tool that allows to 
select the available options during the advancement among the different screens.  
To scroll and configure the different options it’s enough to act on the button Next 
and on the controls displayed during the process until the end.

• Open a drawing Allows analyzing the working session choosing an existing 
drawing from the list of last drawings opened or by the Thumb button. 

No matter which choice has been made, to confirm is necessary to press the button 
OK.
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To be able to use a template as a base for a new drawing, offers many advantages:

• Can be used pre-determined unit of measure, grid configurations, text heights and 
other configurations suitable for the type of drawing to be executed.

• Can be defined special layers.

• Can be included pre-defined blocks and borders.

To create a new drawing based on a template    

1 Do one of the following:

• Choose File > New.

• Type pnew and then press Enter.

2 In the Start dialog:

• If the template is one among the pre-defined ones, click on the button Use a 
Template (the second button starting from the left), choose one from the 
displayed list and press OK. To change the pre-defined path where the templates 
are, click on the button Select then specify one of them and press OK. If the 
template is not present on the list and it’s not needed to define the path of the 
model to be used as default, use the Browse button, select the requested 
prototype and press Open.

• If it’s needed a completely empty prototype click on the button Start from 
Scratch (the first button from the left) then choose the setting (metric or English) 
and confirm with OK.
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Opening a drawing    

You can open drawing (.dwg) files, Drawing Exchange Format (.dxf) files, Design 
Web Format™ (.dwf) files, and drawing template (.dwt) files.

You can also open and check drawings that you suspect are damaged.

Opening an existing drawing
You can open any of these drawing files:

• Standard drawing files with a .dwg extension. 

In addition to your own drawing files, you can open and use one of the sample 
drawings that are included with AViCAD.      

• Drawing Exchange Format files with a .dxf file extension.

• Design Web Format files with a .dwf file extension.

• Drawing templates with a .dwt file extension.

To open an existing drawing 

1 Use one of the following methods:

• Choose File > Open.

• On the Standard toolbar, click the Open tool ( ).

• Type open and then press Enter.

2 In Files of Type, choose the type of file you want to open.

3 Choose the folder containing the desired file.

4 Do one of the following:

• Choose the drawing you want to open and then click Open.

• Double-click the drawing you want to open.

If the drawing requires a password, enter the password, click OK to verify the 
password, and then click Open again.
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TIP You can also open drawings while browsing files on your computer using pro-
grams that came with your operating system, such as Windows File Explorer or My 
Computer. Simply double click the file to open it in AViCAD. Easily find the drawing 
you want by viewing thumbnail images of the drawing files as you browse them. 

NOTE To quickly open a drawing file that you recently used, choose File > <file 
name>. The program tracks the last four drawings.    

Opening damaged files
Files can become damaged for many reasons. For example, if you are working on a 
drawing during a power outage, a system crash, or a hardware failure, your drawing 
file may become damaged. AViCAD allows you to open and check damaged files to 
attempt file recovery.

Recovering a file attempts to open one of the following file types:

A Displays a description of the file size, creation 
date, and other information about the drawing.

B Opens the drawing as read-only to prevent 
making changes to the file.    

C Turns the drawing preview on or off.

D Unavailable when opening drawings; available 
only when saving drawings.

E If a thumbnail image exists in the selected 
drawing, displays an image of the drawing before 
you open it.  

F Defines how drawings display in the list, 
including file details and thumbnail images.

A

B
C
D

E

F
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• Standard drawing files with a .dwg extension. 

• Drawing Exchange Format files with a .dxf file extension.

• Design Web Format files with a .dwf file extension.

• Drawing templates with a .dwt file extension.

You can also audit any open file to check it for errors. You specify whether you want 
AViCAD to fix any errors that are found automatically. AViCAD fixes as many 
errors as possible and any errors that cannot be fixed are reported as “Ignored” in the 
Prompt History window.

To open a damaged file

1 Use one of the following methods:

• Choose File > Utility > Recover.

• Type recover and then press Enter.

2 In Files of Type, choose the type of file you want to recover.

3 Choose the directory containing the damaged file.

4 Choose the damaged file you want to recover.

5 Click Open.

If you want to check all drawings for errors automatically when you open them, 
choose Tools > Options > General tab and mark the check box for Open Drawings 
using Recover.

To check a drawing file for errors

1 With the drawing open that you want to check, do one of the following:

• Choose File > Utility > Audit.

• Type audit and then press Enter.

2 Choose whether you want AViCAD to fix any found errors automatically, and 
then press Enter.

NOTE If the AUDITCTL system variable is set to On and errors are found during a 
file recovery or audit, an ASCII file is created that describes the audit. The ASCII file 
is saved in the same folder as the audited drawing and has the same name as the 
drawing file, but with an .adt extension. 
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Setting up a drawing    

You can specify individual settings when you create a new drawing or when you 
modify settings in a drawing created from a template.

Setting the current layer
Layers in AViCAD® are like the transparent overlays you use in manual drafting. 
You use layers to organize different types of drawing information. In AViCAD, each 
entity in a drawing exists on a layer. When you draw an entity, it is created on the cur-
rent layer. 

You can control the visibility of layers in individual viewports. When you turn a layer 
off, entities drawn on that layer are no longer visible, and they do not print. Although 
a layer may be invisible, you can still select it as the current layer, in which case new 
entities are also invisible until you turn the layer back on. Entities on invisible layers 
can also affect the display and printing of entities on other layers. For example, enti-
ties on invisible layers can hide other entities when you use the Hide command to 
remove hidden lines. 

You can also freeze and thaw layers. Entities drawn on frozen layers do not display, 
do not print, and do not regenerate. When you freeze a layer, its entities do not affect 
the display or printing of other entities. For example, entities on frozen layers do not 
hide other entities when you use the Hide command to remove hidden lines. In addi-
tion, you cannot draw on a frozen layer until you thaw it, and you cannot make a fro-
zen layer current. 

You cannot freeze the current layer. If you attempt to freeze the current layer, a dia-
log box appears prompting you to specify a different layer. You also cannot freeze or 
thaw a viewport layer unless you are working in a Layout tab.

You can lock or unlock layers. The entities on a locked layer are still visible and will 
print, but you cannot edit them. Locking a layer prevents you from accidentally mod-
ifying entities. 

Each layer has its own color, linetype, and lineweight. For drawings that use named 
print styles, layers can also have their own print style. Entities you draw on a particu-
lar layer are displayed in the color, linetype, and lineweight associated with that layer 
unless you override these settings. You control all of the associated settings for layers 
using the Layers elements in the AViCAD Explorer. For details see Chapter 8, 
“Working with the AViCAD Explorer.” 
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Layer Properties Manager
Layers are used to organize and classify the objects of a drawing.  
You can create and name a new layer for each homogeneous group of objects (for 
example walls, dimensions etc.) and then assign common properties to each layer. 
The organization of objects into layers allows you to control the visibility and proper-
ties of a large number of entities separately for each layer and it’s useful to make 
changes quickly. 
Each new AViCAD drawing has a default layer named “0” that can’t be deleted or 
renamed. 
You can create an unlimited number of layers in every drawing and an unlimited 
number of objects for each layer.

To manage layers

1 Do one of the following: 

• Choose Format > Layer.

• On the Entity Properties toolbar, click the Explore Layers icon.

• Type layer and then press Enter.

• Type la and then press Enter.

Creating and naming layers

Layer Names
A layer name can be made of up to 255 characters: letters, numbers, spaces, and sev-
eral special characters. Layer names cannot include the following characters: 

< > / \ “ : ; ? * | = ‘

The Layer Properties Manager sorts layers alphabetically by name. In many cases 
layer names are determined by personal or corporate standards. To organize your cus-
tomized layer naming scheme, use common prefixes for layer names that include cor-
related components of the drawing, in order you can find them quickly typing in wild-
card characters. 
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If you frequently use the same layering scheme, you can set up a drawing template 
with layers, linetypes and colors already assigned.

NOTE:  You can use AViCAD Explorer to copy layers from one drawing to another. 
For example, you might have a drawing that contains all the standard layers needed 
for a project. You can create a new drawing and use the AViCAD Explorer dialog 
box to copy the predefined layers and paste them in the new drawing (see Chapter 8, 
“Working with the AViCAD Explorer.” ).

Setting the current layer
When you create new entities, they are drawn on the current layer. In a drawing you 
can have a great number of layers but only one at a time can be current. It is possible 
to draw on layer 0, but it’s a good standard not to use this layer but to keep the con-
ceptual grouping of objects and draw on layers with specific names defined by the 
user. To draw new entities on a different layer, you must first make that layer the cur-
rent layer. The succeeding objects you create are associated with the new current 
layer and have its colour, linetype, and other properties. You can’t make current a fro-
zen layer. For details see “Setting the current layer” on page 176. 

To make a layer current 

1 Do one of the following:

• On the Entity Properties toolbar, from the layer drop down list, choose the layer 
you want to make current.

• Choose Format > Layer.

• On the Entity Properties toolbar, click the Explore Layers tool.

• Type layer and then press Enter.

• On the status bar, right-click on the current layer control, and from the list, select 
the layer you want to make current.

2 In the Layer Name list, select the layer you want to make current.

3 Do one of the following:

• Choose Edit > Current.

• In the Layer Name list, select the name you want to make current, and then click 
the Current tool .

• Double-click the layer name in the Layer Name list. 

• Right-click the layer name you want to change, and from the shortcut menu 
select Current. 

4 To complete the command and return to your drawing, close the window.
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Controlling layer visibility   
A layer can be visible or invisible. Entities on invisible layers are not displayed and 
do not print. By controlling layer visibility, you can turn off unnecessary information, 
such as construction lines or notes. By changing layer visibility, you can put the same 
drawing to multiple uses.    

For example, if you are drawing a floor plan, you can draw the layout of light fixtures 
on one layer and the location of plumbing lines on another. By selectively turning 
layers on and off, you can print the electrical engineering drawings and the plumbing 
drawings from the same drawing file. For even more convenience, you can control 
the visibility of layers within individual viewports, so that layers that display in one 
viewport are invisible in other viewports in the same drawing.

When you turn a layer off, entities drawn on that layer are no longer visible. When 
you turn the layer back on, the entities on that layer are redisplayed.  For details see 
“Controlling layer visibility” on page 177. 

To turn layers on or off

1 Do one of the following:     

• Choose Format > Layer.     

• On the Entity Properties toolbar, click the Explore Layers tool.

• Type layer and then press Enter.

2 In the Layer Name list, select the layer you want to turn on or off.

3 Turn on or off the layer selected.

4 To complete the command and return to your drawing, close the window.

You can also freeze layers to improve the performance of operations such as zooming 
and panning or producing hidden lines or shaded images. When a layer is frozen, 
entities drawn on that layer are no longer visible.    

To freeze or thaw layers

1 Do one of the following:    

• Choose Format > Layer.     

• On the Entity Properties toolbar, click the Explore Layers tool.

• Type layer and then press Enter.

2 In the Layer Name list, select the layers you want to freeze or thaw.

3 Clic on the freeze icon. 

4 To complete the command and return to your drawing, close the window.
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Locking and unlocking layers 
Locking a layer makes it easy to refer to information contained on the layer, but pre-
vents you from accidentally modifying its entities. When a layer is locked (but visible 
and thawed), its entities remain visible, but you cannot edit them. If you lock the cur-
rent layer, you can still add new entities to it. You can also change the linetype and 
color associated with a locked layer. Unlocking a layer restores full editing capabili-
ties. For details see “Locking and unlocking layers” on page 178.   

To lock or unlock layers

1 Do one of the following:

• Choose Format > Layer.     

• On the Entity Properties toolbar, click the Explore Layers tool.

• Type layer and then press Enter.

2 In the Layer Name list, select the layers you want to lock or unlock.

3 Clic on lock or unlock icon.

4 To complete the command and return to your drawing, close the window.

Remove Layers
You can remove unused layers from your drawing with PURGE or by deleting them 
from the Layer Properties Manager. You can’t delete layers 0 and DEFPOINTS, lay-
ers containing objects (including objects in block definitions), the current layer, and 
xref-dependent layers. 

Setting the current entity color   
An entity’s color determines how it is displayed and, if you are using a color printer, 
how it prints. Entities are created in the current color.

When you open a new drawing, entities are created in the color BYLAYER, which 
adopts the color of the current layer. Initially, layer 0 is both the only layer and the 
current layer. Its default color is white, so your entities appear as white.

There are index colors, which contain two additional color properties that are often 
referred to as colors, true colors, and color book colors. The two additional color 
properties are BYLAYER and BYBLOCK. These color properties cause an entity to 
adopt the color either of the layer or of the block in which it is a member.
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To set the current entity color

1 Do one of the following:      

• Choose Tools > Drawing Settings.

• Type settings and then press Enter.

2 Click the Entity Creation tab.

3 Click Select Color.

4 In the Color dialog box, click one of the following tabs and select a color:

• Index Color — BYBLOCK, BYLAYER, or one of the 255 index colors. You 
can also type the color number in the Index box.

• True Color — Click a basic color, click a color in the color palette, enter the 
Hue, Saturation, and Luminance (HSL) values, or enter the Red, Green, Blue 
(RGB) values. There are more than 16 million true colors from which you can 
choose.

• Color Books — Select a color book from the list, then click a color. You can 
select Show Only Color Book Colors Used in Drawing to limit the selection to 
only those color book colors that are used in the current drawing.

5 Click OK.

6 Click OK again.

NOTE On the status bar, right-click on the current color, and select from the list the 
color you want to use for new entities. You can also click Select Color to choose addi-
tional colors.

For more details about using color in the many aspects of your drawing, see “Work-
ing with colors” on page 57 in this chapter. 
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Setting the current linetype
Linetypes help convey information. You use different linetypes to differentiate the 
purpose of one line from another. A linetype consists of a repeating pattern of dots, 
dashes, or blank spaces. Linetypes determine the appearance of entities both on the 
screen and when printed. By default, every drawing has at least three linetypes: CON-
TINUOUS, BYLAYER, and BYBLOCK. Your drawing may also contain an unlim-
ited number of additional linetypes.           

When you create an entity, it is created using the current linetype. By default, the cur-
rent linetype is BYLAYER. AViCAD indicates that the entity linetype is determined 
by the current layer linetype by assigning the BYLAYER property as the default line-
type setting. When you assign BYLAYER, changing the layer linetype changes the 
linetype of all the entities created on that layer (if they were created using the linetype 
BYLAYER).     

A Click to set the color to one of the standard 
colors.

B Click to set the color to one of the gray shades.

C Click to set the color to any of the available 
colors.

D Indicates the current color.

E Displays the color number.

F Click to set the current color BYLAYER.

G Click to set the current color BYBLOCK.

A

B

D E

G
F

C
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You can also select a specific linetype as the current linetype, which overrides the 
layer’s linetype setting. Entities are then created using that linetype, and changing the 
layer linetype has no effect on them.

As a third option, you can use the linetype BYBLOCK property, in which case new 
entities are drawn using the CONTINUOUS linetype until you group them into a 
block. The entities then inherit the current linetype setting when you insert the block 
into a drawing. For details see “Setting the current linetype” on page 185. 

To set the current linetype

1 Do one of the following:          

• Choose Tools > Drawing Settings.

• Type settings and then press Enter.

2 Click the Entity Creation tab.

3 In the Entity Linetype list, choose the linetype that you want to make current.

4 Click OK.

NOTE On the status bar, right-click on the word BYLAYER for the current linetype, 
click Properties, and then choose the linetype that you want to make current.

Setting the linetype scale    
You can specify the linetype scale. The smaller the scale, the more repetitions of the 
linetype pattern are generated per drawing unit. For example, a linetype pattern is 
defined as a sequence of dashed lines and open spaces, each 0.25 units long. The line-
type scale uses the drawing scale factor to determine the length. A scale factor of 0.5 
would reduce the length of each line and space to 0.125 units; a scale factor of 2 
would increase the length of each to 0.5 units.         

NOTE Setting the linetype scale too large or too small may result in a line pattern 
looking like a solid line, depending on what the scale view is or at what scale the 
drawing is plotted.

You can control a new entity’s individual linetype scale factor as well as the overall 
or global scale factor applied to all the entities in the drawing.
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To set the current individual linetype scale

1 Do one of the following:

• Choose Tools > Drawing Settings.

• Type settings and then press Enter.

2 Click the Entity Creation tab.

3 In the Linetype Scale field, type or choose the linetype scale that you want to 
make current.

4 Click OK.

To change the global linetype scale

1 Do one of the following:     

• Choose Tools > Drawing Settings.

• Type settings and then press Enter.

2 Click the Entity Creation tab.

3 In the Global Linetype Scale field, type or choose the global linetype scale that 
you want to change.

4 Click OK.

Setting the current lineweight
Lineweights help differentiate the purpose of one line from another. Lineweights 
determine how thick or thin entities appear both on the screen and when printed. 
Every drawing has these lineweights: DEFAULT, BYLAYER, BYBLOCK, and 
many additional lineweights in millimeters (or you can use inches).            

When you create an entity, it is created using the current lineweight. By default, the 
current lineweight for a new entity is BYLAYER. This means that the entity line-
weight is determined by the current layer. When you assign BYLAYER, changing a 
layer’s lineweight changes the lineweight of all the entities assigned that layer (if they 
were created using the lineweight BYLAYER).     

You can also select a specific lineweight (or DEFAULT) as the current lineweight, 
which overrides the layer’s lineweight setting. Entities are then created using that lin-
eweight (or the DEFAULT lineweight), and changing the layer lineweight has no 
effect on them.

As a third option, you can use the lineweight BYBLOCK property, in which case new 
entities are drawn using the DEFAULT lineweight until you group them into a block. 
The entities then inherit the block’s lineweight setting when you insert the block into 
a drawing.

If you choose a lineweight that is less than .025 millimeter, it displays as one pixel 
when you create your drawing. When you print your drawing, it prints at the thinnest 
lineweight that is available for your printer.
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You cannot assign lineweights to planes, points, TrueType fonts, or raster images (if 
supported in your version of AViCAD).

To set the current lineweight

1 Do one of the following:         

• Choose Tools > Drawing Settings.

• Type settings and then press Enter.

2 Click the Entity Creation tab.

3 In the Lineweight list, choose the lineweight that you want to make current.

4 Click OK.

TIP On the status bar, right-click the word BYLAYER for the current lineweight, and 
then choose the current lineweight. You can also click the word LWT to toggle the 
display of lineweights on and off.

NOTE To see lineweights in your drawing, you may need to turn on lineweights. For 
details, see “Controlling the display of lineweights” on page 151.  

Setting the current print style
Print styles are used to change the appearance of an entity when it prints, without 
actually changing the entity in the drawing. 

If your drawing uses named print style tables, you can specify a print style for any 
entity. Named print style tables contain print styles that you set up. If your drawing 
uses color-dependent print style tables, the print style is BYCOLOR, which cannot be 
changed. These types of print style tables determine printing requirements by the 
color assigned to an entity or layer. For details about converting a drawing that uses 
color-dependent print style tables to use named print style tables,  see “Changing a 
drawing’s print style table type” on page 415. 

When you create an entity in a drawing that uses named print style tables, the entity is 
created using the current print style. By default, the current print style is BYLAYER. 
When you assign BYLAYER, changing a layer’s print style changes the print style of 
all the entities assigned that layer if they were created using the print style 
BYLAYER. 

You can also select a specific print style as the current print style, which overrides the 
layer’s print style setting. Entities are then created using that print style, and changing 
the layer print style has no effect on them.

As a third option, you can use the print style BYBLOCK, in which case new entities 
use the Normal print style until you group them into a block. The entities then inherit 
the block’s print style setting when you insert the block into a drawing.
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To set the current print style in a drawing that uses named print style tables

1 Do one of the following:          

• Choose Tools > Drawing Settings.

• Type settings and then press Enter.

2 Click the Entity Creation tab.

3 In the Print Style list, choose the print style that you want to make current. If nec-
essary, choose Other and then select a print style.

4 Click OK.

TIP On the status bar, right-click the word BYLAYER for the current print style, 
click Other, and then choose the print style that you want to make current. Or, 
type printstyle to choose the current print style.

Setting drawing units    
With AViCAD, you typically draw at full-size (1:1 scale), and then set a scale factor 
when you print or plot your drawing. Before you begin drawing, however, you need 
to determine the relationship between drawing units and real-world units.            

For example, you can decide whether one linear drawing unit represents an inch, a 
foot, a meter, or a mile. In addition, you can specify the way the program measures 
angles. For both linear and angular units, you can also set the degree of display preci-
sion, such as the number of decimal places or smallest denominator used when dis-
playing fractions. The precision settings affect only the display of distances, angles, 
and coordinates. AViCAD always stores distances, angles, and coordinates using 
floating-point accuracy.     

To set the linear drawing units    

1 Do one of the following:

• Choose Tools > Drawing Settings.

• Type settings and then press Enter.

2 Click the Drawing Units tab.

3 Under Change Settings For, choose Linear Units.

4 Under Unit Types, select a unit type.

5 Under Display Precision, type the display precision according to the number of 
decimal places you want, or click the arrows to select it.

The field above this setting shows an example of the linear unit type at the current 
precision.

6 Click OK.
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To set the angular drawing units                   

1 Do one of the following:

• Choose Tools > Drawing Settings.

• Type settings and then press Enter.

2 Click the Drawing Units tab.

3 Under Change Settings For, choose Angular Units.

4 Under Unit Types, select a unit type.

5 Under Display Precision, type the display precision according to the number of 
decimal places you want, or click the arrows to select it.    

The field above this setting shows an example of the angular unit type at the cur-
rent precision.

6 Under Angle Direction, select the direction in which angles increase when you 
specify a positive angle value.    

A Select the type of linear units. B Choose the display precision for linear 
units.  

A

B
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7 Under Angle Base, specify the compass location for the zero angle.    

For example, by default, angle 0 is at the “three o’clock” or “east” position.

The adjacent icon shows the current location of the angle base.

8 Click OK.

Understanding scale factors    
Instead of drawing to a particular scale, you draw everything in the program full-size. 
Although it’s a good idea to keep your scale factor in mind when setting up a draw-
ing, you don’t need to set the scale until you print it. For example, when you draw a 
mechanical part 40 inches in length with AViCAD, you actually draw it as 40 inches, 
rather than applying a scale factor as you draw. When you print your drawing, you 
can assign the scale at which the drawing is to print.          

Scale, however, does affect the way a few elements such as text, arrows, or linetypes 
print or plot in your drawing. For these, you can make adjustments when you first set 
up your drawing so that they print or plot at the correct size. For example, when you 
draw text, you need to determine the text size so that when you plot it later at a partic-
ular scale, the text height is correct.     

A Determines the type of units you are controlling.

B Select the type of angular units.

C Choose the display precision for angular units.

D Select the direction in which angles increase.

E Select the angle base, the direction of the zero 
angle.

A

B

C

D E
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After you determine the eventual scale of your finished drawing, you can calculate 
the scale factor for the drawing as a ratio of one drawing unit to the actual scale unit 
represented by each drawing unit. For example, if you plan to print your drawing at  
1/8” = 1’-0”, your scale factor ratio is 1:96 (1/8” = 12” is the same as 1 = 96). If you 
want your printed scale to be 1 inch = 100 feet, your scale factor ratio is 1:1200.        

The following table shows some standard architectural and engineering scale ratios 
and equivalent text heights required to create text that measures 1/8-inch high when 
you plot the drawing at the specified scale.           

You can use these scale factors to predetermine the size of your drawing to make sure 
that it fits on a specific size paper when you print it. You control the size of your 
drawing by the drawing limits. To calculate the drawing limits to match the size of 
your paper, multiply the dimensions of your paper size by your scale factor.        

For example, if the paper you use to print measures 36 inches x 24 inches and you 
plot your drawing at 1/8” = 1’-0” (in other words, using a scale factor of 96), the size 
of your drawing measured in drawing units is 36 x 96 (or 3,456 units) wide and 24 x
96 (or 2,304 units) high.

Standard scale ratios and equivalent text heights 

Scale Scale factor Text height

1/16” = 1’-0” 192 24”

1/8” = 1’-0” 96 12”

3/16” = 1’-0” 64 8”

1/4” = 1’-0” 48 6”

3/8” = 1’-0” 32 4”

1/2” = 1’-0” 24 3”

3/4” = 1’-0” 16 2”

1” = 1’-0” 12 1.5”

1 1/2” = 1’-0” 8 1”

3” = 1’-0” 4 0.5”

1” = 10’ 120 15”

1” = 20’ 240 30”

1” = 30’ 360 45”

1” = 40’ 480 60”

1” = 50’ 600 75”

1” = 60’ 720 90”

1” = 100’ 1200 150”
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Keep in mind that you can print the finished drawing at any scale, regardless of the 
scale factor you calculate. You can also print on paper of a different size and use the 
AViCAD paper space feature to create different views of your drawing and to posi-
tion and scale those views differently. The scaling factor is not related to the size of 
the entities you draw; it simply provides a preliminary guide to help you establish the 
text height and drawing limits when you begin your drawing. You can change the text 
height and drawing limits at any time.

Setting the text height            
The text height setting controls the height of text, measured in drawing units. Set this 
value initially so that text used for your most common annotations, when scaled to the 
size at which you will print a drawing, measures 1/8-inch high on the printed draw-
ing.              

For example, if you plan to print your drawing at 1/8” = 1’-0” and you want your text 
to be 1/8-inch high in the final drawing, create that text 1 foot high (in your real-
world drawing units) so that when you print it, it appears 1/8-inch high on the paper. 
You must create text 4 feet high that you want to print 1/2-inch high.

To set the text height

1 Do one of the following:

• Choose Tools > Drawing Settings.

• Type settings and then press Enter.

2 Click the Entity Creation tab.

3 Under Change Settings For, choose Text.

4 In the Default Text Height field, select the text height or type the text height value 
that you want.

5 Click OK.
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NOTE The default text height applies only if the current text style height is 0.0. Oth-
erwise, the text height for the current style takes precedence.

Setting the drawing limits    
You can specify the drawing limits that form an invisible boundary around your 
drawing. You can use the drawing limits to make sure that you do not create a draw-
ing larger than can fit on a specific sheet of paper when printed at a specific scale.       

For example, if you plan to print your drawing at 1/8” = 1’-0” (in other words, using a 
scale factor of 96) on a sheet of paper measuring 36 inches x 24 inches, you can set 
drawing limits to 3,264 units wide (that is, 34 x 96) and 2,112 units high (22 x 96), 
which allows a 1-inch margin around the edges of the printed image.

A Choose Text. B Specify the text height in drawing units.

A

B



56   C H A P T E R  3

To set the drawing limits    
1 Do one of the following:         

• Choose Tools > Drawing Settings.

• Type settings and then press Enter.

2 Click either the Coordinate Input tab or the Display tab.

3 Under Change Settings For, choose Limits.

4 Specify the x-coordinate and y-coordinate of the upper right drawing limit and the 
lower left drawing limit.

You can also click Select to specify the drawing limits by selecting points in the 
drawing.

5 To constrain your drawing to these drawing limits, click the Disallow Input 
Beyond Limits check box.

6 Click OK.

A Choose limits.

B Specify the x-coordinate and y-coordinate of the 
upper right drawing limit.

C Specify the x-coordinate and y-coordinate of the 
lower left drawing limit.

D When you click this check box, the program 
prevents you from drawing outside the drawing 
limits.

E Specify the drawing limits by selecting points in 
the drawing.

A

B

C

D

E
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Working with colors

An entity’s color determines how it is displayed and, if you are using a color printer, 
how it prints. Entities are created in the current color specified for the drawing.

Layers can also control the color of entities. When you open a new drawing, entities 
are created in the color BYLAYER, which adopts the color of the current layer. Ini-
tially, layer 0 is both the only layer and the current layer. Its default color is white, so 
your entities appear as white.

For entities and layers in AViCAD, there are three different types of colors:

• Index colors

• True colors

• Color book colors

NOTE True colors and color books are unavailable in some cases, such as dimen-
sion entities and cursor display.

You can choose colors by selecting them from the Color dialog box. In the command 
bar or in some dialog boxes, you specify a color either by name or by number.

Using index colors
There are 255 standard index colors and two additional color properties that are often 
referred to as colors (BYLAYER and BYBLOCK). You can use seven of the 255 
standard index colors by name: red, yellow, green, cyan, blue, magenta, and white. 
(Numbers eight and nine are not named.) Each index color has a unique number from 
1 to 255. The two additional color properties are BYLAYER and BYBLOCK. These 
color properties cause an entity to adopt the color either of the layer or of the block in 
which it is a member. BYLAYER is color number 256, and BYBLOCK is color num-
ber 0. In all commands for which you would use a color, you can indicate BYLAYER 
and BYBLOCK as well as by numbers 256 and 0, respectively.

To select an index color

1 Click Select Color in the desired dialog box, such as Layers, Drawing Settings, 
Properties, or Multiline Text. The Color dialog box opens.

2 Click the Index Color tab.

3 Do one of the following:

• Click BYBLOCK.

• Click BYLAYER.

• Click the color of your choice, or type the color number in the Current box.

4 Click OK.
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Using true colors
There are more than 16 million true colors from which you can choose. True colors 
are defined using 24-bit color.

Even with so many colors available, you can quickly choose a color from the display 
of basic colors or by clicking  the color palette. Alternatively, if you know the values 
used to define the desired color, you can enter the Hue, Saturation, and Luminance 
(HSL) values, or you can enter the Red, Green, Blue (RGB) values.

A Click to select one of the standard colors.

B Click to select one of the gray shades.

C Click to select any one of the available index 
colors.

D Indicates the current color.

E Displays the color number, or enter the color 
number.

F Click to set the color to BYLAYER.

G Click to set the color to BYBLOCK.

A

B

C

D E

F
G
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To select a true color

1 Click Select Color in the desired dialog box, such as Layers, Drawing Settings, 
Properties, or Multiline Text. 
The Color dialog box opens.

2 Click the True Color tab.

3 Do one of the following:

• Click a basic true color.

• Click a true color in the color palette.

• Enter HSL values for the desired true color.

• Enter RGB values for the desired true color.

4 Click OK.

A Click to select one of the basic true colors.

B Click to select one of the custom true colors, if 
any are defined.

C Click to add the selected color to the custom 
color area.

D Enter (or view)  the amount of red, green, and 
blue of the desired true color.

E Enter (or view) the amount of hue, saturation, and 
luminance of the desired true color.

F Slide or click to adjust the color luminance.

G Click to select a true color in the color palette.

A

B

C

D

E

F

G
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Using color books
AViCAD uses color books to store collections of colors. For example, you can store a 
unique color scheme for a client in a color book and then use colors only from that 
color book for the client’s drawings.

To select a color book color

1 Click Select Color in the desired dialog box, such as Layers, Drawing Settings, 
Properties, or Multiline Text. 
The Color dialog box opens.

2 Click the Color Books tab.

3 Select a color book from the list.

4 If you want to narrow your color search, do one of the following:

• In the list of colors, select a color book page, if one is available. Pages are partic-
ularly helpful in large color books — they help group colors so you can find 
them quickly.

• Select Show Only Color Book Colors Used in Drawing. Only those color book 
colors that are used in the current drawing will display in the list.

5 Select the desired color.

6 Click OK.
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Creating color books
You may have a color book given to you by a client, developed by a third-party, or 
you can create your own. Each color book has an .acb extension and is saved auto-
matically in Extensible Markup Language (XML) format. 

To create a color book

1 Click Select Color in the desired dialog box, such as Layers, Drawing Settings, 
Properties, or Multiline Text. 
The Color dialog box opens.

2 Click the Color Books tab.

3 Click Color Book Editor.

4 In the Color Book Editor dialog box, click the New tool ( ).

5 In Color Book Name, enter the name of the color book. This name will appear in 
the list of color books on the Color Books tab in the Color dialog box.

A Select a color book.

B Click to select a color book color.

C Select to list only those color book colors that 
are used in the current drawing.

D Click to create and modify color books.

E Displays the selected color and its RGB values.

A

B

C

D

E
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6 Do the following to define organizational pages in the color book:

• In the contents of the color book, click an existing page or color where you want 
to add a page.

• Define a color in the palette.

• Enter the name of the page, and then click Add Page.

7 Do the following to define colors in the color book:

• In the contents of the color book, click an existing page or color where you want 
to add a color.

• Define a color in the palette.

• Enter the name of the color, and then click Add Color.

8 Do any of the following to change existing pages and colors in the color book:

• Modify pages and colors — Select a page or color in the color book, define its 
new color settings in the palette, enter any changes to its name, and then click 
Modify.

• Delete pages and colors — Select a page or color in the color book, and then 
click Delete.

• Rearrange pages and colors — Select a page or color in the color book, and then 
click the up arrow ( ) or down arrow ( ).

9 In the Color Book Editor dialog box, click the Save tool ( ).
10 Enter a filename for the color book, and then click Save. 

By default, the file is saved in the default folder where AViCAD searches for 
color books.
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Modifying color books
You can modify your own color books and the color books that came with AViCAD. 
If you modify a color book that came with AViCAD, it is recommended that you save 
it with a new filename first so the original color book is not overwritten.

A Click New to create a color book; click Open to 
open a color book; click Save to save the color 
book; click Save As to save the color book with 
a new filename.

B Select a page or color to modify, delete, or 
reorder it, or to view its settings.

C Click to create a new page in the color book 
using the current color settings.

D Click to create a new color in the color book 
using the current color settings.

E Click to delete the selected page or color from 
the color book.

F Click to redefine the selected page or color to 
use the current color settings.

G Click to move the selected page or color up or 
down one position in the color book.

H Enter the name of the page or color as you want it 
to appear in the color book.

I Enter (or view)  the amount of red, green, and blue 
of the desired color.

J Enter (or view) the amount of hue, saturation, and 
luminance of the desired color.

K Slide or click to adjust the color luminance. 

L Click to select a color.

M Enter the name of the color book.

A

B

C
D

E
F

G H

I

J

K

M

L
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To modify a color book

1 Click Select Color in the desired dialog box, such as Layers, Drawing Settings, 
Properties, or Multiline Text. 
The Color dialog box opens.

2 Click the Color Books tab.

3 Select the color book you want to modify.

4 Click Color Book Editor.

5 In Color Book Name, enter any changes to the color book name. This name 
appears in the list of color books on the Color Books tab in the Color dialog box.

6 Do any of the following to modify pages or colors in the color book:

• Add pages — In the contents of the color book, click an existing page or color 
where you want to add a page. Define a color in the palette, enter the name of 
the page, and then click Add.

• Add colors — In the contents of the color book, click an existing page or color 
where you want to add a color. Define a color in the palette, enter the name of 
the color, and then click Add.

• Modify pages and colors — Select a page or color in the color book, define its 
new color settings in the palette, enter any changes to its name, and then click 
Modify.

• Delete pages and colors — Select a page or color in the color book, and then 
click Delete.

• Rearrange pages and colors — Select a page or color in the color book, and then 
click the up arrow ( ) or down arrow ( ).

7 Do one of the following to save the color book:

• To save the color book with the same filename, click the Save tool ( ) in the 
Color Book Editor.

• To save the color book with a new filename or in a new location, click the Save 
As tool ( ) in the Color Book Editor.

Loading color books
If you have a color book given to you by a client or developed by a third-party, sim-
ply save it on your computer in a folder where AViCAD can find it. By default, color 
books are stored in following folder: \Documents and Settings\YourName\My Docu-
ments\Color Books.

To load a color book

1 Save the color book in the folder where AViCAD searches for color books. 
To verify the folder location, choose Tools > Options, click the Paths/Files tab, 
and find the Color Book folder in the Paths list.

2 In a Color dialog box, click the Color Books tab. 
The previously loaded color book displays in the list of color books.
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Using the grid, snap alignment and cursor restriction

Grid and snap settings are effective tools to use in your drawing to ensure accuracy. 
Although many users find it convenient to match grid points to snap settings, they are 
independent of each other and should not be confused. Grid lines are for visual 
reference only; they do not affect your drawing and they do not print. Snap points are, 
by themselves, not visible; however, when set, they constrain the creation of new 
entities. 

In addition, the cursor can be restricted to move orthogonally only or guides can 
display on the screen automatically at specified polar angle increments.     

Setting a reference grid
A reference grid displays as a pattern of regularly spaced lines. You can turn the dis-
play on and off, and you can specify how far apart the lines are spaced and their color.       

The reference grid extends even over the limits of the drawing, helping you to visual-
ize the boundary of your drawing and to align entities and visualize distances 
between entities. You can turn the grid on and off as needed. You can also change the 
spacing of the grid at any time. 

To turn the grid on and set the grid spacing

1 Do one of the following:         

• Choose Tools > Drawing Settings.

• Type settings and then press Enter.

2 Click the Coordinate Input tab.

3 Under Change Settings For, choose Snap And Grid.

4 Under Reference Grid, click the Show Grid check box.

5 Under Reference Grid Spacing, in the X field, choose the horizontal grid spacing.

6 Under Reference Grid Spacing, in the Y field, choose the vertical grid spacing.    

7 Click OK.

NOTE To toggle the grid display on and off at any time, click the GRID button on 
the status bar or press F7.       
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Setting snap spacing 
Another way to ensure drawing accuracy is to turn on and set snap spacing. When 
snap is turned on, the program restricts the selection points to predetermined snap 
intervals. Although it is often helpful to match the grid spacing to the snap spacing or 
another related setting, the settings do not have to match.           

A Click the check box to enable orthogonal mode.    

B Click the check box to display the reference grid.

C Specify the x and y grid spacing.

D Click the check box to enable snap mode.

E Specify the x and y snap spacing.

F Click the check box to use an isometric snap and 
grid and the isometric plane

G Specify where display the grid

H Click the check box to display the grid over the 
limits 

I  Click the check box to display the grid according 
to the zoom in

J Click the check box to display the grid according 
to the zoom out

K Specify the grid rotation angle.

L Indicates the current grid rotation angle.

M Specify the x- and y-coordinates of the snap 
origin.

N Click to match the grid spacing to the snap 
spacing.

A

B

C

D

E

F

G

K

L

M

N

J

I
H
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To turn snap settings on and set snap spacing

1 Do one of the following:

• Choose Tools > Drawing Settings.

• Type settings and then press Enter.

2 Click the Coordinate Input tab.

3 Under Change Settings For, choose Snap And Grid.

4 Under Snap Settings, click the Snap check box to turn Snap on.

5 Under Snap Settings Spacing, in the X field, choose the horizontal snap spacing.

6 Under Snap Settings Spacing, in the Y field, choose the vertical snap spacing.

7 Click OK.

NOTE To toggle snap settings on and off at any time, click the SNAP button on the 
status bar or press F9.       

In addition to setting the snap spacing, you can change the snap and grid orientation. 
You can also rotate the alignment of the grid or set it to create isometric drawings.

Changing the snap and grid angle and base point
The snap and grid are both normally based on the drawing origin, the 0,0 coordinate 
in the World Coordinate System (WCS). You can relocate the snap and grid origin, 
however, to help you draw entities in relation to a different location. You can also 
rotate the grid to a different angle to realign the crosshairs to the new grid angle. If the 
grid is on, and the grid spacing is 0,0, then the grid defaults to the snap spacing.                 

To change the snap angle and base point

1 Do one of the following:        

• Choose Tools > Drawing Settings.

• Type settings and then press Enter.

2 Click the Coordinate Input tab.

3 Under Change Settings For, select Snap And Grid.

4 Under Snap Settings, click the Snap check box to turn Snap on.

5 Under Reference Grid, click the Show Grid check box to turn Show Grid on. 

6 Under Snap And Grid Settings, in the X Origin field, type the x-coordinate of the 
new snap origin.

7 Under Snap And Grid Settings, in the Y Origin field, type the y-coordinate of the 
new snap origin.

8 Under Snap And Grid Settings, in the Rotation field, type the grid rotation angle. 

9 Click OK
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Using isometric snap and grid
You can use the Isometric Snap And Grid option to create two-dimensional isometric 
drawings. With the isometric option, you are simply drawing a simulated three-
dimensional view on a two-dimensional plane, much the same as you might draw on 
a piece of paper. Do not confuse isometric drawings with three-dimensional draw-
ings. You create three-dimensional drawings in three-dimensional space.                       

The isometric option always uses three preset planes, which are denoted as left, right, 
and top. You cannot alter the arrangement of these planes. If the snap angle is 0, the 
three isometric axes are 30 degrees, 90 degrees, and 150 degrees.

When you check the Isometric Snap And Grid option and select an isometric plane, 
the snap intervals, grid, and crosshairs align with the current plane. The grid is always 
shown as isometric and uses y-coordinates to calculate the grid spacing. If you click 
the Draw Orthogonal check box, the program restricts the drawing of entities to the 
current isometric plane.

NOTE To toggle between isometric planes, press F5.

    Default grid and snap alignment.                                Rotated grid and snap alignment.
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To turn the Isometric Snap And Grid option on

1 Do one of the following:        

• Choose Tools > Drawing Settings.

• Type settings and then press Enter.

2 Click the Coordinate Input tab.

3 Under Change Settings For, select Snap And Grid.

4 Click the Isometric Snap And Grid check box.

5 Under Isometric Crosshairs, click the option for the isometric plane you want 
(Top, Left, or Right).

6 Click OK.
  

Using orthogonal locking
You can restrict cursor movement to the current horizontal and vertical axes so that 
you can draw at right angles, or orthogonally. For example, with the default 0-degree 
orientation (angle 0 at the “three o’clock” or “east” position), when the Draw Orthog-
onal option is enabled, lines are restricted to 0 degrees, 90 degrees, 180 degrees, or 
270 degrees. As you draw lines, the rubber-banding line follows either the horizontal 
or vertical axis, depending on which axis is farthest from the cursor. When you 
enable the isometric snap and grid, cursor movement is restricted to orthogonal 
equivalents within the current isometric plane.            

NOTE AViCAD ignores orthogonal drawing when you type coordinates in the com-
mand bar or when you use entity snaps. Additionally, orthogonal locking and polar 
tracking cannot be used at the same time — turning one option on turns the other 
option off.

To enable orthogonal locking

1 Do one of the following:       

• Choose Tools > Drawing Settings.

• Type settings and then press Enter.

2 Click the Coordinate Input tab.

Isometric planes left (A), right (B), top (C).     

A B

C
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3 Click the Draw Orthogonal check box.

4 Click OK.

NOTE To toggle orthogonal drawing on and off at any time, click the ORTHO but-
ton on the status bar or press F8.    

Using entity snaps   

Entity snaps enable you to quickly select exact geometric points on existing entities 
without having to know the exact coordinates of those points. With entity snaps, you 
can select the endpoint of a line or arc, the center point of a circle, the intersection of 
any two entities, or any other geometrically significant position. You can also use 
entity snaps to draw entities that are tangent or perpendicular to an existing entity.              

You can use entity snaps any time the program prompts you to specify a point—for 
example, if you are drawing a line or other entity. You can work with entity snaps in 
one of two ways:

• Enable a running entity snap that remains in effect until you turn it off by choosing 
an entity snap when no other command is active.    

• Enable a one-time entity snap for a single selection by choosing an entity snap 
when another command is active. You can also use a one-time entity snap to over-
ride a running entity snap.   

TIP If you type the name of the entity snap, you need to type only the first three let-
ters.

When using entity snaps, the program recognizes only visible entities or visible por-
tions of entities. You cannot snap to entities on layers that have been turned off or to 
the blank portions of dashed lines.

When you specify one or more entity snaps, an entity snap target box is added to the 
crosshairs. In addition, an icon appears adjacent to the crosshairs indicating the active 
entity snap. When you select an entity, the program snaps to the snap point closest to 
the center of the target box.            

TIP Type m2p or mtp to enable a one-time snap to the midpoint of two points that 
you specify, such as two points selected using entity snaps.
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To change the size of the entity snap target box      

1 Do one of the following:

• Choose Tools > Drawing Settings.

• Type settings and then press Enter.

2 Click the Coordinate Input tab.

3 Under Change Settings For, choose Entity Selection.

4 Under Entity Snap Aperture, change the value in the Aperture field.

5 Click OK. 
     

Setting entity snaps                                
You can set entity snaps using any of the following methods:        

• Choose Format > Entity Snap, and choose the entity snap you want to set.

• On the Object Snaps toolbar, click one of the entity snap tools or Object Snap Set-
tings tool( ).

• In the command bar, type an entity snap command.

• In the status bar, click ESNAP.     

• Press and hold down the Shift key while right-clicking anywhere within the draw-
ing window to display the entity snap shortcut menu, and then choose the entity 
snap you want to set.  

A Choose Entity Selection. B Type or select the entity snap aperture size.

A

B
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You can also set entity snaps using the Drawing Settings dialog box. To do this, 
choose Format > Entity Snap > Entity Snap Settings. The Drawing Settings dialog 
box is displayed with the Coordinate Input tab active. In the Entity Snap Modes list, 
click the check box for each of the entity snaps that you want to set.

TIP When you select an entity snap, a check mark appears next to the entity snap in 
the menu, the associated tool in the Entity Snaps toolbar is active, and the corre-
sponding box is checked in the Coordinate tab of the Drawing Settings dialog box. 

    

Nearest Snap tool
Use the Nearest Snap tool to snap to the nearest point of another entity. You can snap 
to the nearest point on an arc, circle, ellipse, elliptical arc, line, point, polyline seg-
ment, ray, spline, infinite line or hatch pattern that is visually closest to the cursor.

To set the Nearest Snap    

Do one of the following:

• Choose Format > Entity Snap > Nearest Snap.

• On the Object Snaps toolbar, click the Set Nearest Snap tool ( ).

• Type nearest and then press Enter.

Endpoint Snap tool
Use the Endpoint Snap tool to snap to the endpoint of another entity. You can snap to 
the closest endpoint of an arc, line, polyline segment, ray, hatch pattern, plane, or 
three-dimensional face. If an entity has thickness, the Endpoint Snap also snaps to the 
endpoints of the edges of the entity.       

A Sets the From Snap

B Sets the Endpoint Snap.

C Sets the Midpoint Snap.

D Sets the Intersection Snap.

E Sets the Plan View Intersection Snap.

F Sets the Center Snap.

G Sets the Quadrant Snap.

H Sets the Tangent Snap.

I Sets the Perpendicular Snap.

J Sets the Parallel Snap.

K Sets the  Insertion Point Snap.

L Sets the Node Snap.

M Sets the Nearest Snap.

N Sets the Clear Entity Snaps.

O Object Snap Settings.

A

B

C

D

E

F

G

H

I

J

K

L

M

N

O
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To set the Endpoint Snap

Do one of the following:

• Choose Format > Entity Snap > Endpoint Snap.

• On the Object Snaps toolbar, click the Snap to Endpoint tool ( ).

• Type endpoint and then press Enter.
 

 

Midpoint Snap tool
Use the Midpoint Snap tool to snap to the midpoint of another entity. You can snap to 
the midpoint of an arc, line, polyline segment, plane, infinite line, spline or hatch pat-
tern. In the case of infinite lines, the midpoint snaps to the first defined point. If an 
entity has thickness, the midpoint entity snap also snaps to the midpoint of the edges 
of the entity.        

To set the Midpoint Snap

Do one of the following:

• Choose Format > Entity Snap > Midpoint Snap.

• On the Object Snaps toolbar, click the Snap to Midpoint tool ( ).

• Type midpoint and then press Enter. 
  

Center Snap tool
Use the Center Snap tool to snap to the center point of another entity. You can snap to 
the center of an arc, circle, polygon, ellipse, or elliptical arc. To snap to the center, 
you must select a visible portion of the entity.    

To set the Center Snap

Do one of the following:    

• Choose Format > Entity Snap > Center Snap.

• On the Object Snaps toolbar, click the Snap to Center tool ( ).

To snap to the endpoint, select anywhere on the entity near its endpoint (A).

To snap to the midpoint, select anywhere on the entity near its midpoint (A).

A

A
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• Type center and then press Enter.
  

Perpendicular Snap tool
Use the Perpendicular Snap tool to snap to the perpendicular point of another entity. 
You can snap to an arc, circle, line, polyline, infinite line, ray, spline, hatch pattern or 
edge of a plane to form a perpendicular alignment with that entity or with an imagi-
nary extension of that entity.    

To set the Perpendicular Snap    

Do one of the following:

• Choose Format > Entity Snap > Perpendicular Snap.

• On the Object Snaps toolbar, click the Snap to Perpendicular tool ( ).

• Type perpendicular and then press Enter. 

  

Tangent Snap tool
Use the Tangent Snap tool to snap to the tangent point of another entity. You can snap 
to the point on an arc or circle that, when connected to the previous point, forms a line 
tangent to that entity.

To set the Tangent Snap       

Do one of the following:

• Choose Format > Entity Snap > Tangent Snap.

• On the Object Snaps toolbar, click the Snap to Tangent tool ( ).

• Type tangent and then press Enter.

To snap to the center, select anywhere on the visible portion of the entity (A).

To form a perpendicular angle (A) to an entity (B), select anywhere on the entity.

A

A

B
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Quadrant Snap tool
Use the Quadrant Snap tool to snap to the quadrant point of another entity. You can 
snap to the closest quadrant of an arc, circle, ellipse, or elliptical arc.    

To set the Quadrant Snap    

Do one of the following:

• Choose Format > Entity Snap > Quadrant Snap.

• On the Object Snaps toolbar, click the Snap Quadrant tool ( ).

• Type quadrant and then press Enter.

  

Insertion Point Snap tool
Use the Insertion Point Snap tool to snap to the insertion point of an attribute, block, 
or text entity.              

To set the Insertion Point Snap

Do one of the following:

• Choose Format > Entity Snap > Insertion Point Snap.

• On the Object Snaps toolbar, click the Snap to Insert tool ( ).

• Type insertion and then press Enter. 

To snap to a tangent, select the entity near the tangent point (A).

To snap to a quadrant, select the entity near the quadrant point (A).

A

A
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Point Snap tool
Use the Point Snap tool to snap to a point entity.        

To set the Point Snap

Do one of the following:

• Choose Format > Entity Snap > Point Snap.

• On the Object Snaps toolbar, click the Snap to Node tool ( ).

• Type node and then press Enter. 

  

Mid between two point Snap tool
Use the Mid between two point Snap Tool to snap the mid point between two entities.

To set the Mid between two point Snap

Do one of the following:

• Choose Format > Entity Snap> Mid between two point Snap

• Press Shift and right button of the mouse

To snap to an insertion point, select anywhere on the entity (A).

To snap to a point entity, select the entity (A).

A

A

A
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Intersection Snap tool
Use the Intersection Snap tool to snap to the actual intersection in three-dimensional 
space of any combination of entities. You can snap to the combination of an arc, cir-
cle, line, polyline, ray, infinite line, ellipse, elliptical arc, spline, hatch pattern, poly-
gon mesh, or polyface mesh. You can also snap to an intersection point within a 
single entity, including a polyline or spline.         

The Extended Intersection Snap option snaps to the logical location where two enti-
ties (lines, arcs, or elliptical segments) would intersect if they were of infinite length. 
AViCAD automatically uses the extension option only when you type int in the com-
mand bar (not the full intersection command name) after selecting a command, such 
as Line or Circle. Dashed extension lines are drawn to help show the extended inter-
section.

NOTE There are two types of intersection snaps. You can set the Intersection Snap or 
Apparent Intersection Snap, but you cannot use both at the same time. 

To set the Intersection Snap

Do one of the following:    

• Choose Object > Entity Snap > Intersection Snap.

• On the Object Snaps toolbar, click the Snap to Intersection tool ( ).

• Type intersection and then press Enter.

  

To snap the mid point between two entitie, you should select them .

To snap to an intersection, select the intersection (A).

A

A
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To snap to an extended intersection point

1 Choose a command, for example, line.

2 Type int and then press Enter.

3 Select an extended intersection point. 

The Extended Intersection Snap turns off automatically after you select a point.

Apparent Intersection Snap tool    
The Apparent Intersection Snap tool snaps to the intersection of two entities that do 
not intersect in three-dimensional space but seem to intersect in the current view. You 
can snap to any two entities in the combination of an arc, circle, line, infinite line, 
polyline, ray, ellipse, elliptical arc, spline, hatch pattern, polygon mesh, or polyface 
mesh. You can also snap to an intersection point within a single entity, including a 
polyline or spline.          

The Extended Apparent Intersection Snap option snaps to the logical location where 
two entities (lines, arcs, or elliptical segments) would intersect if they were of infinite 
length. AViCAD automatically uses the extension option only when you type app in 
the command bar (not the full apparent command name) after selecting a command, 
such as Line or Circle. Dashed extension lines are drawn to help show the extended 
apparent intersection.

NOTE There are two types of intersection snaps. You can set the Apparent Intersec-
tion Snap or Intersection Snap, but you cannot use both at the same time. 

To set the Apparent Intersection Snap       

Do one of the following:

• Choose Format > Entity Snap > Plan View Intersection Snap.

• On the Object Snaps toolbar, click the Snap to Apparent Intersect tool ( ).

• Type apparent and then press Enter.

  

To snap to an intersection, select the apparent intersection (A).

A
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To snap to an extended apparent intersection point

1 Choose a command, for example, line.

2 Type app and then press Enter.

3 Select an extended apparent intersection point.

The Extended Apparent Intersection Snap turns off automatically after you select a 
point.

Quick Snap command
Normally, an entity snap searches all the entities crossing the target and selects the 
one closest to the center of the target. Use the Quick Snap command to modify the 
current entity snap so that the program stops searching for the snap point as soon as it 
finds one entity with at least one point of the current entity type.    

To set the Quick Snap    

• Type quick and then press Enter.

Clear Entity Snaps tool
Use the Clear Entity Snaps tool to turn off all entity snap settings, regardless of how 
they were set: by menu, tool, command, or in the Drawing Settings dialog box.

To set Clear Entity Snaps

Do one of the following:

• Choose Format > Entity Snap > All Entity Snaps Off.

• On the Object Snaps toolbar, click Snaps to None tool ( ).

• Type none and then press Enter.

Using fly-over snapping 

Fly-over snapping is a visual aid to help you see and use entity snaps more efficiently. 
When the Fly-over snapping option is set, AViCAD will display a colored marker at 
matching entity snap points as you move the crosshairs around the drawing. 
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Each entity snap has its own type of marker. 

When Fly-over snapping is enabled and multiple entity snaps are on, you can press 
TAB to cycle through the available entity snap points of the entities covered by the 
target box. For example, when the Endpoint and Midpoint snaps are set and the aper-
ture box is on a line, pressing TAB will cycle between the line's closest endpoint and 
midpoint.

Fly-over snap markers    

Marker Entity snap

Endpoint Snap

Nearest Snap

Midpoint Snap

Center Snap

Perpendicular Snap

Tangent Snap

Quadrant Snap

Insertion Snap

Point Snap

Intersection Snap

Apparent Intersection Snap
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To set the Fly-over snapping option 

1 Do one of the following:

• Choose Tools > Drawing Settings.

• Choose Format > Entity Snap > Entity Snap Settings.

• Type settings and then press Enter.

2 Click the Coordinate Input tab.

3 Click Fly-Over. The Options dialog box opens to the Snapping tab. 

4 Mark Enable Fly-Over Snapping to turn on fly-over snapping. 

5 Set the fly-over options, including the color, size, and thickness of the snap 
marker. 

6 Click OK. 

7 Click OK again. 

NOTE For details about the various fly-over snapping options, see “Changing the 
options on the Snapping tab” on page 600. 

Etrack Snap tracking

It’s possible to select a point among a path based on object snap.

The pointing is used in running object snap mode. Before using the pointing from an 
object snap point it’s necessary to set an object snap.

The acquired points are marked by a small sign (+), up to seven points each time. 
After having acquired a point, when the cursor is moved, are used alignment horizon-
tal and vertical trajectories.

To set On or Off Etrack tracking

Push the button in the status bar.

NOTE The function is active when the button appears as recessed. 

Etrack button (A)

A
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To acquire a point

1 Make sure that the button Etrack, placed in the status bar is set as On.

• It’s possible to change the Etrack setting by pushing the related button on the 
status bar.

2 Set at least an object snap.

3 Start a command that asks for the acquisition of a point.

4 Move the cursor on an existing object (or on more then one in relation to the type 
of snap chosen) until it’s displayed the related symbol that indicates the acquire-
ment of the snap.

5 By keeping the cursor steady for a few moments, it will be displayed the sign +.

6 By moving the cursor among one of the direction of the + sign, some trajectories 
will be hatched among which it’s possible to scroll the pointer until the desired 
point will be acquired by clicking on the mouse left button.

NOTE To toggle etrack settings on and off at any time, click the ETRACK button on 
the status bar or press F11.     

Polar Snap tracking

During the creation or modification of the objects, it’s possible to use the polar Point-
ing to view the temporary alignment trajectories defined by the specified polar angles 
and execute the snap of the distances specified among the alignment trajectory.

To set On or Off  Polar Tracking

Push the button in the status bar.

Exsisting object Acquired point Path for the acquired point
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NOTE The function is active when the button appears as recessed. 

To set the polar pointing angles

1 Do one of the following:

• Choose Tools > Drawing Settings, tab Coordinate Input and then in Change 
settings for select Polar Snap.

• On the status bar on the Polar button, click the mouse right button then choose 
Setting.

2 In the list increasing Angle, select the polar pointing angle.

3 To set additional pointing angles, select Additional Angle. Click on New and digit 
the angle value in the text box.

4 In the section Polar Angle Measurement, specify if the polar pointing increments 
are based on UCS or are related to the last object created.

5 Choose Ok button.

To acquire a point with Polar

1 Make sure that the Polar button, placed on the status bar, is set as On.

• It’s possible to change the Polar setting by pushing the related button on the 
status bar.

2 Lay down the setting desired for the point acquirement, see “To set the polar 
pointing angles” on page 83 in this chapter. 

3 Start a drawing or change command.

4 After having specified the first point, while the cursor it’s mowed to the following 
point/points, note the hatched polar pointed line displayed in correspondence to 
the pointing angles set. Now it’s possible to proceed in one of the following ways:

• Click on the mouse left button to specify the desired point on the trajectory.

• Digit a distance when the trajectory gets sketched and press Enter.

Polar button (A)

A
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ATTENTION The specified points are conformed to the polar pointing angle while 
the line is displayed as hatched.

NOTE To toggle polar settings on and off at any time, click the POLAR button on the 
status bar or press F10.     

Saving your drawing    

When you save a drawing, your work is saved in a drawing (.dwg) file. 

After you have saved your drawing for the first time, you can save it with a new 
name. In addition to drawing (.dwg) files, you can also save a drawing in a Drawing 
Exchange Format (.dxf) file or a drawing template (.dwt) file. 

If you created your drawing using a template, saving the drawing does not alter the 
original template.

If you need an added level of security for your drawing files, you can save the draw-
ing with a password so only you and those who know the password can open the 
drawing.

Before proceeding to the drawing saving you can remove not used items in the draw-
ing as blocks, layers, line types, text styles and dimension style. Deleting these items 
you can significantly reduce the file size. 

To purge the items not used in the drawing

1 Do one of the following: 

• Choose File > Utility > Purge.

• Type purge and then press Enter.

Acquired point. Point on the path.
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Using the option buttons above the Items List window, you choose if you want to dis-
play the items that you can purge (items not used) or if you want to display those that 
you cannot purge. 
In the Item List area you can view the items that can be purged divided into catego-
ries. The plus symbol next to group names indicates that there are objects you can 
purge. 
Linetypes definitions are purged only from the current drawing, the definition in the 
file icad.lin remains unchanged. 
If you mark the check box Confirm each item to be purged, you will be asked to con-
firm before purging the items.  

• Purge nested items: removes all the unused named objects from the drawing even 
if they are contained within or referenced by other unused named objects. The 
Confirm Purge dialog box is displayed and you can cancel or confirm the items to 
be purged. 

• Nested Blocks: for example, you create a block from a circle and insert two 
instances of this block in the drawing.  Next, you create a new block that consists 
of two previous circle blocks: in this way you will have a nested block in your 
drawing.     Marking the check box Purge nested items you can purge in one ses-
sion even nested blocks. It is recommended to leave active the position Confirm 
each item to be purged in order to be able to verify the blocks to be purged.

• Purge: purges the selected items.

• Purge All: purges all the unused items.
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NOTE:  If you want to purge objects by means of the command line without using the 
command dialog box, type –purge and then press Enter.

Saving a drawing
To save a drawing, choose any of the following methods:

• Choose File > Save.

• On the Standard toolbar, click Save ( ).

• Type save and then press Enter.

• Type qsave and then press Enter.

TIP When you save a drawing the first time, the program displays the Save Drawing 
As dialog box so that you can choose a directory and type a name for the drawing. 
You can use any name when you first save the drawing. 

A Displays a description of the file size, creation 
date, and other information about the drawing.

B Unavailable when saving drawings; available 
only when opening drawings.

C Turns the drawing preview on or off.

D Saves the drawing with a password.

E Displays an image of the drawing before you 
save it.     

A

B
C

E

D
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Saving a drawing with a new name or file format
You can save a drawing with a new name and in any of the following file formats:

• Standard drawing files with a .dwg extension. You can choose a .dwg file format 
that is compatible with various versions of AutoCAD.

• Drawing Exchange Format files with a .dxf file extension. You can choose a .dxf 
file format that is compatible with various versions of AutoCAD.

• Drawing templates with a .dwt file extension. Drawing templates allow you to eas-
ily create new drawings that reuse your drawing settings and entities.

To save a drawing with a new name or file format 

1 Do one of the following: 

• Choose File > Save As.

• Type saveas and then press Enter.

2 In the Save Drawing As dialog box, under Save As Type, choose the file format.

3 Specify the name of the file you want to create.

4 Click Save.

TIP You can also export drawing files to various file formats. For more details, see 
“Exporting drawings” on page 554. 

Saving a drawing with a password
Sometimes drawings may contain confidential information and you want to control 
who has access to that information. If you need an added level of security, you can 
save a drawing with a password so only you and those who know the password can 
open the drawing.

To save a drawing with a password, you must save it in the DWG 2004, or later,draw-
ing (.dwg) file format.

NOTE If you forget a drawing’s password, the drawing cannot be opened or recov-
ered. You may want to store all passwords in a safe place.
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To save a drawing with a password

1 Do one of the following: 

• Choose File > Save As.

• Type saveas and then press Enter.

2 In the Save Drawing As dialog box, under Save As Type, choose a DWG format 
that is 2004 or later.

3 Click Password Protect.

4 Choose a folder where you want to save the drawing.

5 In File Name, specify the name of the file you want to create.

6 Click Save.

7 In the Password dialog box, enter a password.

8 If desired, record and store the password in a safe place. If you forget the draw-
ing’s password, the drawing cannot be opened or recovered.

9 Click OK.
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Creating simple entities  

With AViCAD®, simple entities include lines (both finite and infinite), circles, arcs, 
ellipses, elliptical arcs, points, and rays. In addition, AViCAD includes a freehand 
sketch tool. Entities drawn freehand are also considered to be simple entities.

This chapter explains how to create simple entities using the different ways that you 
can start the drawing command for each, including how to:

• Use menu commands on the Draw menu.

• Use the tools on the Draw toolbar.

• Type commands in the command bar.

In some cases, there are a number of different ways to create an entity. For the most 
part, one or two are given here. Refer to the online Help to learn how to create entities 
using other methods.

When you use a tool or a drawing command, the program prompts you to enter coor-
dinate points, such as endpoints or insertion points. You can enter the points or dis-
tances either using a mouse or by typing coordinate values at the command prompt. 
As you draw, AViCAD also displays a context-sensitive prompt box with appropriate 
additional options for the type of entity you are drawing.

After you create entities, you can modify them using the entity modification tools.

Topics in this chapter

Drawing lines ...................................................................................................... 90

Drawing circles ................................................................................................... 91

Drawing arcs....................................................................................................... 93

Drawing ellipses.................................................................................................. 95

Drawing elliptical arcs ......................................................................................... 96

Creating point entities ......................................................................................... 97

Drawing rays ....................................................................................................... 99

Drawing infinite lines......................................................................................... 100

Creating freehand sketches.............................................................................. 101
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Drawing lines

A line consists of two points: a start point and an endpoint. You can connect a series 
of lines, but each line segment is considered a separate line entity.  

To draw a line

1 Do one of the following:

• Choose Draw > Line.

• On the Draw toolbar, click the Line tool ( ).

• Type line and then press Enter.

2 Specify the start point.

3 Specify the endpoint.

4 In the prompt box, choose Done to complete the command.

The prompt box provides several options as you draw. For example, when you draw 
the first line segment, you can specify its length or orientation angle. After you draw 
at least one line segment, you can click Undo to remove the previous line segment. 
You can click Done to end the line command. After you draw two or more line seg-
ments, you can click Close to complete the line command by drawing a line segment 
that connects to the start point of the first line segment you drew.

If the last entity you drew was an arc, you can also draw a line tangent to and starting 
from the endpoint of the arc.

To draw a line as a continuation from the end of an arc 

1 Do one of the following:

• Choose Draw > Line.

• On the Draw toolbar, click the Line tool ( ).

• Type line and then press Enter.

2 In the prompt box, choose Follow.

3 Specify the length of the line.

Start point (A) and endpoint (B).

A
B
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Drawing circles

The default method for drawing a circle is to specify a center point and radius. You 
can draw circles using any of the following methods:         

• Center-Radius ( )

• Center-Diameter ( ) 

• Two points ( ) 

• Three points ( )

• Radius-Tangent-Tangent ( ) 

• Convert Arc to Circle ( )

To draw a circle by specifying its center and radius 

1 Do one of the following: 

• Choose Draw > Circle > Center, Radius.

• On the Draw toolbar, click the Circle Center-Radius tool ( ).

• Type circle and then press Enter.

2 Specify the center point.

3 Specify the radius of the circle.

Endpoint of previous arc (A) and length of the line (B).

A

B

Center point (A) and radius (B).

A
B
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To draw a circle tangent to existing entities

1 Do one of the following: 

• Choose Draw > Circle > Tan, Tan, Radius.

• On the Draw toolbar, click the Circle Radius-Tangent tool ( ).  
Go to step 3.

• Type circle and then press Enter.

2 In the prompt box, choose Radius-Tangent-Tangent.

3 Specify the radius of the circle.

4 Select the first entity to which to draw the circle tangent.

5 Select the second entity to which to draw the circle tangent.

To convert an arc to a circle

1 Do one of the following: 

• On the Draw toolbar, click the Convert Arc to Circle tool. ( ).  
Go to step 3.

• Type circle and then press Enter.

2 In the prompt box, choose Turn Arc Into Circle.

3 Select the arc you want to convert to a circle. 

Radius of circle (A) and tangent lines (B) and (C).

Select an arc (A) to convert to a circle.

A

B

C

A
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Drawing arcs

An arc is a portion of a circle. The default method for drawing an arc is to specify 
three points—the start point, a second point, and the endpoint. You can draw arcs 
using any of the following methods:                                                

• Three points on an arc ( ).

• Start point-center-endpoint ( ), or Start point-endpoint-center ( ), or Center-
start point-endpoint ( ).

• Start point-center-included angle ( ), or Start point-included angle-center 
( ), or Center-start point-included angle ( ).    

• Start point-center-chord length ( ), or Center-start point-chord length ( ).   

• Start point-endpoint-radius ( ), or Start point-radius-endpoint ( ). 

• Start point-endpoint-included angle ( ), or Start point-included angle-endpoint 
( ).

• Start point-endpoint-starting direction ( ), or Start point-starting direction-end-
point ( ).

• Start point-radius-angle ( ).

• As a tangent continuation of the previous arc or line ( ).

To draw an arc by specifying three points

1 Do one of the following:

• Choose Draw > Arc > 3 Points.

• On the Draw toolbar, click the 3-Point Arc tool ( ).

• Type arc and then press Enter.

2 Specify the start point.

3 Specify a second point.

4 Specify the endpoint.

Start point (A), second point (B), and endpoint (C).

A

B
C
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The prompt box provides additional options for drawing arcs. For example, after you 
specify the start point of an arc, you can choose Angle, Center, Direction, Endpoint, 
or Radius. You can select the options in a different order as well. For instance, you 
can draw an arc by specifying its start point, endpoint, and radius, or you can specify 
the start point, radius, and then endpoint.

To draw an arc by specifying its start point, center point, and endpoint

1 Do one of the following: 

• Choose Draw > Arc > Start, Center, End.

• On the Draw toolbar, click the Arc Start-Center-End tool ( ).

• Type arc and then press Enter.

2 Specify the start point.

3 In the prompt box, choose Center.

4 Specify the center point.

5 Specify the endpoint.

To draw an arc by specifying two points and an included angle     

1 Do one of the following:

• Choose Draw > Arc > Start, End, Angle.

• On the Draw toolbar, click the Arc Start-End-Angle tool ( ).

• Type arc and then press Enter.

2 Specify the start point.

3 In the prompt box, choose Angle or type angle and insert a value.

4 To draw an arc in a counterclockwise direction, enter a positive value for the 
included angle.

To draw an arc in a clockwise direction, enter a negative value for the included 
angle.

5 Specify the endpoint.

Start point (A), center point (B), and endpoint (C).

A

B

C
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If the last entity you drew was an arc or a line, you can also draw an arc tangent to and 
starting from the endpoint of the arc or line.

To draw an arc tangent to an arc or line 

1 Do one of the following:

• On the Draw toolbar, click the Tangent Arc tool ( ). Go to step 3.

• Type arc and then press Enter.

2 In the prompt box, choose Follow.

3 Specify the endpoint.

NOTE To convert an arc to a circle, on the Draw toolbar, click the Convert Arc To 
Circle flyout tool ( ).

Drawing ellipses

The default method for drawing an ellipse is to specify the endpoints of one axis of 
the ellipse, and then specify a distance representing half the length of the second axis. 
The endpoints of the first axis determine the orientation of the ellipse. The longer axis 
of the ellipse is called the major axis, and the shorter one is the minor axis. The order 
in which you define the axes does not matter. The program determines the major and 
minor axes based on their relative lengths. You can draw ellipses using any of the fol-
lowing methods:  

Start point (A), endpoint (B), and included angle (C).

A
B

C

Endpoint (A).

A
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• Axis-axis ( )

• Axis-rotation ( )

• Center-axis ( ) 

• Center-rotation ( )

To draw an ellipse by specifying the axis endpoints

1 Do one of the following: 

• Choose Draw > Ellipse > Axis, End.

• On the Draw toolbar, click the Ellipse Axis-Axis tool ( ).

• Type ellipse and then press Enter.

2 Specify the first endpoint.

3 Specify the second endpoint. 

4 Specify the half-length of the other axis.

Drawing elliptical arcs

An elliptical arc is a portion of an ellipse. The default method for drawing an ellipti-
cal arc is to specify the endpoints of one axis of the ellipse, and then specify a dis-
tance representing half the length of the second axis. Then you specify the start and 
end angles for the arc, measured from the center of the ellipse in relation to its major 
axis. You can draw elliptical arcs using any of the following methods: 

• Axis-axis ( ) 

• Axis-rotation ( )

• Center-axis ( ) 

• Center-rotation ( )

First axis endpoint (A), second axis endpoint (B), and half-length of other axis (C).

A
C

B
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To draw an elliptical arc by specifying the axis endpoints

1 Do one of the following:

• Choose Draw > Ellipse > Arc.

• On the Draw toolbar, click the Elliptical Arc Axis-Axis tool ( ).

• Type ellipse and then press Enter, and then type a (for Arc) and press Enter.

2 Specify the first endpoint.

3 Specify the second endpoint.

4 Specify the half-length of the other axis.

5 Specify the start angle of the arc.

6 Specify the end angle.

NOTE AViCAD draws elliptical arcs in the direction you specify. Go to Tools > 
Drawing Settings > Drawing Units tab. Under Change Settings For, select Angular 
Units. The default setting is counterclockwise.

Creating point entities

You can draw a point entity formatted as either a single dot or as one of 19 other pos-
sible display styles.        

To draw a point

1 Do one of the following:

• Choose Draw > Point > Single Point.

• On the Draw toolbar, click the Point tool ( ).

• Type point and then press Enter.

2 Specify the location of the point.

First axis endpoint (A), second axis endpoint (B), half-length of other axis (C), start angle of arc (D), and 
end angle (E).

A

D

C
E

B
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To draw several points

1 Do one of the following:

• Choose Draw > Point > Single Point.

• On the Draw toolbar, click the Point tool ( ).

• Type point and then press Enter.

2 In the prompt box, choose Multiple Points.

3 Specify the location of each point.

4 In the prompt box, choose Done to complete the command.

Changing the size and appearance of point entities
Changing the size and appearance of point entities affects all point entities already in 
the drawing, as well as all points that you subsequently draw. Positive values repre-
sent the absolute size of the point entity measured in drawing units. Negative values 
represent a percentage relative to the drawing screen, so that points retain their visual 
size as you use the Zoom command to change the magnification of the drawing.

To change the size and appearance of point entities

1 Do one of the following: 

• Choose Tools > Drawing Settings.

• Type settings and then press Enter.

2 Click the Entity Creation tab.

3 Under Change Settings For, click Points.

4 Under Point Display Type, select the style you want.

5 Under Point Size, select the point size, or choose one of the options.

6 Click OK.

When you regenerate the drawing, all point entities change to reflect the new size and 
appearance settings. 
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Drawing rays

A ray is a line in three-dimensional space that starts at a point and extends to infinity. 
Because rays extend to infinity, they are not calculated as part of the drawing extents. 
The default method for drawing a ray is to select the start point of the ray and then 
specify its direction. You can draw a ray in any of the following ways:

• Horizontal draws the ray parallel to the x-axis of the current user coordinate sys-
tem (UCS). 

• Vertical draws the ray parallel to the y-axis of the current UCS.

• Angle draws the ray parallel to a specified angle.

• Bisect draws the ray perpendicular to an existing entity.

• Parallel draws the ray parallel to an existing entity.

A To increase or decrease the point size, type a 
value or click one of the point size arrows. 

B To use one of the preset point size options, click 
the one that you want.

C Select the button for the Point Display Type that 
you want.

A

B

C
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To draw a ray

1 Do one of the following:

• Choose Draw > Ray.

• On the Draw toolbar, click the Ray tool ( ).

• Type ray and then press Enter.

2 Specify the start point.

3 Specify the direction.

4 To complete the command, press Enter.

Drawing infinite lines

Infinite lines are sometimes referred to as construction lines. An infinite line is a line 
through a given point, oriented at a specified angle in three-dimensional space and 
extending to infinity in both directions. Because infinite lines extend to infinity, they 
are not calculated as part of the drawing extents.  

The default method for drawing an infinite line is to select a point along the line and 
then specify the direction of the line. You can draw an infinite line in any of the fol-
lowing ways:

• Horizontal draws the infinite line parallel to the x-axis of the current UCS. 

• Vertical draws the infinite line parallel to the y-axis of the current UCS.

• Angle draws the infinite line parallel to a specified angle.

• Bisect draws the infinite line perpendicular to an existing entity.

• Parallel draws the infinite line parallel to an existing entity.

To draw an infinite line

1 Do one of the following:   

• Choose Draw > Construction Line.

• On the Draw toolbar, click the Infinite Line tool ( ).

• Type infline and then press Enter.

2 Specify a point along the line.

3 Specify the direction.

4 To complete the command, press Enter.

Start point (A) and direction (B).

A B
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.

You can also draw infinite lines at a specific angle or at an angle relative to an exist-
ing entity.

To draw an infinite line at a specified angle relative to another entity

1 Do one of the following:

• Choose Draw > Construction Line.

• On the Draw toolbar, click the Infinite Line tool ( ).

• Type infline and then press Enter.

2 In the prompt box, choose Angle.

3 In the prompt box, choose Reference.

4 Select the reference entity.

5 Specify the angle of the infinite line in relation to the selected entity.

6 Specify the location of the infinite line.

7 To complete the command, press Enter.

Creating freehand sketches

A freehand sketch consists of many straight line segments, created either as individ-
ual line entities or as a polyline. Before you begin creating a freehand sketch, you 
must set the length, or increment, of each segment. The smaller the segments, the 
more accurate your sketch, but segments that are too small can greatly increase the 
file size.   

Point along the infinite line (A) and the direction (B).

Reference entity (A) and angle in relation to entity (B).

A
B

A B
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After you specify the length of the sketch segments, the crosshairs change to a Pencil 
tool. Your freehand sketch is not added to the drawing until you “write” the sketch 
into your drawing. This means that you temporarily save the segment that you’ve 
drawn and the segment length, and you can continue sketching. 

To create a freehand sketch

1 Do one of the following: 

• Choose Draw > Freehand.

• Type freehand and then press Enter.

2 Specify the length of the sketch segments.

3 Click the mouse button to place the Pencil tool ( ) on the drawing to begin 
sketching.

4 Move the pencil image to draw a temporary freehand sketch.

5 Click the mouse button to lift the pencil up to stop sketching.

6 In the prompt box, choose Write, Then Resume to write the temporary freehand 
sketch into the drawing.

7 Click the mouse button to put the pencil down again and resume sketching.

8 Click the mouse button again to lift the pencil up to stop sketching.

9 In the prompt box, choose Done to write the temporary freehand sketch into the 
drawing and end the command.

Erasing freehand sketch lines
You can erase temporary freehand sketch lines that have not yet been written into the 
drawing by choosing the Delete On option in the prompt box. The pencil changes to 
an Eraser tool. You can erase portions of the line when you move the eraser over a 
temporary freehand line without clicking the mouse button.

To erase freehand sketch lines

1 Do one of the following:

• Choose Draw > Freehand.

• Type freehand and then press Enter.

2 Specify the length of the sketch segments.

3 Select a point on the drawing to display the Pencil tool and begin sketching.

4 Click the mouse button to lift the pencil up to stop sketching.

A freehand sketch consists of individual line entities or a polyline.
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5 In the prompt box, choose Delete On.

6 Move the Eraser tool ( ) to the beginning or end of the freehand sketch line that 
you drew, and then move it as far along the line as you want to erase.

7 Click the mouse button to put the Pencil tool down to resume sketching.

Setting the sketch method and accuracy
Using polylines for freehand sketches makes it easier to go back and edit sketches. 
You control whether to create freehand sketches using line segments or polylines in 
the Drawing Settings dialog box. You can also control the length of sketch segments 
in this dialog box. 

To specify lines or polylines when sketching

1 Do one of the following:

• Choose Tools > Drawing Settings.

• Type settings and then press Enter.

2 Choose the Entity Creation tab.

3 Under Change Settings For, click Freehand Sketches.

4 Under Freehand Sketching Methods, click either Freehand Command Creates 
Lines or Freehand Command Creates A Polyline.

5 Click OK. 

A Select the sketch method. B Specify the default length of sketch segments.

A

B
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Creating complex entities

With AViCAD®, complex entities include polylines (including rectangles and poly-
gons), spline curves, donuts, and planes. In addition, AViCAD includes tools for add-
ing hatching to your drawings.  

This chapter explains how to create complex entities using the different ways that you 
can start the drawing command for each, including how to:

• Use menu commands on the Draw menu.

• Use the tools on the Draw toolbar.

• Type commands in the command bar.

When you type a drawing command or select a tool, the program prompts you to 
enter coordinate points, such as endpoints or insertion points. As you draw, the pro-
gram displays a context-sensitive prompt box with appropriate additional options for 
the type of entity you are drawing.

After you create complex entities, you can modify them using the entity-modification 
tools. Several of these entity types require special editing commands. 

Topics in this chapter

Drawing rectangles ........................................................................................... 106

Drawing polygons ............................................................................................. 107

Drawing polylines.............................................................................................. 109

Drawing double line .......................................................................................... 111

Drawing splines ................................................................................................ 113

Drawing donuts................................................................................................. 115
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Drawing wipeouts ............................................................................................. 118

Creating boundary polylines ............................................................................. 120

Adding hatching................................................................................................ 123
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Drawing rectangles

With AViCAD, rectangles are closed polylines with four sides. You draw a rectangle 
by specifying its opposite corners. The rectangle is normally aligned parallel to the 
current snap and grid alignment, but you can use the Rotated option to align the rect-
angle to any angle.    

To draw a rectangle

1 Do one of the following:

• Choose Draw > Rectangle.

• On the Draw toolbar, click the Rectangle tool ( ).

• Type rectangle and then press Enter.

2 Specify one corner of the rectangle.

3 Specify the opposite corner of the rectangle.    

You can edit each side of a rectangle individually using the Edit Polyline tool in the 
Modify > Object menu. You can convert the sides into individual line entities using 
the Explode tool ( ) on the Modify toolbar. You can control whether wide rectan-
gle lines are shown filled or as outlines using the Fill tool in the Format menu. 

You can also use the Rectangle tool to draw a square. Instead of specifying the oppo-
site corners, you specify the length of one side and the alignment of the square. 

To draw a square     

1 Do one of the following:

• Choose Draw > Rectangle.

• On the Draw toolbar, click the Rectangle tool ( ).

• Type rectangle and then press Enter.

2 In the prompt box, choose Square.

3 Specify one corner of the square.

4 Specify the length of one side of the square by selecting its other end.

The point you specify determines both the size and alignment of the square.

Opposite corners (A and B). Resulting rectangle.

A
B
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NOTE To control the width of the rectangle line, choose the Width Of Line option in 
the prompt box. After you change the width of the line, the new width setting remains 
in effect for subsequent rectangles until you change it again. 

Drawing polygons

Polygons are closed polylines composed of a minimum of three and a maximum of 
1,024 equal-length sides. The default method for drawing a polygon is to specify the 
center of the polygon and the distance from the center to each vertex. You can draw a 
polygon using any of the following methods: 

• Center - Vertex ( ) on the Draw toolbar

• Center - Side ( ) on the Draw toolbar

• Edge ( ) on the Draw toolbar

The vertex polygon drawing method creates an equal-sided polygon defined by its 
center point and the distance to its vertices. You specify the number of sides, the cen-
ter point, and the location of one vertex, which determines both the size and orienta-
tion of the polygon.

To draw a polygon by vertex     

1 Do one of the following:

• Choose Draw > Polygon.

• On the Draw toolbar, click the Polygon, Center-Vertex tool ( ).

• Type polygon and then press Enter.

2 Type 5 to specify five sides for the polygon.

3 Specify the center of the polygon.

4 Specify the vertex of the polygon.  

Endpoints of one side of the square (A and B). Resulting square.

A

B
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Drawing polygons by side
The side polygon drawing method creates an equal-sided polygon defined by its cen-
ter point and the distance to the midpoint of a side. You specify the number of sides, 
the center point, and the location of the midpoint of one side, which determines both 
the size and orientation of the polygon.

To draw a polygon by side    

1 Do one of the following:

• Choose Draw > Polygon.

• On the Draw toolbar, click the Polygon, Center-Side tool ( ).

• Type polygon and then press Enter.

2 Type 3 to specify three sides for the polygon.

3 Specify the center of the polygon.

4 In the prompt box, choose Specify By Side, and then press Enter.

5 Specify the midpoint of the side.
 

You can edit each side of a polygon individually using the Edit Polyline tool in the 
Modify > Object menu. You can convert the sides into individual line entities using 
the Explode tool ( ) on the Modify toolbar. You can control whether wide polygon 
lines are shown filled or as outlines using the Fill tool in the Format menu.               

The center (A) and vertex (B).                      Resulting polygon.

The center (A) and midpoint of one side (B). Resulting polygon.

A
B

A
B
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Drawing polylines    

With AViCAD, a polyline is a connected sequence of arcs and lines that is treated as 
a single entity. You can draw a polyline with any linetype and using a width that 
either remains constant or tapers over the length of any segment. When editing a 
polyline, you can modify the entire polyline or change individual segments.      

After you specify the start point of a polyline, a prompt box provides several options 
as you draw, such as Distance, Halfwidth, and Width. You can specify different start-
ing and ending widths to create a tapered polyline segment.      

After you draw at least one polyline segment, you can use the Undo tool ( ) to 
remove the previous segment. After you draw two or more polyline segments, you 
can use the Close option to complete the command by drawing a segment that ends at 
the start point of the first polyline segment you drew. Choose Done to complete the 
command without closing the polyline.               

To draw a polyline with straight segments

1 Do one of the following:

• Choose Draw > Polyline.

• On the Draw toolbar, click the Polyline tool ( ).

• Type polyline and then press Enter.

2 Specify the start point.

3 Specify the endpoint of each segment.

4 To complete the command, choose Close or Done.

Curved polyline with tapered width. Polyline with straight  
segments.

Closed polyline.

Polyline start point (A) and segment endpoints (B).

A

B

B

B

B
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With the Draw Arcs option, you can continually draw arc segments until you select 
the Draw Lines option to go back to drawing line segments. When you draw arc seg-
ments, the first point of the arc is the endpoint of the previous segment. By default, 
you draw arc segments by specifying the endpoint of each segment. Each successive 
arc segment is drawn tangent to the previous arc or line segment. If you choose Close 
while in the Draw Arcs option, the closing segment is created as an arc. 

You can also specify the arc using any of the following methods: 

• Start point, included angle, center point

• Start point, included angle, radius

• Start point, center point, endpoint

• Start point, included angle, endpoint

• Start point, center point, included angle

• Start point, center point, chord length

• Start point, direction, endpoint

• Start point, radius, included angle

• Start point, second point, endpoint

To draw a line segment followed by an arc polyline segment

1 Do one of the following: 

• Choose Draw > Polyline.

• On the Draw toolbar, click the Polyline tool ( ).

• Type polyline and then press Enter.

2 Specify the start point.

3 Specify the endpoint.

4 In the prompt box, choose Draw Arcs.

5 Specify the endpoint of the arc segment.

6 To complete the command, choose Done.

You can edit entire polylines and individual segments using the Edit Polyline tool in 
the Modify > Object menu. You can convert polylines into arc and line entities using 
the Explode tool ( ) on the Modify toolbar. You can control whether wide 
polylines are shown filled or as outlines using the Fill tool in the Format menu. 

Polyline start point (A), line endpoint/arc start point (B), and arc endpoint (C).

A
B

C



C R E A T I N G  C O M P L E X  E N T I T I E S    111

Drawing double line

A double line is made from two parallel lines, which consist of linear segments con-
nected together. The end of the current segment is the start of the next segment. Ends 
of segments are the vertices of the multiline. 

To draw a double line

1 Do one of the following: 

• Choose Draw > Dline. 

• Type dline and then press Enter. 

2 Specify the width of the trace. 

3 Specify the start point. 

4 Specify additional vertices. 

5 After specifying the last endpoint, choose Done or press Enter. 

Drawing traces 

With the Trace command, you can draw a two-dimensional solid line of specified 
width. 

To draw a trace

1 Do one of the following: 

• Choose Draw > Trace. 

• Type trace and then press Enter. 

2 Specify the width of the trace. 

3 Specify the start point. 

4 Specify additional vertices. 

5 After specifying the last endpoint, choose Done or press Enter. 

Drawing a revision clouds

The revision cloud consists of a series of consecutive arcs of a polyline. It is used to 
draw attention to certain parts of a drawing during its revision. 
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Revising your drawings it is possible to use the Revision cloud command to mark out 
your revisions. REVCLOUD creates a polyline of consecutive arcs making up an 
object in a cloud shape.  

It is possible to set arc length values for a revision cloud. REVCLOUD stores the last 
used arc length.

To create a Revision cloud

1 Do one of the following: 

• Select Draw > Revision cloud.

• On the Draw toolbar, click the Revision cloud icon.

• Type revcloud and then press Enter.

2 Drag the crosshairs along the path of a cloud. 

3 When the start and end lines meet, the following prompt will appear: Cloud fin-
ished. As a result we get a polyline object.  

Arc Length
The Arc length option allows to specify arcs length in a revision cloud.  

To modify arcs length of a revision cloud

At the prompt: Arc length/<Pick cloud starting point>: type a and enter a new arc 
length 

To create a revision cloud

1 Do one of the following: 

• Select Draw > Revision cloud.

• On the Draw toolbar, click the Revision cloud icon.

• Type revcloud and then press Enter.

2 Specify a new arc length or the start point of the revision cloud. The default arc 
length is automatically set according to the drawing units. 

3 Drag the crosshairs to draw a cloud. 

4 Left click of the mouse at any time interrupts drawing of a revision cloud. Return 
to the start point to close the revision cloud.
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Drawing splines    

A spline is a smooth curve defined by a set of points. You can use splines to create 
sculptured shapes such as the cross section of a turbine blade or an airplane wing.            

To draw a spline      

1 Do one of the following:

• Choose Draw > Spline.

• On the Draw toolbar, click the Spline tool ( ).

• Type spline and then press Enter.

2 Specify the first point of the spline.

3 Specify the second point of the spline.

4 Specify as many more points as you want.

5 When you have finished, press Enter.

You can add tangents to the spline, which are lines that give it shape.

To add tangents to a spline

1  Specify the starting tangent point.

2 Specify the ending tangent point.

Specifying fit tolerance
By default, a spline passes through all of the control points. When you draw a spline, 
you can change this by specifying the fit tolerance. The fit tolerance value determines 
how closely the spline fits the set of points you specify. For example, a spline fit tol-
erance value of 0 causes the spline to pass through the control points. A value of 0.01 
creates a spline that passes through the start and endpoints and within 0.01 units of 
the intermediate control points. 

Spline.                                                                      Spline with starting tangent point (A) and ending tangent 
point (B).

A B
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To specify the fit tolerance

1 Do one of the following:

• Choose Draw > Spline.

• On the Draw toolbar, click the Spline tool ( ).

• Type spline and then press Enter.

2 Specify the first point of the spline.

3 Specify the second point of the spline.

4 In the prompt box, choose Fit Tolerance.

5 To accept the default of 0.0000, press Enter.

To specify a different fit tolerance, type the number, and then press Enter.

6 Specify the additional points you need to draw a spline or a closed spline.

Drawing a closed spline
You can draw a closed spline, which is a spline for which the start point and endpoint 
are the same. Because the spline is closed, you specify only one tangent. 

To draw a closed spline

1 Do one of the following:

• Choose Draw > Spline.

• On the Draw toolbar, click the Spline tool ( ).

• Type spline and then press Enter.

2 Specify the first point of the spline.

3 Specify the second point of the spline.

4 Specify as many more points as you want.

5 When you have finished, in the prompt box, choose Close.

6 To complete the command, specify the tangent point. 

The start point and endpoint (A) of a closed spline.

A
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Drawing donuts

Donuts are solid, filled circles or rings created as closed, wide polylines. You can 
draw a donut using one of several methods. The default method is to specify the 
inside and outside diameters of the donut, and then specify its center. You can then 
create multiple copies of the same donut by specifying different center points until 
you press Enter to complete the command.   

To draw a donut

1 Do one of the following:

• Choose Draw > Donut.

• Type donut and then press Enter.

2 Specify the inside diameter of the donut.

3 Specify the outside diameter of the donut.

4 Specify the center of the donut.

5 Specify the center point to draw another donut, or choose Done to complete the 
command.

The prompt box provides additional options for drawing donuts. For example, you 
can specify the width of the donut and two points on the diameter of the donut, or you 
can specify the width and three points on the donut. You can also draw a donut tan-
gent to existing entities.    

NOTE A donut can be a completely filled circle by specifying an inside diameter of 
zero.

Inside diameter (A) and outside diameter (B).

A

B
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To draw a donut tangent to existing entities

1 Do one of the following: 

• Choose Draw > Donut.

• Type donut and then press Enter.

2 In the prompt box, choose Radius Tangent Tangent.

3 Specify the width of the donut.

4 Specify the diameter of the donut.

5 Select the first tangent entity to which to draw the donut.

6 Select the second tangent entity to which to draw the donut.

You can edit donuts using the Edit Polyline tool in the Modify > Object menu. You 
can convert donuts into arc entities using the Explode tool ( ) on the Modify 
toolbar. You can control whether donuts are shown filled or as outlines using the Fill 
tool in the Format menu. 

NOTE You can control the default outside and inside diameter of donuts by choosing 
Tools > Drawing Settings, and then clicking the Entity Creation tab and choosing the 
options you want.

Creating planes    

With the Plane tool, you can draw rectangular, triangular, or quadrilateral areas filled 
with a solid color. The default method is to specify the corners of the plane. After you 
specify the first two corners, the plane is displayed as you specify the remaining cor-
ners. Specify corner points in a triangular manner. The program prompts you for the 
third point and then the fourth point. If you continue specifying points, the third- and 
fourth-point prompts toggle until you press Enter to complete the command.    

Creating planes in AViCAD is similar to the Solid command in AutoCAD.

Width (A) and diameter (B) of the donut and tangent entities (C).

A

B

C

C
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To draw a quadrilateral plane

1 Do one of the following:

• Choose Draw > Plane.

• On the Surfaces toolbar, click the 2D Solid tool ( ).

• Type plane and then press Enter.

2 Specify the first point.

3 Specify the second point.

4 Specify the third point.

5 Specify the fourth point.

6 To complete the command, press Enter.

The prompt box provides additional options for drawing planes. For example, you 
can draw rectangular, square, or triangular planes.

To draw a rectangular plane

1 Do one of the following:

• Choose Draw > Plane.

• On the Surfaces toolbar, click the 2D Solid tool ( ).

• Type plane and then press Enter.

2 Choose Rectangle.

3 Specify the first point.

4 Specify the opposite corner.

5 Specify the rotation angle.

6 To complete the command, specify the opposite corner to draw another rectangle, 
or press Enter.

After you select the first two points (A) and (B), the sequence in which you select the third (C) 
and fourth (D) points determines the shape of the resulting quadrilateral plane.

B

A
D

C

B

A D
C
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You can control whether planes are shown filled or as outlines using the Fill tool in 
the Format menu. You can convert planes into individual line entities corresponding 
to the outline of the plane using the Explode tool ( ) on the Modify toolbar.                              

Drawing wipeouts

Wipeouts are unique entities that can help you hide areas of your drawing. They dis-
play with the current background color, so the details behind the wipeout do not dis-
play or print. 
Wipeouts are similar to other entities — you can copy, mirror, array, erase, rotate, 
and scale them, and they can be used in both model space and paper space. 
If you want to print the wipeout entities located in a drawing, you must print to a ras-
ter-capable printer. Note that in some cases you may have unexpected results when 
printing drawings that contain wipeout entities, for example, if printing on colored 
paper.

NOTE If your version of AViCAD does not include raster image capability (that is, 
does not include an Image menu), wipeout entities display, but the details behind the 
wipeouts also display.

Drawing wipeouts using polygons and polylines
Wipeouts are created using existing polygons, closed zero-width polylines made up 
of only line segments, or new polylines that you draw while using the Wipeout com-
mand.

To draw a wipeout

1 Do one of the following:

• Choose Draw > Wipeout.

• Type wipeout and then press Enter.

2 Specify the start point.

3 Specify the endpoint of each segment.

4 After specifying the last endpoint, choose Done or press Enter.

Opposite corners (A and B) and rotation angle (C). Resulting plane.

A BC
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To create a wipeout using an existing polygon or polyline

1 Do one of the following:

• Choose Draw > Wipeout.

• Type wipeout and then press Enter.

2 Choose Polyline.

3 Select the closed polyline to use for the wipeout.

4 Choose one of the following:

• Yes — Creates the wipeout and deletes the polyline used to create the wipeout. 

• No — Creates the wipeout and keeps the polyline used to create the wipeout. 

Turning wipeout frames on or off
Each wipeout has a frame along its boundary. Wipeout frames can be turned on or off 
for any drawing. When wipeout frames are on, you can select and modify wipeouts. 
You may want to turn off wipeout frames when it’s time to print.

To turn wipeout frames on or off

1 Do one of the following:

• Choose Draw > Wipeout.

• Type wipeout and then press Enter.

2 Choose Frames.

3 Choose On or Off.

Drawing without wipeout. Drawing with wipeout.
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Creating boundary polylines

With the Boundary command, you can designate a specific area of a drawing for 
operations such as hatching and dimensioning. You create a boundary polyline by 
selecting an area inside a closed loop. The area you select can be bounded by a single 
closed entity or by multiple entities that intersect.

In cases where entities intersect, AViCAD interprets the boundary as the closed loop 
closest to the point specifying the area. In the following figure, for example, the area 
point selected in the rectangle results in a boundary consisting of the closed loop 
nearest the point selection, as opposed to the closed loop formed by the rectangle 
itself.         

To make boundaries more specific, you can create a boundary set. A boundary set 
specifies which entities are considered in determining the boundary path. This can 
make creating the boundary polyline faster if you are working with a complex draw-
ing.

In the following figure, the circle and triangle are the selected entities. If you select an 
area anywhere inside the circle or the triangle, the result is a polyline that bounds the 
shaded area.

Wipeout frames turned on. Wipeout frames turned off.

Selected point (A). Resulting boundary (B).

A

B
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Using islands and island detection
Islands are closed loops that reside inside other closed loops. AViCAD provides 
island-detection options so that you can specify which islands, if any, should be con-
sidered in the area selection for a boundary. 

The following figure shows a rectangular polyline with two islands. The circle is 
referred to as the outer island, and the octagon is referred to as a nested island.  

You can choose from two island-detection methods.

• Nested Islands The outer entity and all its islands are considered for the polyline.

• Ignore Islands Only the outer entity is considered for the polyline.

Selected entities (A and B).                                                                    Point specified in the selected area (C), 
which results in a new boundary 
around the shaded area.

Rectangular polyline (A) with outer island (B), with point (C) specifying the area selection, and nested island 
(D).

A

B
C

A

B

C

D
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To draw a boundary polyline

Advanced experience level

1 Do one of the following:

• Choose Draw > Boundary.

• On the Draw toolbar, click the Boundary Polyline tool ( ).

• Type boundary and then press Enter.

2 Specify the entities that you want made available for the boundary polyline by 
doing one of the following:

• Current viewport Select All Visible Entities to have all entities in the drawing 
considered when creating the boundary polyline.

• Existing set Define only specific areas to be considered when creating the 
boundary polyline, which can improve system performance if you are working 
with a complex drawing. Click Select Boundary Set. In the drawing, select the 
entities individually or by choosing a selection method from the prompt box, 
and then press Enter. The Current Selection Set option becomes selected 
automatically, which indicates that the entities you selected with the Select 
Boundary Set button will be considered when creating the boundary polyline. 

NOTE You can alternate between All Visible Entities and Current Selection Set 
without having to select entities again using the  Boundary Set button. The Cur-
rent Selection Set option uses the last set of entities you selected with the Select 
Boundary Set button.

3 Choose an island-detection option.

4 Click Add: Pick points.

5 In the drawing, click inside the area whose closed perimeter forms the boundary, 
not on the polyline itself. If desired, continue clicking inside additional closed 
perimeters.

Nested islands (A) and with ignore islands (B).

A B



C R E A T I N G  C O M P L E X  E N T I T I E S    123

6 To complete the selection, press Enter.

7 In the Boundary dialog box, click OK.

Adding hatching

When you add hatching to a drawing, AViCAD fills entities or enclosed areas with a 
pattern. You can choose a predefined hatch pattern, or you can create your own hatch 
pattern.

First you specify the hatch pattern and other options, and then you choose which enti-
ties or enclosed areas that you want to hatch.           

NOTE Hatch patterns are memory intensive and can take a considerable amount of 
time to draw and display. To improve performance, add hatching as one of the last 
steps when you create a drawing, or insert hatches on a separate layer that you can 
freeze as you continue to work on your drawing. 

A Opens the drawing area for selection of the 
enclosed areas used to create new boundary 
polylines.

B Choose to consider all visible entities when 
creating the boundary polyline. 

C Choose to use the entities you selected for the 
boundary set. (Becomes available after you click 
the Select Boundary Set button.)

D Opens the drawing area for selection of entities 
to be considered when creating the boundary 
polyline.

DB
C

A
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To open the Boundary Hatch dialog box

Do one of the following:

• Choose Draw > Hatch.

• Choose Draw > Gradient

• On the Draw toolbar, click the Hatch tool ( ).

• On the Draw toolbar, click the Gradient tool ( )

• Type bhatch and then press Enter.

Specifying a hatch pattern
A hatch pattern consists of a repeating pattern of lines, dashes, and dots. You can 
select a hatch pattern from a set of predefined patterns, or you can define a pattern of 
your own. The hatch pattern you used most recently is the default pattern the next 
time you add hatching. 

The program supplies predefined standard hatch patterns, which are stored in the 
icad.pat and icadiso.pat hatch pattern library files. You can use other external hatch 
pattern libraries, such as an office standard library, customized patterns, and libraries 
available from vendors or standards organizations. 

NOTE The icad.pat hatch pattern library files are ANSI (American National Stan-
dards Institute)-compliant patterns; the icadiso.pat hatch pattern library files are ISO 
(International Standards Organization)-compliant.

To specify a predefined hatch pattern     

1 Do one of the following:

• Choose Draw > Hatch.

• On the Draw toolbar, click the Hatch tool ( ).

• Type bhatch and then press Enter.

2 In Type list, click Predefined.

With Predefined, you can apply a scale factor to make the pattern larger or smaller 
than the default size. 

3 For Scale, enter the scale factor as a percentage of the default.

4 For Angle, enter the angle of the pattern in degrees (1-360).  
The default angle is clockwise; you can change the angle of any hatch pattern by 
entering a numerical value.

5 For ISO Pen Width, enter the pen width.

If you choose a predefined, ISO standard pattern, you can scale the pattern based 
on the ISO pen width. 

6 For the hatch origin choose an option:

• Use source hatch origin: use the current ucs origin.
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• Specified origin: allows you to choose a new origin. You can click on the 
desired origin or choose an option from Default to boundary extens. You can 
also save the new origin selecting the option Store as default origin.

7 To copy the pattern properties from an existing hatch, choose Inherit properties 
and select the hatch. If necessary, choose also a Draw order option.

8 To associate the hatch pattern to its boundary entities, select the Associative check 
box. An associative hatch updates automatically if you move any of its bound-
aries.

9 To continue, add a hatch by doing one of the following:

• Select the entities you want to add a hatch. For details, see “Selecting entities 
for hatching” on page 128 in this chapter. Begin with step 2.

• Select an area or boundary you want to add a hatch. For details, see “Selecting 
areas for hatching” on page 129 in this chapter. Begin with step 2.

To specify a user-defined hatch pattern   

1 Do one of the following:

• Choose Draw > Hatch.

• On the Draw toolbar, click the Hatch tool ( ).

• Type bhatch and then press Enter.

2 In the Type list, click User Defined.

3 For Spacing, enter the line spacing for the pattern.

4 To crosshatch the pattern, select Double check box. Cross-hatching imposes a 
copy of the specified user-defined pattern at a 90-degree angle over the first pat-
tern you defined.

5 To copy the pattern properties from an existing hatch, choose Inherit Properties, 
select a hatch pattern from a hatched entity in the drawing. You can also choose if 
copy the current origin or leave the source hatch origin.

6 To associate the hatch pattern to its boundary entities, select the Associative check 
box. An associative hatch updates automatically if you move any of its bound-
aries.

7 To continue, add a hatch by doing one of the following:

• Select the entities you want to add a hatch. For details, see “Selecting entities 
for hatching” on page 128 in this chapter. Begin with step 2.

• Select an area or boundary you want to add a hatch. For details, see “Selecting 
areas for hatching” on page 129 in this chapter. Begin with step 2.
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A Determines how the hatch will be defined.

B Determines density of hatching for Predefined 
hatch patterns.

C Sets angle of hatch in relation to entity (User 
Defined only).

D Imposes another copyof the specified pattern at 
a 90-degree angle over the first.

E Determines density of hatching for User Defined 
hatch patterns.

F Sets pen width for ISO-standard pattern.

G Sets the current ucs origin.

H allows you to choose a new origin.

I Select to update the hatch automatically if you 
move any of its boundaries.

J Select to copy an existing hatch pattern 
properties.

A

B

C

E

F

D

J

I

G
H
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To use a predefined library pattern

1 Do one of the following:

• Choose Draw > Hatch.

• On the Draw toolbar, click the Hatch tool ( ).

• Type bhatch and then press Enter.

2 From the Pattern item click on Select Pattern icon.

3 For Hatch File, select the icad.pat or icadiso.pat hatch pattern library file.

4 To select a predefined pattern, do one of the following:

• In the Patterns list, click the pattern name.

• Click the graphical representation of the hatch pattern.

5 To continue, add a hatch by doing one of the following:

• Select the entities you want to add hatching. For details, see “Selecting entities 
for hatching” on page 128 in this chapter. Begin with step 2.

• Select an area or boundary you want to add hatching. For details, see “Selecting 
areas for hatching” on page 129 in this chapter. Begin with step 2 

NOTE Hatch patterns are memory intensive and can take a considerable amount of 
time to draw and display. To improve performance, add hatching as one of the last 
steps when you create a drawing, or insert hatches on a separate layer that you can 
freeze as you continue to work on your drawing.        

A Hatch pattern library files.

B Hatch patterns listed by name.

C Hatch patterns shown graphically.

A

B

C
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Selecting entities for hatching
You can add hatching to any entity that forms a closed boundary, for example, a cir-
cle or rectangle. You can assign hatching to a single entity or several entities at the 
same time. 

To select entities for hatching

1 Do one of the following:

• Choose Draw > Hatch.

• On the Draw toolbar, click the Hatch tool ( ).

• Type bhatch and then press Enter.

2 From the Boundary Hatch dialog box, click the Boundary tab.

3 Under Island Detection Options, choose one of the following:

• Nested Islands The outer entity and all its islands are considered for hatching.

• Outer Only Only the outer entity and its outer island are considered for hatching.

• Ignore Islands Only the outer entity is considered for hatching. 

4 To keep any new entities that are created for drawing the boundary hatch, select 
the Retain Boundaries check box. Existing entities are always retained.

5 Click Add: Select objects.

6 In the drawing, click the entities to be hatched individually or by choosing a selec-
tion method from the prompt box, and then press Enter when done.

7 In the Boundary Hatch dialog box, click OK. 

Nested islands (A), with outer island (B), and with ignore islands (C).

A B C
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Selecting areas for hatching
You can add hatching to an area enclosed by selected entities to form the hatch 
boundary. The hatch is formed in the enclosed area, not the entities themselves. 

After AViCAD draws the hatch, the entire hatch is treated as a single entity and it is 
either associative or independent of the hatch boundary entities. 

A Opens the drawing area for selection of entities 
to be hatched.

B Determines how hatching interacts with islands.
C Mark the check box to keep any new entities that 

are created to draw the boundary hatch. Existing 
entities are always retained.

D (Display only) Indicates the boundary is created 
as a polyline.

E Choose to consider all visible entities when 
creating the boundary hatch.

E

C

A

D

B
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To select an area for hatching

1 Do one of the following:

• Choose Draw > Hatch.

• On the Draw toolbar, click the Hatch tool ( ).

• Type bhatch and then press Enter.

2 From the Boundary Hatch dialog box, see Island Detection and choose an  option:

• Nested Islands The outer entity and all its islands are considered for hatching.

• Outer Only Only the outer entity and its outer island are considered for hatching.

• Ignore Islands Only the outer entity is considered for hatching.

3 To keep any new entities that are created for drawing the boundary hatch, select 
the Retain Boundaries check box. Existing entities are always retained.

4 Specify the entities that you want made available for boundary hatching by doing 
one of the following:

• Current viewport Select All Visible Entities to have all entities in the drawing 
considered when creating the boundary hatch.

• Existing Set: Define only specific areas to be considered when creating the 
boundary hatch, which can improve system performance if you are working 
with a complex drawing. 

NOTE You can alternate between All Visible Entities and Current Selection Set 
without having to select entities again using the Select Boundary Set button. The Cur-
rent Selection Set option uses the last set of entities you selected with the Select 
Boundary Set button.

5 At Boundary item click Add: pick points.

6 In the drawing, click inside the closed perimeter of a boundary, not on the bound-
ary itself. If desired, continue clicking inside additional closed perimeters.

7 To complete the selection, press Enter.

8 In the Boundary Hatch dialog box, click OK. 

Nested islands (A), with outer island (B), and with ignore islands (C).

A B C
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A Opens the drawing area for selection of enclosed 
areas to be hatched.

B Determines how hatching interacts with islands.
C Mark the check box to keep any new entities that 

are created to draw the boundary hatch. Existing 
entities are always retained.

D (Display only) Indicates the boundary is created 
as a polyline

E Choose to consider all visible entities when 
creating the boundary hatch.

B

E

C
D

A
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Gradient hatch
A gradient is a solid hatch that allows to apply a gradient color to a surface

A Show the chosen color.
B Set the shade.

C Show a preview of the gradinet hatch. 
D Set the color orientation.

C

A

D

B
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To use a gradient hatch

1 Do one of the following: 

• Select Draw > Gradient. 

• On the Draw toolbar, click the Gradient tool ( ). 

• Type batch and then press Enter. In the Boundary hatch window select the 
Gradient tab. 

2 Choose one or two colors to use and select a gradient type. 

3 To associate the hatch pattern to its boundary entities, select the Associative check 
box. An associative hatch updates automatically if you move any of its bound-
aries. If necessary, choose also a Draw Order option 

A Show the first chosen color.
B Show the second chosen color.

C Show a preview of the gradinet hatch. 
D Set the color orientation.

C

A B

D
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4 To copy the pattern properties from an existing hatch, choose Inherit Properties, 
select the hatch pattern from the hatched entity in the drawing. You can also 
choose if copy the current origin or leave the source hatch origin. 

5 Specify the entities that you want to make available for boundary hatching by 
doing one of the following. 

• Current viewport: to have all entities in the drawing considered when creating 
the boundary hatch. 

• Existing Set: defines only specific areas to be considered when creating the 
boundary hatch, which can improve system performance if you are working 
with a complex drawing. Click Select Boundary Set. In the drawing, select the 
entities individually or by choosing a selection method from the prompt box, 
and then press Enter. The Current Selection Set option becomes selected 
automatically, which indicates that the entities you selected with the Select 
Boundary Set button will be considered when creating the boundary hatch. 

6 In the Boundaries section click Add: Pick points. 

7 In the drawing click inside the closed perimeter of a boundary, not on the bound-
ary itself. If desired, continue clicking inside additional closed perimeters. 

8 To complete the selection, press Enter. 

9 In the Boundary Hatch dialog box, click OK. 

To modify a gradient hatch

1 Double click on the hatch to modify. 



6

Viewing your drawing

AViCAD® provides many ways to display and view your drawing. You can also 
change various display settings to speed up the display or printing of a drawing. This 
chapter explains how to:

• Navigate within a drawing by scrolling and panning.

• Change the magnification of a drawing by zooming in and out.

• Work with multiple windows or views of a drawing.

• Control the display of elements to optimize performance when working with large 
or complex drawings.

Topics in this chapter

Redrawing and regenerating a drawing ............................................................ 136

Moving around within a drawing ....................................................................... 136

Changing the magnification of your drawing...............................................139

Displaying multiple views.................................................................................. 144

Controlling visual elements............................................................................... 148
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Redrawing and regenerating a drawing     

As you work on a drawing, visual elements may remain after the completion of a 
command. You can remove these elements by refreshing, or redrawing, the display.            

To redraw (refresh) the current window display

Do one of the following:

• Choose View > Redraw.

• Type redraw and then press Enter.

Information about drawing entities is stored in a database as floating point values, 
ensuring a high level of precision. Sometimes a drawing must be recalculated, or 
regenerated, from the floating-point database to convert those values to the appropri-
ate screen coordinates. This occurs automatically. You can also manually initiate a 
regeneration. When the drawing is regenerated, it is also redrawn.       

To regenerate the current window, type regen in the command bar. If more than one 
window is displayed, type regenall to regenerate all the windows.    

Moving around within a drawing  

You can move the view of a drawing displayed in the current viewport by scrolling, 
panning, or rotating the view. Doing this changes the portion of the drawing you are 
viewing without changing the current magnification. Scrolling lets you move around 
in the drawing horizontally and vertically. Panning lets you move the drawing in any 
direction. Rotating lets you view your drawing from any angle.        

NOTE You can also move to a different view using the Model and Layout tabs. For 
more details, see “Viewing drawings in paper space and model space” on page 391. 

Using scroll bars
To assist you in navigating within a drawing, horizontal and vertical scroll bars are 
available in each drawing window. The size of the scroll box in relation to the scroll 
bar indicates the current level of drawing magnification. The position of the scroll 
box in relation to the scroll bar indicates the location of the center of the drawing in 
relation to the extents of the drawing (the smallest rectangle containing all the entities 
in the drawing).       

To turn scroll bars on or off

Do one of the following:

• Choose View > Display > Scroll Bars.
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• Choose Tools > Options > Display tab, and select Show Scroll Bars. 

• Type scrollbar, press Enter, and then select On, Off, or Toggle.

Using the Pan command
You can move the drawing in any direction using the Pan Realtime tool ( ) on the 
Standard toolbar. Panning shifts or slides the view of the drawing horizontally, verti-
cally, or diagonally. The magnification of the drawing remains the same, as does its 
orientation in space. The only change is the portion of the drawing displayed.       

To pan, you can use any of the following methods:

• For precise panning, specify two points defining the magnitude and direction of 
the pan. The first point, or base point, indicates the starting point of the pan. The 
second point indicates the amount of pan displacement relative to the first point.

• To pan in real time, press Ctrl + Shift and use the right mouse button, or use the 
Real-Time Pan tool ( ) on the Standard toolbar. 

• If you have a mouse with a wheel, press and hold the wheel, and then move the 
mouse.

To pan by specifying two points

1 Do one of the following:

• Choose View > Pan > Point.

• Type pan and then press Enter.

2 Specify the pan base point either by typing the coordinates or by specifying a 
point in the drawing window.

3 Specify the pan displacement point either by typing the coordinates or by specify-
ing a point in the drawing window. 

 

Select the pan base point (A), and then select a 
second point (B) to specify the pan displacement.

Result.

A
B
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To pan in real time    

1 Do one of the following:

• Choose View > Pan > Real-Time Pan.

• On the Standard or 3D Orbit toolbar, click the Real-Time Pan tool ( ).

• Type rtpan and then press Enter.

2 Click and hold the left mouse button. 

3 Move the cursor in the direction you want to pan.

4 To stop panning, release the mouse button.

TIP Hold down the right mouse button while  simultaneously pressing and holding 
Ctrl + Shift to pan in real-time.

NOTE If you are working with a large drawing file, it may be helpful to set the 
RTSKIPCOUNT system variable to a higher number to reduce the number of entities 
that display. For example, if the value is set to 10, only the 10th entity will display 
when panning and rotating in real-time.

To pan using a mouse with a wheel    

• Press and hold the wheel, and then move the mouse in the direction you want to 
pan. (The MBUTTONPAN system variable controls this feature.)

Rotating the view in real time
AViCAD allows you to rotate your view of a drawing in real time. This allows you to 
view your model from any angle while in model space. You cannot rotate the view 
while in paper space.

If desired, you can continue the view rotation after you release your mouse. Choose 
Tools > Options to enable continuous motion. For more information, see “Changing 
the options on the Display tab” on page 589.        
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To rotate the view in real time   

1 Do one of the following:

• Choose View > 3d orbit > Real-Time Sphere.

• On the 3D Orbit toolbar, click the Real-Time Sphere tool ( ).

• Type rtrot and then press Enter.

• Press and hold Ctrl. 

2 Click and drag the left mouse button. The view rotates according to the movement 
of your mouse. 

3 To stop rotating, release the mouse button.

4 If the view continues to rotate, press Enter or right-click the drawing when fin-
ished.

TIP You can use the Real-Time X, Real-Time Y, and Real-Time Z commands to lock 
the rotation in the corresponding axis. You can also press Ctrl and use the right 
mouse button to rotate the view about the z-axis.

NOTE If you are working with a large drawing file, it may be helpful to set the 
RTSKIPCOUNT system variable to a higher number to reduce the number of entities 
that display. For example, if the value is set to 10, only the 10th entity will display 
when panning and rotating in real-time.

Changing the magnification of your drawing  

You can change the magnification of your drawing at any time by zooming. The 
cursor changes to a magnifying glass ( ) when a zoom tool is active. Zoom out to 
reduce the magnification so you can see more of the drawing, or zoom in to increase 
the magnification so you can see a portion of the drawing in greater detail. Changing 
the magnification of the drawing affects only the way the drawing is displayed; it has 
no effect on the dimensions of the entities in your drawing.             

NOTE If you are working in a layout viewport and cannot zoom, the layout viewport 
may be locked. The scale and view do not change in model space while panning or 
zooming in a locked layout viewport. For more details, see “Modifying layout view-
ports” on page 398. 



140   C H A P T E R  6

Zooming in and out
One of the easiest ways to change the magnification of the drawing is to zoom in or 
out by a preset increment. On the Zoom toolbar, the Zoom In tool ( )doubles the 
current magnification of the drawing. The Zoom Out tool ( ) reduces the magnifi-
cation of the drawing by half. The portion of the drawing located at the center of the 
current viewport remains centered on the screen as you zoom in and out.            

Zooming methods
To zoom, you can use any of the following methods:

• To define the portion of the drawing to zoom, create a window.

• To zoom in real time, press Ctrl + Shift and use the left mouse button, or use the 
Real-Time Zoom tool ( ) on the Standard  or 3D Orbit toolbar. 

• If you have a mouse with a wheel, use the wheel button to zoom in and out.

To zoom in to an area using a window

1 Do one of the following:

• Choose View > Zoom > Window.

• On the Zoom or Standard toolbar, click the Zoom Window tool ( ).

• Type zoom and then press Enter.

2 Select one corner of the window around the area you want to magnify.

3 Specify the opposite corner of the window around the area you want to magnify.

Zoom in. Zoom out.
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To zoom in real time    

1 Do one of the following:

• Choose View > Zoom > Real-Time Zoom.

• On the Standard or 3D orbit toolbar, click the Zoom Real-Time tool ( ).

• Type rtzoom and then press Enter.

• Simultaneously press and hold Ctrl + Shift.

2 Click and hold the left mouse button.

3 To zoom in, move the cursor up the screen; to zoom out, move the cursor down the 
screen.

4 To stop zooming, release the mouse button.

To zoom using a mouse with a wheel    

• Rotate the wheel away from you to zoom in or toward you to zoom out.

Each rotation of the wheel away from you zooms out .8 times; each rotation 
toward you zooms in 1.25 times.

Displaying the previous view of a drawing
After you zoom in or pan to view a portion of your drawing in greater detail, you may 
want to zoom back out to see the entire drawing. On the View > Zoom menu, the 
Zoom Previous tool ( ) lets you restore the previous view. Selecting this tool 
repeatedly steps back through up to 25 successive zoomed or panned views.      

Zooming to a specific scale  
You can increase or decrease the magnification of your view by a precise scale factor 
measured relative to the overall size of the drawing or in relation to the current dis-
play. When you change the magnification factor, the portion of the drawing located at 
the center of the current viewport remains centered on the screen.    

To specify a rectangular window around the 
area you want to magnify, select first one corner 
(A), and then select the opposite corner (B).

Result.

A

B
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To change the magnification of the view relative to the overall size of the drawing, 
type a number representing the magnification scale factor. For example, if you type a 
scale factor of 2, the drawing appears at twice its original size. If you type a magnifi-
cation factor of .5, the drawing appears at half its original size.

You can also change the magnification of the drawing relative to its current magnifi-
cation by adding an x after the magnification scale factor. For example, if you type a 
scale factor of 2x, the drawing changes to twice its current size. If you type a magnifi-
cation factor of .5x, the drawing changes to half its current size.

To zoom to a specific scale relative to the current display    

1 Do one of the following:

• Choose View > Zoom > Zoom.

• On the Zoom or Standard toolbar, click the Zoom Scale tool ( ).

• Type zoom and then press Enter.

2 Type the scale factor, followed by an x (such as 2x).

3 Press Enter.

Combining zooming and panning  
You can specify the point you want at the center of the view when you change the 
drawing magnification. You can specify the point you want at the lower left of the view 
when you change the magnification of the drawing with the Zoom Left tool in  the 
menu View > Zoom. With the exception of the Zoom Window tool, the other zoom 
tools zoom in or out from the center of the current view.        

To change the center of the current view

1 Do one of the following:    

• Choose View > Zoom > Center.

• On the Zoom toolbar, click the Zoom Center tool ( ).

• Type zoom, press Enter, and then in the prompt box, choose Center.

2 Select the point you want located at the center of the new view.

3 Specify the zoom scale factor or the height of the drawing in drawing units.     
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Displaying the entire drawing
You can use the Zoom All tool ( ) on the Zoom toolbar to display an entire draw-
ing. If you have drawn any entities outside the defined limits of the drawing, the 
extents of the drawing are displayed. If you drew all entities within the limits of the 
drawing, the drawing is displayed all the way to the drawing limits.                 

The Zoom Extents tool ( ) on the Zoom toolbar displays the drawing to its extents, 
making the image fill the display to the greatest possible magnification.  

Aereal view
In a large drawing, you can pan and zoom quickly in a window that can display the 
whole drawing.

You can use the Aerial View window to change the view in your current viewport 
quickly. If you keep the Aerial View window open as you work, you can zoom and 
pan without interrupting your current command. You can also specify a new view 
without having to choose a menu option or enter a command. 

Within the Aerial View window is a view box, a heavy rectangle that displays the 
boundary of the view in your current viewport. You can change the view in the draw-
ing by changing the view box in the Aerial View window.

Current view showing the point to be centered in the new view (A), and the new view zoomed using a scale 
factor of 2x.

Zooming extents. Zooming entire drawing.

A
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To use aereal view

1 Do one of the following:

• Choose View > Aereal view

• Type dsviewer and then press Enter.

2 All pan and zoom operations are performed by left-clicking: to zoom in to the 
drawing, make the view box smaller. To zoom out of the drawing, make the view 
box larger.

3 Right-click to end a pan or zoom operation.

The command has the following options:

Auto Viewport: Displays the model space view of the current viewport automati-
cally when multiple viewports are displayed. When Auto Viewport is off, the Aerial 
View window is not updated to match the current viewport. 

Dynamic Update: Updates the Aerial View window while you edit the drawing. 
When Dynamic Update is off, the Aerial View window is not updated until you click 
in the Aerial View window.

Realtime Zoom: Updates the drawing area in real time when you zoom using the 
Aerial View window.

Displaying multiple views

When you begin a new drawing, it is displayed in a single window. You can view the 
drawing in a second window, or you can divide one window into multiple windows. 
You can also open and display multiple drawings.          

Working with multiple views  of a single drawing
You can open and work with several views of the same drawing simultaneously. 
There are two methods for dividing the current drawing into multiple views:

• Open a new window of the open drawing.

• Divide the current window into multiple views.

After you divide a single window into multiple windows, you can control each win-
dow separately. For example, you can zoom or pan in one window without affecting 
the display in any of the other windows. You can control the grid, snap, and view ori-
entation separately for each window. You can restore named views in individual win-
dows, draw from one window to another, and name window configurations 
individually so you can reuse them later.       

As you draw, any changes you make in one window are immediately visible in the 
others. You can switch from one window to another at any time, even in the middle of 
a command, by clicking the window’s title bar.
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Opening a new window of the same drawing
You can open additional windows to create more than one view of a drawing. To 
open a new window, choose Window > New Window. After you open a new win-
dow, you can change its display without affecting any of the other windows.    

When you open more than one window for a single drawing, each window is assigned 
a unique number (for example, mydrawing:1, mydrawing:2, and so on). If your cur-
rent window is maximized, you can switch to another open window by selecting its 
name from the bottom of the Window menu.              

The names of other open drawings appear at the bottom of the Window menu. You 
can also use the Cascade, Tile Horizontally, and Tile Vertically commands to arrange 
all the open windows and drawings. To arrange all the windows and drawings into a 
stack of identically sized windows, choose Window > Cascade. Arranging windows 
and drawings in this way makes it easy to see the title bar for each window.       

To arrange all the windows and drawings horizontally so they are placed in order 
from top to bottom, choose Window > Tile Horizontally. Arranging windows and 
drawings in this way displays each open window. The windows are resized to fit 
within the available space.    

To arrange all the windows and drawings vertically so they are placed side by side, 
choose Window > Tile Vertically. Arranging windows and drawings in this way dis-
plays each open window. The windows are resized to fit within the available space.

AViCAD uses the commands in the following table to control its windows.  

Dividing the current window into multiple views
You can divide a single drawing window into multiple tiled windows (called view-
ports) on the Model tab. You can control the number of windows created and the 
arrangement of the windows. You can also save and restore named window configu-
rations and display a list of the current and saved window configurations.

AViCAD window-control commands

Command Result

vports Splits the current window into two, three, or four tiled windows.

wcascade Cascades (overlaps) all open windows.

wclose Closes the current window.

wcloseall Closes all windows; also closes all drawings.

whtile Tiles all windows horizontally.

wiarrange Arranges window icons.

wopen Opens another window of the current drawing.

wvtile Tiles all windows vertically.
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To create multiple views   

1 Do one of the following:    

• Choose View > Viewports > Viewports.

• On the Viewports toolbar, click the Viewports tool ( ).

• Type viewports and then press Enter.

2 In the prompt box, choose Create 2 Viewports, Create 3 Viewports, or Create 4 
Viewports.

3 In the prompt box, choose the viewport orientation. 

To join two views

1 Do one of the following:      

• Choose View > Viewports > Viewports.

• On the Viewports toolbar, click the Viewports tool ( ).

• Type viewports and then press Enter.

2 In the prompt box, choose Join.

3 Click anywhere inside the window you want to keep.

4 Click anywhere inside the adjacent window you want to join to the first window.

5 Press Enter.

Saving window configurations
If you have divided the drawing window into multiple views, you can save the current 
window arrangement so that you can recall it to the screen later. The number and 
placement of the windows are saved exactly as they are currently displayed. The set-
tings for each window are also saved.     

To name and save a window configuration        

1 Do one of the following:

• Choose View > Viewports > Viewports.

• On the Viewports toolbar, click the Viewports tool ( ).

• Type viewports and then press Enter.

2 In the prompt box, choose Save.

3 Type a configuration name, and then press Enter.

The name  can contain letters, numbers, the dollar sign ($), hyphen (-), and under-
score (_), or any combination.      
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To restore a named window configuration    

1 Do one of the following:

• Choose View > Viewports > Viewports.

• On the Viewports toolbar, click the Viewports tool ( ).

• Type viewports and then press Enter.

2 In the prompt box, choose Restore.

3 Type the name of the window configuration you want to restore.

Working with multiple drawings
With the multiple-document interface (MDI) feature, you can open more than one 
drawing inside of AViCAD. Because you can open and work on several drawings at 
one time, you can copy, cut, or paste an entity from one drawing to another.          

Each drawing appears in a drawing window, which has the following advantages:

• You can see two or more drawings side by side.

• You can easily copy entities from one drawing to another.

• Using the AViCAD Explorer, you can copy such elements as layers, linetypes, 
and text styles from one drawing to another.

You can divide a drawing window into two windows arranged vertically (A) or horizontally (B); three windows 
arranged left (C), right (D), above (E), below (F), vertically (G), or horizontally (H); or four tiled windows (I).

A B C

D E F

G H I
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• Like viewports on the Model tab, you can tile or overlap drawing windows; unlike 
viewports on the Model tab, drawing windows maximize or reduce to an icon. 

Each drawing window that you open and work on retains in the Prompt History log 
all the commands that you perform, but the command line does not indicate when you 
have switched windows.

If you move an entity from one window to another and then want to undo this action, 
you must undo it in both drawings for it to take effect. If you copy an entity from one 
window to another and then want to undo that action, you must undo it from the 
drawing into which you copied the entity. If you cut and paste an entity and then want 
to undo that action, you must undo it in both drawings. 

Controlling visual elements  

The number of entities in your drawing and the complexity of the drawing affect how 
quickly AViCAD can process commands and display your drawing. You can 
improve overall program performance by turning off the display of certain visual ele-
ments, such as solid fills and text, while you work on the drawing. When you are 
ready to print your drawing, turn on the display of these elements so your drawing 
prints the way you want.       

 One session of AViCAD with four drawings open.
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You can also improve performance by turning off entity-selection highlighting, turn-
ing off the display of marker blips created when you select locations in the drawing, 
and by turning off the display of lineweights.

Turning Fill on and off
You can reduce the time it takes to display or print a drawing by turning off the dis-
play of solid fill. When Fill is turned off, all filled entities, such as wide polylines and 
planes, display and print as outlines. When you turn Fill on or off, you must redraw 
the drawing before the change is displayed.        

To turn Fill on or off

1 Do one of the following:

• Choose Format > Fill.

• Type fill and then press Enter.

2 Choose View > Redraw.    

Turning Quick Text on and off   
Text entities require a considerable amount of time to display and print. You can 
reduce the time it takes to display or print a drawing by enabling Quick Text. For 
example, if you’re doing a preliminary check plot of a drawing, you may want to turn 
Quick Text on to speed up printing. When Quick Text is enabled, text entities are 
replaced by rectangular boxes that indicate the outline of the area occupied by the 
text. When you turn Quick Text on or off, you must regenerate the drawing before the 
change is displayed.          

Fill on. Fill off.
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To turn Quick Text on and off

1 Do one of the following:

• Choose Tools > Drawing Settings.

• Type qtext, press Enter, and then in the prompt box, choose On or Off.

2 Click the Display tab.

3 Under Change Settings For, click Display.

4 Select or clear the Enable Quick Text check box.

5 Click OK.

6 To regenerate your drawing, do one of the following:

• Choose View > Regen.

• Type regen and then press Enter.

Turning highlighting on and off
You can improve overall program performance by turning highlighting off. When 
you select entities to modify, the program highlights them using a dashed linetype. 
This highlight disappears when you finish modifying the entities or when the entities 
are cleared. Sometimes highlighting entities can take a considerable amount of time. 

To turn highlighting on and off

1 Do one of the following:

• Choose Tools > Drawing Settings.

• Type highlight, press Enter, and then in the prompt box, choose On or Off.

2 Click the Display tab.

3 Under Change Settings For, click Display.

4 Select or clear the Highlight Item When Selected check box.

5 Click OK.

Quick Text off. Quick Text on.
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Turning Blips on and off
You can turn Blips off. They are the temporary markers that appear on the screen 
when you select an entity or location. Blips are visible only until you redraw the 
drawing. You cannot select Blips; they are used only for reference and never print.

To turn Blips on and off

1 Do one of the following:

• Choose Tools > Drawing Settings.

• Type blipmode, press Enter, and then in the prompt box, choose On or Off.

2 Click the Display tab.

3 Under Change Settings For, click Display.

4 Select or clear the Show Marker Blips check box.

5 Click OK.

Controlling the display of lineweights
You can reduce the time it takes to display a drawing by turning off the display of lin-
eweights. When you turn off lineweights, all entities display as outlines. 

You can also specify a lineweight scale. Specify a smaller scale to display thinner 
lines; specify a larger scale to display thicker lines. For example, a scale factor of 0.5 
would display a .80 millimeter lineweight as .40 millimeter; a scale factor of 2 would 
increase the same lineweight to display at 1.6 millimeters. This can help you differen-
tiate various lineweights that display in a drawing. Adjusting the lineweight display 
scale affects how the lineweights appear on your screen, not how they appear when 
printed.  

NOTE  Setting the lineweight scale too high may result in slower system performance.

You can also adjust the units for measuring lineweights, and the default lineweight.        

Blips on. Blips off.
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To control the display of lineweights

1 Do one of the following:

• Choose Tools > Drawing Settings.

• Type settings and then press Enter.

• Type lweight and then press Enter.

2 Click the Display tab.

3 Under Change Settings For, click Lineweights.

4 Select or clear Display Lineweights.

5 In Units for Listing, choose Millimeters or Inches.

6 In Default, select the lineweight assigned to layers and entities that use the Default 
lineweight.

7 In Adjust Display Scale, move the slider to the scale you want. By default, the 
slider begins at 1.00.

8 Click OK.

TIP On the status bar, click the word LWT to turn the display of lineweights on or 
off.  

You can turn lineweights on or off when you print. For details, see “Choosing how 
lineweights print” on page 405. 
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Working with coordinates

For accuracy in a drawing, you can locate specific points by entering coordinates as 
you draw or modify entities. When you create two-dimensional entities, you enter 
two-dimensional coordinates; for three-dimensional entities, you specify three-
dimensional coordinates.

You can also specify coordinates in relation to other known locations or entities in a 
drawing. In particular, when you work in three-dimensional drawings, it is often eas-
ier to specify coordinates in relation to a two-dimensional working plane, called a 
user coordinate system (UCS).

This chapter explains how to work with coordinates, including how to:

• Use two-dimensional and three-dimensional coordinate systems.

• Specify absolute and relative coordinates.

• Specify polar, spherical, and cylindrical coordinates.

• Define and manipulate user coordinate systems.

Topics in this chapter

Using Cartesian coordinates ............................................................................ 154

Using two-dimensional coordinates .................................................................. 157

Using three-dimensional coordinates ............................................................... 160

Using xyz point filters........................................................................................ 162

Defining user coordinate systems..................................................................... 164
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Using Cartesian coordinates  

Many commands in AViCAD® require that you specify points as you draw or modify 
entities. You can do so by selecting points with the mouse or by typing coordinate 
values in the command bar. The program locates points in a drawing using a Carte-
sian coordinate system. 

Understanding how coordinate systems work  
The Cartesian coordinate system uses three perpendicular axes—x, y, and z—to spec-
ify points in three-dimensional space. Every location in a drawing can be represented 
as a point relative to a 0,0,0 coordinate point, referred to as the origin. To draw a two-
dimensional entity, you specify horizontal coordinate positions along the x-axis and 
vertical coordinate positions along the y-axis. Thus, every point on a plane can be 
represented as a coordinate pair composed of an x-coordinate and a y-coordinate. 
Positive coordinates are located above and to the right of the origin; negative coordi-
nates are located to the left and below the origin.              

When you work in two dimensions, you need enter only the x- and y-coordinates; the 
program assumes that the z-axis value is always the current elevation. When you 
work in three dimensions, however, you must also specify the z-axis value. When you 
look at a plan view of your drawing (a view from above, looking down), the z-axis 
extends straight up out of the screen at a 90-degree angle to the xy plane. Positive 
coordinates are located above the xy plane, and negative coordinates are below the 
plane.

                                    The three perpendicular axes of the Cartesian coordinate system.
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All AViCAD drawings use a fixed coordinate system, called the World Coordinate 
System (WCS), and every point in a drawing has a specific x,y,z-coordinate in the 
WCS. You can also define arbitrary coordinate systems located anywhere in three-
dimensional space. These are called user coordinate systems and can be located any-
where in the WCS and oriented in any direction.           

You can create as many user coordinate systems as you want, saving or redefining 
them to help you construct three-dimensional entities. By defining a UCS within the 
WCS, you can simplify the creation of most three-dimensional entities into combina-
tions of two-dimensional entities.     

To help you keep your bearings in the current coordinate system, the program dis-
plays a coordinate system icon. When you begin a new drawing, you are automati-
cally in the WCS, indicated by the letter W in the icon. When you display a drawing 
in plan view, you see the coordinate system icon from the top, with the z-axis directed 
straight toward you. When you display a three-dimensional drawing in a view other 
than plan view, the coordinate system icon changes to reflect your new viewpoint.         

NOTE The visible portions of the axes are the positive directions.     

Understanding how coordinates are displayed
The current position of the cursor is displayed as x,y,z-coordinates in the status bar 
and, by default, updates dynamically as you move the cursor. You can toggle the 
coordinate display to static mode by pressing F6, so that it updates only when you 
select a point in the drawing.         

You can also change the coordinate display to a different dynamic mode that shows 
the distance and angle (rather than x,y,z-coordinates) when the program displays a 
rubber-band line. To do this, choose Tools > Drawing Settings and select the Display 
tab. Under Coordinate Display, select the option for Coordinates In Polar Form For 
Distance And Angle Selection.                      

WCS icon. Plan UCS icon. 3D View WCS icon.

                                                                    The coordinates display on the status bar shows the current cursor position.
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Finding the coordinates of a point
To find the x,y,z-coordinates for a point on an entity, such as the endpoint of a line, 
select an appropriate entity snap (such as Endpoint) before selecting the entity. If you 
have no entity snaps set, the x,y-coordinates of the point you specified is displayed, 
with the z-coordinate equal to the current elevation.   

To find the coordinate of a point in the drawing

1 Do one of the following: 

• Choose Tools > Inquiry > ID Point.

• On the Inquiry toolbar, click the Locate Point tool ( ).

• Type idpoint and then press Enter.

2 Select the point for which you want to find the coordinates.

If the command bar is activated, the x,y,z-coordinates for the point you selected 
display in the command bar.

If the command bar is not activated, the Prompt History window displays, show-
ing the x,y,z-coordinates for the point you selected.

                           You can control the coordinate display from the Drawing Settings dialog box.
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Using two-dimensional coordinates

When working in two dimensions, you specify points on the xy plane. You can spec-
ify any point as an absolute coordinate (or Cartesian coordinate), using the exact x-
coordinate and y-coordinate locations in relation to the origin (the 0,0 coordinate 
point at which the two axes intersect), or as a relative coordinate in relation to the pre-
vious point. You can also specify points using relative or absolute polar coordinates, 
which locate a point using a distance and an angle. 

Entering absolute Cartesian coordinates
To enter absolute Cartesian coordinates, type the coordinate location of the point in 
the command bar. For example, to use absolute Cartesian coordinates to draw a line 
from the origin (0,0) to a point 3 units to the right and 1 unit above the origin, start the 
Line command and respond to the prompts as follows: 

    

Start of line: 0,0

Angle • Length • <Endpoint>: 3,1   

When using absolute Cartesian coordinates, you need to know the exact point loca-
tions for anything you draw. For instance, to use absolute Cartesian coordinates to 
draw an 8.5-unit square with its lower left corner at 4,5, you must determine that the 
upper left corner is at coordinate 4,13.5, the upper right corner at 12.5,13.5, and the 
lower right corner at 12.5,5.

Drawing a line using the absolute Cartesian coordinate method.

1

3Y

-Y

-X X

(3, 1)
(0, 0)
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Entering relative Cartesian coordinates
Another, simpler method is to use relative Cartesian coordinates: you specify a 
location in the drawing by determining its position relative to the last coordinate you 
specified. To use relative Cartesian coordinates, type the coordinate values in the 
command bar, preceded by the at symbol (@). The coordinate pair following the @ 
symbol represents the distance along the x-axis and the y-axis to the next point. For 
example, to draw an 8.5-unit square with its lower left corner at 4,5 using relative 
Cartesian coordinates, start the Line command, and then respond to the prompts as 
follows:

Start of line: 4,5

Angle • Length • <Endpoint>: @8.5,0

Angle • Length • Follow • Undo • <Endpoint>: @0,8.5

Angle • Length • Follow • Close • Undo • <Endpoint>: @-8.5,0

Angle • Length • Follow • Close • Undo • <Endpoint>: C

  

The first relative coordinate (@8.5,0) locates the new point 8.5 units to the right 
(along the x-axis) from the previous point of 4,5; the second relative coordinate 
(@0,8.5) locates the next point 8.5 units above (along the y-axis) the previous point, 
and so on. Entering C (for Close) draws the final line segment back to the first point 
specified when you started the Line command.                      

Entering polar coordinates
Using relative polar coordinates makes drawing a square tilted at a 45-degree angle a 
simple task. Polar coordinates base the location of a point on a distance and angle 
from either the origin (absolute coordinate) or from the previous point (relative coor-
dinate).                                

Drawing a square using the relative Cartesian coordinates method; enter C to close.

Y

-Y
-X

5

C

@0, 8.5

@8.5,0

@-8.5, 0
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4 12
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To specify polar coordinates, type a distance and an angle, separated by the open 
angle bracket (<). For example, to use relative polar coordinates to specify a point 1 
unit away from the previous point and at an angle of 45 degrees, type @1<45.                 

To draw the square from the example in the previous section, “Entering relative Car-
tesian coordinates,” this time tilted at a 45-degree angle, start the Line command, and 
then respond to the prompts as follows:     

Start of line: 4,5

Angle • Length • <Endpoint>: @8.5<45

Angle • Length • Follow • Undo • <Endpoint>: @8.5<315

Angle • Length • Follow • Close • Undo • <Endpoint>: @8.5<225

Angle • Length • Follow • Close • Undo • <Endpoint>: C 

NOTE This example, like all examples in this guide, assumes the program’s default 
settings: Angles increase counterclockwise and decrease clockwise. Thus, an angle of 
315 degrees is the same as -45 degrees.

ù

Drawing a tilted square using the relative polar coordinates method; enter 
C  to close.

Y

-Y
-X X
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@8.5<22
(4, 5)

(0, 0)
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Using three-dimensional coordinates  

Specifying coordinates in three-dimensional space is similar to working in two 
dimensions, except that you also use the z-axis to locate coordinates. Three-dimen-
sional coordinates are represented in the format x,y,z (for example, 2,3,6). 

Using the right-hand rule   
To visualize how AViCAD works with three-dimensional space, use a technique 
known as the right-hand rule. Hold up your right hand in a loose fist with your palm 
facing you. Extend your thumb in the direction of the positive x-axis and your index 
finger upward in the direction of the positive y-axis. Then extend your middle finger 
straight toward you in the direction of the z-axis. These three fingers are now pointing 
in the positive x, y, and z directions, respectively.        

You can also use the right-hand rule to determine the positive rotation direction. Point 
your thumb in the positive direction of the axis about which you want to rotate, and 
then curl the rest of your fingers toward your palm. These fingers are curling in the 
positive rotation direction.       

Entering x,y,z-coordinates  
When working in three dimensions, you can specify x,y,z-coordinates as absolute dis-
tances in relation to the origin (the 0,0,0 coordinate point at which the three axes 
intersect) or as relative coordinates based on the last point selected. For example, to 
specify a point 3 units along the positive x-axis, 4 units along the positive y-axis, and 
2 units along the positive z-axis, specify the coordinate 3,4,2.    

The right-hand rule helps you determine the positive direction of the x-, y-, and z-axes and the 
positive rotation direction.

Y

Z

X
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Entering spherical coordinates
When working in three-dimensional space, you can use spherical coordinates to spec-
ify a three-dimensional point by entering its distance from either the origin (absolute 
distance) or the last point (relative distance), along with its angle in the xy plane and 
its angle up from the xy plane. In spherical format, you separate each angle with the 
open angle bracket (<).              

Thus, to draw a line from the origin to a point 10.2500 drawing units away, at an 
angle of 45 degrees from the x-axis and 35 degrees from the xy plane, start the Line 
command, and then respond to the prompts as follows:

Start of line: 0,0,0

Angle • Length • <Endpoint>: 10.2500<45<35 

  

Entering cylindrical coordinates  
When working in three-dimensional space, you can also use cylindrical coordinates 
to specify a three-dimensional point. You specify a point by entering its distance from 
either the origin (absolute distance) or the last point (relative distance), its angle in the 
xy plane, and its z-coordinate value.       

In cylindrical format, you separate the distance and angle with the open angle 
bracket (<) and separate the angle and z value with a comma. For example, to draw a 
line from the last point to a point 7.4750 units away, at an angle of 27 degrees from 
the x-axis in the xy plane and 3 units up in the z direction, start the Line command, 
and then respond to the prompts as follows: 

Start of line: (select point A)

Angle • Length • <Endpoint>: @7.4750<27,3 

When you draw a line from a start point (A) to an endpoint (B) using 
spherical coordinates, you specify its length (C, in this case 10.2500 
units), the angle in the xy plane (D, in this case 45 degrees), and the 
angle from the xy plane (E, in this case 35 degrees).

A

Z

C
E

D
X

Y

B
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Using xyz point filters  

Point filters provide a method of locating a point in a drawing relative to another 
point without specifying the entire coordinate. Using a point filter, you can enter par-
tial coordinates, and then the program prompts you for the remaining coordinate 
information. To use xyz point filters, respond to the prompt for a coordinate with a 
filter in the following form:          

.coordinate

where coordinate is one or more of the letters x, y, and z. The program then prompts 
you for the filtered coordinate(s). For example, if you type .xy, the program prompts 
you to select a point whose xy-coordinate you want, and then prompts you for the z-
coordinate. The filters .x, .y, .z, .xy, .xz, and .yz are all valid filters.

Using point filters in two dimensions
You can use point filters when you work in two dimensions to locate points in rela-
tion to existing entities. For example, to draw a circle centered in a rectangle, start the 
Circle command, and then respond to the prompts as follows:

2Point • 3Point • RadTanTan • Arc • Multiple • <Center of circle>: .y

Select Y of: mid

Snap to midpoint of: (select the left side of the rectangle)

Still need XZ of: mid

Snap to midpoint of: (select top of the rectangle)

Diameter • <Radius>: (specify radius of circle)

When you draw a line from a start point (A) to an endpoint (B) using cylindrical coordinates, 
you specify its length (C, in this case 7.4750), the angle in the xy plane (D, in this case 27 
degrees), and the distance in the z direction (E, in this case 3 units).

A

Z

C B

E

D
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X
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Using point filters in three dimensions
You can use point filters when you work in three-dimensional space to locate points 
in two dimensions and then specify the z-coordinate as the elevation above the xy 
plane. For example, to begin drawing a line from a point with a z-coordinate 3 units 
above the center of a circle, insert the circle, and then start the Line command and 
respond to the prompts as follows:       

ENTER to use last point • Follow • <Start of line>: .xy

Select XY of: cen

Snap to centerpoint of: (select a point on the circle)

Still need Z of: 3 (locates the starting point 3 units above the center of 

the circle)

Length of line: (specify the length of the line)   

You can use point filters to center the circle by separately 
selecting the midpoints of two sides of the rectangle (A and 
B) and then specifying its radius.

You can use point filters to draw a line by first selecting a point in the xy plane (A), 
specifying the z-coordinate (B), and then specifying the length of the line (C).

A

B

A

B

C
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Defining user coordinate systems  

When working in three-dimensional space, you can define a UCS with its own 0,0,0 
origin and orientation separate from the WCS. You can create as many user coordi-
nate systems as you want, and then save and recall them as you need them to simplify 
construction of three-dimensional entities.               

For example, you can create a separate UCS for each side of a building. Then, by 
switching to the UCS for the east side of the building, you can draw the windows on 
that side by specifying only their x- and y-coordinates. When you create one or more 
user coordinate systems, the coordinate entry is based on the current UCS. 

  

Defining a user coordinate system
To define a UCS, you can use any of the following methods:

• Specify a new origin and points on the positive x- and y-axes.

• Specify a new origin and point on the positive z-axis.

• Align the UCS with an existing entity.    

• Rotate the current UCS around any of its axes.     

• Align the UCS with its z-axis parallel to the current viewing direction.

• Align the UCS xy plane perpendicular to the current view.

When you define a new UCS, the UCS icon changes to indicate the origin and orien-
tation of the new UCS.

UCS aligned with the front wall of the house.
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To define a UCS by specifying a new origin and points on the positive x- and y-
axes     

1 Do one of the following: 

• Choose Tools > Named UCS.

• On the UCS toolbar, click UCS tool ( ).

• Type expucs and then press Enter.

2 In the AViCAD Explorer, be sure that Coordinate Systems is selected, and click 
the New Item tool ( ).     

3 In the prompt box, choose 3 Point.

4 Select the new origin.

5 Select a point on the positive x-axis.

6 Select a point in the positive y direction.

7 In the AViCAD Explorer - Coordinate Systems dialog box, type the name for the 
new UCS, and then close the dialog box.  

Using a preset user coordinate system
AViCAD lets you select a preset UCS. The six planes defined by looking along the 
x,y,z-axes align the UCS with the top, left, front, bottom, right, or back, based on 
either the WCS or the current UCS in effect when you select the tool. You can also 
select the previous UCS, align the UCS to the current view, or select the WCS.

When you select a UCS, the cursor orientation and UCS icon change to reflect the 
new UCS. The display does not change, however, unless you select the Change View 
To Plan View Of The Selected UCS check box.     

After you align the UCS to a preset UCS, you can use the AViCAD Explorer to save 
the UCS. To do this, in the AViCAD Explorer window, choose Edit > New > UCS, 
and then select Current.

Define the new UCS by selecting the origin (A), a point on the positive x-axis 
(B), and a point in the positive y direction (C).

A

B

C
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To select a preset UCS 

1 Do one of the following: 

• Choose Tools > Orthographic UCS.

• On the UCS toolbar, click the Display UCS Dialog tool ( ).

• Type setucs and then press Enter.

2 Under Set The Selected UCS Relative To, select either Current UCS to change to 
the new UCS by reorienting relative to the current UCS or World Coordinate Sys-
tem (WCS) to base the new UCS orientation on the WCS.

3 Under Select UCS, click the button corresponding to the UCS you want as the new 
current UCS. 

  

A Specify whether to define the new UCS relative 
to the current UCS or to the World Coordinate 
System (WCS).

B Select to change the display to the plan view of 
the new UCS. 

C Click to select the previous UCS. 

D Click one of these buttons to select the view you 
want of a preset UCS.

E Click to select the WCS.

F Click to align the UCS with the current view.

G Click to display the AViCAD Explorer. 

A

B

C

D

G

E

F
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Working with the AViCAD Explorer

The AViCAD Explorer provides a powerful and convenient way to maintain and 
manage many of the features and settings of your drawings. You can use the 
AViCAD Explorer to work with layers, linetypes, text styles, coordinate systems, 
named views, blocks, and dimension styles within the current drawing or to copy this 
information between drawings.

This section explains how to use the AViCAD Explorer to:

• Manage elements related to settings and entities in your drawings.

• Organize information on layers and manage layers.

• Create and use linetypes.

• Load text fonts and create text styles.

• Select and control coordinate systems.

• Save and restore named views.

• Save, insert, and manage blocks.

• Copy, cut, and paste dimension styles between DWG files.

Topics in this chapter

Using the AViCAD Explorer .............................................................................. 168

Organizing information on layers................................................................173

Working with linetypes ...................................................................................... 184

Working with text fonts and styles..................................................................... 191

Working with coordinate systems ..................................................................... 196

Using named views........................................................................................... 199

Working with blocks and external references..............................................202

Working with dimension styles.......................................................................... 208
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Using the AViCAD Explorer 

The AViCAD Explorer opens in its own, separate window, which you can move or 
resize. The AViCAD Explorer window has its own menu and tools. 

To display the AViCAD Explorer

Do one of the following:    

• Choose Tools > AViCAD Explorer.     

• Type explayers and then press Enter.       

• Type explorer and then press Enter.

• On the status bar, left-click on the current layer, and from the list, select the layer 
you want to make current.

The AViCAD Explorer window has two panes, a left pane and a right pane. The ele-
ments are listed in the left pane, and the drawing settings are listed and described in 
the right pane.

NOTE On the Format menu, you can use the Layer, Explore Blocks, Explore Views, 
Explore Linetypes, Explore Text Styles, and Explore Dimension Styles commands to 
display the layers, blocks, views, linetypes, text styles, and dimension styles for the 
current drawing in the AViCAD Explorer window.   
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Using the AViCAD Explorer, you can create, delete, or modify any of the settings for 
the currently selected element for a given drawing. You can also copy the contents of 
any element from one drawing to another. The tools and menu items on the AViCAD 
Explorer provide the following functions:         

A Tools on the Standard toolbar provide controls common to all 
elements.

B The Elements pane shows an outline view containing the name of 
every drawing currently open and lists the elements you can control 
in each drawing.      

C  Click on a setting to change it.

D The named settings for the selected element.

E Other toolbars appear, depending on the selection in the Elements 
pane.

A
B

C

D

E

AViCAD Explorer tools    

Tool Function

( ) New Item Creates a new layer, linetype, style, coordinate system, view, block, or 
dimension style.

( ) Current Makes the selection current.

( ) Cut Cuts the selection to the Clipboard.

( ) Copy Copies the selection to the Clipboard.

( ) Paste Pastes the selection from the Clipboard into the appropriate list of a 
different drawing.

( ) Delete Deletes the selection from the list.

( ) Properties Displays the properties for the selection.

( ) World Sets the current coordinate system to the World Coordinate System 
(WCS).
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Copying settings   
A particularly powerful feature of the AViCAD Explorer is its capability of copying 
many of the settings—layers, linetypes, text styles, coordinate systems, views, blocks, 
or dimension styles—from one drawing to another. If you have more than one draw-
ing open, the AViCAD Explorer makes it easy to reuse information. For example, 
when you copy layers from one drawing to another, the layer names as well as their 
linetypes, colors, and other settings are also copied, but not the entities on those lay-
ers.    

To copy layers from one open drawing to another open drawing

1 Do one of the following:    

• Choose Tools > AViCAD Explorer.     

• Type explayers and then press Enter.       

• Type explorer and then press Enter.

2 In the Elements pane, select the drawing from which you want to copy layers.

3 If necessary, click the plus (+) symbol to expand the Elements list for the drawing, 
and then click Layers.

4 In the Layers Settings In Drawing list (right pane), select the layers you want to 
copy.

5 Choose Edit > Copy, or click the Copy tool ( ).

6 In the Elements pane, select the drawing to which you want to copy the layers.

7 If necessary, click the plus (+) symbol to expand the Elements list for the drawing, 
and then click Layers.

8 Choose Edit > Paste, or click the Paste tool ( ).

Deleting settings   
You can use the AViCAD Explorer to delete many of the items that appear in the Ele-
ments list. You can delete a layer, linetype, text style, coordinate system, view, block, 
or dimension style.     

( ) Purge Eliminates unreferenced elements from your drawing file.

( ) Regen Recalculates display coordinates for the current window.

( ) On/Off Regen Turns on and off recalculating display coordinates.

AViCAD Explorer tools    

Tool Function
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Because you may have already created entities on a particular layer or using a partic-
ular linetype or text style, deleting one of these elements requires that you make cer-
tain choices from options the program presents. For example, if you attempt to delete 
a layer, the program prompts you to specify whether you want to move any entities 
from that layer to another layer. Every drawing has at least one layer, the default 
layer, named “0.” You cannot delete or rename this layer. Your drawing can also con-
tain an unlimited number of additional layers, each of which you assign a unique 
name.    

If you try to delete a linetype, the program prompts you to specify whether you want 
to convert all entities drawn using that linetype to a different linetype. If you attempt 
to delete a text style, the program prompts you to specify whether you want to convert 
all text entities created using that style to a different style. 

To delete a layer and relocate its entities to another layer

1 Do one of the following:     

• Choose Tools > AViCAD Explorer.     

• Type explayers and then press Enter.       

• Type explorer and then press Enter.

2 From the Layer Name list, select the layer that you want to delete.

If that layer is the current layer, layer 0 automatically becomes the current layer.

3 Choose Edit > Delete, or click the Delete tool ( ).

4 From the dialog box, click Change.

5 In the drop-down list, double-click the layer to which you want to relocate entities.
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Purging elements    
From within the AViCAD Explorer, you can eliminate unused blocks, layers, line-
types, text styles, or dimension styles from your drawing file. Purging unused ele-
ments can significantly reduce the drawing file size. For detail see “To purge the 
items not used in the drawing” on page 84. 

To purge an element

1 Do one of the following:

• Choose Tools > AViCAD Explorer.     

• Type explayers and then press Enter.       

• Type explorer and then press Enter.

2 Select the element from which you want to purge unreferenced elements.

3 From the Standard toolbar, select the Purge tool ( ). 
The main drawing window appears. 

4 From the prompt box, select Yes to purge the element listed in the command line, 
or select Yes To All to purge all unused elements.

A Click to delete the layer and all entities on 
the layer.

B Click to delete the layer after first relocating all 
of its entities to a selected layer.

C Click to cancel the layer deletion.

A

B

C
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Organizing information on layers 

Layers in AViCAD® are like the transparent overlays you use in manual drafting. 
You use layers to organize different types of drawing information. In AViCAD, each 
entity in a drawing exists on a layer. When you draw an entity, it is created on the cur-
rent layer.    

You can control the visibility of layers in individual viewports. When you turn a layer 
off, entities drawn on that layer are no longer visible, and they do not print. Although 
a layer may be invisible, you can still select it as the current layer, in which case new 
entities are also invisible until you turn the layer back on. Entities on invisible layers 
can also affect the display and printing of entities on other layers. For example, enti-
ties on invisible layers can hide other entities when you use the Hide command to 
remove hidden lines.    

You can also freeze and thaw layers. Entities drawn on frozen layers do not display, 
do not print, and do not regenerate. When you freeze a layer, its entities do not affect 
the display or printing of other entities. For example, entities on frozen layers do not 
hide other entities when you use the Hide command to remove hidden lines. In addi-
tion, you cannot draw on a frozen layer until you thaw it, and you cannot make a fro-
zen layer current.     

You cannot freeze the current layer. If you attempt to freeze the current layer, a dia-
log box appears prompting you to specify a different layer. You also cannot freeze or 
thaw a viewport layer unless you are working in a Layout tab.

You can lock or unlock layers. The entities on a locked layer are still visible and will 
print, but you cannot edit them. Locking a layer prevents you from accidentally mod-
ifying entities.     

Each layer has its own color, linetype, and lineweight. For drawings that use named 
print styles, layers can also have their own print style. Entities you draw on a particu-
lar layer are displayed in the color, linetype, and lineweight associated with that layer 
unless you override these settings. You control all of the associated settings for layers 
using the Layers elements in the AViCAD Explorer.    

To display layers in the AViCAD Explorer

Do one of the following:       

• Choose Tools > AViCAD Explorer.     

• Type explayers and then press Enter.       

• Type explorer and then press Enter.
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When Layers are displayed, three tools on the Layer toolbar provide the following 
functions:

( ) Layer On/OffToggles the selected layers on and off.     

( ) Freeze/ThawFreezes or thaws the selected layers.    

( ) Lock/UnlockLocks or unlocks the selected layers.

You can change any of these settings by clicking either the tool or its current condi-
tion. You can edit the color and linetype of a layer by clicking the color or linetype 
name and selecting the values you want in the dialog box.You can also edit a layer’s 
properties by right-clicking it and choosing Properties.

A Select Layers to display the Layers settings.     

B Lists named layers in the current drawing. A check mark 
indicates the current layer.

C Displays the color assigned to each layer.

D Displays the linetype assigned to each layer.

E Indicates the visibility status of each layer.     

F Indicates the locked or unlocked status of each layer. 

G Indicates the frozen or thawed status of each layer for all viewports.

H Indicates the lineweight assigned to each layer.

I Indicates the print style assigned to each layer.

J Indicates the print status of each layer.

K Indicates the frozen or thawed status of the layer in the current 
viewport.

L Indicates the frozen or thawed status of the layer for new viewports on 
a Layout tab.

M Sorts the layers by that property when you click a column head.

A

B C D E F G H I J K L

M
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Creating and naming layers 
You can create an unlimited number of layers in every drawing and use those layers 
for organizing information. When you create a new layer, it is initially assigned the 
color white (or black, depending on your system settings) and the linetype CONTIN-
UOUS. By default, a new layer is also visible. After you create and name a layer, you 
can change its color, linetype, visibility, and other properties. For detail see “Creating 
and naming layers” on page 41.     

To create a new layer

1 Do one of the following:     

• Choose Tools > AViCAD Explorer.     

• Type explayers and then press Enter.       

• Type explorer and then press Enter.

2 Choose Edit > New > Layer.

The program adds a new layer to the Layer Name list, with the default name 
NewLayer1.

3 Type a name for the new layer over the highlighted default name, and then press Enter.

4 To complete the command and return to your drawing, close the window.

A Select to keep the dialog box on the screen 
when you switch back to the AViCAD Explorer.

B Displays the name of the layer whose properties 
are being changed.

C Displays the current layer color.

D Choose the linetype assigned to the selected 
layer.

E Choose the lineweight assigned to the selected 
layer.

F Choose the print style assigned to the selected 
layer (only for drawings that use named print 
style tables).

G Click to display the Color dialog box to select a 
new color.   

H Select or clear check boxes to control other 
properties of the selected layer.

A

B

C

D

E
H

G

F
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NOTE You can also create a new layer by selecting the Layers element for a draw-
ing and clicking the New Item tool ( ).

To change a layer name in the current drawing

1 Do one of the following:     

• Choose Tools > AViCAD Explorer.     

• Type explayers and then press Enter.       

• Type explorer and then press Enter.

2 In the Layer Name list, select the layer you want to make current.

3 Do one of the following:

• Choose Edit > Rename, type a new name, and then press Enter.

• Highlight the layer name you want to change, type a new name, and then press 
Enter.

• Right-click the layer name you want to change, and from the shortcut menu, 
select Rename, type a new name, and then press Enter.

4 To complete the command and return to your drawing, close the window.    

NOTE You cannot rename the 0 layer.

Setting the current layer
When you create new entities, they are drawn on the current layer. To draw new enti-
ties on a different layer, you must first make that layer the current layer.   

To make a layer current 

1 Do one of the following:

• Choose Tools > AViCAD Explorer.     

• Type explayers and then press Enter.       

• Type explorer and then press Enter.

2 In the Layer Name list, select the layer you want to make current.

3 Do one of the following:

• Choose Edit > Current.

• In the Layer Name list, select the name you want to make current, and then click 
the Current tool ( ).

• Double-click the layer name in the Layer Name list. 

• Right-click the layer name you want to change, and from the shortcut menu 
select Current. 

4 To complete the command and return to your drawing, close the window.
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To set the current layer to that of an existing entity

1 Do one of the following:      

• Choose Tools > AViCAD Explorer.     

• Type explayers and then press Enter.       

• Type explorer and then press Enter.

2 Select the entity to set the current layer.    

Controlling layer visibility   
A layer can be visible or invisible. Entities on invisible layers are not displayed and 
do not print. By controlling layer visibility, you can turn off unnecessary information, 
such as construction lines or notes. By changing layer visibility, you can put the same 
drawing to multiple uses.    

For example, if you are drawing a floor plan, you can draw the layout of light fixtures 
on one layer and the location of plumbing lines on another. By selectively turning 
layers on and off, you can print the electrical engineering drawings and the plumbing 
drawings from the same drawing file. For even more convenience, you can control 
the visibility of layers within individual viewports, so that layers that display in one 
viewport are invisible in other viewports in the same drawing. For detail see “Con-
trolling layer visibility” on page 43. 

To turn layers on or off

1 Do one of the following:     

• Choose Tools > AViCAD Explorer.     

• Type explayers and then press Enter.       

• Type explorer and then press Enter.

2 In the Layer Name list, select the layer you want to turn on or off.

3 Do one of the following:

• Choose View > On/Off.

• Right-click the layer you want to change, and from the shortcut menu, select 
Properties and turn the layer on or off. 

• Click the setting in the On/Off column.

The On/Off column shows the new setting.

4 To complete the command and return to your drawing, close the window.

You can also freeze layers to improve the performance of operations such as zooming 
and panning or producing hidden lines or shaded images. When a layer is frozen, 
entities drawn on that layer are no longer visible.    

To control the visibility of external reference layers and save any changes made to 
them in the current drawing, turn on the XRef Layer Visibility system variable.
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To turn on XRef Layer Visibility

1 Do one of the following:    

• Choose Tools > AViCAD Explorer.     

• Type explayers and then press Enter.       

• Type explorer and then press Enter.

2 Choose View > XRef Layer Visibility.

NOTE You can also turn on this variable by typing visretain.

To freeze or thaw layers

1 Do one of the following:    

• Choose Tools > AViCAD Explorer.     

• Type explayers and then press Enter.       

• Type explorer and then press Enter.

2 In the Layer Name list, select the layers you want to freeze or thaw.

3 Do one of the following:

• Choose View > Freeze/Thaw.

• Right-click the layer you want to change, and from the shortcut menu, select 
Properties and freeze or thaw the layer.

• Click the setting in the All Viewports column.

The All Viewports column shows the new setting.

4 To complete the command and return to your drawing, close the window.

Locking and unlocking layers 
Locking a layer makes it easy to refer to information contained on the layer, but pre-
vents you from accidentally modifying its entities. When a layer is locked (but visible 
and thawed), its entities remain visible, but you cannot edit them. If you lock the cur-
rent layer, you can still add new entities to it. You can also change the linetype and 
color associated with a locked layer. Unlocking a layer restores full editing capabili-
ties. For detail see “Locking and unlocking layers” on page 44.    
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To lock or unlock layers

1 Do one of the following:

• Choose Tools > AViCAD Explorer.     

• Type explayers and then press Enter.       

• Type explorer and then press Enter.

2 In the Layer Name list, select the layers you want to lock or unlock.

3 Do one of the following:

• Choose View > Lock/Unlock.

• Right-click the layer name you want to change, and from the shortcut menu, 
select Properties and lock or unlock the layer.

• Click the setting in the Locked column.

The Locked column shows the new setting.

4 To complete the command and return to your drawing, close the window.

Controlling layer printing   
Controlling layer printing is another way you can specify which entities print in your 
drawing. 

By controlling layer printing, you can turn off unnecessary information during print-
ing. For example, if you are drawing a floor plan, you can draw the layout of light fix-
tures on one layer and the location of plumbing lines on another. By selectively 
turning layers on and off when you print, you can print the electrical engineering 
drawings and the plumbing drawings from the same drawing file. By changing layer 
printing, you can put the same drawing to multiple uses.    

When you turn off printing for a layer, entities drawn on that layer are still visible, but 
they do not print. If you turn off a layer’s visibility, entities drawn on that layer do not 
display or print. Controlling layer printing can be especially helpful if you want layer 
visibility on, but do not want to print entities on that layer. 

Layer visibility must be turned on in order to print entities drawn on that layer.

To turn layer printing on or off

1 Do one of the following:     

• Choose Tools > AViCAD Explorer.     

• Type explayers and then press Enter.       

• Type explorer and then press Enter.

2 In the right pane, click the setting in the Print column for the layer you want to 
change. Choose Yes to print entities assigned to the layer. Choose No to omit enti-
ties assigned to the layer during printing.

You can also right-click the layer you want to change, and from the shortcut menu, 
select Properties and change the print setting for a layer.
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Setting the layer color   
Each layer in a drawing is assigned a color. AViCAD uses the BYLAYER color as 
the default color setting for entity creation so that new entities are drawn in the color 
of the layer on which they are inserted (set in the Drawing Settings dialog box).    

Using the AViCAD Explorer, you can set or change the color assigned to a layer. 
With the direct-editing feature, you can click on the color you want to change, and 
then select a new color from the dialog box that appears. Changing a layer’s color 
automatically changes the color of all entities on that layer with the BYLAYER color.

To change the layer color

1 Do one of the following:     

• Choose Tools > AViCAD Explorer.     

• Type explayers and then press Enter.       

• Type explorer and then press Enter.

2 In the right pane, click the color swatch for the layer you want to change.

TIP Right-click the name of the layer you want to change, and from the shortcut 
menu, select Properties and change the layer color.

3 In the Color dialog box, select a color on one of the following tabs:

• Index Color — Click BYBLOCK, BYLAYER, or one of the 255 index colors. 
You can also type the color number in the Index box.

• True Color — Click a basic color, click a color in the color palette, enter the 
Hue, Saturation, and Luminance (HSL) values, or enter the Red, Green, Blue 
(RGB) values. There are more than 16 million true colors from which you can 
choose.

• Color Books — Select a color book from the list, then click a color. You can 
select Show Only Color Book Colors Used in Drawing to limit the selection to 
only those color book colors that are used in the current drawing. If necessary, 
create or edit color books by clicking Color Book Editor. For more details, see 
“Using color books” on page 60. 

4 Click OK.

NOTE You can also assign a specific color to an entity, which overrides the layer’s 
color setting. When you create a new entity, use the Format > Colors > Select Colors 
command to change the current color. For an existing entity, select the entity, right-
click for the shortcut menu, and choose Properties. You can then change the entity’s 
color in the Entity Properties dialog box.   

For more details about using color in the many aspects of your drawing, see “Work-
ing with colors” on page 57. 
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Setting a layer’s linetype    
Each layer uses a default linetype (a repeating pattern of dashes, dots, or blank spaces). 
Linetype determines the appearance of entities both on the screen and when printed.    

It’s a good idea to assign the BYLAYER linetype to any entities that you draw on that 
layer. AViCAD uses the BYLAYER linetype as the default linetype setting for Entity 
Creation (in the Drawing Settings dialog box).

Using the AViCAD Explorer, you can set or change the linetype assigned to a layer. 
With the direct-editing feature, you can click on the linetype you want to change, and 
then select a new linetype from the dialog box that appears. Changing the linetype 
assigned to a layer changes the linetype of all entities drawn on that layer with the 
BYLAYER linetype.

NOTE Only those linetypes already set in the drawing can be assigned to layers. For 
more information about setting additional linetypes, see “Working with linetypes” on 
page 184 in this chapter. 

To change the linetype assigned to one or more layers

1 Do one of the following:    

• Choose Tools > AViCAD Explorer.     

• Type explayers and then press Enter.       

• Type explorer and then press Enter.

2 In the right pane, click the linetype for the layer you want to change.

3 In the Linetype dialog box, select a new linetype for the layer, or click Browse to 
select your linetype file.

You can also right-click the layer you want to change, and from the shortcut menu, 
select Properties and change the linetype assigned to a layer.

NOTE You can also assign a specific linetype to an entity, which overrides the 
layer’s linetype setting. When you create a new entity, use the Format > Explore 
Linetypes command to change the current linetype through the AViCAD Explorer. 
For an existing entity, select the entity, right-click for the shortcut menu, and choose 
Properties. You can then modify the entity’s linetype in the Entity Properties dialog 
box.   

Setting a layer’s lineweight 
Each layer uses a default lineweight. Lineweights determine the thickness of entities 
both on the screen and when printed.              
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All new layers are assigned the DEFAULT lineweight, which is .25 millimeters or 
.01 inches. If you want a different lineweight assigned to a layer, you can easily 
change it using AViCAD Explorer. For example, you may want different lineweights 
on each layer of your drawing to show separate elements, such as walls, dimensions, 
structural steel, and electrical plans. Changing the lineweight assigned to a layer 
changes the lineweight of all entities drawn on that layer with the BYLAYER line-
weight.

When you create new entities, it’s a good idea to assign the BYLAYER lineweight to 
any entities that you draw on that layer, unless you want to override the layer line-
weight. AViCAD uses the BYLAYER lineweight as the default lineweight setting 
when you create entities (in the Drawing Settings dialog box). 

TIP To change the DEFAULT lineweight, choose Tools > Drawing Settings, click 
the Display tab, select Lineweights in Change Settings For, and then select a new 
default.

To change the lineweight assigned to one or more layers

1 Do one of the following:    

• Choose Tools > AViCAD Explorer.     

• Type explayers and then press Enter.       

• Type explorer and then press Enter.

2 In the right pane, click the lineweight for the layer you want to change.

3 In the Lineweight list, click the arrow to scroll the lineweights, and then select a 
new lineweight for the layer.

You can also right-click the layer you want to change, and from the shortcut menu, 
select Properties and change the lineweight assigned to a layer.

NOTE You can also assign a specific lineweight to an entity, which overrides the 
layer’s lineweight setting. When you create a new entity, use the Tools > Drawing 
Settings > Entity Creation tab to change the current lineweight. For an existing 
entity, select the entity, right-click for the shortcut menu, and choose Properties. You 
can then modify the entity’s lineweight in the Entity Properties dialog box.      

Setting a layer’s print style 

If your drawing uses named print style tables, you can specify a print style for each 
layer. Named print style tables contain print styles that you set up to control what enti-
ties look like when they print, without actually changing the entities in the drawing.
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If your drawing uses color-dependent print style tables, you cannot specify a print 
style for a layer. These types of print style tables automatically determine printing 
requirements by the color assigned to a layer or an entity. For details about converting 
a drawing that uses color-dependent print style table to use named print style tables, 
see “Changing a drawing’s print style table type” on page 415. 

In drawings that use named print style tables, the default print style is Normal for all 
new layers. If desired, you can assign a print style using AViCAD Explorer. Chang-
ing the print style assigned to a layer changes the print style of all entities drawn on 
that layer with the BYLAYER print style.

When you create new entities, it’s a good idea to assign the BYLAYER print style to 
any entities that you draw on that layer, unless you want to override the layer print 
style. AViCAD uses the BYLAYER print style as the default print style setting when 
you create entities (in the Drawing Settings dialog box).

To change the print style assigned to one or more layers (only in a drawing that 
uses named print style tables)

1 Do one of the following:    

• Choose Tools > AViCAD Explorer.     

• Type explayers and then press Enter.       

• Type explorer and then press Enter.

2 In the right pane, click the print style for the layer you want to change.

3 If necessary, select a different print style table in the Active Print Style Table list.

4 In Print Styles, select a print style.

5 Click OK. 

You can also right-click the layer you want to change, and from the shortcut menu, 
select Properties and change the print style assigned to a layer.

NOTE For drawings that use named print style tables, you can also assign a specific 
print style to an entity, which overrides the layer’s print style setting. When you cre-
ate a new entity, use the Tools > Drawing Settings > Entity Creation tab to change 
the current print style. For an existing entity, select the entity, right-click for the 
shortcut menu, and choose Properties. You can then modify the entity’s print style in 
the Entity Properties dialog box.     
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Working with linetypes 

AViCAD provides simple and complex linetypes:

• A simple linetype consists of a repeating pattern of dots, dashes, or blank spaces.

• A complex linetype contains embedded shape and text objects along with 
dots, dashes, and spaces.

You can use different linetypes to represent specific kinds of information. For exam-
ple, if you are drawing a site plan, you can draw roads using a continuous linetype, a 
fence using a linetype of dashes square posts, or a gas line using a complex linetype 
showing the text ’GAS’.

By default, every drawing has at least three linetypes: CONTINUOUS, BYLAYER, 
and BYBLOCK. You cannot rename or delete these linetypes. Your drawing may 
also contain an unlimited number of additional linetypes. You can load more line-
types into the program from a linetype library file or create and save linetypes you 
define. 

To display the AViCAD Explorer Linetypes element

Do one of the following:    

• Choose Format > Explore Linetypes.

• Type expltypes and then press Enter.

• Choose Tools > AViCAD Explorer, and then click the Linetypes element.
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Setting the current linetype
You normally draw an entity using the linetype assigned to the current layer, indi-
cated as BYLAYER. You can also assign linetypes on a per-entity basis, which over-
rides the layer’s linetype setting. A third option is to assign the BYBLOCK linetype, 
whereby you draw new entities using the default linetype until you group them into a 
block. The entities inherit the current linetype setting when you insert the block into 
the drawing.    

To make the linetype current

1 Do one of the following:    

• Choose Format > Explore Linetypes.

• Type expltypes and then press Enter.

2 In the Linetype Name list, select the linetype you want to make current.

3 Do one of the following:

• Choose Edit > Current.

• Select it in the Linetype Name list and click the Current tool ( ).

• Double-click the linetype name.

4 To complete the command and return to your drawing, close the window.

A Select Linetypes to display the Linetypes settings.

B Lists names of linetypes loaded in the current drawing. A check mark 
indicates the current linetype.

C Describes linetypes loaded in the current drawing.

D Shows how linetypes will appear in the drawing.

E Sorts the linetypes by that property when you click a column head.

B C D

A

E
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Loading additional linetypes 
Before you can select a new linetype to use in a drawing, you must either create the 
linetype definition or load a predefined linetype from a linetype library file (*.lin). 
AViCAD includes a linetype library file, icad.lin, which contains more than 100 pre-
defined linetypes.    

To load a new linetype from a linetype library

1 Do one of the following:    

• Choose Format > Explore Linetypes.

• Type expltypes and then press Enter.

2 Using one of the following methods, open the New Linetype dialog box:

• Choose Edit > New > Linetype.

• Click the New Item tool ( ).

• With the cursor in the right pane of the window, right-click to display the 
shortcut menu, and then choose New > Linetype.

3 Click Choose From File.

4 Click Browse. 

5 Select the linetype library file, and then click Open.

6 Select the linetype you want to load.

7 Click OK, and then close the window.

Creating and naming linetypes 
In addition to loading predefined linetypes from a linetype library file, you can create 
new linetypes. You can save new linetypes you create to a linetype library file for use 
in other drawings.   

To create a new simple linetype   

1 Do one of the following:    

• Choose Format > Explore Linetypes.

• Type expltypes and then press Enter.

2 Using one of the following methods, open the New Linetype dialog box:

• Choose Edit > New > Linetype.

• Click the New Item tool ( ).

• With your cursor in the right pane of the window, right-click to display the 
shortcut menu, and choose New > Linetype.

3 In the Linetype Description field, type the linetype description.

You can type anything in this field that will help you remember the purpose or 
appearance of this linetype. For example, it is helpful to type text or symbols such 
as __..__.. that approximate the appearance of the linetype.
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4 In the Linetype Definition field, type the linetype definition.

The definition consists of positive and negative numbers separated by commas. A 
positive number draws a solid line segment for the specified number of drawing 
units; a negative number creates a gap for the specified number of units; a zero 
creates a dot.   

5 Click OK.

The program adds the new linetype to the linetypes list with the default name, 
NewLinetype1.

6 To enter a name for the new linetype, type over the highlighted default text, and 
press Enter.

Do not use spaces between words in the new linetype name.

7 To complete the command and return to your drawing, close the window.

A Click to select a predefined linetype from a 
linetype library file.

B Type any description in this box that helps you 
remember the purpose or appearance of the 
linetype.

C Type the definition of the linetype, consisting of 
positive and negative numbers separated by 
commas.

A

B

C
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To create a new complex linetype

A complex linetype can denote utilities, boundaries, contours, and so on. As with 
simple linetypes, complex lines are dynamically drawn as the user specifies vertices. 
Shapes and text objects embedded in lines are always displayed completely; they are 
never trimmed.

1 Do one of the following: 

• Choose Format > Explore Linetypes.

• Type expltypes and then press Enter.

2 Using one of the following methods, open the New Linetype dialog box:

• Choose Edit > New > Linetype.

• Click the New Item tool ( ).

• With your cursor in the right pane of the window, right-click to display the shortcut 
menu, and choose New > Linetype.

3 In the Linetype Description field, type the linetype description.

You can type anything in this field that will help you remember the purpose or 
appearance of this linetype. For complex linetypes, it is helpful to type a text 
description of the linetype.

4 In the Linetype Definition field, type the linetype definition.

As for the simple linetypes, the syntax for a complex linetype is a comma delimi-
nated list of pattern descriptors.

5 Click OK.

The program adds the new linetype to the linetypes list with the default name, 
NewLinetype1.

6 To enter a name for the new linetype, type over the highlighted default text, and 
press Enter.

Do not use spaces between words in the new linetype name.

7 To complete the command and return to your drawing, close the window.

Syntax for a complex linetype definition
Complex linetypes can include shape and text objects as pattern descriptors, as well 
as the dash and dot descriptors of simple linetypes.

The shape descriptor syntax 
You can add a shape object to a complex linetype using the following syntax:

[shape_name, shape_filename] or [shape_name, shape_filename, transform]

The definitions of the fields in the syntax are as follows.

shape_name The name of the shape to add to the linetype. The shape name must exist 
in the specified shape file (shape_filename).



W O R K I N G  W I T H  T H E  A V I C A D  E X P L O R E R    189

shape_filename The name of a compiled shape definition file (extension *.shx). If no 
path is defined for the shape filename, the library path is searched for the file.

transform The transform argument is optional and can be any series of the following 
(each preceded by a comma):

R=value Relative rotation

A=value Absolute rotation

S=value Scale

X=value X offset

Y=value Y offset

In this syntax, value represents a signed decimal number. The rotation is expressed in 
degrees while the other options are in linetype scaled drawing units.

rotation R=value or A=value.

R= determines a relative or tangential rotation with respect to the line’s elaboration.

A= determines an absolute rotation of the shape with respect to the origin. All shapes 
have the same rotation regardless of their relative position to the line. The value can 
be appended with a d for degrees (default), r for radians, or g for grads. If rotation is 
omitted, 0 relative rotation is used.

scale S=value.

Determines a factor by which the shape's internal scale is multiplied. If the shape's 
internal scale is 0, the scale value is used as the scale.

X offset X=value.

Determines a shift of the shape along the X axis of the linetype computed from the 
end of the linetype definition vertex. If X offset is omitted or is 0, the shape is elabo-
rated with no offset. Include this field if you want a continuous line with shapes. This 
value is not scaled by the scale factor defined by S.

Y offset Y=value.

Determines a shift of the shape along the Y axis of the linetype computed from the 
end of the linetype definition vertex. If Y offset is omitted or 0, the shape is elabo-
rated with no offset. This value is not scaled by the scale factor defined by S.

The text descriptor syntax 
You can add a text object to a complex linetype using the following syntax:

["string", style_name] or ["string", style_name, transform]

The definitions of the fields in the syntax are as follows.

string The text to be used in the complex linetype. You cannot use the ` or the " char-
acters in the text string. To use these characters, enter a control code (%%) with the 
ASCII value for the character instead.
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style_name The name of the text style to be elaborated. The specified text style must 
be included. If it is omitted, use the currently defined style.

transform The transform argument is optional and can be any series of the following 
(each preceded by a comma):

R=value Relative rotation

A=value Absolute rotation

S=value Scale

X=value X offset

Y=value Y offset

In this syntax, value represents a signed decimal number. The rotation is expressed in 
degrees while the other options are in linetype scaled drawing units.

rotation R=value or A=value.

R= determines a relative or tangential rotation with respect to the line’s elaboration.

A= determines an absolute rotation of the text with respect to the origin. All text has 
the same rotation regardless of its relative position to the line. The value can be 
appended with a d for degrees (default), r for radians, or g for grads. If rotation is 
omitted, 0 relative rotation is used.

Rotation is centered between the baseline and the nominal cap heights box.

scale S=value.

Determines a factor by which the style's height is multiplied. If the style's height is 0, 
the scale value is used as the scale.

Because the final height of the text is defined by both the scale value and the height 
assigned to the text style, you will achieve more predictable results by setting the text 
style height to 0. It is recommended that you create separate text styles for text in 
complex linetypes to avoid conflicts with other text in your drawing.

X offset X=value.

Determines a shift of the text along the X axis of the linetype computed from the end 
of the linetype definition vertex. If X offset is omitted or is 0, the text is elaborated by 
using the lower left corner of the text as the offset. Include this field if you want a 
continuous line with text. This value is not scaled by the scale factor that is defined by 
S.

Y offset Y=value.

Determines a shift of the text along the Y axis of the linetype computed from the end 
of the linetype definition vertex. If Y offset is omitted or is 0, the text is elaborated by 
using the lower left corner of the text as the offset. This value is not scaled by the 
scale factor that is defined by S.



W O R K I N G  W I T H  T H E  A V I C A D  E X P L O R E R    191

Editing linetypes

To change a linetype name   

1 Do one of the following:    

• Choose Format > Explore Linetypes.

• Type expltypes and then press Enter.

2 Do one of the following:

• Select the linetype, and then choose Edit > Rename. 

• Click the linetype name you want to change, and then type the new name.

• Right-click the linetype name you want to change, and from the shortcut menu, 
select Rename.

3 To complete the command and return to your drawing, close the window.

To change a linetype definition

1 Do one of the following:

• Choose Format > Explore Linetypes.

• Type expltypes and then press Enter.

2 Right-click on the linetype name for which you want to change the definition.

3 From the shortcut menu, select Properties.

4 In the Linetype Definition field, define the linetype using positive and negative 
numbers and zeros. 

A positive number draws a solid line segment for the specified number of drawing 
units. A negative number creates a gap for the specified number of drawing units. 
A zero creates a dot.

5 To complete the command and return to your drawing, close the Linetypes dialog 
box and the AViCAD Explorer window.

NOTE You cannot rename the CONTINUOUS, BYBLOCK, or BYLAYER linetypes.

Working with text fonts and styles 

When you add text to a drawing, it is created using the current text style. The text 
style determines the font, size, angle, orientation, and other text characteristics.   
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Every drawing has at least one text style, named Standard, which initially uses the txt 
font. You cannot delete the Standard style, but you can rename it or modify it. For 
example, you can change the font or the oblique angle applied to the font. You also 
can use an unlimited number of additional text styles in your drawing.    

From the AViCAD Explorer, you can directly edit any setting associated with a text 
style by using the single-click editing method to change the setting.   

To display the AViCAD Explorer Text Styles element

Do one of the following:    

• Choose Format > Explore Text Styles.

• Choose Tools > AViCAD Explorer, and then click the Styles element.

• On the Style toolbar, click the Explore Text Styles tool ( ).

• Type expstyles and then press Enter.
  

A Select Text Styles to display the text style settings.

B Lists names of text styles defined in the current drawing. A check mark 
indicates the current style.    

C Displays the height assigned to the text style.

D Displays the width factor assigned to the text style.    

E Displays the oblique angle assigned to the text style.    

F Displays the font on which the style is based.

G Displays the font style, such as bold or italic.

H Displays the language on which the text style is based.

I Displays whether Asian language big font files are used (for .shx file 
fonts only).

J Indicates whether text will appear backward.    

K Indicates whether text will appear upside down.

L Indicates whether text will appear vertically.

M Click any column head to sort the styles by that property.

A

B C D E F G H I J K L

M
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Creating and naming text styles 
Fonts are character sets that consist of letters, numbers, punctuation marks, and sym-
bols. Each font is stored in its own font file. Text styles apply additional formatting to 
fonts. You can create multiple text styles based on the same font, changing the vari-
ous characteristics to alter the appearance of the font. To create a new text style, you 
assign formatting characteristics to a font.    

AViCAD uses *.shx font files and provides a selection of fonts. These fonts are 
located in the AViCAD/Fonts directory. You can also use any font designed to work 
with AutoCAD. Many fonts are available from third-party vendors.  

To create a new text style

1 Do one of the following:     

• Choose Format > Explore Text Styles.

• On the Style toolbar, click the Explore Text Styles tool ( ).

• Type expfonts and then press Enter.

2 Choose Edit > New > Style.

3 Select the font on which you want to base the new style, and then click Open.

The program adds a new style to the text styles list with the default name, 
NewStyle1.

4 Type the name for the new style by typing over the highlighted default text, and 
then press Enter.

5 To complete the command, close the window.

NOTE You can also create a new text style by selecting the Styles element and click-
ing the New Item tool ( ).

To change a text style name in the current drawing

1 Do one of the following: 

• Choose Format > Explore Text Styles.

• On the Style toolbar, click the Explore Text Styles tool ( ).

• Type expfonts and then press Enter.

2 Do one of the following:

• Select the text style, choose Edit > Rename, type a new name, and then press 
Enter.

• Click the text style name you want to change, type a new name, and then press 
Enter. 

• Right-click the text style name you want to change, and from the shortcut menu, 
select Rename, type a new name, and then press Enter.

3 To complete the command and return to your drawing, close the window.
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Modifying text styles
A new text style is initially assigned default values for height, width factor, oblique 
angle, and other characteristics. You can change these values for both new and exist-
ing text styles. You can also change the font assigned to the text style. If you change 
the font or orientation properties of a text style assigned to text previously inserted in 
the drawing, all text using that style is regenerated to reflect the changes. Oblique 
angle and height, if specified, are given by the style definition when text is created, 
but are not updated for existing text when the style is changed.    

A fixed text height value of 0 allows you to specify the text height at the time you 
insert text into the drawing. Any other value sets height of the text to that value; the 
program does not prompt for the text height when you insert text into the drawing. 
The width factor determines the horizontal scaling of text. A value less than 1 com-
presses the text (for example, 0.75 compresses the text 25 percent); a value greater 
than 1 expands the text (for example, 1.50 expands the text 50 percent). The oblique 
angle determines the forward or backward slant of text as an angle offset from 90 
degrees. Negative values slant text to the left; positive values slant text to the right.

To modify a text style   

1 Do one of the following:     

• Choose Format > Explore Text Styles.

• On the Style toolbar, click the Explore Text Styles tool ( ).

• Type expfonts and then press Enter.

2 Select the text characteristic of a style that you want to modify. 
The text characteristic either toggles its value or a dialog box appears, allowing 
you to make the modifications you want.

3 To complete the command, close the AViCAD Explorer window.
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Setting the current text style
When you insert text in a drawing, the text is created using the current text style. You 
can also select a different text style when you create text.    

To make the text style current

1 Do one of the following:     

• Choose Format > Explore Text Styles.

• On the Style toolbar, click the Explore Text Styles tool ( ).

• Type expfonts and then press Enter.

2 In the Text Style Name list, click the style you want to make current.

3 Use one of the following methods to make the style the current style:

• Choose Edit > Current.

• Click the Current tool ( ).

• With the cursor in the right pane of the window, right-click to display the 
shortcut menu, and choose Current.

A Select to keep the dialog box on the screen 
when you switch back to the AViCAD Explorer or 
another element.

B Displays the name of the text style whose 
properties are being changed.

C Type the fixed text height. 

D Type the width factor.

E Type the oblique angle.

F Select to create text that displays backward.

G Select to create text that displays upside down.    

H Select to create text that displays vertically.    

I Displays a text preview of the text font.

J Select the Asian language big font (for .shx file 
fonts only).

K Select the text style language.

L Select the font style.

M Select the font name.   

A

B

C

D

E

F
G

H
I

L

J
K

M
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4 To complete the command and return to your drawing, close the AViCAD 
Explorer window.

NOTE You can also make a text style current by selecting it in the Text Style Name 
list and clicking the Current tool ( ) or by double-clicking the text style name in the 
Text Style Name list.    

Working with coordinate systems 

When you create entities in a drawing, they are located in relation to the drawing’s 
underlying Cartesian coordinate system. Every drawing has a fixed coordinate system 
called the World Coordinate System (WCS). You cannot delete or modify the WCS.   

Your drawing may contain additional coordinate systems, however, each with its own 
0,0,0 origin and orientation. You can create as many user coordinate systems as you 
want, and then save and recall them as you need them. You can edit the origin of a 
coordinate system from within the AViCAD Explorer by single-clicking the origin 
coordinates and then typing new coordinates.

For example, you can create a separate user coordinate system (UCS) for each side of 
a building. Then, by switching to the UCS for the east side of the building, you can 
draw the windows on that side by specifying only their x- and y-coordinates.

You can create and then switch between various user coordinate systems by selecting 
Coordinate Systems in the AViCAD Explorer.

To display the Coordinate Systems element

Do one of the following:    

• Choose Tools > Explore Coordinate Systems.

• Choose Tools > AViCAD Explorer, and then click the Coordinate Systems ele-
ment.

• Choose Tools > Orthographic UCS, and then click Explore UCSs.

• On the UCS toolbar, click the Display UCS Dialog tool ( ) and Explore UCSs.

• Type expucs and then press Enter. 
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Defining and naming user coordinate systems 
A drawing can contain as many coordinate systems as you want and can be named 
appropriate names so you can remember how they are used in your drawing for 
recalling them later.

To define new user coordinate systems in the AViCAD Explorer

1 Do one of the following:   

• Choose Tools > Explore Coordinate Systems.

• On the UCS toolbar, click the Display UCS Dialog tool ( ) and Explore 
UCSs  .

• Type expucs and then press Enter.

2 Do one of the following:   

• Choose Edit > New > UCS.

• Click the New Item tool ( ).

• With your cursor in the right pane of the window, right-click to display the 
shortcut menu, and choose New > UCS.

A Select Coordinate Systems to display the Coordinate 
Systems settings.

B Lists names of coordinate systems defined in the current 
drawing. A check mark indicates the current coordinate 
system.

C Displays the origin of the coordinate system in relation to 
the WCS.

D Displays the x-axis direction of the coordinate system in 
relation to the WCS.

E Displays the y-axis direction of the coordinate system in 
relation to the WCS.

F Click any column head to sort the coordinate systems by 
that property.

A

B C D E

F
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3 Select a method from the prompt box or command bar by which to define the UCS 
in the drawing window. 

For example, select 3 Point and then specify three points in the drawing window 
to define the x, y, and z axes for your coordinate system.

4 Type the name for the new user coordinate system by typing over the highlighted 
default text, and then press Enter.

5 To complete the command, close the window.

To change a user coordinate system name in the current drawing

1 Do one of the following:

• Choose Tools > Explore Coordinate Systems.

• On the UCS toolbar, click the Display UCS Dialog tool ( ) and Explore 
UCSs  .

• Type expucs and then press Enter.

2 Do one of the following:

• Select the user coordinate system, and then choose Edit > Rename, type a new 
name, and then press Enter.

• Click the user coordinate system name you want to change, type a new name, 
and then press Enter.

• Right-click the user coordinate system name you want to change, and from the 
shortcut menu, select Rename, type a new name, and then press Enter.

3 Type the new user coordinate system name, and then press Enter.

4 To complete the command and return to your drawing, close the window.

Setting the current user coordinate system
When you draw new entities, they are created in relation to the current coordinate 
system. You can set the current UCS from the AViCAD Explorer.    

To set the current UCS from the AViCAD Explorer

Do one of the following:

• Double-click the UCS name in the UCS Name list.

• Select the UCS in the UCS Name list, and then choose Edit > Current.

• Select the UCS in the UCS Name list, and then click the Current tool ( ).     
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Using named views 

As you work on a drawing, you may find that you frequently switch among different 
portions of it. For example, if you are drawing the floor plan of a house, you may 
zoom in to particular rooms of the house and then zoom out to display the entire 
house. Although you can repeat the Pan and Zoom commands to do this, it is much 
easier to save various views of the drawing as named views. You can then quickly 
switch among these views. You can save and later restore named views using either 
the View command or the Views element in the AViCAD Explorer.    

To display Views in the AViCAD Explorer

Do one of the following:    

• Choose Format > Explore Views.

• Choose View > Named Views.

• Type view and then press Enter.

• Choose Tools > AViCAD Explorer, and then click the Views element.  

A To display the Views settings, select Views.

B Lists names of views defined in the current drawing. 
A check mark indicates the current view.    

C Displays the height of the view in drawing units.    

D Displays the width of the view in drawing units.

E Displays the direction of the view, expressed as a three-
dimensional coordinate in the WCS.

F Click any column head to sort the views by that property.

A

B C D E

F
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Saving and naming views 
You can save the view displayed in the current window as a named view. After you 
save a named view, you can restore that view in the current window at any time.    

To save the current view as a named view

1 Do one of the following:     

• Choose View> Named Views.

• On the View toolbar, click the Named Views tool ( ).

• Type view and then press Enter.

2 choose New item and, in the prompt box, press Save.

3 Type a name for the view, and then press Enter.

To save a portion of the current view as a named view

1 Do one of the following:     

• Choose Format > Explore Views.

• Type view and then press Enter.

2 Do one of the following:

• Choose Edit > New > View.

• On the AViCAD Explorer toolbar, click the New Item tool ( ).

3 In the prompt box, choose Window.

4 Specify the first corner of the view window.

5 Specify the opposite corner of the view window.

6 Rename the new view, and then press Enter.

Do not use spaces between words in the new view name.

7 To complete the command and return to your drawing, close the window.

NOTE You can also create a new view by selecting the Views element in the 
AViCAD Explorer and clicking the New Item tool ( ).
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To change a saved view name in the current drawing

1 Do one of the following:

• Choose Format > Explore Views.

• Type view and then press Enter.

2 Do one of the following:

• Select the view, choose Edit > Rename, type a new name, and then press Enter.

• Click the view name you want to change, type a new name, and then press Enter.

• Right-click the view name you want to change, and from the shortcut menu, 
select Rename, type a new name, and then press Enter.

3 Type the new view name, and then press Enter.

4 To complete the command and return to your drawing, close the window.

Restoring named views   
After you save one or more named views, you can restore any of those views in the 
current window using either the View command or the AViCAD Explorer.    

To restore a named view using the View command

1 Do one of the following:

• Choose View > Named Views.

• On the View toolbar, click the Named Views tool ( ).

• Type view and then press Enter.

2 In the prompt box, choose Restore.

3 Type the name of the view you want to restore, and then press Enter.

To restore a named view from the AViCAD Explorer

Do one of the following:

• Select the view name in the list of View settings, and then choose Edit > Current.

• Select the view name in the list of View settings, and then click the Current tool 
( ).

• Double-click the view name in the View list.

Changing named view properties   
Once you create a named view you can modify its properties, such as the target direc-
tion and twist angle. This gives you access to many of the view settings after a view 
has been defined.   
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To change the view options

1 Do one of the following:

• Choose Format > Explore Views.

• Type view and then press Enter.

2 Select the view whose properties you want to change.

3 Choose Edit > Properties.

You can also right-click the view you want to change, and from the shortcut menu, 
select Properties. 

4 Change the values of the settings on any of the tabs and close the dialog box.

5 To complete the command and return to your drawing, close the window.

Working with blocks and external references 

Blocks represent a special type of entity that, once saved, can be inserted and manip-
ulated in the drawing as a single entity. A block can consist of visible entities such as 
lines, arcs, and circles as well as visible or invisible data called attributes. You can 
use attributes to track things such as part numbers and prices and to export attribute 
information to an external database. You can also track the number of parts by count-
ing the number of times a block has been inserted into the drawing. Blocks are stored 
as part of the drawing file.    

External references have similar uses to blocks. Using external references, you can 
attach entire drawings to your current drawing. Unlike a block, however, an external 
reference does not become part of the current drawing.    

You can save blocks in the AViCAD Explorer. You can also use the AViCAD 
Explorer to manage and insert copies of blocks. The AViCAD Explorer lists the 
names of all blocks contained in the current drawing, along with other information 
about each block or external reference.    

You can also rename a block, modify its insertion point, and change the path of an 
externally referenced drawing by single-clicking on the property and making your 
edits within the AViCAD Explorer.

To display blocks in the AViCAD Explorer

Do one of the following:    

• Choose Format > Explore Blocks.

• Choose Tools > AViCAD Explorer, and then click the Blocks element.

• Type expblocks and then press Enter.

The Blocks element in the AViCAD Explorer defaults with images on. The Images 
view shows you a small image of each block or external reference.     
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When blocks are displayed, additional tools on the Block toolbar provide the func-
tions described in the following table: 
    

To see more information about each block, click the Details tool ( ). In the Details 
view, you can edit the path and the insertion point by clicking the setting and typing 
your changes. 

The Images view shows an image of each block in the selected drawing. Click an image to select it.

Additional tools on the Block toolbar   

Tool Function

( ) Images Displays a small image of each block.

( ) Details Displays information about each block.

( ) Insert Inserts a block.

( ) Insert External File Blocks Inserts a drawing available from disk as a block.

( ) Save Block Saves selected block as independent.dwg file.

( ) Attach Drawing Attaches drawing as an external reference.
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Creating and naming blocks
You can combine any number of entities into a single block. After you create a block, 
you can insert copies of it into a drawing. Each block insertion is treated as a single 
entity; for example, you can rotate or scale each block when you insert it. The program 
adds the name of the new block you insert to the Block Name list in the AViCAD 
Explorer.    

To create a block

1 Do one of the following:     

• Choose Format > Explore Blocks.

• Type expblocks and then press Enter.

2 Do one of the following:

• Choose Edit > New > Block.

• On the AViCAD Explorer toolbar, click the New Item tool ( ).

3 Enter a name for the new block.    

4 Specify the insertion point for the block.

5 Select the entities to be combined into the block, and then press Enter.

The program adds a new block to the blocks list, with the name you entered for it.

6 To complete the command and return to your drawing, close the window.

A To display the Blocks settings, select Blocks.

B Lists names of blocks and external references defined in the 
current drawing.    

C Displays the number of occurrences of the block in the current 
drawing.     

D Displays the insertion point of the block in the current drawing.

E Displays the name and path for externally referenced drawings.

F Click any column head to sort the blocks by that property.

A

B C D E

F
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To change a block name in the current drawing

1 Do one of the following:

• Choose Format > Explore Blocks.

• Type expblocks and then press Enter.

2 Do one of the following:

• Select the block, choose Edit > Rename, type a new name, and then press Enter.

• Click the block name you want to change, type a new name, and then press 
Enter.

• Right-click the block name you want to change, and from the shortcut menu, 
select Rename, type a new name, and then press Enter.

3 To complete the command and return to your drawing, close the window.

Inserting a block
You can insert into a drawing any block listed in the Block Name list in the AViCAD 
Explorer. This includes blocks contained within any open drawing. 

To insert a block

1 Do one of the following:     

• Choose Format > Explore Blocks.

• Type expblocks and then press Enter.

2 If you wish to insert a block from another open drawing, select the drawing in the 
Elements pane. (If the block is contained within the same drawing, you can skip 
this step.)

3 In either the Details or Images view, select the block to be inserted.

4 On the AViCAD Explorer toolbar, click the Insert tool ( ).

5 In the drawing, specify the insertion point.    

6 Specify the x, y, and z scale factor and the rotation angle, or in the prompt box, 
select Done.   

7 To complete the command and return to your drawing, close the window.

NOTE You can also insert a block by choosing Tools > AViCAD Explorer, and then 
double-clicking the name of the block you want to insert in the Block Name list.

NOTE You can also insert a block from the Insert menu. (See Chapter 13, “Working 
with blocks, attributes, and external references.)” 
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Inserting a drawing as a block      
You can insert as a block another drawing into the current drawing. After you do this, 
the block name is added to the Block Name list in the AViCAD Explorer. Changes 
made later to the inserted drawing will not be reflected in this drawing.    

To insert a drawing as a block

1 Do one of the following:     

• Choose Format > Explore Blocks.

• Type expblocks and then press Enter.

2 On the AViCAD Explorer toolbar, click the Insert External File Blocks tool ( ).    

3 In the Insert Block dialog box, select the drawing you want to insert, and then 
click Open.   

4 In the drawing, specify the insertion point.

5 Specify the x, y, and z scale factor and the rotation angle, or in the prompt box, 
select Done.

6 To complete the command and return to your drawing, close the window.

Attaching a drawing as an external reference
You can attach another drawing to the current drawing as an external reference and 
insert a copy of the drawing into the current drawing. The name of the external refer-
ence drawing is added to the Block Name list. Changes made later to the referenced 
drawing will appear in this drawing when you reload the external reference.    

To attach an external reference

1 Do one of the following:     

• Choose Format > Explore Blocks.

• Type expblocks and then press Enter.

2 On the AViCAD Explorer toolbar, click the Attach Drawing tool ( ).    

3 In the Select File To Attach dialog box, select the drawing you want to attach, and 
then click Open.

4 In the drawing, specify the insertion point.     

5 Specify the x, y, and z scale factor and the rotation angle, or in the prompt box, 
select Done.    

6 To complete the command and return to your drawing, close the window.
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To edit the path of an external reference

1 Do one of the following:    

• Choose Format > Explore Blocks.

• Type expblocks and then press Enter.

2 Click the path you want to change.

3 From the Insert Block dialog box, select the new drawing you want as the external 
reference.

4 Click Open.

5 To complete the command and return to your drawing, close the window.

Saving a block as a separate drawing
You can save a block as a separate drawing, and then you can open and modify that 
drawing as you would any other drawing.     

To save a block as a separate drawing file

1 Do one of the following:     

• Choose Format > Explore Blocks.

• Type expblocks and then press Enter.

2 In either the Details or Images view, select the block you want to save.

3 On the AViCAD Explorer toolbar, click the Save Block To Disk tool ( ).

4 In the Save Block dialog box, select the folder in which you want to save the 
block.

5 In the File Name field, type a name for the new drawing file (or accept the default, 
in which case the new drawing name is the same as the name of the block), and 
then click Save.    

NOTE You can also work with external references using the Xref Manager. For 
details, see “Working with external references” on page 375. 
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Working with dimension styles    

From the AViCAD Explorer, you can use the Dimension Styles element to cut, copy, 
and paste dimension styles from one drawing to another.     

NOTE You can select the dimension style and use the Microsoft Windows shortcut 
keys (Ctrl+A to select all, Ctrl+X to cut, Ctrl+C to copy, Ctrl+V to paste) to accom-
plish the same results. You can use these shortcut keys with all other AViCAD 
Explorer elements as well.

A dimension style contains the settings that control the appearance of a dimension. 
Although you cannot control these settings from within the AViCAD Explorer, you 
can use the Dimension Settings dialog box to control settings related to the appear-
ance of arrows, lines, text, units, and other formatting characteristics. 

To display the AViCAD Explorer Dimension Styles element

Do one of the following:    

• Choose Format > Explore Dimension Styles.

• Choose Tools > AViCAD Explorer, and then click the Dimension Styles element.

• On the Dimension toolbar, click the Dimension Style tool ( ).

• Type setdim and then press Enter.    

A To display the Dimension Styles settings, select Dimension 
Styles.

B Lists the names of dimension styles defined in the current 
drawing.

C Click the Dimension Style Name column head to sort by 
name.

A

B

C
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Creating and naming dimension styles 
By using the Dimension Styles element in combination with the Dimension Settings 
dialog box, you can create new dimension styles, modify them, and copy them into a 
different drawing. 

To create a dimension style

1 Do one of the following:

• Choose Dimension > Style.

• On the Dimension toolbar, click the Dimension Style tool ( ).

• Type setdim and then press Enter.

2 In the Dimension Settings dialog box, click New.

3 Type the name of the new dimension style.

4 Click Create.

5 In the Dimension Settings dialog box, click one of the other tabs, and then change 
the dimension settings as necessary.

Repeat this step for each tab, as needed.

6 To end the command, click OK.

To change a dimension style name in the current drawing

1 Do one of the following:

• Choose Format > Explore Dimension Styles.

• Type expdimstyles and then press Enter.

2 Do one of the following:

• Select the dimension style, choose Edit > Rename, type a new name, and then 
press Enter.

• Click the dimension style name you want to change, type a new name, and then 
press Enter.

• Right-click the dimension style name you want to change, and from the shortcut 
menu, select Rename, type a new name, and then press Enter.

3 To complete the command and return to your drawing, close the window.



210   C H A P T E R  8

To copy a dimension style from one drawing to another

1 Do one of the following:

• Choose Format > Explore Dimension Styles.

• Type expdimstyles and then press Enter. 

2 Right-click the dimension style name you want to copy.

3 From the shortcut menu, select Copy.

4 In the left pane, select the drawing to which you want to copy the dimension style.

5 Click the Dimension Styles element for that drawing.

6 In the right pane, right-click, and then from the shortcut menu, select Paste.

NOTE Each drawing contains a dimension style named Standard. You cannot delete 
this dimension style, but you can rename it from within the AViCAD Explorer or mod-
ify its properties in the Dimension Settings dialog box.    
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Getting drawing information

AViCAD® stores accurate, detailed information about all the entities in a drawing. 
You can get details about an existing drawing and its entities using the tools for mea-
suring distances and calculating areas. You can also track the amount of time you 
spend editing a drawing. This chapter explains how to:

• Measure distances along an entity.

• Measure distances and angles.

• Divide an entity into a number of equal segments.

• Calculate areas.

• Display information about entities in a drawing.

• Track the amount of time spent editing a drawing.

Many of the functions described in this chapter require that you set AViCAD to the 
Advanced experience level.

Topics in this chapter

Specifying measurements and divisions........................................................... 212

Calculating areas.............................................................................................. 215

Calculating distances and angles ..................................................................... 218

Displaying information about your drawing .................................................219
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Specifying measurements and divisions      

You can divide a line, arc, circle, or polyline into a number of equal segments or mark 
off intervals of a specific length along an entity. (Note that divide is not the same as 
break.) For example, you may want to place station-point markers every 50 feet along 
the centerline of a roadway or divide the plan view of a window into three equal-
width sections of glass, placing a mullion at each division point.    

To specify measurements and divisions, use these commands:

• For the length of the segments, use the Measure command.

• For the number of equal-length segments, use the Divide command.

You can measure or divide arcs, circles, lines, and polylines. With either command, 
you can identify the segments by placing either a block or point entity at the end of 
each interval. If you use points, you can snap to the ends of intervals using the point 
entity snap. The appearance of the point entities is determined by the current point 
display type, which you control in the Drawing Settings dialog box.    

To use a block as the marker, the block must already be defined in the current draw-
ing. You can further indicate whether to rotate the block to align perpendicularly to 
the entity you are measuring or dividing.   

AViCAD begins measuring or dividing based on the point at which you select the 
entity and the type of entity with which you are working. For most entities, measuring 
starts from the endpoint closest to the point you used to select the entity. If you select 
the entity to be measured or divided using a method other than pointing (for example, 
using a window or fence selection), the program prompts you to specify the end from 
which you want to begin measuring.

Block not aligned with entity. Block aligned with entity.



G E T T I N G  D R A W I N G  I N F O R M A T I O N    213

Measuring intervals on entities
You can mark specified length increments along a selected entity using either a point 
entity or a block.    

To measure intervals along an entity and mark them using point entities

Advanced experience level

1 Do one of the following:

• Choose Draw > Point > Measure.

• Type measure and then press Enter.

2 Select the entity.

3 Specify the segment length, and then press Enter.    

To measure intervals along an entity and mark them using blocks 

Advanced experience level

1 Do one of the following:    

• Choose Draw > Point > Measure.

• Type measure and then press Enter.

2 Select the entity.

3 In the prompt box, choose Insert Blocks.

4 Type the name of the block you want to insert as the marker.

5 In the prompt box, choose either Yes-Align Blocks to rotate each insertion of the 
block so that its vertical alignment is always perpendicular to the entity or No-Do 
Not Align to insert each copy of the block with a zero rotation angle.

6 Specify the segment length, and then press Enter.

When you select the entity by pointing, intervals are measured from the end closest to the point at which 
you select the entity (A). Blocks or point entities (B) are placed along the entity at the specified interval.

A B
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Dividing entities into segments
You can place markers along a selected entity, dividing that entity into a specified 
number of equal-length segments. You can use either a point entity or a block to mark 
the segments.    

To divide an entity into segments and mark them using point entities

Advanced experience level

1 Do one of the following:    

• Choose Draw > Point > Divide.

• Type divide and then press Enter.

2 Select the entity.

3 Specify the number of segments, and then press Enter.  

To divide an entity into segments and mark them using blocks    

Advanced experience level

1 Do one of the following:

• Choose Draw > Point >  Divide.

• Type divide and then press Enter.

2 Select the entity.

3 In the prompt box, choose Insert Blocks.

4 Type the name of the block you want to insert as the marker.

5 In the prompt box, choose either Yes-Align Blocks to rotate each insertion of the 
block so that its vertical alignment is always perpendicular to the entity or No-Do 
Not Align to insert each copy of the block with a zero rotation angle.

6 Specify the number of segments, and then press Enter.

When you select the entity by pointing, divisions are marked beginning from the end closest to the 
point at which you select the entity (A). Blocks or point entities (B) are placed along the entity to mark 
it in equal intervals.

A

B
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Calculating areas       

You can calculate the area and perimeter of a polygon based on a series of points you 
specify or enclose with a circle or closed polyline. You can also determine the area of 
several combined entities and add or subtract the area of one or more entities from a 
total combined area.   

Calculating areas defined by points
You can find the area and perimeter of any closed region by specifying a series of 
points. The program calculates the area and perimeter of the space that is enclosed by 
an imaginary polygon consisting of straight-line segments connecting each point.

To calculate the area defined by points you specify

1 Do one of the following:

• Choose Tools > Inquiry > Area.

• On the Inquiry toolbar, click the Area tool ( ).

• Type area and then press Enter.

2 Specify the first point.

3 Specify the second point.

4 Continue specifying points in sequence to define the perimeter of the area you 
want to measure.

As you select each successive point, the resulting polygon is displayed on the 
screen.

5 To complete the calculation, press Enter.

The area and perimeter of the region you defined are displayed. For example, the 
following type of information is displayed:

Area = 11.0583, Perimeter = 15.3092    

Select the points (A, B, C) that form a polygon. The area and 
perimeter of the region are then calculated.

A

C

B
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Calculating areas of closed entities
You can find the area of any closed entity. In addition, the program calculates either the 
circumference or the perimeter of the entity, depending on the type of entity you select.

To calculate the area of a closed entity

1 Do one of the following:

• Choose Tools > Inquiry > Area.

• On the Inquiry toolbar, click the Area tool ( ).

• Type area and then press Enter.

2 In the prompt box, choose Find Area Of One Entity.

3 Select the entity.

The following type of information is displayed:

Area = 62.3837, Circumference = 27.9989

Calculating combined areas  
You can find the total area of several combined regions by specifying points or by 
selecting entities. You can also subtract the areas of entities or polygons from a 
running total.    

To add areas to calculate a combined area    

1 Do one of the following:

• Choose Tools > Inquiry > Area.

• On the Inquiry toolbar, click the Area tool ( ).

• Type area and then press Enter.

2 In the prompt box, choose Add Areas Together.

3 Using one of the following methods, identify the first area:

• Specify points defining a polygon, and then in the prompt box, choose Done 
Specifying Area.

• In the prompt box, choose Add Entities To Area, select the entities you want to 
add, and then press Enter to complete the calculations.

4 To complete the command, choose Done in the prompt box.
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To subtract areas when calculating a combined area    

1 Do one of the following:    

• Choose Tools > Inquiry > Area.

• On the Inquiry toolbar, click the Area tool ( ).

• Type area and then press Enter.

2 In the prompt box, choose Add Areas Together.

3 Using one of the following methods, identify the first area:

• Specify points defining a polygon, and then in the prompt box, choose Done 
Specifying Area.

• In the prompt box, choose Add Entities To Area, select the entities you want to 
add, and then press Enter to complete the calculations.

4 In the prompt box, choose Subtract Areas.

5 Using one of the following methods, identify the area to be subtracted:

• Specify points defining a polygon, and then in the prompt box, choose Done 
Specifying Area.

• In the prompt box, choose Subtract Entities From Area, select the entities you 
want to subtract, and then press Enter to complete the calculations.

6 To complete the command, choose Done in the prompt box.

As you select entities, the program displays the calculations. If the command bar is 
displayed, the information appears there. If the command bar is not displayed, the 
program opens the Prompt History window and displays the calculations. The follow-
ing type of information is an example of what is displayed:

To calculate the area of the gasket using the Area command, first add 
the area of the entire gasket (A), and then subtract the areas of the two 
circles (B and C).

A
B

C
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Entity • Add • Subtract • <First point>: Choose Add Areas Together

Adding: Entity • Subtract • <First point>: Choose Add Entities to Area

Adding area: <Select entities>: Select the first entity

Area = 64.6259, Perimeter = 33.3049

Total length = 33.3049

Total area = 64.6259

Adding area: <Select entities>: press Enter

Adding: Entity • Subtract • <First point>: Choose Subtract Areas

Subtracting: Entity • Add • <First point>: Choose Subtract Entities from 

Area

Subtracting area: <Select entities>: Select the first entity to subtract

Area = 3.1597, Circumference = 6.3012

Total length = 27.0036

Total area = 61.4662

Subtracting area: <Select entities>: Select the second entity to subtract

Area = 3.1597, Circumference = 6.3012

Total length = 20.7024

Total area = 58.3066

Subtracting area: <Select entities>: Press Enter

Subtracting: Entity • Add • <First point>: Choose Done

Calculating distances and angles            

You can calculate the distance between any two points you select. The following 
information is displayed:          

• The distance between the points, measured in drawing units.

• Their angle in the xy plane.

• Their angle measured from the xy plane.

• The change (delta) in the x, y, and z distances between the two points.       
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To calculate the distance between two points and their angle

1 Do one of the following:    

• Choose Tools > Inquiry > Distance.

• On the Inquiry toolbar, click the Distance tool ( ).

• Type distance and then press Enter.

2 Specify the first point.

3 Specify the second point.

The following type of information is displayed:

Distance = 13.2850, Angle in XY Plane = 31º, Angle from XY Plane = 0º

Delta X = 11.3878, Delta Y = 6.8418, Delta Z = 0.0000  

NOTE  To use specific points on selected entities, use entity snaps to select the pre-
cise points on the entities.     

Displaying information about your drawing      

You can display a variety of information about a drawing and the entities it contains, 
including:    

• Information in the drawing database about selected entities.

• The current drawing status.

• The time spent working on the drawing.

This information is displayed in the Prompt History window and in the command bar.    

Use the Distance command to calculate the distance (A) between two points (B 
and C), the angle in the xy plane (D), the angle from the xy plane, and the delta 
x (E), delta y (F), and delta z distances between the two points.

A

B D

E

F

C



220   C H A P T E R  9

Displaying information about entities
You can display information about the selected entities. The information varies, 
depending on the type of entities you select. All of the listings display the following 
information:    

• Entity type.     

• Layer.

• Color.

• Linetype.   

• The location of the entity (its xyz-coordinates relative to the current user 
coordinate system [UCS]).     

• The current space (model space or paper space).     

• The size of the entity (the information varies, depending on the entity type).    

To display information about an entity

Advanced experience level     

1 Do one of the following:

• Choose Tools > Inquiry > List.

• On the Inquiry toolbar, click the List tool ( ).

• Type list and then press Enter.

2 Select one or more entities.

3 Press Enter.

NOTE To return to the drawing window, press F2.

The following type of information is displayed:

------ Circle ---------------------------------------------------

Handle: 2C

Current space: Model

Layer: 0

Color: BYLAYER

Linetype: CONTINUOUS

Handle: 4C

Current space: Model

Center point: X= -5.8583 Y= 7.2752 Z= 0.0000

Radius: 4.4562

Circumference: 27.9989

Area: 62.3837
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Displaying the drawing status
You can display information about the current status of a drawing, including:    

• Drawing name.

• Limits.     

• Insertion base point.     

• Snap and grid settings.

• Current layer, color, and linetype.     

• Current settings for various modes (fill, grid, orthogonal, snap, blips, and so on).    

To display the drawing status

Advanced experience level

Do one of the following:    

• Choose Tools > Inquiry > Drawing Status.

• Type status and then press Enter.

The following type of information is displayed:    
Current drawing name: Site Plan

Drawing limits are: X=0.0000 Y=0.0000 Z=0.0000

X=12.0000 Y=9.0000 Z=0.0000

Paper space limits are: X=0.0000 Y=0.0000 Z=0.0000

X=12.0000 Y=9.0000 Z=0.0000

Screen width (pixels): 971

Screen height (pixels): 569

Insertion base is: X=0.0000 Y=0.0000 Z=0.0000

Snap resolution is: X=0.5000 Y=0.5000 Z=0.0000

Grid spacing is: X:0.5000 Y:0.5000 Z=0.0000

Current layer: 0

Current color: BYLAYER

Current linetype: BYLAYER

Current elevation: 0.0000

Current thickness: 0.0000

Fill: on

Grid: off

Ortho: off

Snap: off

Blips: off

Drag: on
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Command echo: on

Positive angle direction: Counterclockwise

Angular units: Decimal degrees

Dimension units: Decimal

Pick box height: 3

Entities in drawing: 288

Tracking time spent working on a drawing
You can display information about the amount of time you have spent working on a 
drawing, including:    

• The date and time the drawing was created.

• The date and time the drawing was most recently saved.    

• The total amount of time spent working on the drawing.

• The time spent working on the drawing during the current editing session.    

You can turn the elapsed-time timer on and off or reset it to zero.   

To display the timer information

Advanced experience level    

1 Do one of the following:

• Choose Tools > Inquiry > Time Variables.

• Type time and then press Enter.

2 Select any of the prompt box options:

• Choose Timer On to turn the elapsed timer on.

• Choose Timer Off to turn the elapsed timer off.

• Choose Display Timer to redisplay the timer information.

• Choose Reset Timer to reset the elapsed timer to zero.

3 In the prompt box, choose Cancel to exit the command.

Each time you display the timer information, the following type of information is 
displayed:

The current time is Fri Dec 19 09:58:43 1997

Drawing was created on: Wed 17 Dec 1997 at 16:17:59.8090

Drawing was last updated on: Thur 18 Dec 1997 at 09:58:43.3040

Total editing time: 1  2: 35:4.2345

Elapsed timer (on): 0  1: 21:5.6324    
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Modifying entities

AViCAD® provides many editing tools for modifying a drawing. You can easily 
move, rotate, or stretch drawing entities, or change their scale. When you want to 
remove an entity, you can delete it with a few clicks of the mouse. You can also make 
multiple copies of any entity and copy entities from one drawing to another. 

You can modify most entities using general-purpose editing commands. Some com-
plex entities require special commands to modify specific properties. Most of these 
tools and commands are located on the Modify toolbar and the Modify menu.

In addition to the modifying standard tools, some extensions have been implemented 
and gathered in the Express menu.
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This chapter explains how to:

• Select entities using entity-selection methods and grips.

• Change the properties of entities.

• Rearrange entities by moving or rotating.

• Resize entities by stretching, scaling, extending, trimming, or editing their lengths.

• Break and join entities.

• Group entities.

• Edit polylines.

• Explode entities.

• Create chamfers and fillets.

Selecting entities       

You can create a selection set that consists of one or more entities before you modify 
them. Use any of the following methods to create a selection set:    

• Choose a command or tool first, and then select entities.

• Select entities first, and then choose a command or tool (most entities).

• Select entities by pointing, and then use grips to modify them.

Displaying selected entities highlighted
You can specify whether to display selected entities highlighted, which makes the 
selection set easier to see. By default, the highlighting feature is turned on.    

To turn the highlighting feature on or off

1 Do one of the following:     

• Choose Tools > Drawing Settings.

• Type settings and then press Enter.

2 Click the Display tab.

3 In the Change Settings For box, select Display.

4 Select or clear the Highlight Item When Selected check box.

5 Click OK. 
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Entity-selection methods    
When you choose a command that requires you to select entities (when you’re delet-
ing or changing entity properties, for example), you can use any of the following 
selection methods by choosing them in the prompt box or entering them in the com-
mand bar:    

• Select all entities (ALL) Selects all entities in the current drawing.    

• Add to set (+ or A) Adds one or more entities to the selection set.    

• Subtract from set (- or R) Removes one or more entities from the selection set.    

• Previous selection (P) Selects entities included in the previous selection set.    

• Last entity in drawing (L) Selects the entity most recently added to the drawing.    

• Window-Inside (W) Selects entities contained entirely within a rectangular selec-
tion window.    

• Crossing window (C) Selects entities contained within or crossing the boundary of 
a rectangular selection window.    

• Outside window (O) Selects entities falling completely outside a rectangular 
selection window.    

• Window polygon (WP) Selects entities contained entirely within a polygon selec-
tion window.    

• Crossing polygon (CP) Selects entities contained within or crossing the boundary 
of a polygon selection window.    

• Outside polygon (OP) Selects entities falling completely outside a polygon selec-
tion window.    

• Window circle (WC) Selects entities contained entirely within a circular selection 
window.    

• Crossing circle (CC) Selects entities contained within or crossing the boundary of 
a circular selection window.    

• Outside circle (OC) Selects entities falling completely outside a circular selection 
window.    

• Point (PO) Selects any closed entities that surround the selected point.    

• Fence Selects entities crossing a line or line segments.

• Select by Properties (PRO) Selects entities that match a particular set of proper-
ties—for example, all entities on a particular layer or drawn in a certain color.  

You can also use a few selection methods automatically, without displaying the 
prompt box. For example, you can simply click to select entities, or you can use a 
Window-Inside or Crossing Window by defining the opposite corners of a rectangu-
lar selection window. The direction in which you define the points of the rectangle 
(left-to-right or right-to-left) determines which type of window you create.
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To create a Window-Inside

1 Click to select a point in the drawing.    

2 Click to the right of the first point to select a second point in the drawing. 

 

This method is most commonly referred to as simply a window or selection window.

To create a Crossing Window

1 Click to select a point in the drawing.    

2 Click to the left of the first point to select a second point in the drawing.    

In addition to a rectangular window, you can define a selection window using other 
shapes such as a polygon, circle, or fence (a multisegmented line that selects entities 
it crosses).

To select entities using Window Polygon 

1 Activate an entity-modification command.    

2 In the prompt box, choose Window Polygon.

3 Specify the vertices of the polygon.

4 To complete the selection polygon, press Enter. 

Window-Inside by selecting the first (A) and second (B) points.        Resulting selection.

Crossing Window by selecting the first (A) and second 
(B) points.

Resulting selection.

A

B

A

B
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To select entities using Fence 

1 Activate an entity-modification command.

2 In the prompt box, choose Fence.

3 Specify the endpoints of the Fence segments.

4 To complete the Fence, press Enter.    

To select entities using their properties

1 Activate an entity-modification command.

2 In the prompt box, choose Select by Properties.

3 Choose an option for selection: Color, Layer, Linetype, Name, Thickness, Type, 
Value (of attributes, text, or multi-line text), Width (of polylines), or Location.

4 Make your selections, depending on the option you choose.

5 To complete the selection, press Enter.  

Choosing the command first    
When you choose an entity-modification tool or command, the program prompts you 
to select entities and displays a prompt box from which you can choose a selection 
method. You can select individual entities or use other techniques such as selection 
windows to select multiple entities.

Window Polygon by specifying the vertices of the 
polygon (A, B, and C).

Resulting selection.

A

C

B

Fence by specifying the endpoints of the fence segments 
(A, B, and C).

Resulting selection.

A

B

C



228   C H A P T E R  1 0

When you select entities, you add them to the selection set. After you select at least 
one entity, you can remove entities from the selection set. To finish adding entities to 
the selection set, press Enter. Most entity-modification commands then act on the 
entire selection set.    

Selecting entities first    
You can select entities first and then choose how to modify them. As you select each 
entity, it is highlighted with small squares called grips, which appear at strategic 
points on the entity.    

The locations of the grips depend on the type of entity selected. For example, grips 
appear at the endpoints and midpoint of a line, at the quadrant points and center point 
of a circle, and at the endpoints, midpoint, and center of an arc.    

After you select one or more entities, you can choose an entity-modification com-
mand, such as Copy or Move, from the Modify menu or toolbar. You can also click 
the right mouse button to display a shortcut menu containing the entity-modification 
commands appropriate for the selected entities, and then choose the command from 
the menu.

When you select entities and then issue a command, the program immediately acts on 
the entities you’ve selected. In many cases, a command-specific prompt box provides 
additional options for that editing operation. If you want to modify the selection set at 
that point, right-click to display the prompt box with the selection options and choose 
the option you want. To redisplay the command-specific prompt box, right-click 
again.

Deselecting entities
If an entity is no longer needed in a selection set, you can deselect it to remove it from 
the selection set.

To remove an entity from the selection set

1 Press Shift, and then select the entity again.

Examples of grip locations.
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NOTE Pressing Shift while selecting entities using a crossing window removes all 
entities from the specified selection set.

To remove all entities from the selection set

1 Press Escape.

Quick Select
Specifies the filtering criteria and how you want AViCAD to create the selection set 
from that criteria. 

Applies the filtering criteria to the entire drawing or to the current selection set (if one 
exists). To select a group of objects to which you want to apply the filtering criteria.

To create the selection set

1 Do one of the following:     

• On the Properties Palette toolbar, click the Quick Select tool ( ).

• Type qselect and then press Enter.

2 Select the type of objects to include in the filter criteria.

3 Select the object property for the filter.

4 Set an option button in How to apply section to specify whether you want the new 
selection set to include or exclude objects.
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5 Set the check box Apped to Current Selection Set whether the selection set create 
is  append to the current selection set.

Element Type 

Specifies the type of objects to include in the filtering criteria. If the filtering criteria 
are being applied to the entire drawing, the Object Type list includes all object types, 
including custom.  

Properties 

Specifies the object property for the filter. This list includes all searchable properties 
for the selected object type. AViCAD determines the sort order alphabetical for the 
properties.

How to Apply 

Specifies whether you want the new selection set to include or exclude objects that 
match the specified filtering criteria. 

Choose:

• Include in New Selection Set to create a new selection set composed only of 
objects that match the filtering criteria. 

• Exclude from New Selection Set to create a new selection set composed only of 
objects that do not match the filtering criteria. 

Append to Current Selection Set 

Specifies whether the selection set created by QSELECT replaces or is appended to 
the current selection set.

Turning grips on and off
You can turn the use of grips on and off and control the size and color of grips.

To change grip settings

1 Do one of the following:

• Choose Tools > Drawing Settings.

• Type ddgrips and then press Enter.

2 In the Drawing Settings dialog box, click the Display tab.

3 In the Change Settings For list, click Grips.

4 Change the desired settings, and then click OK. 
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Editing with grips
To use grips for editing, you select an entity to display the grips, and then click a grip 
to make it active. The grip you select depends on the type of entity you’re modifying 
and the editing operation you’re performing. For example, to move a line entity, drag 
it by its midpoint grip. To stretch the line, drag one of the endpoint grips. You do not 
need to enter a command when using grips.    

Modifying the properties of entities    

You can change the layer, thickness, linetype, color, and linetype scale of one or 
more entities. Depending on the type of entity or entities you select, you can also 
change other properties, such as the start point and endpoint of lines, the center point 
and radius of circles, and the vertices of polylines.   

You can modify all the properties of all entities simultaneously. For example, using 
the entprop command, select all entities on a particular layer, and then move the enti-
ties to another layer by simply selecting a name from the Layer text box. Addition-
ally, using the select command and the Select by Properties option, select all blue 
entities and change their color to green.

A Click to activate grips for all selected entities.

B Click to assign the color for grips.

C Specify the grip size.

D Displays the current grip size.

A

B

C

D
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In the Entity Properties dialog box and Properties Window, changes that you make in 
the Layer, Thickness, Linetype, Color, and Entity Linetype Scale fields affect all 
selected entities. If you select several entities that all have different properties, the 
default value initially is Varies. Changes that you make in the entity tabs, such as Cir-
cle, Line, and Arc, affect all selected entities of that type. You can select the entities 
to be changed using any entity-selection method.    

To modify the properties of entities 

1 Type entprop and then press Enter

2 Select the entities, and then press Enter.

3 Make changes to the properties you want to change, and then click OK.

TIP Use the Entity Properties toolbar or Properties palette to change the properties 
of selected entities. Note that the Entity Properties toolbar settings that display when 
no entities are selected determine the properties of new entities when you draw them. 

The Entity Properties dialog box, shown in the following illustration, has two sec-
tions. The All Selected Entities section (the upper part of the dialog box) displays 
properties common to all selected entities, such as Layer, Color, and Thickness. This 
portion of the dialog box is equivalent to the dialog box displayed by the AutoCAD 
ddchprop command. 

The lower section of the Entity Properties dialog box contains options specific to the 
selected entities. Each tab displays the properties appropriate for the entity. This fea-
ture is equivalent to repeatedly applying the AutoCAD ddmodify command to one 
entity at a time.
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Properties palette
The Properties palette is the main tool for viewing and modifying properties of 
AViCAD objects.You can enter commands and work in AViCAD while the Proper-
ties palette is open. When you select an object in the drawing area, the Properties pal-
ette displays the properties of that object. If you select multiple objects, the Properties 
palette displays all the properties they have in common. 

The AViCAD Entity Properties dialog box.
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The Properties palette can be docked in the drawing area. You can Hide the palette 
and give it a trasparency effects.

To modify properties using the Properties palette select the object whose properties 
you want to change and use one of the following methods: 

• Enter a new value.

• Select a value from a list.

• Change the property value in a dialog box.

• Use the Pick Point button to change a coordinate value.

The properties common to the selected objects are displayed in the Properties palette. 
You can then modify the properties of the selected objects in the Properties palette or 
you can make other changes to the selected objects by entering an editing command.
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To modify the properties from Properties Palette 

1 Do one of the following:

• Choose Tools >  Properties.

• On the Standard toolbar, click the Properties tool ( ).

• Type properties and then press Enter.

2 Select the entities, and then press Enter.

3 Make changes to the properties you want to change, and then click OK.
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 Deleting entities

You can remove entities from a drawing. You can delete entities using any of the 
entity-selection methods.    

To delete a selection set    

1 Do one of the following:

• Choose Edit > Delete.

• On the Modify toolbar, click the Erase tool ( ).

• Type delete and then press Enter.

2 Select the entities, and then press Enter.

NOTE Typing the Undelete command restores the most recently deleted selection 
set. If you have made additional modifications since deleting the entities, use Unde-
lete rather than Undo to restore those entities without reversing those modifications.    

Copying entities    

You can copy one or more entities, making one copy or multiple copies within the 
current drawing. You can also copy entities between drawings.    

Use any of the following methods to copy entities within the current drawing:

• Create a copy at a location referenced from the original.

• Create a copy aligned parallel to the original.

• Create a copy as a mirror image of the original.

• Create several copies in a rectangular or circular pattern.

Copying entities within a drawing
You can duplicate entities within the current drawing. The default method is to create 
a selection set and then specify a starting point, or base point, and an endpoint, or dis-
placement point, for the copy. You can also make multiple copies or copy the selec-
tion set to a location you specify, using a direction vector.     
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To copy a selection set     

1 Do one of the following:

• Choose Modify > Copy.

• On the Modify toolbar, click the Copy Object tool ( ).

• Type copy and then press Enter.

2 Select the entities, and then press Enter.

3 Specify the base point.

4 Specify the insertion point.

5 Continue specifying insertion points to place additional copies or press Enter to 
complete the command.

6 To complete the command, press Enter.      

NOTE The COPYMODE system variable controls whether you are prompted for 
multiple copies.

To make a single copy of an entity, select the 
entity to copy (A), base point (B), and then 
displacement point (C).

Result.

To make multiple copies of an entity, select the 
entity to copy (A), specify the base point (B), and 
then specify the displacement points (C, D, and 
E).

Result.

A B
C

A

B
C

D
E
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Copying between drawings
You can use the Clipboard to cut or copy entities from one drawing to another. 
Cutting removes the selected entities from a drawing and stores them on the 
Clipboard. Copying duplicates the selected entities from a drawing and places them 
on the Clipboard.     

To cut entities to the Clipboard

1 Select the entities you want to cut.

2 Do one of the following:   

• Choose Edit > Cut.

• On the Standard toolbar, click the Cut to Clipboard tool ( ).

• Type cutclip and then press Enter.

To copy entities to the Clipboard

1 Select the entities you want to copy.

2 Do one of the following:

• Choose Edit > Copy.

• On the Standard toolbar, click the Copy tool ( ).

• Type copyclip and then press Enter.

Anything that you can copy to the Clipboard can be pasted into a drawing. The format 
in which the program adds the Clipboard contents to the drawing depends on the type 
of information in the Clipboard. For example, if you copy AViCAD drawing entities 
to the Clipboard, the program pastes them into the drawing as AViCAD entities. If 
you copy objects to the Clipboard from other programs, they are pasted into the cur-
rent drawing as embedded ActiveX objects.

Copy Quick
You can use the new command Copy Quick to copy a great number of objects from 
one AViCAD drawing to another. It’s a AViCAD version of the standard Copy, 
which  is very useful when you have to copy quickly a lot of objects. You can use it 
only with AViCAD drawings. Both the original file that contains the objects you 
want to copy and the destination file where objects will be copied must be opened.

To make a quick copy 

1 Do one of the following

• Select Edit > Copy Quick

• Use the keyboard shortcut CTRL+D

2 Select objects in the file of origin.

3 Click the destination drawing Tab to make it current.

4 Select Paste from the menu Edit or press CTRL+V.
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In the Edit menu you can find both Copy Quick and Copy Quick with base point 
(CTRL+SHIFT+D). With this command option you can indicate quickly a base point 
for the copy.

 

The Edit menu contains all the principal functions of Copy/Paste.

NOTE:  To copy objects in the same drawing it’s better to use Copy (alias CP) from 
the Modify menu or the toolbar.

To paste entities from the Clipboard

1 Do one of the following:     

• Choose Edit > Paste.

• On the Standard toolbar, click the Paste from Clipboard tool ( ).

• Type pasteclip and then press Enter.

To paste as a block the copied objects

1 Do one of the following:

• Select Edit > Paste as Block.

• Bring to an end all active commands, right click in the working area and choose 
Paste as Block from the context menu.

• Type pasteblock and then press Enter.

The objects copied in Notepad will be pasted as a block in the insertion point speci-
fied in the drawing.
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In the Insert Block mask, set the position and dimensions of the block. If the Position 
block when inserting box is checked, the insertion point coordinates, scale factor and 
rotation angle can be specified directly on the screen during block insertion.

Making parallel copies
You can use the offset feature to copy selected entities and align them parallel to the 
original entities at a specified distance. You can make parallel entities using arcs, cir-
cles, ellipses, elliptical arcs, lines, two-dimensional polylines, rays, and infinite lines.    

Making parallel copies of curved entities creates larger or smaller curves, depending 
on which side of the original entity you place the copy. For example, placing a paral-
lel copy of a circle outside the circle creates a larger concentric circle; positioning the 
copy inside the circle creates a smaller concentric circle.

To make a parallel copy by specifying the distance 

1 Do one of the following:

• Choose Modify > Offset.

• On the Modify toolbar, click the Offset tool ( ).

• Type offset and then press Enter.

2 Specify the distance by selecting two points or by entering a distance.

3 Select the entity to copy.

4 Specify on which side of the entity to place the parallel copy.

5 Select another entity to copy, or press Enter to complete the command. 
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To make a parallel copy passing through a point

1 Do one of the following:     

• Choose Modify > Offset.

• On the Modify toolbar, click the Offset tool ( ).

• Type offset and then press Enter.

2 In the prompt box, choose Through Point.

3 Select the entity to copy.

4 Specify the point for the entity to pass through.

5 Repeat steps 3 and 4, or press Enter to complete the command.    

Mirroring entities    
You can create a mirror image of an entity. You mirror the entity about a mirror line, 
which you define by specifying two points in a drawing. You can delete or retain the 
original entities.    

To make a parallel copy, specify the distance between 
copies by entering a distance or selecting two points (A and 
B), select the entity to copy (C), and specify on which side to 
place the copy (D).

Result.

To make a parallel copy passing through a point, select the entity to copy (A) and then specify the through 
point (B).

A

B

C

D

A

B
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To mirror entities

1 Do one of the following:     

• Choose Modify > Mirror.

• On the Modify toolbar, click the Mirror tool ( ).

• Type mirror and then press Enter.

2 Select the entity, and then press Enter.

3 Specify the first point of the mirror line.

4 Specify the second point of the mirror line.

5 In the prompt box, choose one of the following:

• Yes-Delete Entities to delete the original entities.

• No-Keep Entities to retain the original entities.    

Arraying entities
You can copy an entity in a rectangular or polar (circular) pattern, creating an array. 
For a rectangular array, you control the number of copies in the array by specifying 
the number of rows and columns. You also specify the distance between each row 
and column. For a polar array, you control the number of copies that compose the 
array and whether to rotate the copies.      

To create a polar array    

1 Do one of the following:

• Choose Modify > Array.

• On the Modify toolbar, click the Array tool ( ).

• Type array and then press Enter.

2 In the Array dialog box, choose Polar Array.

3 Next to Center Point, do one of the following: 

• Enter an X value and a Y value for the center point of the polar array.

To mirror an entity, select it (A), and then specify the 
first point (B) and second point (C) of the mirror line.

Result.

A B

C
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• Click the pick Center point button . The array dialog box closes and 
AViCAD prompts for object selection. Use the pointing device to specify the 
center point of the polar array.

4 Choose Select Objects .

• The Array dialog box closes and AViCAD prompts for object selection.

5 Select the objects to be arrayed.

6 In the Method combo box, select one of the following methods: 

• Number of elements and total angle.

• Number of elements and angle between elements.

• Total angle and angle between elements.

7 Enter the number of elements, including the original object if available.

8 Use one of the following methods: 

• Enter the Total angle  and Angle between elements , if available. 
Total angle specifies the distance to fill around the circumference of the array. 
Angle between elements specifies the distance between each item.

• Click the Total angle button and Angle between elements button and use the 
pointing device to specify the total angle and the angle between items. 

9 Select Rotate objects, to rotate the objects as they are arrayed.

10 Choose OK to create the array. 
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To create a rectangular array

1 Do one of the following:  

• Choose Modify > Array.

• On the Modify toolbar, click the Array tool ( ).

• Type array and then press Enter.

2 In the Array dialog box, choose Rectangular Array.

3 Choose Select Objects .

• The Array dialog box closes and AViCAD prompts for object selection.

4 Select the objects to be arrayed and then press Enter.

5 In the Rows and Columns boxes, enter the number of rows and columns in the 
array.

6 Specify the horizontal and vertical spacing (distances) between objects by using 
one of the following methods: 

• In the Row distance and Column distance boxes, enter the distance between 
rows and between columns. Adding a plus sign (+) or a minus sign (-) deter-
mines direction. 

• Click the pick Both distances button  to use the pointing device to specify 
the diagonal corners of a cell in the array. The cell determines the vertical and 
horizontal spacing of the rows and columns. 

• Click the pick Row distance  or pick Column distance  button to use 
the pointing device to specify the horizontal and vertical spacing. 

7 To change the rotation angle of the array, enter the new angle next to Series 
Angle.

8 The default angle 0 direction setting can also be changed in UNITS.

9 Choose OK to create the array.

To create a polar array, select the entity to copy (A), specify the center point of the array (B), and then 
specify the number of items to array, the angle the array is to fill, and whether to rotate the items.

A

B
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Rearranging entities    

You can move one or more entities, and you can also rotate entities about a specified point. 
If you have entities that overlap, you can also change the display order.

Moving entities    
You can move entities around within the current drawing or from one drawing to 
another. The default method is to create a selection set and then specify a starting 
point, or base point, and an endpoint, or displacement point, to define the relocation 
of the entities. You can also relocate the entities using a direction vector.    

To create a rectangular array, select the entity to copy (A), type the number of rows and columns, and then 
specify the distance between each row (B) and column (C).

A

B

C
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To move a selection set

1 Do one of the following:     

• Choose Modify > Move.

• On the Modify toolbar, click the Move tool ( ).

• Type move and then press Enter.

2 Select the entities, and then press Enter.

3 Specify the base point.

4 Specify the displacement point.    

You can also move entities using grips. To move an entity using grips, select the 
entity to display its grips, and then click a grip and drag it. The grip you select 
depends on the type of entity you’re modifying. For example, to move a line entity, 
select the midpoint grip. To move a curved entity, such as an arc, circle, or ellipse, 
select the center point grip. Not all entities can be moved using grips.    

To move an entity using grips

1 Select the entity.

2 Click a grip to select it.

3 Drag the entity to where you want to relocate it.

4 Click to release.

Rotating entities    
You can rotate entities about a specified point at a specified rotation angle or by an 
angle referenced to a base angle. The default method rotates the entities using a rela-
tive rotation angle from their current orientation.    

To move an entity, select it (A), and then specify 
the base point (B) and the displacement point 
(C).

Result.

A

B

C
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To rotate a selection set

1 Do one of the following:     

• Choose Modify > Rotate.

• On the Modify toolbar, click the Rotate tool ( ).

• Type rotate and then press Enter.

2 Select the entities, and then press Enter.

3 Specify the rotation point.

4 Specify the rotation angle.  

To rotate a selection set in reference to a base angle

1 Do one of the following:

• Choose Modify > Rotate.

• On the Modify toolbar, click the Rotate tool ( ).

• Type rotate and then press Enter.

2 Select the entities, and then press Enter.

3 Specify the rotation point.

4 In the prompt box, choose Base Angle.

5 Specify the base angle.

6 Specify the new angle.    

To rotate an entity, select the entity to rotate (A), and then specify the rotation point (B) and the rotation 
angle (C).

To rotate an entity in reference to a base angle, select the entity (A), specify the rotation point (B), select the 
base angle and pick point (B) again (or type the @ symbol), specify the second point (C), and then specify 
the point representing the new angle (D).

A
B

C

A

B C

D
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Reordering entities 
When multiple entities overlap, you can change the order in which they are displayed 
and printed. You can move entities to the front, back, or on top or below of another 
entity.

To reorder entities  

1 Do one of the following:

• Choose Tools > Draw Order.

• On the Modify II toolbar, click the Draw Order tool ( ).

• Type draworder and then press Enter.

2 Select the entity you want to reorder, and then press Enter.

3 In the prompt box, specify the new drawing order, and then press Enter.

4 If you are reordering above or under, select the entity you want the first entity to 
be above or below, and then press Enter.

NOTE The SORTENTS system variable automatically turns on, which may affect sys-
tem performance.

Resizing entities    

You can change the size of an entity or set of entities by stretching, scaling, extend-
ing, trimming, or editing their lengths.     

Stretching entities    
You can change the size of entities by stretching them. When you stretch entities, you 
must select the entities using either a crossing window or a crossing polygon. You 
then specify a displacement distance or select a base point and a displacement point. 
Entities that cross the window or polygon boundary are stretched; those completely 
within the crossing window or crossing polygon are simply moved.    
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To stretch an entity

1 Do one of the following:

• Choose Modify > Stretch.    

• On the Modify toolbar, click the Stretch tool ( ).

• Type stretch and then press Enter.

2 In the prompt box, choose Crossing Window or Crossing Polygon.

3 Select the entities, and then press Enter.

4 Specify the base point.

5 Specify the second point of displacement.    

To stretch an entity using grips, you select it to display its grips and then select a grip 
to make it the active grip. This becomes the base point. Then you move the active 
grip to a new location. The grip you select depends on the type of entity you’re modi-
fying. For example, to stretch one corner of a rectangle, select the corner point grip. 
To stretch a line, select an endpoint grip. Not all entities can be stretched using grips.     

To stretch an entity using grips

1 Select the entity.

2 Click a grip to activate it.

3 Drag the grip.

4 Click to release.    

To stretch entities, select them using a crossing window (A) or crossing polygon, and then specify the base 
point (B) and displacement point (C).

To stretch an entity using grips, select the entity 
(A), select a grip (B), and drag the grip to its new 
location (C).

Result.

A

B

C

A
B

C



250   C H A P T E R  1 0

Scaling entities
You can change the size of a selected entity by scaling it in relation to a base point. 
You can change the size of an entity by specifying a base point and a length, which is 
used as a scale factor based on the current drawing units, or by specifying a scale fac-
tor. You can also use a scale factor referenced to a base scale factor, for example, by 
specifying the current length and a new length for the entity.    

To scale a selection set by a scale factor

1 Do one of the following: 

• Choose Modify > Scale.

• On the Modify toolbar, click the Scale tool ( ).

• Type scale and then press Enter.

2 Select the entities, and then press Enter.

3 Specify the base point.

4 Specify the scale factor.    

You can also scale some entities using grips. To scale an entity, you select the entity, 
and then click a grip. You then change the size of the entity by moving the grip. The 
grip you select depends on the type of entity you’re modifying. For example, to scale 
a circle, select a quadrant point grip.

To scale an entity using grips

1 Select the entity.

2 Click a grip to select it.

3 Drag the grip.

4 Click to release.

To scale an entity by a scale factor, select the entity (A),  
and then specify the base point (B) and the scale factor.

Result.

A
B
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Extending entities    
You can extend entities so that they end at a boundary defined by other entities. You 
can also extend entities to the point at which they would intersect an implied bound-
ary edge. When extending entities, you first select the boundary edges, and then spec-
ify the entities to extend, selecting them either one at a time or using the fence 
selection method.    

You can extend arcs, lines, two-dimensional polylines, and rays. Arcs, circles, 
ellipses, lines, splines, polylines, rays, infinite lines, and viewports in paper space can 
act as boundary edges.

To extend an entity

1 Do one of the following:

• Choose Modify > Extend.

• On the Modify toolbar, click the Extend tool ( ).

• Type extend and then press Enter.

2 Select one or more entities as boundary edges, and then press Enter.

3 Select the entity to extend.

4 Select another entity to extend, or press Enter to complete the command.  

To scale using grips, select the entity (A), click a grip (B), and 
scale the entity by dragging the grip to its new 
location (C).

Result.

To extend entities, select the boundary edge (A), and then 
select the entities to extend (B).

Result.

A

B

C

A

B
B
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To extend an entity to an implied boundary    

1 Do one of the following:

• Choose Modify > Extend.

• On the Modify toolbar, click the Extend tool ( ).

• Type extend and then press Enter.

2 Select one or more boundary edges, and then press Enter.

3 In the prompt box, choose Edge Mode.

4 In the prompt box, choose Extend.

5 Select the entity to extend.

6 Select another entity to extend, or press Enter to complete the command.    

To extend several entities using the fence selection method    

1 Do one of the following:

• Choose Modify > Extend.

• On the Modify toolbar, click the Extend tool ( ).

• Type extend and then press Enter.

2 Select one or more boundary edges, and then press Enter.

3 In the prompt box, choose Fence.

4 Specify the first point of the fence.

5 Specify the second point of the fence.

6 Specify the next fence point, or press Enter to complete the command.

NOTE: using the shift button you can switch between the trim and extend command

Select the boundary edge (A), and then select the entities to 
extend (B).

Result.

A
B

B
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When you extend a wide polyline, its centerline intersects the boundary edge. 
Because the end of the polyline is always cut at a 90-degree angle, part of the polyline 
may extend past the boundary edge. A tapered polyline continues to taper until it 
intersects the boundary edge. If this would result in a negative polyline width, the 
ending width changes to 0.        

Trimming entities    
You can clip, or trim, entities so they end at one or more implied cutting edges 
defined by other entities. You can also trim entities to the point at which they would 
intersect an implied cutting edge. When trimming entities, you first select the cutting 
edges and then specify the entities to trim, selecting them either one at a time or using 
the fence selection method.    

You can trim arcs, circles, lines, open two-dimensional and three-dimensional 
polylines, and rays. Arcs, circles, lines, polylines, rays, infinite lines, and viewports 
in paper space can act as cutting edges. An entity can be both a cutting edge and one 
of the entities being trimmed.

NOTE: using the shift button you can switch between the trim and extend command

Select the boundary edge (A), and then specify the  
first point (B) and second point (C) of the fence. 

Result.

A tapered polyline (A) continues to taper until  
it intersects the boundary edge (B).

Result.

A

B

C

A

A

B
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To trim an entity

1 Do one of the following:

• Choose Modify > Trim.

• On the Modify toolbar, click the Trim tool ( ).

• Type trim and then press Enter.

2 Select one or more cutting edges, and then press Enter.

3 Select the entity to trim.

4 Select another entity to trim, or press Enter to complete the command.    

To trim an entity to an implied boundary

1 Do one of the following:     

• Choose Modify > Trim.

• On the Modify toolbar, click the Trim tool ( ).

• Type trim and then press Enter.

2 Select one or more cutting edges, and then press Enter.

3 In the prompt box, choose Edge Mode.

4 In the prompt box, choose Extend.

5 Select the entity to trim.

6 Select another entity to trim, or press Enter to complete the command.    

To trim entities, select the cutting edge (A), and then select 
the entities to trim (B).

Result.

Select the implied boundary edge (A), and then select 
the entities to trim (B).

Result.

A

B

A

B
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To trim several entities using the fence selection method

1 Do one of the following:     

• Choose Modify > Trim.

• On the Modify toolbar, click the Trim tool ( ).

• Type trim and then press Enter.

2 Select one or more cutting edges, and then press Enter.

3 In the prompt box, choose Fence.

4 Specify the first point of the fence.

5 Specify the second point of the fence.

6 Specify the next fence point, or press Enter to complete the command.     

Editing the length of entities   
You can change the length of entities or the included angle of arcs. Use any of the fol-
lowing methods to change the length of an entity:    

• Dynamically drag the endpoint or angle.

• Specify an incremental length or angle measured from an endpoint.

• Specify the new length as a percentage of the total length or angle.

• Specify a new length or included angle.

You can change the length of arcs, lines, and open polylines.

To change the length of an entity by dragging

1 Do one of the following:     

• Choose Modify > Edit Length.

• On the Modify toolbar, click the Edit Length tool ( ).

• Type editlen and then press Enter.

2 In the prompt box, choose Dynamic.

3 Select the entity you want to change.

4 Specify the new endpoint or included angle. 

Select the boundary edge (A), and then specify the 
first point (B) and second point (C) of the fence.

Result.

A B

C
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Breaking and joining entities    

You can break an entity into two parts, removing a portion of the entity in the pro-
cess. You can also join two entities into a single entity.    

Breaking entities
You can break arcs, circles, ellipses, lines, polylines, rays, and infinite lines. When 
breaking entities, you must specify two points for the break. By default, the point you 
use to select the entity becomes the first break point; however, you can use the First 
option to select a break point different from the one that selects the entity.    

To break an entity

1 Do one of the following:     

• Choose Modify > Break.

• On the Modify toolbar, click the Break tool ( ).

• Type break and then press Enter.

2 Select the entity.

3 Specify the second break point.    

Select the entity (A), and then select the new 
endpoint (B).

Result.

A
B

A B

Select the entity (A), and then specify the second break 
point (B).

Result.

A

B



M O D I F Y I N G  E N T I T I E S    257

To select an entity and then specify the two break points

1 Do one of the following:

• Choose Modify > Break.

• On the Modify toolbar, click the Break tool ( ).

• Type break and then press Enter.

2 Select the entity.

3 In the prompt box, choose First.

4 Specify the first break point.

5 Specify the second break point.  

NOTE To break an entity in two without removing a portion of the entity, specify the 
same point for the first and second break points by typing the at sign (@) and press-
ing Enter instead of specifying the second break point.    

Joining entities
You can join two entities into a single entity. You can join either two lines or two arcs. 
The two lines must be parallel; the two arcs must share the same center point and radius.    

When you join two lines, the farthest endpoints remain at their existing locations; the 
program draws a new line between these points. Arcs are joined counterclockwise, 
from the first arc you select to the second.

To join two entities

1 Do one of the following:

• Choose Modify > Join.

• Type join and then press Enter.

2 Select the first arc or line.

3 Select the second arc or line.

Select the entity (A), and then specify the first (B) and 
second (C) break points.

Result.

A
B

C
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Grouping entities   

A group is a collection of entities saved together that you can select and edit as a unit. 
Groups allow to easy combine drawing elements that you need to manage as a unit. 
For example, groups are useful in associating 3D solids when you do not want to 
combine them with a Boolean operation.

After you select the entities that belong to the group, you can later add more entities, 
remove entities, and re-order these entities. If necessary, you can also ungroup the 
objects at any time to work with them separately.

Groups represent a blocks alternative method of combining objects. The groups you 
create are saved from session to session, and you can edit single objects in groups 
easier than in blocks, which must be first exploded.

When you create a group selecting the command from the Modify menu or from the 
command bar, you can give it a name and a description. If you select the command to 
create a group from the toolbar or from the context right click menu, you create an 
unnamed group. Unnamed groups are listed in the Group dialog box only if the Dis-
play Unnamed Groups option is selected. The objects in your drawing can be 
included in more than one group, and groups can be nested in other groups.

NOTE  Don’t create groups containing hundreds or thousands of objects. A large 
group reduces remarkably the performance of the program. 

Groups toolbar

The Group dialog box controls the settings for all groups in a drawing.

Select the first arc or line (A), and then select 
the second arc or line (B).

Result.

A

A

B

B
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The Group dialog box and the toolbar Groups let you  specify objects to be added to 
or removed from a group at any time. From the dialog box you can also revise a 
group's name or description. If removing from a group or deleting an object cause the 
group to remain empty, the group is still defined but without any members. 

Creating groups 
When you create a group, you enter a group name and description, and then select the 
entities for the group. 

To create a group

1 Do one of the following:

• Choose Modify > Group.

• Type group and then press Enter.

• Click the button Groups ( ) and follow number 5

2 Under Create New Group, enter the name and description of the group.

3 Click Selectable if you want all entities in the group to be selected when you select 
one entity of the group in the drawing.

4 Click Select Entities and Create Group.

5 Select the entities for the group, and then press Enter.

6 In the Group dialog box, click OK.
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NOTE You can enter the name of a group when selecting objects at the command 
prompt.

Modifying groups
When the group selection option is turned on, you can modify groups just as you can 
modify individual objects. If you need to edit single objects of a group, turn off group 
selection setting the value of the variable PICKFIRST to 0 or use grips to edit indi-
vidual objects.

To modify a group and its entities

1 Do one of the following:

• Choose Modify > Group.

• Type group and then press Enter.

2 In the Group dialog box, select the group you want to modify.

3 Under Modify Selected Group, do one or more of the following:

• Enter a new name, and then click Rename Group.

• Enter a new description, and then click Change Group Description.

• Select whether you want the group to be selectable in the drawing.

• Click Add Entities to Group, select the entities to add to the group, and then 
press Enter.

• Click Remove Entities from Group, select the entities to remove from the group, 
and then press Enter.

4 In the Group dialog box, click OK.

To change the order of entities in a group 

1 Do one of the following:

• Choose Modify > Group.

• Type group and then press Enter.

2 In the Group dialog box under Modify Selected Group, click Re-order Entities.

3 In the Re-Order Grouped Entities dialog box, select the group you want to re-
order.

4 To see the order of entities in the group, click Highlight. Follow the prompts that 
display to view the entities, one by one.

5 To reverse the order of all entities in the group, click Reverse Order.



M O D I F Y I N G  E N T I T I E S    261

6 To change the order of specific entities or a range of entities:

• In Remove from Position, enter the current position of the entity. 

• In Place to Position, enter the new position of the entity. 

• In Number of Entities, enter the number of entities or range of entities to re-
order. For example, if you are changing the order of only one entity, enter 1. 

• Click Re-Order.

NOTE The entities in a group are numbered 0, 1, 2, 3, and so on.

7 Click OK, and then click OK again.

Explode groups
The Explode Groups button allows to explode a group previously created

To exlode a group

1 Click the button Explode Groups ( ).

2 Select groups to explode and end the command with Enter or Esc.

Add to a group
After you create a group it is possible to add entities using the option Add to Group

To add objects to a group

1 Click the button Add to Group ( ) .

2 Select a group to add objects to and then press Enter.

3 Select objects to add to the group and then press Enter.

Ungrouping entities
When you ungroup entities, the entities remain in the drawing but the group is deleted 
from the drawing.

To ungroup entities

1 Do one of the following:

• Choose Modify > Group.

• Type group and then press Enter.

2 In the Group dialog box, select the group to delete.

3 Under Modify Selected Group, click Ungroup Entities.

4 Click OK.
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Remove Groups
You can delete a group by using the “explode” option in the Groups Toolbar or 
Ungroup Entities in the dialog box. This operation is not the same as exploding a 
block, hatch, or dimension. Objects that belonged to the exploded group aren’t modi-
fied in any ways, remain in the drawing and can only be selected one by one

Remove objects from a group
After you create a group it is possible to remove objects from it with the option 
Remove from Group.

To remove objects from a group

1 Click the button Remove from Group ( ).

2 Select a group to remove objects from and press Enter.

3 Select objects to remove from the group and then press Enter.

Editing polylines    

You can modify any type of two-dimensional or three-dimensional polyline. Entities 
such as rectangles, polygons, and donuts, as well as three-dimensional entities such as 
pyramids, cylinders, and spheres, are all variations of polylines that you can edit.    

You can edit a polyline by opening or closing it, by changing its overall width or the 
widths of individual segments, and by converting a polyline with straight line seg-
ments into a flowing curve or an approximation of a spline. In addition, you can use 
the Edit Polyline tool to edit individual vertices, adding, removing, or moving verti-
ces. You can also add new segments to an existing polyline, change the linetypes of a 
polyline, and reverse the direction or order of the vertices.    

To modify a polyline, you first select the polyline, and then select a polyline editing 
option. The available options vary depending on whether the selected polyline is a 
two-dimensional or three-dimensional entity. If the selected entity is not a polyline, 
the Edit Polyline tool provides the option of turning it into one. You can convert only 
arcs and lines into polylines. If several arcs or lines are joined endpoint to endpoint, 
they can all be selected and turned into one polyline.    
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To convert an entity into a polyline

1 Do one of the following:

• Choose Modify > Object > Edit Polyline.

• Type editpline and then press Enter.

2 Select the entity.

3 In the prompt box, choose Yes-Turn Into Polyline.

4 In the prompt box, choose another option, or choose Done to complete the com-
mand.

Opening and closing polylines
When you close a polyline, the program draws a straight polyline segment from the 
last vertex of the polyline to the first vertex. Opening a polyline removes the closing 
segment. When you select a polyline for editing, the prompt box displays either the 
Open or Close option, depending on whether the polyline you select is closed or 
open.    

To close an open polyline

1 Do one of the following:

• Choose Modify > Object > Edit Polyline.

• Type editpline and then press Enter.

2 Select the polyline.

3 In the prompt box, choose Close.

4 In the prompt box, choose another option, or choose Done to complete the com-
mand.    

Closing an open polyline adds a straight 
polyline segment between the first (A) and last 
(B) vertices.

Result.

A B
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Curving and decurving polylines   
You can convert a multisegment polyline into a smooth curve using either the Fit or 
Spline option. The Fit option creates a smooth curve connecting all the vertices. The 
Spline option computes a smooth curve that is pulled toward the vertices but passes 
through only the first and last vertices. The Decurve option removes Fit or Spline 
curves and arcs, leaving straight segments between the vertices.    

To fit a curve to a polyline

1 Do one of the following:    

• Choose Modify > Object > Edit Polyline.

• Type editpline and then press Enter.

2 Select the polyline.

3 In the prompt box, choose Fit.

4 In the prompt box, choose another option, or choose Done to complete the com-
mand.  

Joining polylines    
You can add an arc, line, or polyline entity to an existing open polyline, forming one 
continuous polyline entity. To join an entity to a polyline, that entity must already 
share an endpoint with an end vertex of the selected polyline.    

When you join an entity to a polyline, the width of the new polyline segment depends 
on the width of the original polyline and the type of entity you are joining to it:

• A line or an arc assumes the same width as the polyline segment for the end vertex 
to which it is joined.

• A polyline joined to a tapered polyline retains its own width values.

• A polyline joined to a uniform-width polyline assumes the width of the polyline to 
which it is joined.    

Original polyline. After applying Fit curve. After applying Spline.



M O D I F Y I N G  E N T I T I E S    265

To join an arc, line, or polyline to an existing polyline 

1 Do one of the following:

• Choose Modify > Object > Edit Polyline.

• Type editpline and then press Enter.

2 Select the polyline.

3 In the prompt box, choose Join.

4 Select the arc, line, or polyline to join.

5 In the prompt box, choose another option, or choose Done to complete the com-
mand.

Changing the polyline width    
You can change the width of an entire polyline, applying a uniform width to the entire 
entity or tapering the polyline uniformly along its entire length.    

To apply a uniform width to an entire polyline    

1 Do one of the following:

• Choose Modify > Object > Edit Polyline.

• Type editpline and then press Enter.

2 Select the polyline.

3 In the prompt box, choose Width.

4 Specify the new polyline width.

5 In the prompt box, choose another option, or choose Done to complete the com-
mand.

To taper a polyline uniformly along its length

1 Do one of the following:     

• Choose Modify > Object > Edit Polyline.

• Type editpline and then press Enter.

2 Select the polyline.

3 In the prompt box, choose Taper.

4 Specify the starting width.

5 Specify the ending width.

6 In the prompt box, choose another option, or choose Done to complete the com-
mand.
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Editing polyline vertices    
You can use the Edit Vertices option to modify individual polyline vertices. When 
you select this option, the program switches into a special vertex editing mode and 
places an x on the first vertex. The x indicates the vertex you are editing. The Next 
and Previous options move the x to the next or previous vertex. You can edit only one 
vertex at a time.    

When editing vertices, you can modify the polyline in the following ways:

• Convert a polyline segment into a curve by specifying a new tangent angle.

• Break a polyline into two separate polylines.

• Insert a new vertex after the current vertex.

• Move the current vertex.

• Straighten the polyline segment between two vertices.

• Change the width of the polyline segment between two vertices.

To move a polyline vertex    

1 Do one of the following:

• Choose Modify > Object > Edit Polyline.

• Type editpline and then press Enter.

2 Select the polyline.

3 In the prompt box, choose Edit Vertices.

4 In the prompt box, choose Next Vertex.

Repeat until the x reaches the vertex you want to move.

5 In the prompt box, choose Move.

6 Specify the new location for the vertex.

7 In the prompt box, choose another option, or choose Exit to stop editing vertices.

8 In the prompt box, choose another option, or choose Done to complete the com-
mand.    

Select the polyline (A), move the current vertex 
marker to the vertex you want to move (B), and then 
specify the new vertex location (C).

Result.

A

B

C
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To taper the width of an individual polyline segment

1 Do one of the following:     

• Choose Modify > Object > Edit Polyline.

• Type editpline and then press Enter.

2 Select the polyline.

3 In the prompt box, choose Edit Vertices.

4 In the prompt box, choose Next Vertex.

Repeat until the x reaches the first vertex of the segment you want to taper.

5 In the prompt box, choose Width.

6 Specify the starting width.

7 Specify the ending width.

8 In the prompt box, choose another option, or choose Exit to stop editing vertices 
and update the display.

9 In the prompt box, choose another option, or choose Done to complete the com-
mand.    

Exploding entities    

You can convert a complex entity, such as a block or polyline, from a single entity 
into its component parts. Exploding a polyline, rectangle, donut, polygon, dimension, 
or leader reduces it to a collection of individual line and arc entities that you can then 
modify individually. Blocks are converted to the individual entities, possibly includ-
ing other, nested blocks that composed the original entity.                                               

With the following exceptions, exploding an entity usually has no visible effect on a 
drawing:

• If the original polyline had a width, the width information is lost when you explode 
it. The resulting lines and arcs follow the centerline of the original polyline.    

Select the polyline (A), move the current vertex 
marker to the first vertex of the segment you want to 
taper (B), and then specify the new starting and 
ending widths for that segment.

Result.

A B
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• If you explode a block containing attributes, the attributes are lost, but the original 
attribute definitions remain.    

• Colors and linetypes assigned BYBLOCK may appear different after exploding an 
entity, because they will adopt the default color and linetype until inserted into 
another block.    

To explode an entity

1 Do one of the following:

• Choose Modify > Explode.

• On the Modify toolbar, click the Explode tool ( ).

• Type explode and then press Enter.

2 Select the entities to explode.

3 Press Enter.

Chamfering and filleting entities             

You can chamfer or fillet entities. A chamfer connects two nonparallel entities with a 
line to create a beveled edge. A fillet connects two entities with an arc of a specified 
radius to create a rounded edge. If both entities you are working with are on the same 
layer, the chamfer or fillet is drawn on that layer. If they are on different layers, the 
chamfer or fillet is drawn on the current layer.                                     

The Chamfer/Fillet settings in the Drawing Settings dialog box control the chamfer 
and fillet settings. The portions of the entities that extend beyond the chamfer or fillet 
are normally deleted when you create the chamfer or fillet. You can retain these 
original entities, however, by changing the settings in the dialog box. 
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Chamfering entities    
You can connect two nonparallel entities by extending or trimming them and then 
joining them with a line to create a beveled edge. You can chamfer lines, polylines, 
rays, and infinite lines. When creating a chamfer, you can specify how far to trim the 
entities back from their intersection (distance-distance method), or you can specify 
the length of the chamfer and the angle it forms along the first entity (distance-angle 
method).    

When chamfering a polyline, you can chamfer multiple segments between two 
selected polyline segments, or you can chamfer the entire polyline.

A Click to remove or retain portions of entities that 
extend beyond the chamfer or fillet.

B Click to create a chamfer using two chamfer 
distances (distance-distance method).

C Specify the first and second chamfer distances 
when using the distance-distance method.

D Specify the chamfer length and angle when 
using the distance-angle method.

E Click to create a chamfer using the chamfer 
length and angle (distance-angle method).

F Click to specify the fillet radius by selecting two 
points in the drawing.    

G Specify the fillet radius.

A

B

C

D

E

F

G



270   C H A P T E R  1 0

To chamfer two entities using the distance-distance method

1 Do one of the following:     

• Choose Modify > Chamfer.

• On the Modify toolbar, click the Chamfer tool ( ).

• Type chamfer and then press Enter.

2 In the prompt box, choose Chamfer Settings.

3 In the Drawing Settings dialog box, click the Entity Modification tab.

4 Under Chamfer Distances And Angles, click Distance-Distance.

5 Under Chamfer Distances And Angles, specify the first and second chamfer 
distances.

6 Click OK.

7 Select the first entity.

8 Select the second entity.    

To chamfer two entities using the distance-angle method

1 Do one of the following:

• Choose Modify > Chamfer.

• On the Modify toolbar, click the Chamfer tool ( ).

• Type chamfer and then press Enter.

2 In the prompt box, choose Chamfer Settings.

3 In the Drawing Settings dialog box, click the Entity Modification tab.

4 Under Chamfer Distances And Angles, click Distance-Angle.

5 Under Chamfer Distances And Angles, specify the chamfer distance and angle.

6 Click OK.

7 Select the first entity.

8 Select the second entity.

Select the first (A) and second (B) entities. The chamfer is drawn, based on the first (C) and second (D) 
chamfer distances.

A

B

C

D
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To chamfer all vertices in a polyline

1 Do one of the following:     

• Choose Modify > Chamfer.

• On the Modify toolbar, click the Chamfer tool ( ).

• Type chamfer and then press Enter.

2 In the prompt box, choose Polyline.

3 Select the polyline.  

To chamfer selected vertices in a polyline

1 Do one of the following:

• Choose Modify > Chamfer.

• On the Modify toolbar, click the Chamfer tool ( ).

• Type chamfer and then press Enter.

2 Select the polyline along the segment where you want to begin the chamfer.

3 Select the polyline along the segment where you want to end the chamfer.

Select the first (A) and second (B) entities. The chamfer is drawn, based on the distance measured along 
the first entity (C) and the angle (D) formed with the first entity.

Original polyline. Result after chamfering.

A

B

C

D
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Filleting entities    
You can connect two entities with an arc of a specified radius to create a rounded 
edge. You can fillet pairs of line segments, straight polyline segments, arcs, circles, 
rays, and infinite lines. You can also fillet parallel lines, rays, and infinite lines. When 
filleting a polyline, you can fillet multiple segments between two selected segments, 
or you can fillet the entire polyline.    

To fillet two entities

1 Do one of the following:

• Choose Modify > Fillet.

• On the Modify toolbar, click the Fillet tool ( ).

• Type fillet and then press Enter.

2 In the prompt box, choose Fillet Settings.

3 In the Drawing Settings dialog box, specify the fillet radius.

4 Click OK.

5 Select the first entity.

6 Select the second entity.    

Select the polyline along the (A) and (B) 
segments.

Result after chamfering.

Select the first (A) and second (B) entities. Result after filleting.

A B

A

B
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To fillet an entire polyline

1 Do one of the following:

• Choose Modify > Fillet.

• On the Modify toolbar, click the Fillet tool ( ).

• Type fillet and then press Enter.

2 In the prompt box, choose Polyline.

3 Select the polyline.    

To fillet selected vertices in a polyline

1 Do one of the following:    

• Choose Modify > Fillet.

• On the Modify toolbar, click the Fillet tool ( ).

• Type fillet and then press Enter.

2 Select the polyline along the segment where you want to begin the fillet.

3 Select the polyline along the segment where you want to end the fillet.    

When you fillet circles and arcs, more than one fillet can exist between the entities. 
The point at which you select the entities determines the fillet. 

Select the polyline (A). Result after filleting.

Select the polyline along the (A) and (B) 
segments.

Result after filleting.

A

A B
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You can fillet parallel lines, rays, and infinite lines. The first entity must be a line or 
ray; the second entity can be a line, ray, or infinite line. The diameter of the fillet arc 
is always equal to the distance between the parallel entities. The current fillet radius is 
ignored.         

Select entities (A and B). Results after filleting.

Original entities. Result after filleting.

B

A

B

A

B

A

B

A
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Express

The latest complete AViCAD versions implement a tools library for the efficiency 
that makes AViCAD even more powerful.

Characterized by a simple use and a fast integration in the menu and in the toolbars, 
they include a wide rang of functions among which are the layer management and 
blocks attributions, the selection and modification of the objects.

Layer
Layer is an additional tool for quick working with entities and layers.

Set layer
Set an entity layer as current.

To set an entity layer as current

1 Do one of the following:

• Choose Express > Layer > Set layer.

• On the Express Tool:Layer toolbar, click Setlayer tool ( ).

• Type SLA and then press Enter.

2 Set the current layer to that of the selected entity.

Change to current layer
Set the current layer for the selected entities.

To set the current layer for the selected entities

1 Do one of the following:

• Choose Express > Layer > Change to current layer.

• On the Express Tool:Layer toolbar, click Chgtocurrentlayer tool ( ).

• Type CCL and then press ENTER key.

2 Select the entities to set in the current layer.

3 Press ENTER key or right mouse button.
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Move to layer
Move some entities on another entity's layer.

To move some entities on another entity's layer

1 Do one of the following:

• Choose Express > Layer > Move to layer.

• On the Express Tool:Layer toolbar, click Movetolayer tool ( ).

• Type MTL and then press ENTER key.

2 Select the entities to move on a new layer.

3 Press ENTER key or right mouse button.

4 Select an entity on a layer to set for the previous ones.

New layer
Move some entities on new layer.

To move some entities on new layer

1 Do one of the following:

• Choose Express > Layer > New layer.

• On the Express Tool:Layer toolbar, click Newlayer tool ( ).

• Type NLA and then press ENTER key.

2 Select the entities to move on a new layer.

3 Type the new layer name and press ENTER key or the right mouse button to con-
firm.

• If the layer doesn't exist, you can choose if you want to create a new one. The 
new layer will be set for the previous selected entities.

• If the layer exist, it will be set for the previous selected entities.

Isolate layer
Set all layer to OFF except the selected entity layer.

To set all layer to OFF except the selected entity layer

1 Do one of the following:

• Choose Express > Layer > Isolate layer.

• On the Express Tool:Layer toolbar, click Isolatelayer tool ( ).

• Type ILA and then press ENTER key.

2 Select the entity to isolate.

3 Press ENTER key or right mouse button.
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Freeze layer
Freeze a selected entity layer.

To freeze a selected entity layer

1 Do one of the following:

• Choose Express > Layer > Freeze layer.

• On the Express Tool:Layer toolbar, click Freezlayer tool ( ).

• Type FLA and then press ENTER key.

2 Select the entity which layer will be frozen.

To set off a selected layer

1 Do one of the following: 

• Choose Express > Layer > Layer Off. 

• On the Express Tool:Layer toolbar, click Layer Off tool ( ). 

• Type ola and then press enter. 

2 Pick entity on the layer you want turned off. 

Multiple freeze layer
Freeze all layer of the selected entities.

To freeze all layer of the selected entities

1 Do one of the following:

• Choose Express > Layer > Multiple freeze layer.

• On the Express Tool:Layer toolbar, click Multiplefreeze tool ( ).

• Type MLF and then press ENTER key.

2 Select the entities whose layers will be frozen.

3 Press ENTER key or right mouse button.

Lock layer
Lock a selected entity layer.

To lock a selected entity layer

1 Do one of the following:

• Choose Express > Layer > Lock layer.

• On the Express Tool:Layer toolbar, click Locklayer tool ( ).

• Type LLA and then press ENTER key.

2 Select the entity whose layer will be locked.

Unlock layer
UnLock a selected entity layer.
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To unlock a selected entity layer

1 Do one of the following:

• Choose Express > Layer > Unlock layer.

• On the Express Tool:Layer toolbar, click Unlocklayer tool ( ).

• Type ULA and then press ENTER key.

2 Select the entity whose layer will be unlocked.

Set on all layers

To set all layers On

1 Do one of the following:

• Choose Express > Layer > Set on all layers.

• On the Express Tool:Layer toolbar, click On All tool ( ).

• Type ON and then press ENTER key.

Set off all layers

To set all layers Off

1 Do one of the following:

• Choose Express > Layer > Set off all layers.

• On the Express Tool:Layer toolbar, click Off All tool ( ).

• Type OFF and then press ENTER key.

Thaw all layers

To thaw all layers

1 Do one of the following:

• Choose Express > Layer > Thaw all layers.

• On the Express Tool:Layer toolbar, click Thaw All tool ( ).

• Type THAW and then press ENTER key.

Freeze all layers

To freeze all layers

1 Do one of the following:

• Choose Express > Layer > Freeze all layers.

• On the Express Tool:Layer toolbar, click Freeze All tool ( ).

• Type FREEZE and then press ENTER key.
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Unlock all layers

To unlock all layers

1 Do one of the following:

• Choose Express > Layer > Unlock all layers.

• On the Express Tool:Layer toolbar, click Unlock All tool ( ).

• Type UNLOCK and then press ENTER key.

Lock all layers

To lock all layers

1 Do one of the following:

• Choose Express > Layer > Lock all layers.

• On the Express Tool:Layer toolbar, click Lock All tool ( ).

• Type LOCK and then press ENTER key.

Clone entity
Copy one or more entities on another layer.

To copy one or more entities on another layer

1 Do one of the following:

• Choose Express > Layer > Clone entity.

• On the Express Tool:Layer toolbar, click Clone tool ( ).

• Type CLONE and then press ENTER key.

2 Select one or more entities to clone.

3 Press ENTER key or right mouse button.

4 Type the layer name.

• If the layer doesn't exist, you can choose if you want to create a new one. The 
new layer will be created and the entities will be cloned.

• If the layer exist, it will be cloned the previous selected entities.

Copy to layer
Copy one or more entities on a selected entity's layer.

To copy one or more entities on a selected entity's layer

1 Do one of the following:

• Choose Express > Layer > Copy to layer.

• On the Express Tool:Layer toolbar, click Copytolayer tool ( ).

• Type CTL and then press ENTER key.
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2 Select one or more entities to be copied on a layer.

3 Press ENTER key or right mouse button.

4 Select an entity on whose layer the entities will be copied.

Blocks

Copy nested objects
Allows duplicating one or more objects belonging to a block.

To copy nested objects in a block

1 Do one of the following:

• Choose Express > Blocks > Copy Nested Objects.

• On the Express Tools toolbar, click Copy Nested Objects tool ( ).

• Type ncopy and press Enter key.

2 Select the block entities to copy and press Enter.

3 Specify the base point.

4 Specify the displacement point.

Trim to nested objects
Execute the trim on some entities considering the block objects as trim limit.

To trim some entities using the ones of a block as trim limit

1 Do one of the following:

• Choose Express > Blocks > Trim to Nested Objects.

• On the Express Tools toolbar, click  Trim to Nested Objects tool ( ).

• Type btrim and press Enter key.

2 Select the block entities to be considered as trim limit and press Enter.

3 Choose one of the trim methods and proceed selecting the entities to be trimmed.

Extend to nested objects
Extends some entities considering the block objects as extension limit.

To extend some entities considering the block objects as extension limit

1 Do one of the following:

• Choose Express > Blocks > Extend to Nested Objects.

• On the Express Tools toolbar, click  Extend to Nested Objects tool ( ).

• Type bextend and press Enter key.

2 Select the block entities to be considered as extension limit and press Enter.

3 Select one of the extension methods and proceed by selecting the entities to be 
extended.
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Replace block with another block
Replaces in a drawing all the occurrences of a specific block with another block.

To replace a block with another

1 Do one of the following:

• Choose Express > Blocks > Replace block with another block.

• Type blockreplace and press Enter key.

2 Do one of the following:

• Select in the list the block to be replaced and choose OK.

• Click on Pick and choose the block to be replaced in the drawing.

3 Do one of the following:

• Select in the list the block that replaces the block previously selected and choose 
OK.

• Click on the Pick button and choose in the drawing the block that replaces the 
block previously selected.

4 If, at the end of the procedure, the intention is to delete the blocks that don’t refer 
to the drawing anymore answer Yes, otherwise No.

Convert block with xref
BLOCKTOXREF replaces all references of a block with an xref that you specify.
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To replace a block with an xref

1 Do one of the following:

• Choose Express > Blocks > Convert block with xref.

• Type blocktoxref and then press Enter.   

2 Choose one of the following:

• Select a block to be replaced with an xref and press OK.

• Use the Pick button to select blocks from the drawing.

   

3 Select an external reference file and then press Open.



M O D I F Y I N G  E N T I T I E S    283

As the command is completed you can have the unreferenced block purged if you 
choose the default answer to the request Purge unreferenced items when finished? 
<Y>:.

Text

Text fit
Fit the text by extending it or tightening it up in relation to two points specified by the 
user.

To fit the text in relation to two points

1 Do one of the following:

• Choose Express > Text > Text Fit.

• On the Express Tools toolbar, click  Text Fit tool ( ).

• Type textfit and press Enter key.

2 Select the text to be fitted.

3 To specify the starting point digit s then Enter.

4 Specify the first point in which the text will be fitted.

5 Specify end point.

Text Mask
Text Mask allows to hide objects around a text with an empty area offset from the 
text by a specified value, to make the text more legible. 

You can create a Wipeout, a 3dface or a solid to mask objects around a text.

To create a text mask

1 Do one of the following: 

• Select Express > Text > Text Mask

• Type textmask and then press Enter.

2 Select text objects to mask. 
The options allow to choose the mask type, set the distance from the text, proceed 
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creating the mask with default settings. With the option Mask, you can choose the 
masktype among Wipeout, 3dface or Solid. Wipeout is a default choice.

• Wipeout: A wipeout is a polygonal area that masks objects under a text with the 
current background colour. This area is surrounded by a rectangular frame that 
can be displayed if you need to modify it or can be removed if you want to print. 
If you don’t want to display the frame around the text mask, type:

• 3dface: Creates a 3D Face behind the text. The 3D plane obtained by this option 
has all of its edges set to invisible. If you need to select the mask, set the variable 
SPLFRAME to On or 1, to make the edges visible.

NOTE:  To remove the mask it is not necessary to select and delete it, but you can 
quickly use the command Unmask Text of the Express Tools.

• Solid: Choosing this option, the text is masked with a 2D solid in a specified 
colour. You’re prompted to select the colour from the colour palette.

• Offset: Specify the distance from the text. The initial default value for the offset 
factor is 0.35. Type a new offset factor relative to the text height and then press 
Enter.

To remove text mask

1 Do one of the following: 

• Select Express > Text > Unmask Text.

• Type textunmask and then press Enter.

2 Select the text from which you want to remove the mask and then press Enter or 
right click the mouse

Explode text
Explodes the text in some geometries to which it’s possible to assign some heights or 
an elevation.

To explode a text

1 Do one of the following:

• Choose Express > Text > Explode Text.

• On the Express Tools toolbar, click  Explode Text tool ( ).

• Type textexp and press Enter key.

2 Select the text to explode.

Convert text to mtext
Convert a single line text to multiline text.
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To Convert Text to MText

1 Do one of the following:

• Choose Express > Text > Convert Text to MText.

• Type text2mtxt and press Enter key.

2 Select the text to convert and press Enter key.

Justify Text
Changes a text justification without changing its position. For example, you can have 
a table with a text in it justified to the left instead of to the right. After modifying the 
justification, any changes of this text will be justified to the right for any further input 
or modification. It works with the text, mtext, and attribute definition objects. 

To justify text

1 Do one of the following:

• Select Express > Text > Justify Text

• Type tjust and then press Enter.

2 Select the text which justification you want to modify

Rotate Text
Rotates a single line text or an Mtext of a specific angle.

To rotate a text

1 Do one of the following:

• Choose Express > Text > Rotate Text.

• Type torient and press Enter key.

2 Select the text or the Mtext to be rotated and press Enter.

3 Specify the new absolute rotation angle and press Enter.

Enclose text with object 
Encloses single line texts or the Mtexts in entities specified by the user: circles, slots, 
rectangles.

To enclose texts with object

1 Do one of the following:

• Choose Express > Text > Enclose Text with Object.

• Type tcircle and press Enter key.

2 Select the entities to be enclosed and press Enter.

3 Type the text distance from the entity that encloses it (offset) and press Enter.
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4 Type one of the following options and press Enter:

• Circles To enclose the texts with circles.

• Slots To enclose the texts with slots.

• Rectangles To enclose the texts with rectangles.

5 Type one of the following options and press Enter:

• Constant The dimensions of the entities that enclose the text are not fitted to 
the different dimensions of the texts to be enclosed.

• Variable The dimensions of the entities that enclose the text are fitted to the 
different dimensions of the texts to be enclosed.

Automatic text numbering
Adds a sequential numbering to text objects. The numbering can be inserted as a pre-
fix, suffix, or restore text.

To automatically numbering a text

1 Do one of the following:

• Choose Express > Text > Automatic Text numbering.

• Type tcount and press Enter key.

2 Select the text enteritis on a single line text or Mtext to be numbered and press 
Enter.

3 Type one of the following options and press Enter:

• X Place some numbers at the x coordinate increment of the selected text.

• Y Place some numbers when the value of the y coordinate of the selected text 
decreases.

• Select-order Place the number in relation to the text order of selection.

4 Type one of the following options to determine the type of ordering and press 
Enter:

• Increasing

• Descreasing

5 Type the first number from which the numbering starts and press Enter.

6 Type the increment for the numbering and press Enter.

7 Type one of the following method of entering and press Enter:

• Overwrite Restore the selected text strings with numbers.

• Prefix Add the number as prefix to the text.

• Suffix Add the number as suffix to the text.

• Find&replace Replaces a text specified by the user with a number.



M O D I F Y I N G  E N T I T I E S    287

Change Text Case
Changes the case of the selected text, mtext, attributes and dimension text.

To change the text case

1 Do one of the following: 

• Select Express > Text > Change Text Case.

• Type tcase and then press Enter.

2 Choose one of the following:

• Sentences case: capitalizes the first letter of a sentence.

• lowercase: converts all the letters in the lower case.

• UPPERCASE: capitalizes all the letters.

• Title: begins every word with the capital letter.

• tOGGLE cASE: inverts the case of each individual character. This option is 
useful if you type with Caps Lock on without realizing it.

3 Press OK  to confirm.

Modify

Move/Copy/Rotate
Move, copy, rotate and scale objects with a single command.

To move, copy, rotate and scale objects with a single command

1 Do one of the following:

• Choose Express > Modify > Move/Copy/Rotate.

• Type mocoro and press Enter key.

2 Select the desired entities and press Enter.

3 Specify a base point.
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4 Type one of the following method of entering and press Enter:

• Move Move the selected entities in a new position after having specified the 
displacement point.

• Copy Copy the selected entities in a new position after having specified the 
displacement point. Press Enter to go back to the main options menu.

• Rotate Rotate the selected entities by the angular value specified by the user. 
Specify another point to determine the angle in relation to the base point or digit 
an angular value and press Enter.

• Scale Scale the selected entities. Specify a point to determine the scale factor 
or digit the scale factor and press Enter.

• Base Reset the position of the base point. Specify the new position of the base 
point.

• Undo Delete the last change.

• Exit Ends the command.

Extended Clip
Clips xrefs or images with lines and curves.  
Allows curved clipping of blocks, xref drawings, images, and Wipeouts using 
polylines, circles, arcs, ellipses or texts. 

To make an extended clip

1 Do one of the following:

• Select Express > Modify > Extended Clip.

• Type clipit and then press Enter.

2 Draw arcs, circles, and/or polylines to define clipping boundaries for blocks, xrefs, 
images and wipeouts.

3 Pick a polyline, circle, arc, ellipse or text object for clipping edge...

4 Pick an image, a wipeout, or an xref/block to clip...

5 Enter the maximum allowable error distance for resolution of arc segments  <0.1>:

Clipit makes clipping to curved boundaries workable by traversing arc segments with 
a series of short straight segments. Clipit lets you specify the maximum distance 
between the midpoint of any given segment and the arc to control the precision with 
which it traverses arc segments. 

Entering a large error value generates fewer segments and faster AViCAD perfor-
mance, but arcs appear less smooth. On the contrary, entering a very small value 
results in smooth clipping of arcs, but slows down AViCAD during the regeneration 
process of a drawing.
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NOTE  To increase performance, enter relatively large values while creating your 
drawing and, when you are ready to plot, use CLIPIT again and specify a smaller 
error value for arc resolution.
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Flatten objects
Change the elevation of the selected objects.

To change the elevation of the objects

1 Do one of the following:

• Choose Express > Modify > Flatten objects.

• Type flatten and press Enter key.

2 Select the entities and press Enter key.

3 Type a new elevation and press Enter key.

Multiple copy
Copies more the one object by using the options: repeat, array, divide and measure.

To execute the multiple copy of objects

1 Do one of the following:

• Choose Express > Modify > Multiple Copy.

• Type copym and press Enter key.

2 Select the entities to copy and press Enter key.

3 Specify a base point.
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4 Digit one of the following method of entering and press Enter:

• Repeat (last) Repeats the copy command by using the last offset. To be able 
to use this option it’s needed to make a copy specifying manually the first offset 
point for the copy.

• Divide Divides the specified distance by the number of parts defined by the 
user. Select a point to determine the interval to be divided into, digit the number 
of copies and press Enter.

• Measure Copies the selected entities at a distance specified by the user in a 
defined interval.  Select a point to determine the interval to be measured, and 
then specify the distance among the copies. Pick (dynamic) Specify a point to 
select the angle or digit an angular value and press Enter.

• Array (dynamic) Digit one of the following method of entering and press 
Enter:

• Pick (dynamic) Specify a point to select the angle or type an angular 
value and press Enter key. Click a point to determine the distance between 
the lines and the columns. Specify with the mouse another point to 
determine the area to be filled. Press Enter key to end.

• Measure Specify a point to select the angle or digit an angular value and 
press Enter. Click a point to determine the distance between the lines and 
the columns. Specify with the mouse another point to determine the area to 
be filled.

• Divide Specify a point to select the angle or digit an angular value then 
press Enter. Click a point to determine the distance between the lines and 
the columns. Digit the number of columns and press Enter. Digit the number 
of lines and press Enter.

Extended offset
This offset command improved version, offers many advantages among which are: 
the layer control, the undo and multiple options.

To execute extended offset

1 Do one of the following:

• Choose Express > Modify > Extended Offset.

• Type exoffset and press Enter key.

2 Click two points or digit the distance and press Enter to define the offset.

3 Digit Option and press Enter to access to the advanced options. 
Digit one of the following options and press Enter:

• Distance Reset the distance for the offset. Click two points or digit the 
distance and press Enter to define the offset.
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• Layer Specifies the layer for the new objects. Digit one of the following 
options:

• Source Place the new entities on the same layer of the reference entities.

• Current Places the new entities on the current layer.

• Gaptype Sets and changes the offset mode controlled by the variable 
OFFSETGAPTYPE. Digit one of the following options and press Enter:

• Normal.

• Fillet.

• Chamfer.

4 Press Enter to return to the main options menu.

5 Select the entities for which realize the offset.

6 It’s possible to digit one of the following options and press Enter to modify the 
type of entering:

• Multiple Allows making more the one entering of the same entity selected.

• Option Allows returning to the configuration of the options previously 
described.

• Undo Deletes the last change.

7 Specify with a click of the mouse the side on which the new entities will be cre-
ated.

8 Press Enter to end the command.

Delete duplicate objects
Removes unnecessary objects which geometry is redundant by deleting duplicates 
and combining line and arc segments that overlap. For example: 

• Duplicate copies of objects are deleted 

• An arc drawn directly over a portion of a circle is deleted. 

• Two lines drawn at the same angle so that they partially overlap are combined to 
form a single line. 

• A duplicate line and/or arc segments within polylines are removed.

To delete duplicate objects

1 Do one of the following: 

• Choose Express > Modify > Delete duplicate objects.

• Type overkill and then press Enter.

2 After having selected objects in the overkill dialog box, set options for deleting 
duplicate objects and then confirm with OK.
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• Object comparison settings: the settings of this section of the dialog box control 
how OVERKILL compares objects. 

• Ignore options: all the options under Ignore have similar behaviour. For 
example, when the Ignore Layers option is selected, OVERKILL ignores object 
layers when comparing objects. Thus, two overlapping objects that reside on 
different layers may be considered equivalent. This option allows objects on 
different layers that overlap to be deleted or modified, to resolve duplication 
and/or overlap. 

• Numeric fuzz: the Numeric Fuzz value allows you to set the precision with 
which OVERKILL makes numeric comparisons. If this value is 0, two objects 
being compared must match before OVERKILL deletes or modifies one of 
them. On the other hand, if the fuzz value is higher than 0, two objects being 
compared do not have to match one of them to be deleted or modified.  
The fuzz value works in this way for other numeric comparisons such as X, Y 
and Z coordinate comparisons, as well as object comparisons involving scale, 
height, width, and so on. 

• Lines, Arcs and Plines: the settings of this section of the dialog concern how 
overkill deals with lines, arcs and plines. 

• PLINES - Optimize segments within plines. When the Plines option is selected, 
overkill checks individual line and arc segments within selected plines and 
removes any duplicate or unnecessary vertices. Also, if a pline segment dupli-
cates a line or an arc object, one of them is deleted. If this option is not selected, 
overkill examines each pline as a single unit; that is, it deletes a pline only if it 
is a duplicate of another pline. 
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• OVERLAP - Combine co-linear objects that partially overlap. The Overlap 
option controls how overkill handles objects that partially overlap one another. 
When this option is selected, objects that overlap are combined to form a single 
object. Otherwise, if this option is not selected, overkill does not change 
partially overlapping objects.  
For example, you have a horizontal line and another horizontal line drawn from 
the midpoint of the first line to a point beyond the end of the first line. (See the 
following illustration) The second line partially overlaps the first line. If the 
Overlap option is selected, overkill combines the two lines to form a single line 
that extends from the leftmost point to the rightmost point. If the Overlap option 
is not selected, no change is made.  
(The red X marks show the endpoints of the first line and the blue X marks show 
the endpoints of the second line.)

• END to END - Combine co-linear objects when aligned end to end.  
Using this option, you can combine co-linear objects that have common 
endpoints. The following illustration shows how overkill works with the End to 
End option: the red X marks show the endpoints of the first line and arc. The 
blue X marks show the endpoints of the second line and arc.
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Tools/Entity Data
The ability to create and modify the data of the extended entities has been originally 
implemented for the application developed by third parties and it required the pres-
ence of an external application to place the extended data on certain entities. 
This function is also available to the AViCAD user by an extended entities editor 
with a graphic interface. 
In this contest the term “Application" refers to a key or an index by which can be 
referred or modified the data of the extended entity.

Create or edit entity data

To create or edit entity data

1 Do one of the following:

• Choose Express > Tools > Entity Data > Create or Edit Entity Data.

• Type editedata and press Enter key.

2 Select an entity to create or edit the entities database. 
It will be displayed the mask Create or Edit Entity Data.

ATTENTION Before entering any data must be present the name of an applica-
tion.

3 To create the name of an application click on the button Insert, then choose from 
list Application Name. 
An item with the name of default Application in edit mode will be displayed on 
the list, then digit the name for the application and press Enter.

4 After having created an application name or having chosen an existing one, it’s 
possible to insert the other data. Click on the Insert button, and then choose one 
the type of datum available.

5 To edit an existing data:

• Select the data from the list and press Edit.

• Digit a new value and press Enter.

6 To delete an existing data, select it from the list and click on Delete.

7 To confirm the modifications click on OK.

Copy entity data

To copy  entity data

1 Do one of the following:

• Choose Express > Tools > Entity Data > Copy Entity Data.

• Type copyedata and press Enter key.

2 Type the application name and press Enter key.
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NOTE To display the name of the applications available digit ? and press Enter.

3 Select the entity from which copy the data.

4 Select the entity for the destination data.

NOTE If one of the entities of destination already contains the definition of the same 
application, it will be asked if replacing or no replacing the existing data.

Move entity data

To move the entity data

1 Do one of the following:

• Choose Express > Tools > Entity Data > Move Entity Data.

• Type moveedata and press Enter key.

2 Type the application data and press Enter key.

NOTE To display the name of the available applications digit ? and press Enter.

3 Select the entity from which move the data.

4 Select the entity for the destination data.

NOTE If one of the entities of destination already contains the definition of the same 
application, it will be asked if replacing or no replacing the existing data.

Delete entity data

To delete the entity data

1 Do one of the following:

• Choose Express > Tools > Entity Data > Delete Entity Data.

• Type deledata and press Enter key.

2 Type the application name and press Enter.

NOTE To display the name of the available applications digit ? and press Enter.

3 Select the entities from which delete the data and press Enter.
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Reassociate entity data

To reassociate the data merged with an application with another application

1 Do one of the following:

• Choose Express > Tools > Entity Data > Reassociate Entity Data.

• Type reassocapp and press Enter key.

2 Digit in the box Original Application and Reassociate Entity Data with, the origi-
nal application name and the application name by which the entity is being merg-
ing.

3 Select the box Replace original data with new data for duplicate variables in 
order to restore the data in the original application with the data of the new merged 
application.

4 Click OK.

5 Select the entity to reassociate the data with the new application.

6 Select the entities that will have to be reassociate with the new application and 
press Enter.

Quick Perspective

Specify View
To produce a perspective view rather than the command dview it is possible to use 
the rapid command for the perspective in the Express menu. The perspective gives a 
realistic representation of the observer’s eye vision. The lines that compose the 3D 
views of objects aren’t parallel but convergent or divergent.

To obtain a rapid perspective view

1 Do one of the following:

• Select Express > Tools > Perspective > Specify View.

• Type p_perspective and then press Enter.

2 Specify drawing units. 
If the current visualization isn’t plan view, it’s automatically set plan view to posi-
tion the camera and target points.

3 Specify a camera position. While using the mouse to point out the position of the 
camera it is possible to perform zoom to magnify or reduce the visualization. The 
camera is automatically positioned to 160 cms (or 1,6 mt or 1600 mm) elevation.

4 Specify a target position

Create Auto Perspective
The command automatically calculates the target point, camera position and focal 
length. The objects nearer to the camera position appear greater and some parts, fur-
ther from the camera, appear smaller. If the command is repeated and the object is 
very close, it becomes rather deformed and it could disappear from the screen.
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To obtain a rapid perspective view

1 Do one of the following:

• Select Express > Tools > Perspective > Create Auto Perspective

• Type autopersp and then press Enter

After having performed the command, it is possible to modify the angle and the zoom 
of the perspective using the views shortcuts:

CTRL + Left Click : Realtime Sphere 

CTRL + Right Click: Realtime along axis

CTRL + SHIFT + Left Click: RealTime Zoom In&Out

Mouse up Zoom In, Mouse down Zoom Out

CTRL + SHIFT + Right Click : RealTime Pan

Move the cursor to pan 

(Click the Real-Time Zoom button of the Standard Toolbar to see the Views Short-
cuts)
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Working with text

You can insert text into your drawing and control its appearance, allowing you to pro-
vide additional information for your AViCAD® drawings. This chapter explains how 
to:

• Create line text.

• Create paragraphs.

• Create text styles.

• Format text.

• Change text.

• Change paragraph text.

• Check the spelling of text

• Use an alternate text editor.

• Working with text written in different languages.

Topics in this chapter

Creating line text ............................................................................................... 300

Creating paragraph text .................................................................................... 300

Working with text styles..................................................................................... 303
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Checking the spelling........................................................................................ 311

Using an alternate text editor ............................................................................ 315

Working with text written in different languages................................................ 317
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Creating line text       

When you create text, you end each line of text by pressing Enter. Each line of text is 
created as a separate entity that you can modify.

To create text 

1 Do one of the following:           

• Choose Draw > Text > Single Line Text.

• On the Text toolbar, click the Single Line Text tool ( ).

• Type dtext and then press Enter.    

2 Specify the insertion point for the first character.    

3 Specify the height of the text.

4 Specify the text rotation angle.     

5 Type the text, and then press Enter at the end of each new line.

6 To complete the command, press Enter again.

NOTE If you’ve already created text and want new text to appear immediately below 
the previous text, choose Draw > Text > Single Line Text. When prompted for an 
insertion point, press Enter. The new text will keep the same height and rotation 
angle as the previous text.

Creating paragraph text    

Paragraph text consists of one or more lines of text or paragraphs that fit within a 
boundary width that you specify. Each paragraph text entity you create is treated as a 
single entity regardless of the number of individual paragraphs or lines of text it 
contains.    

When you create paragraph text, you first determine the paragraph’s boundary width 
by specifying the opposite corners of a rectangle. The paragraph text automatically 
wraps so that it fits within this rectangle. The first corner of the rectangle determines 
the default attachment point of the paragraph text. You can change the location of the 
attachment point in reference to the rectangle, and you can determine the direction in 
which text flows within the rectangle. You can also select the text and paragraph for-
mat text style, text height, and the rotation angle of the entire paragraph text entity.    
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To create paragraph text 

1 Do one of the following:

• Choose Draw > Text > Multiline Text.

• On the Draw toolbar, click the Multiline Text tool ( ).

• Type mtext and then press Enter.    

2 Select the first corner of the text area.

3 In the MTEXT prompt box, select the properties you want to change, or proceed 
directly to step 4. 

You can select these properties in steps 7 and 8.

4 Select the second corner of the text area.

5 In the Multiline Text dialog box, click the Text tab.

6 In the window, type the text you want. 

To create paragraphs, press Enter and continue typing.

7 Make any selections or changes you want to the following:

• Font, text height, bold, italic, underline, and color. 

• Indents on the ruler. Move the upper left arrow to define the first line indent, 
move the lower left arrow to define the paragraph indent, and move the right 
arrow to define the right indent.

• Tabs on the ruler. Click the ruler to create tabs, move any tab marker to modify 
its location, and drag any tab off the ruler to delete it.

Your selections affect highlighted text, or if no text is highlighted, new text when 
you type it.

8 Click the Properties tab, and make selections or changes you want to the text 
Style, Justification, Width, and Rotation.           

9 Click OK.

NOTE You can paste text from the Clipboard into the Multiline Text dialog box.        
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A Click to view and select text attributes.

B Select the text font.

C Mark the first line indent, paragraph indent, right indent, and 
tabs.

D Type and select text.

E Select or type a zoom magnification.

F Select BYBLOCK, BYLAYER, the color of your choice, or 
choose Select Color to select from additional colors.

G Click to undo the previous action.

H Click to bold, italicize, and underline text.

I Select or type the text height.

A Click to view and select text style and text box properties.

B Select a text style.

C Mark the first line indent, paragraph indent, right indent, and 
tabs.

D Type and select text.

E Select or type the text box angle.

F Select or type the text width.

G Select the text box justification.

A
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D
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Working with text styles    

When you add text to a drawing, it uses the current text style. Text style determines 
the font, size, angle, orientation, and other characteristics.           

Every drawing has a default text style, named Standard, which initially uses the 
icad.fnt font. You cannot delete the Standard style, but you can rename it or modify 
it. You can change the font, the size of the font, and the obliquing angle applied to it. 
If you change the font or orientation of an existing style, all existing text entities cre-
ated using that style are automatically updated to reflect the new font or orientation. 
Changing any other characteristic has no effect on existing text. You also can create 
and use an unlimited number of additional text styles.        

The text style determines the characteristics shown in the following table.                   

To create a text style     

1 Do one of the following:     

• Choose Format > Explore Text Styles.

• On the Style toolbar, click the Explore Text Styles tool ( ).

• Type expfonts and then press Enter.

2 Choose Edit > New > Style.

3 Type a new text style name, or press Enter to accept the default name.

4 Choose Edit > Properties to open the Styles dialog box.

5 Under Text Font, select the name, style, and language of the font you want to use.      

6 Under Text Measurements, enter the Fixed Text Height, Width Factor, and 
Oblique Angle measurement.    

7 Under Text Generation, select the check boxes you want to indicate the direction 
for printed text to appear.

8 Close the Styles dialog box, then close the AViCAD Explorer dialog box.

Style characteristics 
Characteristic Default Description

Font file icad.fnt The font file on which the style is based.

Text height 0 The character height. A value of 0 prompts for text height upon insertion. 

Width factor 1 The horizontal expansion or compression of the text. Values less than 1 compress the text; 
values greater than 1 expand the text.

Obliquing angle 0 The slant of the text, in degrees. Negative values slant the text to the left; positive values slant 
the text to the right.

Backward No Determines whether text appears backward.

Upside down No Determines whether text appears upside down.

Vertical No Determines whether text has a vertical orientation.
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9 To begin using the new style, choose Insert > Text. 

10 In the prompt box, select Use Defined Style.

Formatting text    

When you create text, you choose the text style and set the alignment. The style deter-
mines the font characteristics for the text. For line text, the alignment determines how 
the text aligns with the text insertion point. For paragraph text, the alignment deter-
mines the location of the attachment point in relation to the paragraph text boundary 
and the direction in which text flows within the boundary.         

Setting the line text style
You can set the text style before you specify the insertion point. You select the text 
style by typing the name of a previously defined style.       

To specify a line text style

1 Do one of the following:     

• Choose Draw > Text > Single Line Text.

• On the Draw toolbar, click the Single Line Text tool ( ).

• Type dtext and then press Enter.

2 In the prompt box, choose Use Defined Style.

3 Type the name of a previously defined text style, and then press Enter.        

To display a list of available text styles, type a question mark (?), and then press 
Enter.    

4 Specify the text insertion point.     

5 Specify the text height.     

6 Specify the rotation angle.    

7 Type the text line, and then press Enter.

8 To complete the command, press Enter again.

Setting the paragraph text style
You can set the paragraph text style before you specify the insertion point. You select 
the text style by typing the name of a previously defined style.



W O R K I N G  W I T H  T E X T    305

To specify a paragraph text style

1 Do one of the following:

• Choose Draw >  Text > Multiline Text.

• On the Draw toolbar, click the Multiline Text tool ( ).

• Type mtext and then press Enter.

2 Specify the first point of the Multiline Text box.

3 In the prompt box, choose Text Style.

4 Type the name of a previously defined text style, and then press Enter.

5 Specify the text height.

6 Specify the rotation angle.

7 Specify the opposite corner of the Multiline Text box.

8 Type the text, and then press Enter.

9 To complete the command, press Enter again.

Setting the line text alignment    
When you create text, you can set the text alignment before you specify the insertion 
point. You set the alignment by choosing it in the prompt box. By default, text is left 
justified. You can align text at the left, center, or right and at the top, middle, or base-
line of the text or at the bottom of descending letters.                  

You can also align text so that it fits or aligns between two points. The Align option 
creates text that scales up or down while maintaining a constant height/width ratio; 
the Fit option expands or compresses the text to fit between the two points.        

A Top left

B Middle left

C Left

D Bottom left

E Center

F Bottom center

G Bottom right

H Baseline

I Right
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K Top right
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To specify the line text alignment

1 Do one of the following:       

• Choose Draw > Text > Single Line Text.

• On the Draw toolbar, click the Single Line Text tool ( ).

• Type dtext and then press Enter.    

2 In the prompt box, choose an alignment option, or choose Justification Options to 
display all the justification options.

3 Specify the text insertion point, and then continue creating the line text.

Setting the paragraph text alignment
When you create paragraph text, you can set the text alignment by specifying the 
attachment point location in relation to the paragraph text boundary and the direction 
in which text flows within the boundary. You can set the paragraph text alignment 
either in the prompt box displayed after you specify the first corner of the paragraph 
text boundary or from the Multiline Text dialog box. You can specify the attachment 
point at the top left, top center, top right, middle left, middle center, middle right, bot-
tom left, bottom center, or bottom right. The paragraph text can flow left to right, 
right to left, top to bottom, or bottom to top.

Including special text characters    
You can use control codes to overscore or underscore text or to include special char-
acters. Both overscore and underscore can be active at the same time. To include con-
trol codes, as you type text, type two percent symbols (%%) followed by the special 
control code or character. A single percent sign is treated as a normal text character. 
A triple-percent control code is provided for those instances where a control-code 
sequence must follow a percent sign in the text.                         

Text aligned between two points maintains a 
constant height/width ratio.

Text fit between two points expands or compresses 
to fit.

Special text characters   
Control code Function

%%o Toggles overscore mode on and off.

%%u Toggles underscore mode on and off.

%%d Draws a degree symbol (º).
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Changing text    

Changing line text
You can edit and modify the text as you would any other drawing entity. That is, you 
can delete, move, rotate, and scale text.                      

To edit text     

1 Do one of the following:     

• Choose Modify > Object > Text.

• On the Text toolbar, click the Edit Text tool ( ).

• Type ddedit and then press Enter.

2 Select the text entity.

3 In the Text field, edit the text, and then click OK.

To change text properties

1 Do one of the following:           

• Choose Modify > Object > Text.

• On the Text toolbar, click the Edit Text tool ( ).

• Type ddedit and then press Enter.

2 Select the text entity.

3 Under Text Settings, change the text properties you want.

4 Click OK.  

%%p Draws the plus-or-minus symbol (±).

%%c Draws the circle diameter symbol (Ø).

%%% Forces a single percent sign.

%%nnn Draws special character number nnn.

Special text characters   
Control code Function

Text created using special text characters: Ut wisi %%uenim%%d ad%%p%%u minim %%c %%oveniam.
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Changing paragraph text
You can modify the text as you would any other drawing entity. That is, you can 
delete, move, rotate, and scale text.

To edit paragraph text

1 Do one of the following:

• Choose Modify > Object > Text.

• On the Text toolbar, click the Edit Text tool ( ).

2 Select the text entity.

3 Select Text tab in the dialog box, change the text and apply font style changes.

4 Click OK.

To change paragraph text properties

1 Do one of the following:

• Choose Modify > Object > Text.

• On the Text toolbar, click the Edit Text tool ( ).

2 Select the text entity.

3 Select Property tab in the dialog box and perform changes you want

4 Click OK.

Find
This command allows you to find, replace, or select a text and it controls the results 
of the search.

To find and replace a text

1 Do one of the following:

• Select Edit > Find and Replace

• Type find and then press Enter.

2 In the find and replace mask you can see these options:
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• Find Text String : Indicates the text string to find. Enter a text string including 
any wild card characters, or choose one from the list of the six most recently 
used strings.

• Replace With: Indicates the text string you want to use to replace the found 
text. Enter a string or choose one from the list of the most recently used strings.

• Search In: Indicates whether to search the entire drawing or only the current 
selection. If something is already selected, Selection is the default value. If 
nothing is selected, the default value is Entire Drawing. You can use the Select 
Objects button to close temporarily the dialog box and create or modify the 
selection set. When selection is completed press Enter or right click to open the 
dialog box again.

• Select Objects Button: Closes temporarily the dialog box so that you can select 
objects in your drawing. Press ENTER to return to the dialog box. When you 
select objects, the Search In field displays Current Selection.

• Options: Displays the Find and Replace Options dialog box, in which you can 
define the type of words that you want to find.



310   C H A P T E R  1 1

• Find: Finds the text that you have entered in the Find Text String field. This 
option is not available if you have not entered any text in the Find Text String 
field. The found text is displayed in the Context area. Once you have found the 
first instance of the text, the Find option becomes Find Next, which you can use 
to find the next instance.

• Replace: Replaces the found text with the text that you entered in the Replace 
With field.

• Replace All: Finds all occurrences of the text that you entered in Find Text 
String and replaces it with the text in Replace With. The Search In setting 
controls whether to find and replace the text in the entire drawing or the text in 
the current selection. The status area confirms the replacements and indicates 
the number of replacements that have been made.

• Select All: Finds and selects all the objects containing instances of the text that 
you entered in the Find Text String field. This option is available only when you 
select objects in a drawing and the Search In control is set to Selection. When 
you choose Select All, the dialog box closes and a message in the command 
prompt shows the number of objects founded and selected. Select All does not 
replace the text.

• Zoom To: Displays the area in a drawing that contains the results of a find or 
replace search.
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Checking the spelling

Check Spelling
Corrects the spelling in text objects of a drawing. 
It is possible to do the spell checking for any text of a drawing, including:

• Single line text

• Multiline text

• Text in block attributes

• External references

For attributes, only values are checked.  
To do the check spelling in another language, you can choose a different  dictio-
nary. You can also customize and manage several dictionaries and switch 
between them.

To do the check spelling

1 Do one of the following: 

• Choose Tools > Spell Check.

• Type spell and then press Enter.
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A Displays the current dictionary.

B Displays the misspelled word and its context in 
the drawing.

C Displays (or you can type) a new word to replace 
the misspelled word in the drawing.

D Displays a list of suggested words from the 
current dictionary to replace the misspelled 
one.Select a replacement word from the list or 
edit, or enter a replacement word in the top 
Suggestions text area.

E Displays the dialog box Change Dictionaries.

F Adds the word entered in the box to the current 
custom dictionary.

G It allows to choose one of the words in the 
Suggestions box, to obtain other suggestions 
about that item.

H Replaces the current word in all the selected text 
objects.

I Replaces the current word with the word 
specified in the Suggestions box.

J Ignore the current word

K Move the slider to zoom in or out on the text.
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A Type a word for the custom dictionary.

B Displays the words in the custom dictionary.

C Click to delete the currently selected word from 
the custom dictionary.

D Click to add the current word in the edit box (A) 
to the custom dictionary.

E Click to select a different custom dictionary.

F Displays the custom dictionary filename. You can 
type a new path and filename or click Browse to 
select a file.

A

B

F

E

D

C
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Main Dictionary
The check spelling function allows to choose a main dictionary among many differ-
ent languages. Dictionary files have a .dic extension.  
To do the check spelling in another language, you can switch to a different main dic-
tionary.

Do one of the following:

• From the Main Dictionary box, select another dictionary in a language that you 
need.

• With the Download button you can download a new dictionary.

The download button is linked to a web page that manages a lot of free downloadable 
dictionaries in many different languages. Put downloaded dictionaries in the same 
folder shown in the Custom Dictionary box.

NOTE  It is possible to switch between other dictionaries using the system variables 
DCTMAIN or DCTCUST. To have a list of main dictionaries, type DCTMAIN from 
the command bar.

A Select the desired spelling dictionary. B Click to open the default Internet browser to a 
web page where you can download spelling 
dictionaries in different languages.

A

B
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Creating and modifying a custom dictionary
You can create an unlimited number of custom dictionaries and switch between them 
when it is necessary. A custom dictionary is a list of the user’s spelling exceptions. 
The extension of custom dictionary files is .cus.

During a spelling check, words in the drawing are matched to words in the current 
main and custom dictionaries. All spelling exceptions that you add with the Add 
option are stored in the current custom dictionary. For example it is possible to add 
personal or place names to skip automatically those words in spell check. The current 
custom dictionary is the icad .cus file stored in the AViCAD application data folder.

To select  a custom dictionary

1 Click Browse...

2 Choose the necessary .cus file.

3 Click Open.

To add the content of a custom dictionary to the current one

1 Select a custom dictionary from the list displayed in the custom dictionary area.

2 Click OK

Using an alternate text editor    

AViCAD includes a built-in text editor for creating paragraph text using the MTEXT 
command described earlier in this chapter (See Creating paragraph text300). You 
can also specify an alternate text editor for the MTEXT command.

Selecting an alternate text editor    
Before you can use an alternate text editor, you must specify the editor by setting the 
MTEXTED system variable.                      

To select an alternate text editor     

1 Type mtexted and then press Enter. 

2 Enter the path and name of the executable file for the text editor you want to use to 
create or edit multiline text. For example, to use Microsoft Wordpad, you would 
type something similar to the following (adjusting the path name as necessary):

C:\Program Files\Windows NT\Accessories\Wordpad.exe

Creating paragraph text in an alternate text editor    
After you set up AViCAD to use an alternate text editor, you can start using it to 
include text in your drawings.
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To use an alternate text editor     

1 Do one of the following:     

• Choose Draw > Text > Multiline Text.

• On the Draw toolbar, click the Multiline Text tool ( ).

• Type mtext and then press Enter.    

2 Select the first and second corners of the text area, as described earlier in this 
chapter.

3 In the Multiline Text dialog box, click the Text tab.

4 In the window, type the text you want, using the special characters from the table 
shown below to achieve special formatting. Enter \P to end a paragraph and start a 
new paragraph on the next line. For example, to use an alignment value of 1 and 
stack two numbers to display them as a fraction:

{\A1;\S1/2;}\P 

5 When your text is complete, save the changes and exit the text editor. 

Special formatting characters   
Format characters Function

\0...\o Toggles overscore mode on and off.

\L...\l Toggles underscore mode on and off.

\~ Inserts a nonbreaking space.

\\ Inserts a backslash.

\{...\} Inserts an opening and closing brace.

\Cvalue; Sets the color to a specified value.

\File name; Sets the font based on a specified font file name.

\Hvalue; Sets the text height to a specified value.

\Hvaluex; Sets the text height to a multiple of the current text height.

\S...^...; Stacks the subsequent text at the /, #, or ^ symbol.

\Tvalue; Adjusts the space between characters, from 0.75 to 4 times.

\Qangle; Changes obliquing angle.

\Wvalue; Changes width factor to produce wide text.

\A Sets the alignment value.

\P Ends paragraph.

\p[i],[l],[tX1,X2,...,X32] Formats paragraph: i = first line indent; l = paragraph offset; t = tab 
positions.
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Working with text written in different languages

You can include text in your drawings that is written in different languages.

Using Unicode characters
AViCAD supports the Unicode character encoding standard, which enables you to 
display and write text in different languages using different letters. Unicode fonts 
contain many more characters than typically defined in a system.  

For more details about using special characters, see “Including special text charac-
ters” on page 306 in this chapter. You can also use a different text editor; see “Using 
an alternate text editor” on page 315 in this chapter.

Specifying character sets for drawings
The character set used to display text in drawings typically depends on the character 
set specified by your operating system, for example, ANSI_1252 is Latin 1, 
ANSI_1253 is Greek, and ANSI_1254 is Turkish. This is also called the code page.

AViCAD allows you to manage which code page is assigned to a drawing when you 
open the drawing or after you open it. This unique feature is usually not necessary if 
you distribute drawings within the same geographic region, but it can be very helpful 
when sharing or distributing drawings between different geographic regions. Chang-
ing the code page is highly desirable especially in geographic regions where several 
languages are used that require different character sets to display text properly.

Setting the code page doesn’t change the language of your text; instead it specifies 
the character set in which the text displays. Some fonts can display its characters sev-
eral different ways depending on the code page setting.

There are two system variables that relate to the code page of a drawing:

• SYSCODEPAGE — Character set defined for your operating system.

• DWGCODEPAGE — Character set defined for an individual drawing that over-
rides the operating system code page.

Special Unicode characters   
Control code Function

\U+00B0 Draws a degree symbol (º).

\U+00B1 Draws the plus-or-minus symbol (±).

\U+2205 Draws the circle diameter symbol (Ø).
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To manage how code pages are assigned to drawings

1 Type codepage and then press Enter. 
The Code Page Manager dialog box opens.

2 If you want to convert the drawing to use a different code page, in Drawing Code 
Page, select the desired code page.

3 Select one of the following options:

• No conversion when a drawing is opened — Keeps the drawing code page 
unchanged when you open a drawing.

• Always open this dialog when a drawing is opened — Opens the Code Page 
Manager dialog box every time you open a drawing.

• Only open this dialog when the drawing and system code pages differ — 
Opens the Code Page Manager dialog box only when the operating system code 
page is different from the drawing code page. This setting can be helpful if you 
sometimes send or receive drawings created using a code page that is different 
from the one used by your operating system.

• Automatically convert the code page when a drawing is opened — Always 
use the same code page when opening drawings (the Code Page Manager dialog 
box will not open).

4 If you selected to automatically convert the code page, select one of the following:

• Use alternate code page — When converting drawings automatically, always 
use the code page that you select.

• Use system code page — When converting drawings automatically, use the 
code page defined for the operating system (this is the code page displayed for 
the SYSCODEPAGE system variable).

TIP If you want to always use the code page assigned to a drawing, choose No Con-
version when a Drawing is Opened (this is the default setting). You can change the 
drawing code page after opening a drawing, if necessary. If you want to always use 
the code page specified for your operating system, choose Automatically Convert the 
Code Page, and then choose Use System Code Page.
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A Displays the code page for your operating 
system.

B Select the code page for the current drawing. 

C Choose to keep the drawing code page 
unchanged when you open a drawing.

D Choose to open the Code Page Manager 
dialog box every time you open a drawing.

E Choose to open the Code Page Manager 
dialog box only when the operating system 
code page is different from the drawing code 
page.

F Choose to always use the same code page 
when opening drawings (the Code Page 
Manager dialog box will not open).

G Choose to always use the operating system code 
page when opening drawings (available only if you 
selected to automatically convert drawings).

H Choose to always use the selected code page when 
opening drawings (available only if you selected to 
automatically convert drawings).

I Click to preview the first text entity using the current 
code page settings.

J Click to preview the next text entity using the current 
code page settings.

A

B

C
D

E

F

G

H

I

J
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Dimensioning your drawing

The AViCAD® dimensioning tools let you add measurements to a drawing. You can 
quickly add dimensions by simply pointing to entities. You can also add tolerance 
symbols to your drawings. 

The program’s many dimensioning variables let you control the appearance of the 
dimensions. With dimension styles, you can save dimension variable settings so you 
can reuse them without having to re-create them.

This chapter explains how to:

• Create dimensions as linear, angular, diametral, radial, and ordinate.

• Create leaders and annotations.

• Edit dimensions.

• Use dimension styles and variables.

• Add geometric tolerances.

• Control dimension tolerance.

• Control alternate dimension units. 

Topics in this chapter

Understanding dimensioning concepts............................................................. 322

Creating dimensions......................................................................................... 324

Editing dimensions............................................................................................ 334

Understanding dimension styles and variables ................................................ 337

Adding geometric tolerances ............................................................................ 347
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Understanding dimensioning concepts  

You can create five basic types of dimensions: linear, angular, radial, diametral, and 
ordinate. You can create dimensions for existing entities by selecting them, or you 
can create dimensions by selecting points within a drawing. For example, you can 
create a linear dimension either by selecting the entity to be dimensioned or by speci-
fying the first and second extension line origins.             

When you create a dimension, the program draws it on the current layer, using the 
current dimension style. Each dimension has an associated dimension style, which 
controls the appearance of the dimension, such as the types of arrowheads, text style, 
and colors of various components. You can modify existing dimension styles by 
changing one of the dimension variable settings and then updating the dimension 
style to reflect the new settings.    

Each dimension you create consists of several parts. A dimension line shows where a 
dimension begins and ends. When you create an angular dimension, the dimension 
line is a dimension line arc that subtends the measured angle.    

A Radial dimension.

B Vertical linear dimension.

C Angular dimension.

D Linear continued dimensions.

E Aligned dimension.

F Diametral dimension.

G Horizontal linear dimension.

H Linear baseline dimension.

A

B

C

D

E
F

H

G
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Extension lines, also called projection lines, are lines that extend away from the entity 
for which you are creating a dimension, so that you can place the dimension line 
away from the entity. Arrowheads form the termination at each end of the dimension 
line.   

Dimension text contains the measured dimension and can also include prefixes, suf-
fixes, tolerances, and other optional text. As you insert dimensions, you can control 
the dimension text and specify its position and orientation.        

Dimensions can also contain other optional components. A leader is a line leading 
from a feature of the drawing to an annotation. Leaders begin with an arrowhead, and 
you can use them to place a dimension away from the dimension line or to add notes. 
When you create a radial dimension, you can add a center mark, which is a small 
cross that marks the center of a circle or an arc, or you can add centerlines, which are 
crossing lines that extend out from the center of a circle or an arc.      

A Extension line.

B Arrowhead.

C Dimension line.

D Dimension text.

A
B

C D

Leader. Center mark. Centerlines.
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Creating dimensions  

You can create dimensions by:    

• Selecting the entity to dimension and specifying the dimension line location.

• Specifying the extension line origins and the dimension line location.

When you create dimensions by selecting an entity, the program automatically places 
the extension line origins at the appropriate definition points based on the type of 
entity you select. For example, the definition points are located at the endpoints of 
arcs, lines, and polyline segments. When you create dimensions by specifying the 
extension line origins, the points you specify determine the definition points. To 
establish these points precisely, use entity snaps.  

You can create dimensions in model space or paper space.

Quick dimensioning
To create and modify quickly a series of dimensions you can use the QDIM com-
mand. This command is particularly useful when you create a series of baseline or 
continued dimensions  or when you dimension a series of circles and arcs.

To create a quick dimension

1 Do one of the following:

• Select Dimension > Quick Dimension.

• Select Quick Dimension from the Dimension toolbar.

• Type QDIM and press Enter.

2 Select objects for dimensioning, then specify position of the dimension line or 
choose from the options:

• Continuous: creates a series of continued dimensions.

• Staggered: creates a series of staggered dimensions.

• Baseline: creates a series of baseline dimensions.

• Ordinate: creates a series of ordinate dimensions.

• Radius: creates a series of radium dimensions.

• Diameter: creates a series of diameter dimensions.

• Datum Point: sets a new point of origin for ordinate and baseline dimensions.

• Edit: Modifies a series of dimensions. It is suggested that you add or remove 
points of existing dimensions.
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Creating linear dimensions  
Linear dimensions annotate linear distances or lengths and can be oriented horizon-
tally, vertically, or aligned parallel to an existing entity or to the selected extension 
origin points. After you create a linear dimension, you can add a baseline dimension 
or a continued dimension. A linear baseline dimension inserts an additional dimen-
sion from a common first extension line origin of a previous linear dimension. A lin-
ear continued dimension continues a linear dimension from the second extension line 
of a previous linear dimension.    

TIP To select precise ordinate points, use entity snaps.

To create a horizontal or vertical dimension

1 Do one of the following:    

• Choose Dimension > Linear.

• On the Dimension toolbar, click the Linear Dimension tool ( ).

• Type dimlinear and then press Enter.    

2 Press Enter, and then select the entity to dimension.    

Or, you can insert the dimension by specifying the first and second extension line 
origins.

3 Specify the dimension line location.            

To insert a linear dimension by selecting the entity, select the 
entity (A) to dimension, and then specify the dimension line 
location (B).

Result.

To insert a linear dimension by selecting the extension line 
origins, select the first extension origin (A), select the second 
extension origin (B), and then specify the dimension line 
location (C).

Result.

A
B

A

BC
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To create an aligned dimension    

1 Do one of the following:     

• Choose Dimension > Aligned.

• On the Dimension toolbar, click the Aligned  Dimension tool ( ).

• Type dimaligned and then press Enter.    

2 Press Enter, and then select the entity to dimension.

Or, you can insert the dimension by specifying the first and second extension line 
origins.

3 Specify the dimension line location.        

To insert an aligned dimension by selecting the entity, select 
the entity (A) to dimension, and then select the dimension line 
location (B).

Result.

To insert an aligned dimension by selecting the extension line 
origins, select the first extension origin (A), select the second 
extension origin (B), and then specify the dimension line 
location (C).

Result.

A
B

A

C B
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To create a linear baseline dimension

NOTE  Before you can use this procedure, you must first create a dimension.

1 Do one of the following:    

• Choose Dimension > Baseline.

• On the Dimension toolbar, click the Baseline Dimension tool ( ).

• Type dimbaseline and then press Enter.    

2 To select a starting dimension, press Enter.

3 Select the next extension line origin, and then press Enter.

Or press Enter, and then select an existing dimension for the baseline. Select the 
origin of the next extension line, and then press Enter.

The program automatically places the new baseline dimension above or below the 
previous dimension line. The distance between the two dimension lines is determined 
by the Baseline Offset value in the Dimension Settings dialog box.         

To add a baseline dimension to an existing linear dimension, select the existing dimension (A), select the 
next extension line origin (B), and select as many additional points as you want (C).

A B

C

Result.
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To create a linear continued dimension

NOTE  Before you can use this procedure, you must first create a dimension.

1 Do one of the following:    

• Choose Dimension > Continue.

• On the Dimension toolbar, click the Continue Dimension tool ( ).

• Type dimcontinue and then press Enter.     

2 To select a starting dimension, press Enter.

3 Select the next extension line origin, and then press Enter.

Or press Enter, and then select an existing dimension to continue.

4 To add continued dimensions, continue selecting extension line origins.

5 To end the command, press Enter twice.        

To add a continued dimension to an existing linear dimension, select the existing dimension (A), select the 
next extension line origin (B), and select another extension line origin (C).

Result.

A B

C
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Creating angular dimensions   
Angular dimensions annotate the angle measured between two lines. You can also 
dimension an angle by selecting an angle vertex and two endpoints. After you create 
an angular dimension, you can add a baseline dimension or a continued dimension. 
An angular baseline dimension inserts an additional dimension from a common first 
extension line origin of a previous angular dimension. An angular continued dimen-
sion continues an angular dimension from the second extension line of a previous 
angular dimension.       

To dimension an angle encompassed by an arc    

1 Do one of the following:     

• Choose Dimension > Angular.

• On the Dimension toolbar, click the Angular Dimension tool ( ).

• Type dimangular and then press Enter.    

2 Select the arc.

3 Specify the dimension arc location.          

To dimension an angle between two lines

1 Do one of the following:    

• Choose Dimension > Angular.

• On the Dimension toolbar, click the Angular Dimension tool ( ).

• Type dimangular and then press Enter.

2 Select one line.

3 Select the other line.

4 Specify the dimension line location.

To dimension the angle subtended by an arc, select 
the arc (A), and then specify the dimension arc 
location (B).

Result.

A

B
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Creating diametral and radial dimensions  
Diameter and radius dimensions annotate the radii and diameters of arcs and circles. 
You can optionally include centerlines or center marks.    

To create a diametral dimension    

1 Do one of the following:    

• Choose Dimension > Diameter.

• On the Dimension toolbar, click the Diameter Dimension tool ( ).    

• Type dimdiameter and then press Enter.    

2 Select the arc or circle.

3 Specify the dimension line location.  

To create a radial dimension

1 Do one of the following:     

• Choose Dimension > Radius.

• On the Dimension toolbar, click the Radius Dimension tool ( ).

• Type dimradius and then press Enter.    

2 Select the arc or circle.

3 Specify the dimension line location. 

Select one line (A), select the other line (B), and then specify the 
dimension line location (C).

Result

Select the circle (A), and then specify the  
dimension line location (B).

Result.

A

B
C

A B
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Creating ordinate dimensions
An ordinate dimension annotates the perpendicular distance from an origin or base 
point (the origin of the current user coordinate system [UCS]). Ordinate dimensions 
consist of an x- or y-coordinate and a leader. An x-ordinate dimension measures dis-
tances along the x-axis; a y-ordinate dimension measures distances along the y-axis.    

As you select ordinate points, the program automatically determines whether the 
point is an x- or y-ordinate based on which direction you drag the second point. You 
can also specify whether the ordinate represents an x- or y-ordinate. Ordinate dimen-
sion text is always aligned with the ordinate leader lines, regardless of the text orien-
tation specified by the current dimension style.     

Select the circle (A), and then specify the  
dimension line location (B).

Result.

A B

Ordinate dimensions measure the distance along the x- or y-axis from an origin to a selected ordinate point.
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To create an ordinate dimension

1 Do one of the following:     

• Choose Dimension > Coordinate.

• On the Dimension toolbar, click the Ordinate tool Dimension ( ).

• Type dimordinate and then press Enter.    

2 Select the point for ordinate dimension.

3 Specify the ordinate leader endpoint.     

NOTE To select precise ordinate points, use entity snaps.

Creating leaders and annotations
Leaders consist of a line or series of lines that connects a feature in a drawing to an 
annotation. Generally, you place an arrowhead at the first point. An annotation, cre-
ated as dimension text, is placed immediately adjacent to the last point. By default, 
the text placed at the end of the leader line consists of the most recent dimension. You 
can also type an annotation as a single line of text.    

To create a leader and an annotation

1 Do one of the following:     

• Choose Dimension > Leader.

• On the Dimension toolbar, click the Quick Leader tool ( ).

• Type dimleader and then press Enter.    

2 Specify the starting point of the leader.

3 Specify the endpoint of the leader line segment.

4 Specify additional leader line segment endpoints.

5 After you specify the last endpoint, press Enter.

6 Type the annotation, or press Enter to accept the most recent dimension as the 
default annotation.  

Select the ordinate point (A), and then specify the ordinate leader endpoint (B).

A B
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Dimensioning model space entities in paper space
To increase efficiency, you can separate your drawing model from annotations using 
the Model and Layout tabs.

It takes time to display dimensions, title blocks, keynotes, and other annotations. If 
you draw these on a Layout tab, display-time and visual clutter are reduced when you 
work on your model (on the Model tab). AViCAD allows you to dimension model 
space entities on either the Model tab or a Layout tab — you can make the choice 
depending on the method that works best for your needs.

To dimension model space entities in paper space

1 Click a Layout tab.

2 Create at least one layout viewport. For details, see “Creating layout viewports” 
on page 395. 

3 Lock the desired layout viewport by doing the following:

• Right-click the edge of the layout viewport that you want to use for creating 
dimensions.

• Choose Properties.

• Mark Lock Viewport, and then click OK. 
Locking the viewport is not required, but it is extremely helpful when you zoom 
or pan in the layout viewport; it prevents the viewport scale and view center 
from changing.

TIP You may want to place the layout viewports on their own layer and after 
locking the layout viewports, hide the layer that contains them. This allows you to 
work within the layout viewport without it cluttering your display or selections.

Specify the starting point of the leader (A) 
and the endpoint of the leader line segment 
(B).

Result.

A

B
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4 Make sure you are working in paper space by verifying that the Model/Paper 
Space toggle in the status bar begins with “P.” If necessary, switch to paper space 
by clicking the Model/Paper Space toggle in the status bar.

5 Create a dimension. You can select the model space entities directly, specify defi-
nition points, or use entities snaps to help accurately select the definition points. 
The dimension is created in paper space.

For more details about using paper space and model space, see “Understanding paper 
space and model space” on page 389. 

Editing dimensions  

You can use grips to edit entity dimensions. You can also edit the dimension text. 
You can rotate dimension lines and dimension text at any angle, and you can reposi-
tion the dimension text anywhere along the dimension line.   

Making dimensions oblique    
Extension lines are normally created at a perpendicular angle to the dimension line. 
You can change the angle of the extension lines, however, so that they tilt relative to 
the dimension line.    

To make oblique extension lines

1 Do one of the following:     

• Choose Dimension > Make Oblique.

• On the Dimension toolbar, click the Dimension Edit tool ( ) and then in the 
prompt box, choose Oblique Lines.

• Type dimedit, press Enter, and then in the prompt box, choose Oblique Lines.    

2 Select the linear dimension, and then press Enter.

3 Type the obliquing angle, and then press Enter.       

Select the dimension to be made oblique (A), and then type 
the obliquing angle.

Result.

A
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NOTE To align the oblique angle if you don’t know the exact measurement, use 
snaps to pick two points on the entity.

Editing dimension text
You can rotate the text of an existing dimension, move the dimension text to a new 
position, or replace selected dimension text with new text. You can also restore 
dimension text to its original position as defined by the current dimension style.        

When you rotate or replace selected text, you specify the change first, and then select 
one or more dimensions to which to apply the change. All the selected dimensions are 
updated simultaneously.

To rotate dimension text

Advanced experience level      

1 Do one of the following:

• Choose Dimension > Rotate Dimension Text.

• On the Dimension toolbar, click the Dimension Edit tool ( ) and then in the 
prompt box, choose Rotate Text.

• Type dimedit, press Enter, and then in the prompt box, choose Rotate Text.

2 Type the new dimension text angle, and then press Enter.

3 Select the dimension to be rotated, and then press Enter.    

NOTE The dimension text angle is relative to the dimension line. If the dimension 
text rotation is set to zero, the text angle is defined by the dimension type and the 
dimension style. 

Select the dimension to be rotated (A), and then  
type the rotation angle.

Result.

A
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To move dimension text

Advanced experience level    

1 Do one of the following:

• Choosen Dimension > Reposition Dimension Text.

• On the Dimension toolbar, click the Dimension Edit tool ( ).

• Type dimtedit and then press Enter.

2 Select the dimension to reposition text.

3 Select the new text position.   

To restore dimension text to its home position    

Advanced experience level     

1 Do one of the following:

• Choose Dimension > Restore Text Position.

• On the Dimension toolbar, click the Dimension Edit tool ( ) and then in the 
prompt box, choose Restore Text. 

• Type dimedit, press Enter, and then in the prompt box, choose Restore Text.

2 Select the dimension text to restore, and then press Enter.

To replace existing dimension text with new text    

Advanced experience level    

1 Do one of the following:

• Choose Dimension > Edit Dimension Text.

• On the Dimension toolbar, click the Dimension Text Edit tool ( ).

• Type dimedit and then in the prompt box, choose Edit Text.

2 Type the new dimension text, and then press Enter.

3 Select the dimension to be replaced, and then press Enter.

Select the dimension to be moved (A), and then 
select the new text position (B).

Result.

A
B
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Understanding dimension styles and variables  

Dimensions that you insert are created using the current dimension style. You can 
create, save, restore, and delete named dimension styles.    

To display information about the current dimension style and compare it with other 
style names, you can use the dimstyle command.

Dimension styles provide a way for you to change various settings that control the 
appearance of dimensions. You can then save those settings for reuse. If you don’t 
define a dimension style before creating dimensions, the program uses the Standard 
dimension style, which stores the default dimension variable settings. Each option in 
the Dimension Settings dialog box relates to a variable that you can set manually. See 
the online Command Reference for more information.

To create a dimension style

1 Do one of the following:    

• Choose Dimension > Dimension Style.

• On the Dimension toolbar, click the Dimension Style tool ( ).

• Type setdim and then press Enter.

2 In the Dimension Settings dialog box, click New.

3 Type the name of the new dimension style.

4 Click Create.

5 In the Dimension Settings dialog box, click one of the other tabs, and then change 
the dimension settings as necessary.

Repeat this step for each tab, as needed.

6 To end the command, click OK.

To select a dimension style

1 Do one of the following:

• Choose Dimension >  Style, select a dimension style from the list, and then click 
OK.

• On the Style toolbar, select a dimension style from the list.

• Type setdim, press Enter, select a dimension style from the list, and then click 
OK.
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To rename a dimension style

1 Do one of the following:    

• Choose Dimension > Dimension Style.

• On the Dimension toolbar, click the Dimension Style tool ( ).

• Type setdim and then press Enter.

2 In the Dimension Settings dialog box, click Rename.

3 In the Rename list, click the dimension style to be renamed.

4 In the To box, type the new dimension style name.

5 Click Rename.

6 Click OK.

To delete a named dimension style

1 Do one of the following:    

• Choose Dimension > Dimension Style.

• On the Dimension toolbar, click the Dimension Style tool ( ).

• Type setdim and then press Enter.

2 In the Dimension Settings dialog box, click Delete.

3 Select the dimension style to delete.

4 Click Delete.

5 Click OK.

To display information about the current style

1 Type dimstyle and then press Enter.   

2 Type the dimension style name, and press Enter.

Controlling dimension arrows   
You can control the appearance and size of arrowheads or tick marks placed at the 
ends of dimension lines. Any changes you make affect the current dimension style. 
The arrowheads you choose display both below the User-Defined Arrowheads check 
box and in the image tile on the right side of the Dimension Settings dialog box.    

You can choose from a number of arrowhead types. You can specify different arrow-
heads for each end of a dimension line. The Start arrow corresponds to the first exten-
sion line; the End arrow corresponds to the second extension line. The Arrow Size 
value determines the size of the arrowhead, measured in drawing units. You can also 
use tick marks instead of arrowheads.    
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To choose an arrowhead

1 Do one of the following:

• Choose Dimension > Dimension Style.

• On the Dimension toolbar, click the Dimension Style tool ( ).

• Type setdim and then press Enter.    

2 Click the Arrows tab.   

3 In the Start or End list, click to select the Start or End arrowhead, respectively.

4 In the Leader list, click to select a leader type.

5 Click OK.

NOTE  You can also specify leader arrow types using the DIMLDRBLK system vari-
able.

A Type or select arrowhead size.

B Click to select a starting arrowhead, or click the 
arrowhead picture to scroll the list automatically.

C Click to select an ending arrowhead, or click the 
arrowhead picture to scroll the list automatically.

D Click to select a leader arrowhead, or click the 
arrowhead picture to scroll the list automatically.

E Select to enable tick marks instead of arrowheads.

F Type or select tick mark size.

A

B

C

D

E

F
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Controlling dimension format  
You can control the way dimension text and arrowheads are placed in relation to the 
dimension lines. Any changes you make affect the current dimension style. The 
image tile on the right side of the Dimension Settings dialog box shows the appear-
ance of dimensions based on the current dimension style settings.       

The program determines whether both dimension text and arrowheads will fit 
between the extension lines by comparing the distance between the extension lines to 
the size of the dimension text, the size of the arrowheads, and the amount of space 
required around dimension text. The program applies the best fit method based on the 
available space. If possible, both the dimension text and arrowheads are placed 
between the extension lines. If both will not fit between the extension lines, you can 
determine how text and arrowheads are placed using the Fit Method settings on the 
Dimension Settings dialog box.     

To format dimensions     

1 Do one of the following:    

• Choose Dimension > Dimension Style.

• On the Dimension toolbar, click the Dimension Style tool ( ).

• Type setdim and then press Enter.    

2 Click the Format tab.

3 Click the Fit option that you want.

4 Click OK. 

NOTE You can also specify how dimension text and arrows are arranged using the 
DIMATFIT system variable. You can specify how dimension text is moved using the 
DIMTMOVE system variable.

  

Text and arrowheads placed 
outside extension lines.

Text placed between extension 
lines and arrowheads outside 
extension lines.

Text placed above 
dimension line with a leader 
connecting the text to the 
dimension line.
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Controlling line settings  
You can control settings affecting dimension lines, extension lines, and center marks. 
Any changes you make affect the current dimension style. The image tile on the right 
side of the Dimension Settings dialog box shows the appearance of the dimensions 
based on the current dimension style settings.       

A Click to place both text and arrowheads inside 
the extension lines when both do not 
automatically fit between them.

B Click to place arrowheads only between 
extension lines and text outside extension lines 
when both do not fit between them.

C Click to fit either text or arrowheads between 
extension lines when both do not fit between 
them.

D Click to automatically determine the best fit 
method.

E Click to place text beside the dimension line with a 
leader when both text and arrowheads do not fit 
between the extension lines.

F Click to place text above the dimension line with a 
leader connecting the text to the dimension line 
when both text and arrowheads do not fit between 
the extension lines.

G Click to place text above the dimension line 
without a leader when both text and arrowheads 
do not fit between the extension lines.

H Type or select the distance around the dimension 
text.

A
B

C
D

E
F
G

H
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To set the color for dimension lines    

1 Do one of the following:     

• Choose Dimension > Dimension Style.

• On the Dimension toolbar, click the Dimension Style tool ( ).

• Type setdim and then press Enter.

2 Click the Lines tab.

3 Under Dimension Lines, click Select Color.

4 In the Color dialog box, click the dimension line color, and then click OK.

5 Click OK.   

Controlling dimension text  
You can control the settings affecting the appearance of dimension text. Any changes 
you make affect the current dimension style. The image tile on the right side of the 
Dimension Settings dialog box shows the appearance of the dimensions based on the 
current dimension style settings.      

A Extend past dimension.

B Baseline offset.

C Offset from origin.

A

B

C
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A Type or select center mark size. Positive values 
create a center mark. Negative values create 
centerlines.

B Type or select the baseline offset distance (the 
distance to offset successive dimension lines when 
creating baseline dimensions) and the offset from 
origin (the distance extension lines are offset from 
their origin points).

C In Dimensions, type or select the distance that 
extension lines extend beyond dimension lines. In 
Obliques, type or select the distance that 
dimension lines extend beyond extension lines.  

D Select the dimension lineweight and the dimension 
line color.

E Select the extension lineweight and the extension 
line color.

F Select to prevent the creation of the first and 
second dimension lines.

G Select to prevent the creation of the first and 
second extension lines.

H Select to prevent the creation of dimension lines 
outside extension lines.

I Select to draw dimension lines between extension 
lines when text and arrows are placed outside 
extension lines.

A

B

C

D

F

E

G
H
I

Text between extension lines aligned  
horizontally.

Text between extension lines 
aligned with dimension line.
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To align dimension text with the dimension line    

1 Do one of the following:     

• Choose Dimension > Dimension Style.

• On the Dimension toolbar, click the Dimension Style tool ( ).

• Type setdim and then press Enter.     

2 Click the Text tab.     

3 Select the Align Inside Text With Dimension Line check box.

4 Click OK.   

A Click to select the text style used for dimension 
text.

B Type or select the text height, measured in 
drawing units.

C Type a prefix or suffix to be appended to 
dimension text.

D Click to display the AViCAD Explorer, Text Styles 
element.

E Click to select the dimension text color.

F Select to align text placed between the extension 
lines with the dimension line.

G Select to align text placed outside the extension 
lines with the dimension line.

H Select to force text between the extension lines.

I Type or select the vertical text offset distance.

J Click to select the horizontal or vertical justification 
of dimension text.

K Formats integers in superscript after the specified 
number of decimal places.

A

B

C

D
E
F
G
H
I

J

K
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Controlling dimension units  
You can determine the appearance and format of the primary and alternate dimension 
units. The image tile on the right side of the Dimension Settings dialog box shows the 
appearance of the dimensions based on the current dimension style settings.     

  

To round off dimensions        

1 Do one of the following:     

• Choose Dimension > Dimension Style.

• On the Dimension toolbar, click the Dimension Style tool ( ).

• Type setdim and then press Enter.    

2 Click the Units tab.

3 In the Round Linear Distances To field, type or select the nearest value to which 
you want to round off dimensions.

4 Click OK. 

NOTE You can also specify units for linear dimensions using the DIMLUNIT system 
variable. You can specify fraction formats using the DIMFRAC system variable.

  

Round off distance set to .0100 
(original dimension before 
rounding).

Round off distance set to 0.2500.           Round off distance set to 1.0000.
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A Select the linear dimension format.

B Type or select the number of decimal places you 
want displayed in linear dimension text.

C Enter the marker symbol used for decimals.

D Type or select the nearest value to which you 
want to round off linear distances.

E Select to prevent the inclusion of leading zeros or 
the inclusion of feet in dimension text when the 
dimension is less than one foot.

F Select to prevent the inclusion of trailing zeros or 
the inclusion of inches in dimension text when the 
number of inches is zero.

G Select the angular dimension format.

H Type or select the number of decimal places you 
want displayed for angular dimension text. Select 
whether to suppress leading or trailing zeros.

I Type or select the scale factor applied to all 
dimensions.

J Type or select the linear scale factor applied to all 
lengths measured by dimensioning commands.

A
B

C

D

E
F

G
H

I

J
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Adding geometric tolerances    

Geometric tolerances indicate the maximum allowable variations in the geometry 
defined by a drawing. AViCAD draws geometric tolerances using a feature control 
frame, which is a rectangle divided into compartments.    

Each feature control frame consists of at least two compartments. The first compart-
ment contains a geometric tolerance symbol that indicates the geometric characteris-
tic to which the tolerance is applied, such as location, orientation, or form. For 
example, a form tolerance may indicate the flatness or roundness of a surface. The 
geometric tolerance symbols and their characteristics are shown in the following 
table.                                                                   

The second compartment contains the tolerance value. When appropriate, the toler-
ance value is preceded by a diameter symbol and followed by a material condition 
symbol. The material conditions apply to features that can vary in size. The material 
condition symbols and their meanings are shown in the following table. 

Geometric tolerance symbols

Symbol Characteristic Type

Position Location

 Concentricity or coaxiality Location

 Symmetry Location

 Parallelism Orientation

 Perpendicularity Orientation

 Angularity Orientation

 Cylindricity Form

 Flatness Form

 Circularity or roundness Form

 Straightness Form

 Profile of a surface Profile

 Profile of a line Profile

 Circular runout Runout

 Total runout Runout
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The tolerance value can then be followed by primary, secondary, and tertiary datum 
reference letters, along with the material conditions of each datum. Datum reference 
letters are generally used as reference tolerances to one of up to three perpendicular 
planes from which a measurement is made, although datum reference letters can also 
indicate an exact point or axis.       

When two tolerances apply to the same geometry, you can also add a composite toler-
ance consisting of a primary tolerance value followed by a secondary tolerance value. 
To make a tolerance even more specific, it can also contain a projected tolerance con-
sisting of a height value followed by a projected tolerance symbol. For example, you 
can use a projected tolerance to indicate the perpendicularity of an embedded part.       

To add a geometric tolerance

1 Do one of the following:     

• Choose Dimension > Tolerance.

• On the Dimension toolbar, click the Tolerance tool ( ).

• Type tolerance and then press Enter.    

2 To display the geometric tolerance symbols, on the first line, click the Sym box.

3 Click to select a geometric tolerance symbol.

4 Under Tolerance 1, click the Dia box to add a diameter symbol.

5 In the field, type the first tolerance value.

Material conditions

Symbol Definition

At maximum material condition (MMC), a feature contains the maximum amount of 
material stated in the limits.

At least material condition (LMC), a feature contains the minimum amount of 
material stated in the limits.

Regardless of feature size (RFS) indicates that the feature can be any size within 
the stated limits.

A Geometric characteristic symbol.

B Diameter symbol.

C Tolerance value.

D Material condition symbol.

E Datum reference.

A B C D E
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6 To display the material condition symbols, click the M.C. box.

7 Click to select a material condition.

8 Under Tolerance 2, repeat steps 4 through 7 to add a secondary tolerance value, if 
appropriate.

9 Under Datum 1, type the primary datum reference letter.    

10 To display the material condition symbols, click the M.C. box.

11 Click to select a material condition.

12 Repeat steps 9 through 11 to add secondary and tertiary datum, if appropriate.

13 In the second row, repeat steps 2 through 12 to add composite tolerances, if 
appropriate.

14 In the Height box, type a projected tolerance zone height value, if appropriate.

15 To insert a projected tolerance zone symbol, click the Projected Tolerance Zone 
box, if appropriate.

16 Click OK.

17 In the drawing, specify the location of the feature frame. 

A Use this row to include composite tolerances.

B Type a projected tolerance height value.

C Type a datum identifier.

D Click to include a projected tolerance symbol.

E Click to select the material condition symbol for tertiary 
data.

F Type the tertiary datum reference letter.

G Click to select the material condition symbol for 
secondary datum.

H Type the secondary datum reference letter.

I Click to select the material condition symbol for primary 
datum.

J Type the primary datum reference letter.

K Click to select the material condition symbol for the 
second tolerance value.

L Type the second tolerance value.

M Click to include a diameter symbol for the second 
tolerance value.

N Click to select the material condition symbol for the first 
tolerance value.

O Type the first tolerance value.

P Click to include a diameter symbol for the first tolerance 
value.

Q Click to select a geometric tolerance symbol.

A

B

C

D

EFGHIJKLMNOPQ
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Controlling dimension tolerance   
You can create dimensions as either tolerance or limits dimensions. When creating a 
tolerance dimension, you can control the upper and lower tolerance limits as well as 
the number of decimal places of the dimension text. The image tile on the right side 
of the Dimension Settings dialog box shows the appearance of tolerance and limits 
dimensions based on the current dimension style settings.    

To create a tolerance dimension

1 Do one of the following:

• Choose Dimension > Dimension Style.

• On the Dimension toolbar, click the Dimension Style tool ( ).

• Type setdim and then press Enter.

2 Click the Tolerance tab.

3 Select the Append Dimension Tolerances check box.

4 Type or select the lower tolerance limit.

5 Type or select the upper tolerance limit.

6 Click OK.

7 Insert the dimension. 

Tolerance dimension. Limits dimension.
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Controlling alternate dimension units   
You can include alternate dimensions in addition to the primary dimension text. You 
can also determine the appearance and format of the alternate dimensions, including 
the scale factor applied to generate alternate dimensions. The image tile on the right 
side of the Dimension Settings dialog box shows the appearance of the dimensions 
based on the current dimension style settings.    

A Select to insert dimensions as upper and lower 
tolerance limits.

B Select to include plus and minus tolerance values 
with the dimension text.

C Type or select the minimum tolerance or lower limit 
value.

D Type or select the maximum tolerance or upper 
limit value.

E Type or select the number of decimal places 
displayed in limits or tolerance dimensions.

F Select to prevent the inclusion of leading zeros or 
the inclusion of feet in dimension limits when the 
dimension is less than one foot.

G Select to prevent the inclusion of trailing zeros or 
the inclusion of inches in dimension limits when the 
number of inches is zero.

A
B

C

D

E

F
G
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To create an alternate dimension

1 Do one of the following:

• Choose Dimension > Dimension Style.

• On the Dimension toolbar, click the Dimension Style tool ( ).

• Type setdim and then press Enter.

2 Click the Alternate Units tab.

3 Select the Enable Alternate Units check box.

4 Type or select the scale factor.

5 In the Suffix field, type a suffix to be appended to the alternate dimension.

6 Click OK.

7 Insert the dimension.

Alternate dimension created using a scale factor of 25.4, with an appended suffix.
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A Select to include alternate dimensions.

B Select to prevent the inclusion of leading zeros or 
the inclusion of feet in alternate dimensions when 
the dimension is less than one foot.

C Select to prevent the inclusion of trailing zeros or 
the inclusion of inches in alternate dimensions 
when the number of inches is zero.

D Type or select the number of decimal places 
displayed in alternate dimensions.

E Type or select the scale factor applied to 
measured dimensions to generate the alternate 
dimensions.

F Click to select the format for alternate 
dimensions.

G Type a prefix to be appended to alternate 
dimensions.

H Type a suffix to be appended to alternate 
dimensions.

I Type or select the number of decimal places 
displayed in limits or tolerances included as part of 
alternate dimensions.

J Select to prevent the inclusion of leading zeros or 
the inclusion of feet in limits or tolerances included 
as part of alternate dimensions.

K Select to prevent the inclusion of trailing zeros or 
the inclusion of inches in limits or tolerances 
included as part of alternate dimensions. 

A
B
C

D

E

F

G

H

I
J
K
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13

Working with blocks, attributes, and 
external references

Blocks, attributes, and external references provide mechanisms for managing entities 
in your drawings and for including additional information with the standard drawing 
entities. With blocks, you can combine numerous entities into a single entity, and 
then reuse it, inserting multiple copies. With attributes, you can associate text, such as 
part numbers or prices, with blocks, and then extract the text-attribute information to 
a separate file, such as a database, for further analysis. With external references, you 
can link separate reference drawing files to a drawing to combine information without 
adding the contents of the reference drawings to the current drawing. If you make 
changes to the referenced file, all references are updated automatically.

This chapter explains how to:

• Create, insert, and redefine blocks.

• Create, edit, and insert attributes.

• Extract attribute data to a separate file.

• Attach and work with external references.

Topics in this chapter

Working with blocks .......................................................................................... 356

Working with attributes ..................................................................................... 364

Working with external references...................................................................... 375
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Working with blocks    

Usually, blocks are several entities combined into one that you can insert into a draw-
ing and manipulate as a single entity. A block can consist of visible entities such as 
lines, arcs, and circles, as well as visible or invisible data called attributes. Blocks are 
stored as part of the drawing file.        

Blocks can help you better organize your work, quickly create and revise drawings, 
and reduce drawing file size. Using blocks, you can create a library of frequently used 
symbols. Then you can insert a symbol as a block rather than redraw the symbol from 
scratch.    

After you create a block from multiple entities, you save it once, which also saves 
disk space. You insert only multiple references to a single block definition. You can 
change the block definition to quickly revise a drawing, and then update all instances 
of the block.    

If you insert a block that contains entities originally drawn on layer 0 and assigned 
color and linetype BYLAYER, it is placed on the current layer and assumes the color 
and linetype of that layer. If you insert a block that contains entities originally drawn 
on other layers or with explicitly specified colors or linetypes, the block retains the 
original settings.    

If you insert a block that contains entities originally assigned color and linetype 
BYBLOCK, and the block itself has the color and linetype BYLAYER, those entities 
adopt the color and linetype of the layer onto which they are inserted. If the block is 
assigned an explicit color or linetype, such as red or dashed, those entities adopt those 
qualities.    

A procedure called nesting occurs when you include other blocks in a new block that 
you are creating. Nesting is useful when you want to combine and include small com-
ponents, such as nuts and bolts, into a larger assembly and you need to insert multiple 
instances of that assembly into an even larger drawing.    

Creating blocks 
The tools and commands for creating blocks appear on the Draw toolbar and the 
Draw > Block menu, respectively, when you set the program to the Advanced experi-
ence level. You can also use the AViCAD Explorer to create blocks.    

You can create blocks in two ways:

• By saving a block for use within the current drawing only.        

• By saving the block as a separate drawing file that you can insert into other draw-
ings.

When you create a block, you specify its name, its insertion point, and the entities that 
compose the block. The insertion point is the base point for the block and serves as 
the reference point when you later insert the block into a drawing.    
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To create a block for use within a current drawing

Advanced experience level    

1 Do one of the following:

• Choose Draw > Block > Make.

• On the Draw toolbar, click the Create Block tool ( ).

• Type block and then press Enter.

2 In the displayed dialog specify the base point by executing one of the following 
procedures:

• Click on the Pick point button ( ).

• Specify the coordinates in the boxes X, Y, Z.

3 Click on the Select objects button  ( ).

4 Select the object that will be part of the block and press Enter.

5 Choose one of the following options:

• Retain Define the block but leave unchanged in the drawing the objects that 
compose it.

• Convert to block Coverts the objects that define it in block.

• Delete Create the block and delete the objects that have been used for its 
definition.

6 In the list box Name do one of the following:

• Select the block to be redefined from the list. 

• Digit a name for the block to be made.

7 Click OK button.

A Specify the block name.

B Pick or type  the base point coordinates.

C Number of items selected for the block creation.

D Specify if retain, convert or delete the selected 
entities for the block creation.

E Clic to select the entities for the block creation.

A

B

C

D

E
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ATTENTION If it’s specified the name of a block that has been already assigned, it’s 
requested if the intention is to redefine the block. If the answer is positive, the defini-
tion of the existing block gets replaced with the new one, updating all the occurrences 
inserted in the drawing. Otherwise gets back to the mask to specify a new name.

You can create a block as a separate drawing file that you can insert into other drawings.

To save a block as a separate drawing file    

Advanced experience level    

1 Do one of the following:

• Choose Draw > Block > Save Block To Disk.

• Type wblock and then press Enter.

2 Select the Location File.

3 Choose one of the following:

• Block This option saves one existing block entity to a separate drawing file. 
Select the name of the block.

• Entire Drawing This option immediately saves the entire drawing to a 
separate drawing file.

• Objects This option saves those entities you select to a separate drawing file. 
Specify the base point for the block and select the entities for the block with pick 
buttons, and then press Enter. You can choose:  Retain, Convert to Block or 
Delete from Drawing option to mantain, convert or delete the entities selected 
in the drawing.

4 If you have select Objects option in the Name field, type the name of the drawing 
file you want to create.

5 Confirm with Ok button.
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Inserting blocks   
You can insert blocks and other drawings into the current drawing. When you insert a 
block, it is treated as a single entity. When you insert a drawing, it is added to the cur-
rent drawing as a block. You can then insert multiple instances of the block without 
reloading the original drawing file. If you change the original drawing file, those 
changes have no effect on the current drawing unless you redefine the block by rein-
serting the changed drawing.      

You can also insert blocks from another drawing into the current drawing, using the 
AViCAD Explorer. Both drawings must be open at the same time to do this. (See 
Chapter 8, “Working with the AViCAD Explorer”)   

When you insert a block or drawing, you must specify the insertion point, scale, and 
rotation angle. The block’s insertion point is the reference point specified when you 
created the block. When you insert a drawing as a block, the program takes the speci-
fied insertion point as the block insertion point. You can change the insertion point, 
however, by first opening the original drawing and redefining the block.      

A Pick button for Base Point. B Pick button to select Objects.

A B
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To insert a block    

1 Display the Insert Block dialog box by doing one of the following:    

• Choose Insert > Block.

• On the Draw or Insert toolbar, click the Insert Block tool ( ).

• Type ddinsert and then press Enter.

2 In the Insert Block dialog box, under Insert, click Block Name.

3 In the Block Name box, select the name of the block you want to insert.

4 Click Insert.

5 Specify the insertion point for the block.

6 Specify the x, y, and z scale factors and the rotation angle, or press Enter to accept 
the default values.

To insert an entire drawing into the current drawing

1 Do one of the following:     

• Choose Insert > Block.

• On the Draw or Insert toolbar, click the Insert Block tool ( ).

• Type ddinsert and then press Enter.

2 In the Insert Block dialog box, under Insert, click From File.

3 Type the path and the drawing file name, or click Browse to specify the file from 
the Insert Drawing dialog box, and click Open.

4 Click Insert.

5 Specify the insertion point for the block.

6 Specify the x, y, and z scale factors and the rotation angle, or press Enter to accept 
the default values.

NOTE You can specify the insertion point, scale factors, and rotation angle in the 
Insert Block dialog box before inserting the block. You can also control whether the 
block is exploded back into its original component entities after insertion. Under 
Positioning, clear the Position Block When Inserting check box, and specify the 
appropriate coordinates. If you want to explode the block immediately, select the 
Explode Upon Insertion check box.        
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Redefining blocks    
You can redefine all instances of a block within the current drawing. To redefine a 
block that was created in the current drawing, you create a new block using the same 
name. You can update all the blocks in the current drawing by redefining the block. If 
the block was inserted from a separate drawing file that was subsequently updated, 
reinsert that block to update all other instances in the current drawing.    

To redefine a block in the current drawing

Advanced experience level    

1 Do one of the following:

• Choose Draw > Block > Make...

• On the Draw toolbar, click the Create Block tool ( ).

• Type block and then press Enter.

A Click and then enter the path and drawing file 
name to insert the entire drawing file as a block.

B Click to position the block when inserting.

C Specify the insertion point, scale factors, and 
rotation angle before you insert the block (available 
only when Position Block When Inserting is 
cleared).

D Click to explode the block on insertion. 

E Specify columns, column spacing, rows, and row 
spacing.

F Click to insert the block.

G Click to select the block insertion point in the 
drawing before inserting the block (available only 
when the Position Block When Inserting check box 
is cleared).

A

B

C

D

E

F

G
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2 Select from the list Name the block you want to redefine.

3 Specify the insertion point for the block.

4 Select the entities for the block, and then press Enter.

5 In the prompt box, choose OK to redefine the block.

The block is immediately redefined.

Exploding blocks
You can explode an inserted block to its original component entities. When you 
explode a block, only that single instance of the block is affected. The original block 
definition remains in the drawing, and you can still insert additional copies of the 
original block. If you explode a block that contains attributes, the attributes are lost, 
but the original attribute definitions remain.    

Exploding dissociates component entities to their next simplest level of complexity; 
blocks or polylines in a block become blocks or polylines again.

To explode a block

1 Do one of the following:

• Choose Modify > Explode.

• On the Modify toolbar, click the Explode tool ( ).

• Type explode and then press Enter.

2 Select the block.

3 Press Enter.

In-place block edit
In the previous AViCAD versions to modify and therefore replace all the occurrences 
inserted in a block drawing, it was needed to explode it, make the changes, and make 
it up again with the same name to redefine it.

Now it’s possible to modify the block definition directly in the current drawing using 
the options of local modification.

Using the option of local modification, it’s possible to modify it staying in the visual 
contest of the current drawing. 

At the modification time a toolbar is displayed: Refedit. Using the toolbar buttons, 
it’s possible to add or remove objects of the working group and delete or save the 
modifications made to the reference.

The group of the objects extracted from the block, is displayed as usual, while all the 
other objects, included the ones of the current drawing, and are displayed with less 
intensity.
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During the local modification of a block it’s possible to add or remove objects from 
the working group. If a new object is created during the local modification of a refer-
ence, that object is almost always automatically added to the working group. The 
objects that are not added to the working group are displayed in the drawing with a 
reduced intensity.

To modify a local block

1 Do one of the following:

• Choose Tools > In-place Block Edit > Edit Reference and then select the block.

• Double click on the block to modify.

• Type refedit and press Enter key, then select the block.

2 Modify the working group objects then click on the icon Save changes ( ). 
The objects of the working group will be saved in the block and the occurrences of 
the same drawing will be updated.

To add objects to a block

1 Do one of the following:

• Choose Tools > In-place Block Edit > Edit Reference and then select the block.

• Double click on the block to modify.

• Type refedit and press Enter key, then select the block.

2 Do one of the following:

• If the objects to be added don’t exist yet it’s enough to create them. They will 
be display with the same intensity of the ones that are part of the working group.

• Instead, if the objects are present in the drawing but displayed with less intensity 
compared to the ones that are part of the working group , click on the icon Add 
objects ( ), select the objects to be added and press Enter.

3 Click on the icon Save changes ( ). 
The block occurrences in the drawing will be updated.

To remove the object from a block

1 Do one of the following:

• Choose Tools > In-place Block Edit > Edit Reference and then select the block.

• Double click on the block to modify.

• Type refedit and press Enter key, then select the block.

2 Do one of the following:

• If the objects must be removed from the block definition but not from the 
position in which they are in the local block occurrence that gets changed, click 
on the icon Remove objects ( ), select the objects to be removed and press 
Enter.
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• If the objects have to be completely removed from the block definition and from 
the drawing, select the objects and press Canc.

3 Click on the icon Save changes ( ). 
The block occurrences in the drawing will be updated.

To delete the block local change

1 Do one of the following:

• Choose Tools > In-place Block Edit > Edit Reference and then select the block.

• Double click on the block to modify.

• Type refedit and press Enter key, then select the block.

2 Modifying the objects of the working group.

3 Click on the icon Discard changes ( ).

Working with attributes    

An attribute is a particular entity that you can save as part of a block definition. 
Attributes consist of text-based data. You can use attributes to track such things as 
part numbers and prices. Attributes have either fixed or variable values. When you 
insert a block containing attributes, the program adds the fixed values to the drawing 
along with the block, and you are prompted to supply any variable values.        

After you insert blocks containing attributes, you can extract the attribute information 
to a separate file and then use that information in a spreadsheet or database to produce 
a parts list or bill of materials. You can also use attribute information to track the 
number of times a particular block is inserted into a drawing.    

Attributes can be visible or hidden. Hidden attributes are neither displayed nor plot-
ted, but the information is still stored in the drawing and written to a file when you 
extract it.        

Defining attributes    
You add an attribute to a drawing by first defining it and then saving it as part of a 
block definition. To define an attribute, you specify the characteristics of the 
attribute, including its name, prompt, and default value; the location and text format-
ting; and optional modes (hidden, fixed, validate, and predefined).        
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To define an attribute          

Advanced experience level

1 Do one of the following:

• Choose Draw > Block > Attributes.

• Choose Insert > Define Attributes.

• Type ddattdef and then press Enter.

2 In the Define Attribute dialog box, type the name, prompt, and default value.

3 Under Insert Coordinates, specify the location of the attribute, or click Select to 
select a point in the drawing.

4 Under Attribute Flags, select the optional attribute modes.

5 Under Text, specify the text characteristics.

6 To add the attribute to the drawing, do one of the following:

• Click Define to add the attribute and keep the dialog box active so you can 
define another attribute.

• Click Define And Exit to add the attribute and end the command.
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A Type the name you want to assign to the attribute.         

B Enter the identifying prompt information displayed 
when you insert a block containing the attribute.

C Enter the default or constant value. For variable 
attributes, the default value is replaced by the 
actual value when you later insert a block 
containing the attribute.

D Specify the x-, y-, and z-coordinates for the 
attribute insertion point.

E Select to create a hidden attribute.

F Select to create a fixed-value attribute.

G Select to create an attribute whose value must be 
validated when you later insert a block containing 
the attribute.    

H Select to create an attribute whose value is 
defined and not requested when you later insert a 
block containing the attribute, but that you can edit 
after the block is inserted. 

I Click to add the attribute and keep the dialog 
box active so you can define another attribute.

J Click to add the attribute and end the 
command.

K Specify the text rotation angle, or click to 
specify the rotation angle by selecting two 
points in the drawing.    

L Specify the text height, or click to specify the 
height by selecting two points in the drawing.

M Choose the text justification.

N Choose the text style from those styles already 
defined in the drawing.

O Click to specify the attribute insertion point by 
selecting a point in the drawing.

A
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Editing attribute definitions    
You can edit an attribute definition before you associate it with a block and before it 
is saved as part of a block definition.         

To edit an attribute definition           

Advanced experience level

1 Do one of the following:

• Choose Modify > Object > Text.

• On the Text toolbar, click the Edit Text tool ( ).

• Type ddedit and then press Enter.

2 Select the attribute definition text to edit.

3 Modify the attribute name, prompt string, default value, and other attribute defini-
tion characteristics.

4 Click OK.  

A Modify the name assigned to the attribute.    

B Modify the prompt that displays when you insert 
the attribute into the drawing.

C Modify the identifying prompt information 
displayed when you insert a block containing the 
attribute.

D Modify the attribute insertion point.

E Modify the attribute text style and appearance.

F Modify the attribute insertion flags to create 
hidden, fixed-value, validated, or defined 
attributes.

A
B

C

D

E

F
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Attaching attributes to blocks
You can attach attributes to a block after you define it and select it as one of the enti-
ties to include. Include the attributes when the program prompts you for the entities to 
include in the selection set for a block. After the attribute is incorporated into a block, 
the program prompts you each time you insert the block, so you can specify different 
values for the attributes each time you insert it into a new drawing.    

Editing attributes attached to blocks
You can edit the attribute values of a block that has been inserted into a drawing.           

To edit an attribute attached to a block     

Advanced experience level

1 Do one of the following:

• Choose Modify > Object > Attribute > Single.

• Type ddatte and then press Enter.

2 Select the block to edit.

The Edit Block Attributes dialog box displays all the attributes attached to the 
block you select.

3 Edit the attribute values as necessary.

4 Click OK. 
    

A Identifies the name of the block.

B Displays the names of all 
attributes attached to the block.

C Click to select attribute.

D Type the new value for the 
selected attribute.

E Click to update the attribute 
values and exit.

F Displays the value of each 
attribute attached to the block.

G Displays the prompt for each 
attribute attached to the block.

A
B

C

D

E

F

G
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Extracting attribute information    
You can extract attribute information from a drawing and save it to a separate text file 
for use with a database program. You can save the file in any of the following for-
mats:      

• Comma Delimited Format (CDF) Contains one line for each instance of a block, 
with individual attribute fields separated by commas. Character string fields are 
enclosed with single quotation marks. You must specify a template file when 
extracting to a CDF file.       

• Space Delimited Format (SDF) Contains one line for each instance of a block. 
Each attribute field has a fixed length; there are no separators or character string 
delimiters. You must specify a template file when extracting to a SDF file.       

• Drawing Exchange Format (DXF) Creates a subset of a standard DXF file (a *.dxx 
file) containing all the information about each block, including the insertion 
points, rotation angles, and attribute values. No template file is required.       

Before extracting attributes to a CDF or SDF file, you must create a template file. The 
template file is an ASCII text file that specifies the attribute data fields to be written 
in the extract file. Each line of the template file specifies one attribute field. 
AViCAD® recognizes 15 different fields, which contain elements such as the block 
name, the x-, y-, and z-coordinates of its insertion point, the layer on which it is 
inserted, and so on. You can include any of these fields. The template file must 
include at least one attribute name.        

Each line in the template file must start with the field name. Block name and inser-
tion-point values must begin with BL:. The next nonblank character must be either a 
C (indicating a character string field) or an N (indicating a numeric field). This char-
acter is then followed by three digits indicating the width of the field (in characters). 
The final three digits indicate the number of decimal places (for numeric fields). In 
the case of character fields, the last three digits must be zeros (000). A typical tem-
plate file is similar to the one shown here:             
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To create a template file

1 Create a template file using any ASCII text editor (such as Microsoft Notepad or 
Microsoft WordPad) or a word-processing program such as Microsoft Word.

2 Include the necessary fields in the template file.

3 Save the template file in ASCII text format.

To extract attribute information 

1 Do one of the following:

• Choose Tools > Extract Attributes.

• Type ddattext and then press Enter.

2 Click Select, specify the entities from which to extract attributes, and then press 
Enter.

3 Specify the format of the extracted file.

4 For CDF and SDF formats, specify the template file.

5 Specify the extract output file. 

6 Click Extract.

A Field name.

B Block name. Block names must 
begin with BL:.

C Insertion point. Insertion-point 
values must begin with BL:.

D Attribute tags.

E Number of decimal places for 
numeric fields or 000 for 
character fields.

F Field width for character or 
numeric fields.

G C for character fields; N for 
numeric fields.

A

B

C

D

E
F
G
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Extract data from attributes
You can extract information from the blocks with attributes in the current drawing. 
The information is used to create a data extraction table saved in an external file

To extract data from attributes

1 Do one of the following: 

• Select Tools > Data Extraction…

• Type EATTEXT and then press Enter.

A Click to select blocks in the drawing containing 
attributes you want to extract.

B Click to specify the format of the extracted file.

C Specify the template file for CDF and SDF 
extracts.

D Specify the extract output file.

E Click to extract attributes.

F Click to specify the output file using a file dialog 
box.

G Click to specify the template file using a file 
dialog box.

H Indicates the number of blocks with attributes 
selected for extraction.

A

B

C

D

E

F

G

H
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2 The data extraction process starts with the Drawing and template selection dialog 
box.

• Block selection: select Current drawing if you want to extract information from 
all the blocks in the current drawing or Select objects if you want to specify 
blocks to extract information from.

• Template selection: a template contains the block and attribute selection data 
saved in a file .blk. 
No Template: creates a new data extraction.  
Use Template: uses the settings previously saved in an attribute extraction 
template file (BLK). As you move through the command masks, each page is 
already filled in with the settings coming from the template file. You can change 
these settings.

3 Press Next >  to pass on to the Attribute Selection mask.
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4 Select blocks and attributes that contain information you want to extract.

• Blocks: displays the list of blocks in the current drawing or those previously 
selected. 
Block name: check the box near the block name to display its attributes in the 
Attributes for block list. Block Alias Name You can provide an alias for the 
block name. Aliases are used to issue commands by entering one or two letters 
rather than the entire command name. 
Number: displays the number of instances of blocks in the current drawing. 

• Attributes for block: displays the list of attributes for the selected blocks. 
Attribute: the box near the attribute name is checked to extract information 
from a selected block. If you don’t want to extract information click on the box 
to remove the tick mark. 
Attribute Value: displays the value for each selected attribute. 
Alias: you can provide an alias for attributes.

• Check all: check all the blocks or attributes to extract information from.

• Uncheck all: Remove the check from all the blocks and attributes.

5 Press Next > to pass on to the Output View mask that displays a preview of the 
attributes extracted. The list shows all the attributes selected for the data extrac-
tion.
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• The Block name column displays all the selected block names. The Count 
column shows the number of instances of each block with the same values. The 
following columns display names of attributes, rows display values.

• Copy Data To Clipboard: copies into the clipboard all the information or only 
selected one. 

6 Press Next > to pass on to Export final mask. 

• Output file: In Select output file type specifies a file format for the data 
extraction. The available file formats are a comma-separated file format (CSV) 
and a tab-separated file format (TXT). In Enter a valid file name choose a file 
name to save the information from the data extraction. Press Browse to select a 
folder.
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• Template file: a data extraction file can be also used as a template to perform the 
same type of extraction in a different drawing. Press Save Template to store the 
current settings in a template file. The data extraction file is created when you 
press Finish in the Export Dialog Window

Working with external references           

You can link entire drawings to the current drawing as external references. Unlike 
inserting a drawing as a block, in which you add all the entities from the separate 
drawing into the current drawing, external references attach a pointer to the external 
file. The entities in the external reference appear in the current drawing, but the enti-
ties themselves are not added to the drawing. Thus, attaching an external reference 
does not significantly increase the size of the current drawing file.        

External references provide additional capabilities not available when you insert a 
drawing as a block. When you insert a drawing as a block, the entities are stored in 
the drawing. Any changes you make to the original drawing are not reflected in the 
drawing in which you inserted it. When you attach an external reference, however, 
any changes you make to the original drawing file are reflected in the drawings that 
reference it. These changes appear automatically each time you open the drawing 
containing the external reference. If you know that the original drawing was modi-
fied, you can reload the external reference anytime you’re working on the drawing.    

External references are useful for assembling master drawings from component draw-
ings. Use external references to coordinate your work with others in a group. External 
references help reduce drawing file size and ensure that you are always working with 
the most recent version of a drawing. However, if you send or receive drawings that 
contain external references, it is important to include with the master drawing all of 
the external references attached to it. When you open a drawing that contains external 
references, the source external reference files must be accessible for the external ref-
erences to display in the drawing. 

The Xref Manager helps you easily attach and work with external references.



376   C H A P T E R  1 3

Attaching external references
Attaching a separate drawing to the current one creates an external reference. The 
external reference appears in the drawing as a block definition, but the drawing enti-
ties are linked rather than added to the current drawing. If you modify the linked 
drawing, the current drawing that contains the external reference is updated automati-
cally when you open it, or you can reload the external reference manually so it 
reflects the latest version of the external reference.            

When you attach an external reference, its layers, linetypes, text styles, and other ele-
ments are not added to the current drawing. Rather, these elements are also linked 
from the referenced file. 

A Click to display a detailed list or hierarchical tree. 

B Select an external reference to modify its 
attachment.

C Type or click Browse to specify the external 
reference location.

D Type or click Browse to specify other search 
directories where external references may be 
located.

E Click to open the source drawing for the external 
reference.

F Click to make the external reference a 
permanent part of the drawing.

G Click to remove the external reference, but 
keep elements and path information for easy 
reloading.

H Click to update with changes from the external 
reference.

I Click to completely remove the external 
reference.

J Click to link a drawing.
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There are two ways you can attach an external reference:

• An attachment is an inserted drawing that contains a link to the original file. 
Attachments can themselves contain other, nested reference files. When you 
attach an external reference, any nested references contained in the file also appear 
in the current drawing.  

• An overlay is an inserted drawing that contains a link to the original file. Overlays 
allow you to lay a drawing on top of another drawing, similar to the way you work 
manually with transparencies. When a drawing that contains overlaid external ref-
erences is itself attached or overlaid as an external reference in another drawing, 
the overlays do not appear as part of the external reference. Use overlaying when 
you want to see reference geometry in a drawing but you do not need to include 
that geometry in drawings that will be used by others (nested external references).         

You can attach as many copies of an external reference file as you want. Each copy 
can have a different position, scale, and rotation angle.      

To attach an external reference           

1 Do one of the following:

• Choose Insert > Xref Manager.

• On the Reference toolbar, click the External Reference tool ( ).

• Type xrm and then press Enter.

2 Click Attach. 

3 Specify the drawing file to attach as an external reference, and then click Open.

4 In Reference Type, choose how you want to insert the drawing:

• Attachment – inserts a copy of the drawing and includes any other drawings that 
are externally referenced within the referenced drawing.

• Overlay – lays a copy of a drawing over your original drawing; it does not 
include any nested external references from the externally referenced drawing. 

5 Make any additional selections.

6 Click OK.

7 If you marked Specify On-Screen for any items, follow the prompts to attach the 
external reference.
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Viewing the list of external references
You can view a list of the external references that are linked to the current drawing 
two different ways using the Xref Manager:    

• List View displays the external references in a list, which allows you to sort the list 
of references by name, status, size, type, date, or saved path.

• Tree View displays a hierarchical representation of the external references and the 
relationships between them. The tree view shows the level of nesting relationships 
of the attached external references.

To view a list of external references

1 Do one of the following:     

• Choose Insert > Xref Manager.

• On the Reference toolbar, click the External Reference tool ( ).

• Type xrm and then press Enter.

2 Click List View ( ) or Tree View ( ).

A Displays the external reference to attach, or 
select one from the list. 

B Select to save the folder location of the 
referenced drawing. If not selected, the 
referenced drawing must be located in the same 
folder as the current drawing.

C Click Attachment to link a drawing, including any 
of its own external references. Click Overlay to 
link a drawing, omitting any of its own nested 
external references.

D Choose to specify the insertion point in the 
drawing, or enter x-, y-, and z-coordinates.

E Choose to specify the scale in the drawing, or 
enter x-, y-, and z-scale factors.

F Choose to specify the rotation angle in the 
drawing, or enter a rotation angle.

G Click to locate and select a different external 
reference.
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Opening external references
From the Xref Manager you can quickly open the source drawing for any external 
reference. This is especially helpful if you are working with nested external refer-
ences, which you cannot bind or detach. From the Xref Manager, open the source 
drawing, make changes, and then save and close the source drawing. When the Xref 
Manager displays again, simply reload the external reference.

To open an external reference

1 Do one of the following:     

• Choose Insert > Xref Manager.

• On the Reference toolbar, click the External Reference tool ( ).

• Type xrm and then press Enter.

2 Select the external reference to open.

3 Click Open.

Removing external references 
Removing external references from the current drawing is easy with the Xref Man-
ager. You can unload an external reference, which keeps some information about the 
external reference in the current drawing for easy reloading later, or you can detach 
the external reference entirely.  

When you unload an external reference, you remove it from the current drawing. 
However, its elements, such as layers and linetypes, remain in the drawing and it is 
still listed in the Xref Manager. By detaching an external reference you remove it and 
all of its elements from the current drawing, and it is no longer listed in the Xref Man-
ager.

To unload an external reference

1 Do one of the following:     

• Choose Insert > Xref Manager.

• On the Reference toolbar, click the External Reference tool ( ).

• Type xrm and then press Enter.

2 Select the external reference to unload.

3 Click Unload.

To detach an external reference

1 Do one of the following:     

• Choose Insert > Xref Manager.

• On the Reference toolbar, click the External Reference tool ( ).

• Type xrm and then press Enter.

2 Select the external reference to detach.

3 Click Detach.
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NOTE Only the external references that are attached directly to the current drawing 
can be detached; nested external references cannot be detached.

Reloading external references
When you open or print a drawing, any external references in the drawing are updated 
automatically. If a drawing is already open and a referenced drawing is modified, you 
can update the current drawing manually to display the latest version of the refer-
enced drawing.     

You may also want to reload an external reference that has been unloaded tempo-
rarily.

To reload an external reference

1 Do one of the following:     

• Choose Insert > Xref Manager.

• On the Reference toolbar, click the External Reference tool ( ).

• Type xrm and then press Enter.

2 Select the external reference to reload.

3 Click Reload.

Changing the path for external references
If the file associated with an external reference is moved to a different directory or 
renamed, the program displays a message indicating that it cannot load the external 
reference. You can re-establish the link to the file by doing any of the following:

• Change the path for the external reference.          

• Specify additional directories for AViCAD to search. This is especially helpful if 
you have several external references that have moved to a new directory.

To change the path for a single external reference

1 Do one of the following:     

• Choose Insert > Xref Manager.

• On the Reference toolbar, click the External Reference tool ( ).

• Type xrm and then press Enter.

2 Select the external reference whose path you want to change.

3 In Xref Path, do one of the following:

• Enter a new filename or location. 

• Click Browse to locate and select the referenced drawing.

AViCAD reloads the specified external reference automatically.
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NOTE You cannot recursively reference a drawing from the same original drawing.

To change the search paths for all external references in the drawing

1 Do one of the following:     

• Choose Insert > Xref Manager.

• On the Reference toolbar, click the External Reference tool ( ).

• Type xrm and then press Enter.

2 In Additional Xref Search Paths, do one of the following:

• Enter a new directory and its path. Separate multiple paths with a semicolon, for 
example, c:\My Drawings;d:\My Drawings\Backup.

• Click Browse to locate and select a directory. 

AViCAD searches the specified directories; any found external references are 
reloaded automatically.

Binding external references to drawings
External references are not part of the drawing. Rather, they are links to an externally 
referenced file. To provide a copy of a drawing containing external references to 
someone else, you must also provide all the external reference files. In addition, the 
person receiving the drawings must either re-create the same paths you used when 
linking the external references or change the paths for the external references.            

To provide a copy of a drawing that contains external references, it is often easier to 
first bind the external references to the drawing. Binding the external references 
makes them a permanent part of the drawing, which is similar to inserting a separate 
drawing as a block.

You can bind external references that are attached directly to the current drawing; you 
cannot bind nested external references.

To bind an existing external reference to a drawing

1 Do one of the following: 

• Choose Insert > Xref Manager.

• On the Reference toolbar, click the External Reference tool ( ).

• Type xrm and then press Enter.

2 Select the external reference to bind.

3 Click Bind. 

4 Choose one of the following:

• Bind Binds the external reference and creates a unique name for each named 
entity, such as a layer or block, that is located in the external reference. For 
example, a layer named Electric in the external reference will be named 
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Xref$0$Electric in the current drawing. If the current drawing already has a 
layer or block with the same name, the name is changed incrementally, for 
example, Xref$1$Electric.

• Insert Binds the external reference, but does not change the names of any named 
entities in the external reference. For example, a layer named Electric in the 
external reference will have the same name, Electric, in the current drawing. If 
the current drawing has a layer or block with the same name, the named entity 
in the external reference takes on the properties of the named entity in the 
current drawing.

5 Click OK.

Clipping external references 
When you attach a drawing as an external reference, all of the referenced drawing 
displays in the current drawing. However, after you attach an external reference, you 
can define a clipping boundary that determines which portion of the referenced draw-
ing is visible or hidden.

You can edit, move, or copy clipped external references the same way you modify 
unclipped external references. The boundary moves with the reference. If an external 
reference contains nested clipped external references, they also appear clipped in the 
drawing. 

TIP In addition to clipping external references, you can also partially hide blocks 
using clipping boundaries.
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Adding a clipping boundary
When you create a clipping boundary, it affects only the display of the referenced 
drawing; it does not affect the original referenced drawing or any referenced geome-
try. The portion of the external reference within the clipping boundary is visible and 
the remainder of the external reference becomes hidden.

To define a rectangular clipping boundary

1 Do one of the following:

• Choose Modify > Clip Xref.

• On the Reference toolbar, click the External Reference Clip tool ( ).

• Type xclip and then press Enter.

2 Select the external references to clip. If desired, you can also select blocks.

3 Press Enter.

4 Press Enter to create a new clipping boundary.

5 If prompted, press Enter to delete any existing boundaries.

6 Choose Rectangular.

7 Define the first corner of the clipping rectangle.

8 Define the second corner of the clipping rectangle.

The selected external references are clipped by the rectangle.

 Example of an external reference clipped using a clipping boundary. 
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TIP You can first select all external references, right-click the selection, and then 
select Xref Clip from the shortcut menu.

To define a clipping boundary using a polyline

1 Draw a polyline where you want to clip external references.

2 Do one of the following:

• Choose Modify > Clip Xref.

• On the Reference toolbar, click the External Reference Clip tool ( ).

• Type xclip and then press Enter.

3 Select the external references to clip. If desired, you can also select blocks.

4 Press Enter.

5 Press Enter to create a new clipping boundary.

6 If prompted, press Enter to delete any existing boundaries.

7 Choose Select Polyline.

8 Select the polyline to use as clipping boundary.

Turning clipping boundaries on and off
You can turn xref clipping on or off. When a clipping boundary is turned off, the 
boundary does not display and the entire external reference is visible, provided that 
the geometry is on a layer that is on and thawed. When a clipping boundary is turned 
off, it still exists and can be turned on. However, deleting a clipping boundary is per-
manent.  

To turn clipping boundaries on and off

1 Do one of the following:

• Choose Modify > Clip Xref.

• On the Reference toolbar, click the External Reference Clip tool ( ).

• Type xclip and then press Enter.

2 Select the desired external references.

3 Press Enter.

4 To turn off clipping boundaries, choose Off. To turn on existing clipping bound-
aries, choose On.

5 Press Enter. 

If you are turning off a clipping boundary, click the clipped portion of the external 
reference to view the previously hidden portion of the referenced drawing.

TIP When the XCLIPFRAME system variable is on (set to 1), you can select and 
print the clipping boundary frame.
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Deleting a clipping boundary
If you no longer need a clipping boundary for an external reference, you can delete it.

To delete a clipping boundary

1 Do one of the following:

• Choose Modify > Clip Xref.

• On the Reference toolbar, click the External Reference Clip tool ( ).

• Type xclip and then press Enter.

2 Select the desired external references.

3 Press Enter.

4 Choose Delete, and then press Enter.

5 Click the clipped portion of the external reference. 

The previously hidden portion of the referenced drawing displays.    
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Printing drawings

You can print a copy of your drawing exactly as you created it, or you can add 
formatting and specify print controls to change how your drawing looks when it is 
printed.

Sometimes you may require multiple printed drawings, each with a different look or 
layout. For example, you may need one printed drawing for a client presentation, 
along with several other variations for production contractors. For each type of 
printed drawing that you require, you can create a layout that defines its 
characteristics, including scale, area to print, print style tables, and more.

This section explains how to:

• Start printing right away.

• Set up a drawing to print multiple layouts from paper space on a Layout tab.

• Define how you want your drawing to look when it is printed.

• Print or plot your drawing.

• Print a PDF or JPG file.

• Print with hidden lines.

Topics in this chapter

Getting started printing......................................................................................388

Defining layouts for printing...............................................................................388

Customizing print options..................................................................................400

Printing or plotting your drawing........................................................................418

Print a PDF or JPG file......................................................................................421

Print a Viewport with hidden lines or shaded mode ..........................................422
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Getting started printing

When you create a drawing, you do most of your work on the Model tab. At any time 
you can print your drawing to see how it looks on paper. It’s easy to get started 
printing, and then later create layouts and custom print settings to enhance your 
printed output.

To start printing

1 From the Model tab, do one of the following:

• Choose File > Plot.

• On the Standard toolbar, click the Plot tool ( ).

• Type print and then press Enter.

2 Click Print.

There are many options that you can set before printing, such as the scale of the 
drawing, print area, print style tables, and more. For details, see “Customizing print 
options” on page 400 in this chapter. 

NOTE Type qprint and then press Enter to print the current viewport. The Print dia-
log box is bypassed and the drawing is sent directly to the selected printer.

Defining layouts for printing

You can print your drawing directly from the Model tab where you created it, or you 
can create custom layouts for printing on Layout tabs. 

When printing from the Model tab, you can print your drawing exactly the way it 
appears, or you can modify the drawing before printing by adding dimensions, a 
legend, or a title block.

You typically use the Layout tabs for printing if you require multiple print layouts. 
You may also want to use a Layout tab for printing even if you want your drawing 
printed only one way. For example, if you want to include large amounts of text on 
your printed drawing, you can add the text to a Layout tab so it does not clutter your 
drawing while you work on the Model tab.

Understanding layouts
When you create a drawing, you do most of your work on the Model tab. Each 
drawing that you create can contain numerous layouts that simulate the paper on 
which you will print a copy of the drawing. Each of these layouts is created on a 
Layout tab.
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You can prepare a separate layout for each way you want to print your drawing. The 
layout allows you to organize different views to control which portion of your 
drawing prints and at what scale. 

Before you print, you can also include additional entities and layout settings that 
control how your drawing prints. Additional items only appear on the Layout tab, not 
on the Model tab. For example, a layout can contain dimensions, title blocks, legends, 
or keynotes that print with your model, but do not clutter the screen when you work 
with your model on the Model tab.

Use these general steps to prepare your drawing for printing multiple layouts:

1 On the Model tab, create your drawing.

2 Create a new layout. You can use an existing Layout1 or Layout2 tab, or you can 
create a new Layout tab. For details about creating a new layout, see “Creating a 
new layout” on page 393 in this chapter. 

3 Create at least one layout viewport on the Layout tab. Use each viewport to help 
control which portion of the drawing prints and at what scale. For details, see 
“Working with layout viewports” on page 395 in this chapter. 

4 Include any additional items that may be required for the specific layout, such as 
dimensions, a legend, or a title block.

5 Specify additional settings for the layout, such as the scale of the drawing, print 
area, print style tables, and more. For details, see “Customizing print options” on 
page 400 in this chapter. 

6 Print or plot your drawing. For more details, see “Printing or plotting your draw-
ing” on page 418 in this chapter. 

Understanding paper space and model space
When you start a drawing session, your initial working area is called model space. 
Model space is an area in which you create two-dimensional and three-dimensional 
entities based on either the World Coordinate System (WCS) or a user coordinate 
system (UCS). You view and work in model space while using the Model tab.

Your view of this area is a single viewport that fills the screen. You can create 
additional views on the Model tab, called viewports, which can show the same or 
different two-dimensional or three-dimensional views, all of which are displayed in a 
tiled manner. You can work in only one of these viewports at a time on the Model tab, 
and you can print only the current viewport. Selecting the layout tab you can view a 
paper representation in the specified paper size. The paper preview in layouts allow to 
get a better idea of the print result positioning.                    
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AViCAD provides an additional work area, called paper space. The contents of paper 
space represent the paper layout of your drawing. In this work area, you can create 
and arrange different views of your model similar to the way you arrange detail 
drawings or orthogonal views of a model on a sheet of paper. You can also add 
dimensions, keynotes, annotations, borders, title blocks, and other print-related 
entities in paper space, which reduces clutter when you work with your model in 
model space. Besides the paper size you can see a shadow at the foot and on the right 
that serves to distinguish the paper from the background. You can see a rectangular 
dashed line on the page that indicates the printable area: all the objects drawn outside 
of this area are cut and not printed. The printable area dimensions  are determined by 
the printer drivers of the selected output device. 
Creating a new layout one viewport is automatically generated by default where you 
can see objects drawn in the model space.              

You view and work in paper space while using a Layout tab. Each view, or layout 
viewport, that you create in paper space provides a window of your drawing in model 
space. You can create one layout viewport or several. You can place layout viewports 
anywhere on the screen; their edges can be touching or not; and you can print them all 
at the same time. 

NOTE:  It is possible to set the colour of the paper in the Options dialog box in the 
Display tab. 

  Model space with two viewports.



P R I N T I N G  D R A W I N G S    391

You do not need to use paper space to print your drawing, but it offers several 
advantages: 

• Print the same drawing with different print settings that you save with each layout, 
for example, printer configuration files, print style tables, lineweight settings, 
drawing scale, and more.

• Add print-related entities that are not essential to the model itself, such as key-
notes or annotations, to reduce clutter when you work with your model in model 
space on the Model tab.

• For a single layout, create multiple layout viewports that print the model at differ-
ent views and scales.      

Viewing drawings in paper space and model space
When you work in paper space on a Layout tab, you can still view your drawing in 
model space. First you need to create a layout viewport in paper space; this allows 
you to view your model space entities from paper space. 

Within a layout viewport you can modify and snap to model space entities while 
working in model space and even snap to model space entities from paper space. 
Snapping to model space entities from paper space allows you to accurately dimen-
sion model space entities in paper space. And although it is generally more conve-
nient to modify entities on the Model tab, there are often times when it is convenient 
to make modifications from a layout viewport on a Layout tab.

Zooming or panning the drawing in model space or paper space affects the entire 
drawing, unless you use multiple windows or viewports. Additionally, if you are 
working from paper space, you can lock the layout viewport so the viewport scale and 
view center do not change while panning and zooming in the layout viewport.

   Paper space with layout viewports.
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To view a drawing in model space on the Model tab       

Do one of the following:

• Click the Model tab.

• Right-click the Model/Paper Space toggle in the status bar, and then choose 
Model.

To view a drawing in paper space on a Layout tab   

Do one of the following:    

• Click one of the Layout tabs. 

• Type layout and then press Enter. In the prompt box, choose Set. Type a name for 
the layout you want to make current, and then press Enter.

• Click the Model/Paper Space toggle in the status bar. For example, double-click 
“Model” or “M:Tab Name” in the status bar to switch to paper space.

• While using a Layout tab, type pspace and then press Enter. 

• While using a Layout tab, double-click outside of the layout viewport.

The first time you switch to a Layout tab, your drawing seems to disappear. This is 
normal. You must create at least one layout viewport to see your model. For details, 
see “Working with layout viewports” on page 395 in this chapter.         

To view a drawing in model space on a Layout tab       

Do one of the following:

• Click the desired Layout tab, and then create and view a layout viewport. For more 
details, see “Working with layout viewports” on page 395 in this chapter. 

• Click the Model/Paper Space toggle in the status bar. For example, double-click 
“P:Tab Name” in the status bar to switch to model space on the current Layout tab.

• Type mspace and then press Enter.

• While using a Layout tab, double-click inside of the layout viewport.

Displaying the Model and Layout tabs
The Model and Layout tabs can be hidden, if desired. You may want to hide the tabs 
if you only work on the Model tab or if you use the command bar and status bar to 
switch between tabs.      

To turn the Model and Layout tabs display on or off

Choose Tools > Options > Display tab, and choose Show Tabs.
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Creating a new layout
In AViCAD, you can create multiple layouts for a single drawing. Each layout 
represents a sheet of paper. For each layout you can specify the print area, print 
styles, print scale, lineweight scale, pen mappings, and add viewports, dimensions, a 
title block, and other geometry specific to the layout. The entities you add to a layout 
in paper space do not appear in model space.

Each layout requires at least one layout viewport. This viewport displays the 
drawing’s model space entities. 

When you create a new drawing, the drawing automatically contains two default 
layouts: Layout1 and Layout2. You can start by using one of the default layouts, you 
can create your own, or your can create a new layout from another template (.dwt) 
file, drawing (.dwg) file, or drawing interchange (.dxf) file. 

Each drawing can contain up to 255 layouts.

To create a new layout using the Layout1 or Layout2 tab

1 Click the Layout1 or Layout2 tab.

2 Set up at least one layout viewport. For details, see “Working with layout view-
ports” on page 395 in this chapter. 

3 If desired, rename the layout. For details, see “To rename a layout” on page 394 in 
this chapter. 

To create a new layout using a new Layout tab 

1 Do one of the following:

• Choose Insert > Layout > New Layout.

• On the Layouts toolbar, click the New Layout tool ( ).

• Type layout, press Enter, and choose New. 

2 Type a unique name for your layout and then press Enter.

The name can be up to 255 characters in length and can contain letters, numbers, 
the dollar sign ($), hyphen (-), and underscore (_), or any combination.

3 Set up at least one layout viewport. For details, see “Working with layout view-
ports” on page 395 in this chapter. 

To create a new layout from an existing file

1 Do one of the following:

• Choose Insert > Layout > Layout from Template.

• On the Layouts toolbar, click the Layout from Template tool ( ).

• Type layout, press Enter, and choose Template. 

2 Select the desired template, drawing, or drawing interchange file that contains the 
layout you want, and then click Open.
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3 Select the layout(s), and then click OK. You can choose multiple layouts by hold-
ing down Ctrl while selecting layout names.

Reusing layouts from other files
Save time by re-using layouts that you have already created. Within the same 
drawing, you may want to make a copy of a layout that contains most of the settings 
you want, and then make changes to the new copy. If you created layouts that you 
want to use again when you create new drawings, you can save the layouts as a 
drawing template. 

To make a copy of a layout

1 Type layout and then press Enter. 

2 In the prompt box, choose Copy.

3 Type the name of the layout you want to copy, and then press Enter.

4 Type a name for the new layout, and then press Enter.

To save a layout as a drawing template

1 Type layout and then press Enter.    

2 In the prompt box, choose Save.

3 Type the name of the layout that you want to save, and then press Enter.

4 Specify the file name and location for the template, and then click Save.

After you save a layout as a template, you can use the template when you create new 
drawings. You can also import the template’s layouts into another drawing.

Managing layouts in a drawing
You can rename layouts, delete layouts, and view a list of all layouts available in a 
drawing. You can also change the order in which the Layout tabs appear; the Model 
tab is always stationary. 

If you want to rename or delete a layout when the Layout tabs are hidden, you can 
type layout to make your changes.

To rename a layout 

1 Right-click the Layout tab to rename.

2 Type a new name for the layout.

3 Click OK.

The name can be up to 255 characters in length and can contain letters, numbers, the 
dollar sign ($), hyphen (-), and underscore (_), or any combination.

To delete a layout 

1 Right-click the Layout tab to delete.

2 Click OK to confirm the deletion.
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NOTE You cannot delete the Model tab or the last remaining Layout tab. To delete 
all geometry from the Model tab or a Layout tab, first select all geometry and then 
use the Erase command.

To reorder the Layout tabs  

1 Right-click the Layout tab you want to move.

2 Do one of the following:

• Choose Move Right, and then choose a new location.

• Choose Move Left, and then choose a new location.

To view a list of all layouts 

1 Type layout and then press Enter.

2 In the prompt box, choose ? to list all layouts.

3 Type s or press Enter to scroll through the layouts.

Working with layout viewports
When you begin working in a drawing on the Model tab, it consists of a single view 
of your model. You may have created additional views by dividing the drawing space 
into multiple windows; each window is a separate viewport on the Model tab.       

On a Layout tab, you must create at least one layout viewport to see your model. 
However, you can create multiple layout viewports that display unique views of your 
model located in model space. Each layout viewport functions as a window into your 
model space drawing — with each window looking different from the next. You can 
customize the view center, scale, layer visibility, and contents of each layout view-
port. Each layout viewport is created as a separate entity that you can move, copy, or 
delete.     

Click any layout viewport to make it the current viewport, and then add or modify 
model space entities in that viewport, even while snapping to model space entities 
from paper space. Any changes you make in one layout viewport are immediately 
visible in the other viewports (if the other layout viewports are displaying that portion 
of the drawing). Zooming or panning in the current viewport affects only that 
viewport.                    

This section focusses on working with layout viewports in paper space on a Layout 
tab. For additional information about viewports in model space, see “Dividing the 
current window into multiple views” on page 145. 

Creating layout viewports
The first time you switch to a Layout tab, all of your model space entities disappear. 
You must create at least one layout viewport on the Layout tab to see your work. 

You can create layout viewports anywhere inside the drawing area. You can control 
the number of viewports created and the arrangement of the viewports.            
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To create layout viewports

1 Do one of the following:

• Choose View > Viewports.

• On the Layouts toolbar, click the  Viewports tool ( ).

• Type mview and then press Enter.

2 In the prompt box, choose Fit To View, Create 2 Viewports, Create 3 Viewports, 
or Create 4 Viewports, or specify two opposing corners to create a custom view-
port.

3 In the prompt box, choose the viewport orientation.

4 Do one of the following:

• To arrange the viewports to fill the current graphic area, in the prompt box, 
choose Fit To Screen.

• To fit the viewports within a bounding rectangle, specify the corners of a 
rectangle.

TIP When you create a layout viewport, the layout viewport border is created on the 
current layer. You can make layout viewport borders invisible by creating a new 
layer before you create layout viewports and then turning off that layer after you cre-
ate the layout viewports. To select a layout viewport’s borders, you must turn that 
layer back on before you can rearrange or modify the layout viewport.

You can create a single layout viewport, or you can divide the graphic area into two viewports arranged 
vertically (A) or horizontally (B); three viewports arranged left (C), right (D), above (E),  
below (F), vertically (G), or horizontally (H); or four viewports (I).

A B C

D E F

G H I
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Poligonal viewport
Using the Object option you can select some closed entities, such as a circle or a 
closed polyline created in paper space, and trasform it in a layout viewport

To create a poligonal viewport

1 Draw a circle or a closed polyline 

2 Do one of the following: 

• Choose View > Viewports> Object. 

• Type mview, press Enter and choose Object option. 

• On the Viewports toolbar, click Object tool  ( ).

3 Select the drawn object. 

Viewing and scaling layout viewports
If you have created numerous layout viewports, your system performance may be 
affected. If necessary, you can turn a layout viewport on or off. Turning off a layout 
viewport does not delete the viewport or its contents; it simply turns off its display. 

You can also change how you view items within a layout viewport by specifying a 
scale factor, which changes how large or small model space entities appear within the 
layout viewport. 

To turn layout viewports on or off 

1 Click the desired Layout tab.

2 Do one of the following:

• Choose View > Viewports.

• On the Layouts toolbar, click the Viewports tool ( ).

• Type mview and then press Enter.

3 Choose On or Off.

4 Select the edge of the layout viewport to turn on or off, and then press Enter.

To change the layout viewport scale 

1 Type entprop and then press Enter.

2 Select the edge of the layout viewport. 

3 In Scale, enter the scale at which you want to view model space entities from 
within the layout viewport.

4 Click OK.
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To change the scale of model space entities relative to paper space  

1 Click the Model tab. 

2 Click a viewport to make it current.

3 Choose View > Zoom > Zoom.

• On the Zoom toolbar, click the Zoom Scale tool ( ).

4 Type the zoom scale factor relative to paper space by appending the suffix xp to 
the scale factor, and then press Enter. 

For example, to increase the scale of the entities in the viewport on the Model tab 
to twice the size of paper space units, type 2xp. To decrease the scale to half the 
size of paper space units, type .5xp.

Modifying layout viewports
After you create layout viewports, you can modify them as needed. On the Layout 
tab, you can snap to the viewport borders using entity snaps. You can also copy, 
delete, move, scale, and stretch layout viewports as you would any other drawing 
entity.

Additionally, you can lock a layout viewport so the viewport scale and view center do 
not change in model space while panning or zooming in the layout viewport. If you 
are working on model space entities from a Layout tab, locking the layout viewport 
prevents you from constantly changing the layout viewport scale and view center.

And assigning a UCS to each viewport allows you to quickly switch between layout 
viewports and immediately draw in a different UCS. This can greatly increase pro-
ductivity, especially when creating complex 3D models.

Modifying a layout viewport on a Layout tab does not affect the model space entities 
within the layout viewport.

To modify layout viewport properties

1 Type entprop and then press Enter.

2 Select the edge of the layout viewport you want to modify.

3 Adjust the center point, width, or height of the viewport.

4 In Scale, enter the scale at which you want to view model space entities from 
within the layout viewport.

5 Mark Lock Viewport to lock the viewport scale and view in model space while 
panning or zooming in the layout viewport.

6 Mark UCS per Viewport if you want to use a unique UCS for each layout view-
port.

7 Click OK.

NOTE You can select only layout viewports for modification. If you click a viewport 
on the Model tab, it makes that viewport active, not available for modification.
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Modifying view mode in a layout viewport

It's possible to set a different view mode for every Viewport in the Paper Space.

To modifying view mode in a layout viewport

1 Click the desired Layout tab.

2 Type entprop and then press Enter

3 Select the edge of the layout viewport you want to modify.

4 Select the desired View mode from the Vis. Type list (2D is set by default). 

5 Press Ok to confirm.

A Enter the center point of the layout viewport.

B Enter the width of the layout viewport.

C Enter the height of the layout viewport.

D Enter the scale used for viewing model space 
entities from within the layout viewport.

E Select the visualization type.

F Mark to use a unique UCS for each layout 
viewport.

G Mark to lock the viewport scale and view in model 
space while panning or zooming in the layout 
viewport.

H Click to select the center of the layout viewport in 
the drawing.

A

B

C

D

E

F

G

H
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Customizing print options

Before you print, you can set up many aspects of printing: 

• Specify paper size and paper and drawing orientation.

• Select and configure a printer or plotting device.

• Specify the view and scale of a printed drawing, including which portion of a 
drawing to print, the print scale, and the origin of the print area.

• Choose whether to print and scale lineweights.

• Choose whether to implement print style tables to control colors, pen widths, line-
types, and lineweights.

• Open printer configuration (PCP) files; create and save PCP files.

Setting the paper size and paper and drawing orientation
You can specify a paper size and paper and drawing orientation for all drawings. 

To select the paper size and paper and drawing orientation 

1 Do one of the following:

• Choose File > Print Setup, and then click Device tab. 

• On the Standard toolbar, click the Plot tool ( ), and then click Device tab.

• Type print and press Enter, and then click Device tab.

2 Select the paper size and paper and drawing orientation.

3 Select Save Changes to Layout, and then click Apply to save your changes.

You can also adjust the orientation by printing a drawing upside down on the paper. 
Each layout in your drawing can specify whether to print upside down.      

To print a drawing upside down

1 If necessary, click the desired Layout tab or the Model tab.

2 Do one of the following:

• Choose File > Plot.

• On the Standard toolbar, click the Plot tool ( ).

• Type print and then press Enter.

3 Click the Advanced tab.

4 Select Print Upside Down.

5 Select Save Changes to Layout, and then click Apply to save your changes.
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Selecting a printer or plotter
You can specify a printer or plotter to be used when printing any drawing. You can 
print your drawing on any printer or plotter that is compatible with Windows, 
including raster printers. 

To select a printer or plotter               

1 Do one of the following:

• Choose File > Print Setup, and then click Device tab. 

• On the Standard toolbar, click the Plot tool ( ), and then click Device tab.

• Type print and press Enter, and then click Device tab.

2 From the Printer list, select a printer or plotter.

3 Select Save Changes to Layout, and then click Apply to save your changes.

Setting the scale and view
You can print or plot the entire drawing or a selected portion, depending on which 
options you select in the Print dialog box. You can choose to print what is visible on 
the screen, or you can specify to print an area of the drawing.

A Select the printer.

B Select the paper size.

C Select the paper orientation.

D Select the drawing orientation.

E Type the number of the copies.

F Select to print into file the drawing.

G Click the button to set the advanced features for 
the selected printer.

A

B

C

D
E

F

G
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You can control the position of the drawing on the paper by specifying the origin of 
the print area, the location of the lower left corner of the print area, in relation to the 
lower left corner of the paper. The origin is normally set to 0,0, which places the 
lower left corner of the print area as close to the lower left corner of the paper as the 
printer or plotter will allow. You can specify a different origin.

When you create a drawing, you generally draw entities full-size. When you print the 
drawing, you can specify the scale of the resulting print or let the program adjust the 
size of the drawing to fit the paper. To print the drawing at a specific scale, specify 
the scale as a ratio of drawing units to printed units.

If you are printing from a Layout tab, the scale and view options you specify can be 
different for each layout that you create.

To automatically scale the drawing for printing

1 If necessary, click the desired Layout tab or the Model tab.

2 Do one of the following:

• Choose File > Plot.

• On the Standard toolbar, click the Plot tool ( ).

• Type print and then press Enter.

3 Click the Scale/View tab.

4 To scale the drawing to fit on one printed page, in Print Scale, select Scale to Fit.

5 Select Save Changes to Layout, and then click Apply to save your changes.

To specify the scale factor yourself

1 If necessary, click the desired Layout tab or the Model tab.

2 Do one of the following:

• Choose File > Plot.

• On the Standard toolbar, click the Plot tool ( ).

• Type print and then press Enter.

3 Click the Scale/View tab.

4 In Print Scale, do one of the following:

• Select a pre-defined scale. For example, choose 1:2 if you want 1 printed unit 
(inch or millimeter) to equal 2 drawing units.

• Select Custom, and then under User Defined Scale, type the ratio of printed units 
of measure (inches or millimeters) to drawing units.

5 To specify the printed units of measure, click Inches or Millimeters.

6 Select Save Changes to Layout, and then click Apply to save your changes.
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To specify a portion of the drawing to print 

1 If necessary, click the desired Layout tab or the Model tab.

2 Do one of the following:

• Choose File > Plot.

• On the Standard toolbar, click the Plot tool ( ).

• Type print and then press Enter.

3 Click the Scale/View tab.

4 Under Print Area, click one of the following:

• Current View – prints the view on the screen.

• Saved View – prints the selected saved view.

• Extents – prints the area that contains entities in the drawing.

• Limits – prints to the limits defined for the layout or drawing.

• Window – prints the portion of the drawing contained in the specified window, 
maintaining the aspect ratio of the windowed area to the drawing.

If you clicked Window, you must specify the window. Under Windowed Print 
Area, enter the diagonal x- and y-coordinates of the window, or select the area on 
the screen. 

To print only the area in the window without considering whether there is extra 
space on the screen, select the Print Only Area Within Specified Window check 
box.

5 Under Entities To Print, click one of the following:

• All Entities Within Print Area – prints all drawing entities contained within the 
specified print area.

• Selected Entities Within Print Area – prints only the entities you select from 
within the specified print area. 

6 Select Save Changes to Layout, and then click Apply to save your changes.  

NOTE AViCAD saves your print settings each time you print. To restore the 
AViCAD default print settings, click Reset in the Print dialog box. 
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A Displays either “Model” or the layout name to which 
the print settings apply. 

B Click to select the area of the drawing that you want 
to print.

C Type the x- and y-coordinates of the two opposing 
corners of the rectangular area to print; or, to 
specify coordinates in the drawing window, click 
Select Print Area.

D Select to print the area of the window while ignoring 
the aspect ratio to the remainder of the drawing.

E Click to specify drawing units and paper size in 
millimeters or inches.

F Specify the custom scale for the print area by typing 
the ratio of drawing units to printed inches or printed 
millimeters. (Available only if Custom is selected for 
Print Scale.)

G Select to fit the specified print area to the current 
paper size select a scale ratio, or select to specify 
your own custom scale in User Defined Scale.

H Click to print only selected entities within the 
specified print area.

I Click to print all entities within the specified print 
area.

J Select to save the print settings for the model or 
layout.

K Select to print using the current print settings or 
using the settings from the last time you printed. 

A
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To specify the print  area origin

1 If necessary, click the desired Layout tab or the Model tab.

2 Do one of the following:

• Choose File > Plot.

• On the Standard toolbar, click the Plot tool ( ).

• Type print and then press Enter.

3 Click the Advanced tab.

4 Under Print Offset, do one of the following:

• To center the specified print area on the printed page, select the Center on Page 
check box.

• To specify an origin for the print area, type the x- and y-offset.

5 Select Save Changes to Layout, and then click Apply to save your changes.

Choosing how lineweights print
If entities are assigned lineweights, you can control whether they print with the 
assigned lineweights. If you turn off lineweight printing, entities print with a default 
outline. You can also control whether lineweights print in proportion to the scale you 
set on the Scale/View tab.

Each layout in your drawing can specify whether to print and scale lineweights. 

To set lineweight options    

1 If necessary, click the desired Layout tab or the Model tab.

2 Do one of the following:

• Choose File > Plot. 

• On the Standard toolbar, click the Plot tool ( ).

• Type print and press Enter.

3 Click the Advanced tab.

4 Choose how you want to print lineweights:

• Print Lineweights – prints entities with their assigned lineweights. If not 
selected, entities print with a default outline.

• Scale Lineweights – prints lineweights in proportion to the scale you set on the 
Scale/View tab. If not selected, lineweights print at their assigned size without 
adjustments for the print scale. (A Layout tab must be active to scale 
lineweights.)

5 Select Save Changes to Layout, and then click Apply to save your changes.

NOTE Print styles can also affect how lineweights print. For details, see the next 
section.
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NOTE AViCAD saves your print settings each time you print. To restore the 
AViCAD default print settings, click Reset in the Print dialog box. 

A Displays either “Model” or the layout name to 
which the print settings apply. 

B Select a print style table.

C Click to load print settings from a PCP file.

D Click to save the current configuration as a PCP 
file.

E Select to print the drawing upside down on your 
printer.

F Select to print entities with their assigned 
lineweights.

G Select to print lineweights in proportion to the 
scale you set on the Scale/View tab. (A Layout 
tab must be active.)

H Type x- and y-coordinates to specify the origin of 
the print area.

I Select to center the print area on the page.

J Click to make changes to the selected print style 
table.

K Click to create a new print style table.

L Select to save the print settings for the model or 
layout.

M Select to load print settings from the current 
layout (or model) or the last time you printed. 
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Using print styles
AViCAD uses print styles to change the appearance of your printed drawing without 
modifying the actual entities in your drawing. Assigning print styles allows you to 
customize the color, pen width, linetype, and lineweight that are used to print your 
drawing.  

Print styles help you control what your drawing looks like when it is printed. Rather 
than describe what an entity looks like on your screen, print styles describe what an 
entity will look like when you print it. For example, you can map all yellow entities in 
your drawing to print in blue without modifying the actual entities. You could also 
map all yellow entities to print with whatever lineweight, linetype, or pen width that 
you specify.

Because print styles are saved in print style tables, which are files located on your 
computer, disk, or server, you can reuse them to help eliminate the need to 
reconfigure your print settings each time you print a drawing. For example, you may 
have multiple clients who have their own printing preferences. You can save print 
styles in a named file for each of your clients. You can even share the file with co-
workers, or store the files on a network to ensure that everyone in your office uses the 
same standards.

Understanding print style tables
A print style table is a collection of print styles that allows you to change the 
appearance of your printed drawing without modifying the actual entities in your 
drawing. Each print style table is saved in a file that can be located on your computer, 
disk, or server.  

A drawing can use one type of print style table at a time. There are two types of print 
style tables:

• Color-dependent print style tables (CTB) contain a collection of print styles based on 
each of the 255 index colors available in a drawing. True colors and color books 
are not applicable to color-dependent print style tables. 

• Named print style tables (STB) contain a collection of print styles that you define. 
They can vary regardless of color. 

With color-dependent print style tables, you cannot assign print styles to individual 
entities or layers. To use these print styles, you assign a specific color to an entity or 
layer. When you specify a color-dependent print style table at printing time, the entity 
colors and layer colors map to color-based print styles in the print style table that you 
specify.

With named print style tables, you can assign named print styles to individual entities 
and layers. Entities and layers assigned print styles are printed according to the print 
style table that you specify at printing time. If you specify a print style for a specific 
entity, that print style overrides any print style assigned to the layer on which the 
entity resides. 
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Sometimes a named print style assigned to an entity or layer is not located in the print 
style table that is assigned to a layout or drawing. This can happen if the print style 
has been deleted from the named print style table or if you assign a different named 
print style table to the drawing that does not contain the named print style. In this 
case, the entity is printed using its default properties, which is similar to assigning the 
Normal print style to an entity or layer. If you plan on interchanging named print style 
tables within the same drawing, it’s a good idea to coordinate the tables to use the 
same print style names.

If a new drawing is based on a template, the new drawing uses the same type of print 
style table as the template. If a new drawing is created without a template, the type of 
print style table is specified in the New Drawing Wizard; by default, the new drawing 
uses the print style table type specified in Tools > Options on the Printing tab. Every 
drawing is designed to use print style tables, but you decide whether to implement 
them.  

Comparison of print style table types

Color-dependent print  
style table (CTB) Named print style table (STB)

Description Contains pre-defined print styles 
according to color; there is one print style 
for each of the 255 index colors available 
in the drawing. Entities with the same 
color are printed the same way. 

Contains unique print styles that you 
create. Entities with the same color can 
have different print settings. 

Example All blue entities print with a .5 millimeter 
lineweight.

One entity prints with a .7 millimeter 
lineweight; a second blue prints with a .5 
millimeter lineweight.

Number of 
print styles

255 (fixed). At least one (varies).

Print style 
names

Print style names range from “Color_1” 
to “Color_255”. You cannot rename print 
styles. 

You define new print style names. You 
can rename all print styles except the 
Normal print style.

Add, delete, 
and modify 
print styles

You can modify the existing print styles, 
but you cannot add or delete print styles.

You can add and delete print styles. You 
can modify all print styles except the 
Normal print style, which uses the 
default characteristics of the entity.
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Implementing print style tables
Every drawing is designed to use print style tables, but you decide whether to 
implement them. Even if you use one of the default print style tables available with 
AViCAD, using print style tables requires planning ahead of time to ensure that your 
drawing prints as planned.

For example, a single drawing of a floor plan might require the printing of the 
following drawing sheets:

• Main Floor Plan Walls print with thick, black lines.

• Electrical Plan Walls print with normal gray lines, indicating that they are not the 
focus.

• HVAC Plan Walls print with normal gray lines, indicating that they are not the 
focus.

• Roof Plan Walls print with thin, gray lines and a hidden linetype, indicating that 
they are hidden under the roof in a plan view.

In this example, you can create four named print style tables, each containing a print 
style named “WallPstyle”. Each print style table contains its own settings for  
“WallPstyle” to control how the walls print. Assign WallPstyle to either the wall 
entities or to a wall layer. Then, assign a different named print style table each time 
you print, or create four layouts and assign a different print style table to each layout.

The following table describes, in order, the steps to get you started using both color-
dependent and named print style tables.

Create 
additional 
tables

Yes. Yes.

Assignment Current print style: New entities always 
assigned BYCOLOR.

Print styles: Assigned to colors in the 
print style table.

Print style tables: Assigned to a Layout 
tab or the Model tab.

Current print style: Assigned to new 
entities.

Print styles: Assigned to entities and 
layers.

Print style tables: Assigned to a Layout 
tab or the Model tab.

Legacy file 
support

You can import existing printer 
configuration files (PCP) files into the 
print style table. CTB files are similar to 
PCP files primarily used in previous 
versions of AViCAD. 

Not applicable.

Comparison of print style table types

Color-dependent print  
style table (CTB) Named print style table (STB)
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The following table describes how to further customize how print styles work within 
your drawings.

   Getting started using print style tables

Color-
dependent Named Task Command Where to get details

X X Create a new drawing. Select a drawing 
template that uses the desired print style 
table type or choose it in the New Drawing 
Wizard.

File > New Creating a new drawing, page 34

X X (Optional) Create a new print style table. File > Print Styles Manager Creating new print style tables, 
page 412

X Assign colors to entities and layers that 
correspond with print style table settings.

Modify > Properties
Tools > AViCAD Explorer

Setting the current entity color, 
page 44; Modifying the properties 
of entities, page 231; Setting the 
layer color, page 180

X Set the current print style assigned to new 
entities.

Tools > Drawing Settings > 
Entity Creation tab; status 
bar; printstyle

Setting the current print style, 
page 49

X Assign print styles to entities. Modify > Properties; Entity 
Properties toolbar; printstyle

Modifying the properties of 
entities, page 231

X Use AViCAD Explorer to assign print styles 
to layers.  

Tools > AViCAD Explorer Setting a layer’s print style, page 
182

X X Assign a print style table to the Model tab, 
a layout, or to all layouts in the drawing.

File > Plot > Advanced tab Assigning print style tables, page 
411

X X (Optional) Make changes to the assigned 
print style table.

File > Print Styles Manager
File > Plot > Advanced tab

Modifying print style tables, page 
412

X X Print the drawing. File > Plot Printing or plotting your drawing, 
page 418

Further customizing print style tables

Task Command Where to get details

Copy, rename, or delete print style 
tables.

File > Print Styles Manager Copy, rename, or delete 
print style tables, page 
414

Change a drawing to use another type 
of print style table, for example, change 
a drawing that uses color-dependent 
print style tables to one that uses 
named print style tables. 

convertpstyles Changing a drawing’s 
print style table type, 
page 415
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Assigning print style tables
Select a print style table before printing if you want to change how your drawing 
appears when you print it. Print style tables can modify how colors, pen widths, 
linetypes, and lineweights look when they are printed.

You can assign print style tables globally for all layouts (including the Model tab), or 
individually for the Model tab or a Layout tab. Assigning a print style table to an 
individual layout allows you to further customize the layouts you use to print a 
drawing. 

However, assigning different named print style tables to various layouts may result in 
mismatched print style names; a named print style assigned to an entity or layer may 
not be located in the assigned print style table at print time. In this case, entities are 
printed using their default properties, which is similar to assigning the Normal print 
style to an entity or layer.

To assign print style tables

1 If necessary, click the desired Layout tab, or click the Model tab.

2 Do one of the following:

• Choose File > Plot.

• On the Standard toolbar, click the Plot tool ( ).

• Type print and then press Enter.

3 Click the Advanced tab.

4 Under Print Style Table (Pen Assignments), select a print style table that you cre-
ated or one of the following:

• None – Applies no print style table. Entities print according to their own 
properties.

• Icad – Uses the default print style table and its color assignments.

• Monochrome – Prints all colors as black.  

5 At the prompt, choose Yes to assign the print style table to all layouts in the draw-
ing, including the Model tab, or choose No to assign the print style table only to 
the individual layout listed in Layout Name on the Print dialog box.

Convert a color-dependent print style 
table to a named print style table.

convertctb Converting print style 
tables, page 416

Change the default location where print 
style tables are stored.

Tools > Options > Paths/
Files tab

Changing the options on 
the Paths/Files tab, page 
588

Customize how print styles work with 
new drawings that you create and older 
drawings that you open.

Tools > Options > Printing 
tab

Changing the options on 
the Printing tab, page 598

Further customizing print style tables

Task Command Where to get details
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6 Select Save Changes to Layout, and then click Apply to save your changes.

NOTE When your drawing was first created it was set up to use either color-depen-
dent or named print style tables. For details on converting a drawing to use a differ-
ent type of print style table, see “Understanding print style tables” on page 407 in 
this chapter. 

Creating new print style tables
AViCAD offers several print style tables to help you get started. If you want to 
customize your print output further, you can create your own print style table. You 
can create a new print style table entirely from scratch, based on AViCAD registry 
settings, or by importing a printer configuration file (PCP file).         

To create new print style tables

1 Do one of the following:

• Choose File > Print Styles Manager.

• Type stylesmanager and then press Enter.

2 Double-click Create a Print Style Table.

3 Complete the setup wizard. 

On the last wizard page, you can click Print Style Table Editor to set up the print 
styles for the table. For more details about the Print Style Table Editor options, see 
the next section.

Modifying print style tables
When your drawing was created, it was set up to use color-dependent or named print 
style tables.  

Color-dependent print style tables (.ctb files) You can modify individual print styles 
within the table, but you cannot add, rename, or delete print styles. Color-dependent 
print style tables always have 255 print styles, each named for a specific color. Your 
changes affect all entities and layers assigned that color.  

Named print style tables (.stb files) You can add, modify, rename, and delete individual 
print styles within the table. However, you cannot modify, rename, or delete the 
Normal print style. Your changes affect all entities and layers that are assigned that 
print style name.  

TIP If you can’t remember what type of print style table is assigned to your drawing, 
use the PSTYLEMODE system variable to determine the print style table type.

Each print style within a print style table specifies a color, pen numbers, linetype, and 
lineweight. AViCAD recognizes additional characteristics for compatibility with 
AutoCAD only, including: dither, grayscale, screening, adaptive, line end style, line 
join style, and fill style.        
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When specifying print style characteristics, be sure to consider the limitations of your 
output device.

NOTE It is recommended that you only modify print style tables that you have cre-
ated. If you modify a default print style table that came with AViCAD, you overwrite 
the original information which is then lost.

To modify print style tables

1 Do one of the following:

• Choose File > Print Styles Manager.

• Type stylesmanager and then press Enter.

2 Double-click the print style table you want to modify.

3 Click the General tab, and then do any of the following:

• Enter a new table description.

• Select Apply Global Scale Factor to Non-ISO Linetypes to apply the scale factor 
to non-ISO linetypes used for any print style in the current print style table. This 
also applies to fill patterns, which are not used in AViCAD, but are recognized 
for compatibility with AutoCAD.

• Enter a scale factor to apply to non-ISO linetypes used for any print style in the 
current print style table.

4 Click the Properties tab, and then do any of the following:

• Make format changes to a print style by selecting it in the Print Styles list, then 
make color, pen map, linetype, or lineweight changes for the print style. Your 
changes are saved automatically for the selected print style.

• Add a new print style by clicking Add Style. Enter a new name, and then click 
OK. Select the options for the print style. (Available for named print styles 
only.)

• Rename a print style by selecting it in the Print Styles list. Single-click the print 
style again, and then enter a new name. (Available for named print styles only.)

• Delete a print style by selecting it in the Print Styles list. Click Delete Style. 
(Available for named print styles only.)

5 Click OK.
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Copy, rename, or delete print style tables
Copy, rename, or delete a print style table just as you would any other file on your 
computer. Regardless of which print style table type your drawing uses, you can use 
the Print Style Manager to manage both color-dependent and named print style tables.

To copy, rename, or delete print style tables

1 Do one of the following:

• Choose File > Print Styles Manager.

• Type stylesmanager and then press Enter.

2 Select a print style table. 
Color-dependent print style tables are .ctb files and named print style tables are 
.stb files.

A Select a print style to modify it. 

B Enter a description for the selected print style.

C Click to create a new print style. (Named print 
style tables only.)

D Click to delete the selected print style. (Named 
print style tables only.)

E Click to modify the list of available lineweights for 
the current print style table.

F Click to save the print style table with a new 
name or in a new location.

G Choose a lineweight for the selected print style.

H Choose a linetype for the selected print style.

I Type or scroll to the width of the virtual pen for 
the selected print style (for printers that don’t 
have physical pens, such as laser or inkjet 
printers).

J Type or scroll to the width of the physical pen for 
the selected print style.

K Choose a color for the selected print style.

A
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3 Copy, rename, or delete the print style table just as you would any other file on 
your computer.

Changing a drawing’s print style table type
When your drawing was created, it was set up to use color-dependent print style 
tables (.ctb files) or named print style tables (.stb files). A drawing can use one type 
of print style table at a time. If necessary, after a drawing is created you can convert 
the drawing to use the other type of print style table.     

If you can’t remember what type of print style table is assigned to your drawing, use 
the PSTYLEMODE system variable to determine the print style table type.

To change a drawing to use named print style tables

1 If you want to reuse any of the existing print style information, convert your color-
dependent print style tables to named print style tables. For details, see “To con-
vert a color-dependent print style table to a named print style table” on page 416 in 
this chapter. 

2 Open the drawing that uses color-dependent print style tables (.ctb files).

3 Type convertpstyles, and then press Enter.

4 If you have already converted your individual color-dependent print style tables to 
named tables, click OK in the prompt that displays. 

If you have not converted the tables, click Cancel. First use convertctb to convert 
your color-dependent print style tables to named tables. If you do not, all of the 
print style information you specified in your drawing will be lost. 

5 Select a named print style table (.stb file) that you want to use with the drawing.

6 Click Open.

NOTE If you have not converted a color-dependent print style table to a named print 
style table, you will be warned that the table you have selected does not contain color 
mapping and the drawing cannot be converted.

To change a drawing to use color-dependent print style tables

1 Open the drawing that uses named print style tables (.stb files).

2 Type convertpstyles, and then press Enter.

3 If you are sure you want to convert the drawing and lose all print style assign-
ments, click OK in the prompt that displays. 

If you do not want to lose the print style assignments, click Cancel.

NOTE Converting a drawing to use color-dependent print style tables will remove 
all of the named print style information from entities and layers. However, the named 
print style tables are not deleted from your computer.
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Converting print style tables
You can convert a color-dependent print style table to a named print style table. You 
cannot convert a named print style table to a color-dependent print style table because 
color-dependent tables contain only print styles that are named after the 255 colors to 
which they map.        

Converting a color-dependent print style table to a named print style table can be 
helpful in the following situations:

• You don’t want to create a named print style table from scratch.

• You want to create a named print style table that has the same settings as a color-
dependent print style table, but with some new print styles or other custom set-
tings.

• You want to convert a drawing to use named print style tables and you want to 
reuse most of print styles already defined in a color-dependent print style table.

To convert a color-dependent print style table to a named print style table

1 Type convertctb, and then press Enter.

2 Select the color-dependent print style table (.ctb file) that you want to convert.

3 Click Open.

4 Enter a name for the new named print style table (.stb file).

5 Click Save. 

The print styles in the new table are named Style 1, Style 2, and so on. If want to use 
different print style names, rename the print styles before you assign them to entities 
and layers in your drawing. If you rename the print styles after assigning them, they 
will not match when you print your drawing. For information about renaming print 
styles, see “Modifying print style tables” on page 412 in this chapter. 

Turning off print style tables
When you turn off print style tables, entities print according to their own properties. 
However, all of the print style information is saved so you can easily turn on print 
styles again. Actual print style table files are not deleted, and for drawings that use 
named print style tables, entities and layers retain their assigned print styles.  

To turn off print style tables

1 If necessary, click the desired Layout tab, or click the Model tab.

2 Do one of the following:

• Choose File > Plot.

• On the Standard toolbar, click the Plot tool ( ).

• Type print and then press Enter.

3 Click the Advanced tab.

4 Under Print Style Table (Pen Assignments), select None.
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5 At the prompt, choose Yes to turn off print style tables for all layouts in the draw-
ing, including the Model tab, or choose No to turn off print style tables only for 
the individual layout listed in Layout Name on the Print dialog box.

6 Select Save Changes to Layout, and then click Apply to save your changes.

Reusing print settings
After you set up print settings for a drawing or layout, you can save them and reuse 
them again using printer configuration files. 

Printer configuration files store the printer information you create for specific 
drawings or layouts, which eliminates the need to completely reconfigure your print 
settings each time you print a drawing. Printer configuration files also allow you to 
share and reuse print settings between different drawings and layouts.

AViCAD supports the printer configuration (PCP) file format used by AutoCAD. 
This feature makes it possible to use existing PCP files saved in AutoCAD, as well as 
to save your AViCAD print configuration settings to a PCP format.

The printer configuration files that you specify can be different for each layout that 
you create.

To save print settings in a PCP file 

1 If necessary, click the desired Layout tab or the Model tab.

2 Do one of the following:

• Choose File > Plot.

• On the Standard toolbar, click the Plot tool ( ).

• Type print and then press Enter.

3 Click the Advanced tab.

4 Specify the desired print settings.

5 Under Printer Configuration File, click Save.

6 Name the file, and then click Save.

To assign a PCP file    

1 If necessary, click the desired Layout tab or the Model tab.

2 Do one of the following:

• Choose File > Plot.

• On the Standard toolbar, click the Plot tool ( ).

• Type print and then press Enter.

3 Click the Advanced tab.

4 Under Printer Configuration File, click Open.

5 Locate and select the PCP file, and then click Open.

6 Select Save Changes to Layout, and then click Apply to save your changes.
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PCP files created before AViCAD contain obsolete PenMap/Width settings that you 
can convert to use with print style tables. Import the PCP file to create a new color-
dependent print style table. For details, see “Creating new print style tables” on page 
412 in this chapter.  

TIP It is easy to reuse print settings from the last time you printed. In the Print dia-
log box under Use Settings, choose Previous Print.

Printing or plotting your drawing

After you have configured your drawing and any layouts for printing, you are ready 
to print. If desired, you can preview your page before printing.

Previewing a drawing before printing
Viewing a drawing before printing gives you a preview of what your drawing will 
look like when it is printed. This helps you see if there are any changes you want to 
make before actually printing the drawing.

If you are using print style tables, the preview shows how your drawing will print 
with the assigned print styles. For example, the preview may display different colors 
or lineweights than those used in the drawing because of assigned print styles.

To preview a drawing before printing          

1 If necessary, click the desired Layout tab or the Model tab.

2 Do one of the following:

• Choose File > Plot Preview.

• On the Standard toolbar, click the Plot Preview tool ( ).

• Type ppreview and then press Enter.

3 After checking the preview image, do one of the following:

• To print the drawing, click Print Settings to display the Print dialog box.

• To return to the drawing, click Cancel.
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A Click to zoom in.

B Click to zoom out. If you have zoomed in 
several times, click multiple times to restore 
the entire preview image. 

C Click to display the Print Settings dialog box.

D Click to print the drawing.

E Click to close the preview and return to the 
drawing.

A B C D E
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Printing a drawing    
The Print dialog box is organized by tabs into two functional areas: scaling and 
viewing, and advanced printing options. The print setting options available under 
each tab were described in the previous sections. 

NOTE You cannot print a rendered image directly to a printer. To print a rendered 
image, you must first save the drawing to a different format and then print it from 
another graphics program. For more details, see “Render to File” on page 536. 

To print a drawing

1 If necessary, click the desired Layout tab or the Model tab.

2 Do one of the following:

• Choose File > Plot.

• On the Standard toolbar, click the Plot tool ( ).

• Type print and then press Enter.

3 From the Print dialog box, make any adjustments to the settings.

4 Click Print.

NOTE Instead of using the print settings you saved with your layout, you can select 
Previous Print in the Use Settings list to print according to the settings used the last 
time you printed. If necessary, you can click Reset to restore the AViCAD default 
print settings.

WARNING If occour any printing problems go to the printer manifacturer home page 
and download the latest printer's driver.

WARNING There are some known problem with the Custom paper size setting in the 
Print dialog box for some particular hardware configuration and printer models. To 
avoid this problem, set the paper size from "Printing preferences" from the context 
menu of the selected printer (Start > Control Panel > Printers) before setting the 
printer in AViCAD's Print dialog box
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Print a PDF or JPG file

When installing AViCAD two new virtual printers are added to the system to create a 
PDF or JPG file.

Creating a PDF or JPG File
Creating a PDF or JPG file from a drawing is very simple, like printing on paper.

To create a PDF or JPG File

1 If necessary, click the desired Layout tab or the Model tab.

2 Do one of the following:

• Choose File > Plot.

• On the Standard toolbar, click the Plot tool ( ).

• Type plot and then press Enter.

3 Select Device tab.

4 From Printer list select one of the following:

• AViCAD PDF Printer 2011.

• AViCAD JPG Printer 2011.

5 Select the paper size from the Paper section. To set a custom paper size:

• Click on the  Property button near the printer name.

• Select Custom from the paper size list.

• Specify With and Length.

• Confirm the settings clicking on the Ok button.

6 Select the paper and drawing orientation: Portrait or Landscape.

7 Set the other parameters like paper printing.

8 Press the Print button.

9 Specify the name of the PDF or JPG file in the dialog box shown.
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Print a Viewport with hidden lines or shaded mode

It's possible to print one or some Viewports in the Paper Space with a different view 
mode.

To print a viewport with hidden lines or shaded mode

1 Click the desired Layout tab.

2 Type entprop and then press Enter

3 Select the edge of the layout viewport you want to modify and press Enter.

4 Select the desired View mode from the Vis. Type list (2D is set by default).

5 Press Ok to confirm. 
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.

Proceed with printing. For more details, see “Printing or plotting your drawing” on 
page 418. 
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Drawing in three dimensions

Paper drawings typically represent two-dimensional views of three-dimensional enti-
ties. With AViCAD®, you can create three-dimensional models of three-dimensional 
entities.

This section explains how to:

• View entities in three dimensions.

• Create three-dimensional entities.

• Create Surface.

• Create Solids.

• Edit entities in three-dimensional space.

• Edit three-dimensional solids.

• Display hidden-line and shaded views of three-dimensional entities.

The tools and commands for many of the functions described in this section appear 
on the Surfaces, Solids, Solid Editings toolbar and the Draw, Modify menu, respec-
tively, when you set the program to the Advanced experience level.

Topics in this chapter

Viewing entities in three dimensions .................................................................426

Creating three-dimensional entities...................................................................440

Creating Surfaces..............................................................................................450

Creating Solids..................................................................................................458

Editing in three dimensions ...............................................................................468

Editing three-dimensional solids .......................................................................473

Hiding, shading, and rendering .........................................................................484
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Viewing entities in three dimensions 

You can view a AViCAD drawing from any position in three-dimensional space. 
From any selected viewing position, you can add new entities or modify existing 
enti¬ties. You can also generate hidden-line and shaded views from any viewing 
position. 

Setting the viewing direction 
You view three-dimensional drawings by setting the viewing direction. The viewing 
direction establishes the viewing position, the Cartesian coordinate corresponding to 
the viewpoint looking back at the origin point, the 0,0,0 coordinate. When you view a 
drawing from the default viewpoint (0,0,1), you see a plan view of the drawing. 

You can view a three-dimensional drawing using any of the following methods:

• Rotating the view in real time (3D Orbit)

• Preset Views

• Preset Viewpoints 

• Dynamic View Control

• Plan View

You can change the viewing direction to look at the drawing from a different vantage 
point or to work on a three-dimensional model from a different orientation.

Rotating the view in real time (3D Orbit ) 
AViCAD allows you to rotate the visualisation in real time to view your drawing 
from any angle while in model space. You cannot rotate the view while in paper 
space, but also within the layout windows.

If desired, you can continue the rotation of a view after you release the mouse button. 
Choose Tools > Options to enable continuous motion. For more information, see 
Chapter 20, “Changing the options on the Display tab” 

To rotate the view in real time 

1 Do one of the following:

• Choose View > 3d orbit > Real-Time Sphere.

• On the 3D Orbit toolbar, click the Real-Time Sphere tool ( ).

• Type rtrot and then press Enter.

• Press and hold Ctrl. 

2 Click and drag the left mouse button. The view rotates according to the movement 
of your mouse. 

3 To stop rotating, release the mouse button.
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4 If the view continues to rotate, press Enter or right-click the drawing when fin-
ished.

To modify the viewing direction and the magnification you can use the views short-
cuts:

• Realtime Sphere  : CTRL + Left Click: rotate the view in any direction without 
reference to the planes.

• Realtime along axis : CTRL + Right Click: rotate the view along an axis orthogo-
nal to the view
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• RealTime Zoom In&Out : CTRL + SHIFT + Left Click: mouse up Zoom In, 
Mouse down Zoom Out. 

• RealTime Pan : CTRL + SHIFT + Right Click: move the cursor to pan 

NOTE  While the 3DFORBIT command is active you cannot edit objects.

Preset Views
To quickly set a view, you can choose one of the predefined 3D views. You can select 
predefined standard orthographic views Top, Bottom, Front, Left, Right, and Back or 
SW (southwest) Isometric, SE (southeast) Isometric, NE (northeast) Isometric, and 
NW (northwest) Isometric views. 
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Orthographic views
Orthographic views show objects from points of view that are perpendicular to XY, 
XZ and YZ plans, obtaining Top, Bottom, Front, Left, Right, and Back views.

Draw a cube and a cylinder as shown in the example:  

To set the Top viewing direction 

• Do one of the following:

• Choose View > 3D Views > Top.

• On the View toolbar, click  Top View ( ).

• Type _viewpoint and press Enter, then type 0,0,1 and press Enter. 

To set the Bottom viewing direction 

1 Do one of the following:

• Choose View > 3D Views > Bottom.

• On the View toolbar, click  Bottom View ( ).

• Type _viewpoint and press Enter, then type 0,0,-1 and press Enter.
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To set the Left viewing direction 

1 Do one of the following:

• Choose View > 3D Views > Left.

• On the View toolbar, click  Left View ( ).

• Type _viewpoint and press Enter, then type -1,0,0 and press Enter.

To set the Right viewing direction 

1 Do one of the following:

• Choose View > 3D Views > Right.

• On the View toolbar, click  Right View ( ).

• Type _viewpoint and press Enter, then type 1,0,0 and press Enter. 
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To set the Front viewing direction 

1 Do one of the following:

• Choose View > 3D Views > Front.

• On the View toolbar, click  Front View ( ).

• Type _viewpoint and press Enter, then type 0, -1,0 and press Enter. 

To set the Back viewing direction 

1 Do one of the following:

• Choose View > 3D Views > Back.

• On the View toolbar, click  Back View ( ).

• Type _viewpoint and press Enter, then type 0, 1,0 and press Enter. 

Isometric views
To understand how the isometric views work, look down at the top of a box. If you 
move toward the lower-left corner, you are viewing the box from the SW Isometric 
View. If you move toward the upper-right corner of the box, you are viewing it from 
NE Isometric View
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To set the SW Isometric viewing direction 

1 Do one of the following:

• Choose View > 3D Views > SW Isometric.

• On the View toolbar, click  SW Isometric ( ) .

• Type _viewpoint and press Enter, then type -1,-1,1 and press Enter.

To set the SE Isometric viewing direction 

1 Do one of the following:

• Choose View > 3D Views > SE Isometric.

• On the View toolbar, click  SE Isometric ( ).

• Type _viewpoint and press Enter, then type 1,-1,1 and press Enter.
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To set the NE Isometric viewing direction 

1 Do one of the following:

• Choose View > 3D Views > NE Isometric.

• On the View toolbar, click  NE Isometric ( ).

• Type _viewpoint and press Enter, then type 1,1,1 and press Enter.

To set the NW Isometric viewing direction 

1 Do one of the following:

• Choose View > 3D Views > NW Isometric.

• On the View toolbar, click  NW Isometric ( ).

• Type _viewpoint and press Enter, then type -1,1,1 and press Enter.
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Preset Viewpoints.
To select a preset viewpoint you can also use the Preset Viewpoints dialog box that 
contains preset views buttons formerly explained plus isometric views from under-
neath the XY plane.

To set a new viewing direction    

1 Do one of the following:

• Choose View > Viewpoint Presets.

• On the View toolbar, click the Preset Viewpoints tool ( ).

• Type setvpoint and then press Enter.

2 Click the preset view you want to use. 

A Click to select a non-axis viewpoint.

B Click to select the previous viewpoint.

C Click to select a viewpoint aligned with an axis.

A

B

C
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You can dynamically rotate the viewpoint within the xy plane and relative to the xy 
plane, and you can pan and zoom the drawing. As you change the viewpoint settings, 
the drawing display automatically updates.    

To dynamically set a view direction    

1 Do one of the following:

• Choose View > 3D Views > View Control.

• Type viewctl and then press Enter.

2 Click the appropriate tools to dynamically change the viewpoint.

3 To complete the command, click OK.

You can set the current viewing direction to the plan view of the current user coordi-
nate system (UCS), a previously saved UCS, or the World Coordinate System 
(WCS).

A Indicates the current viewpoint.

B Click to pan the drawing.

C Click to display the Preset Viewpoints dialog box.

D Click to update the drawing display whenever 
you click a tool.

E Click to zoom extents.

F Click to zoom out.

G Click to zoom in.

H Shows the current viewpoint orientation.

I Type or select the rotation angle increment.

J Click to rotate the view about a predefined axis.

A

B

C

D

E

F

G

H

I

J
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To display a plan view of the current drawing

1 Do one of the following:    

• Choose View > 3D Views > Plan View.

• Type plan and then press Enter.

2 In the prompt box, choose one of the following:

• Current displays the plan view of the current UCS.

• UCS displays the plan view of a saved UCS. The program prompts you for the 
name of the UCS.

• World displays the plan view of the WCS.

Dinamic view
Dynamically defines parallel or visual perspective views. Cameras and targets are 
used to dynamically view your three-dimensional drawing. You can specify the view-
ing direction between the camera and the target. The center point of the selected enti-
ties is considered the target.  

To create a dynamic 3D view

1 Do one of the following:

• Select View> dynamic view

• Type dview and then press Enter.

2 Select the objects to be used in the preview. If you select too many items the oper-
ations of draging and updating images  become slow.

3 Select an option to create the view:

In the command Dynamic view you have the following options:

• Camera: Specify a new location for the camera by rotating around the point of 
aim. The magnitude of rotation is determined by two angles: the angle in the XY 
plane and the XY plane. 
The figure shows the effect of camera rotation from the initial position to the right, 
leaving unchanged the angle to the XY plane.
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• Rotation: Set the camera position using the rotation buttons. The buttons above 
set positive rotations, those under, negative. The default value for rotation 
increment is 6 degrees and it can be changed in the Change by spin control.

• Angle in XY plane: Indicates the camera position at a certain degree in the XY 
plane relative to the X axis of the current UCS. Setting the rotation value at 0 
degree you can obtain a view toward the X axis in the origin point direction.

• Angle from XY plane: Indicates the camera position with an angle above or 
under the XY plane. Angled at 90 degrees the camera produces a downward 
view, a -90 degrees angle produces an upward view. Setting the value at 0 
degree, the camera is positioned in the same direction of the XY plane of the 
current UCS.

• Zoom: Extents: Displays the drawing to the greatest possible magnification. 
Zoom In: Doubles the current magnification of the drawing. Zoom Out: 
Reduces the magnification of the drawing by half.

• Target: You can specify a new position for the target (the entities you are view-
ing) by rotating the target around the camera.

A B

A B
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• To twist the view: You can tilt the view of your three-dimensional drawing by 
twisting the view around the line of sight between the camera and the target.  

TIP The twist angle is measured counterclockwise.

• To specify the camera's distance from the target: You can move the camera in 
or out along the line of sight relative to the target. This option turns on perspective 
viewing, that means that objects farther from the camera appear smaller than those 
closer to the camera. A special perspective icon replaces the coordinate system 
icon. You are prompted for the new camera-to-target distance. 
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If the target and camera points are close to each other, or if you specify long-focal-
length lens, you might see very little of your drawing when you specify a new dis-
tance. If you see little or none of your drawing, magnify the drawing without turn-
ing the perspective viewing on with the Zoom option of DVIEW.

• To specify the x,y,z coordinates of the camera and target: Locates the camera 
and target points using the X,Y,Z coordinates. You can use the XYZ point filters. 
A rubber-band line is drawn from the current target position to the crosshairs. You 
are asked for a new target location and a rubber-band line connects the target point 
to the crosshairs to help you place the camera relative to the target. 

• To turn perspective off: Turns off the perspective viewing. To turn on the per-
spective choose the option Distance..

• To remove the visualization of hidden lines: To aid in visualization, you can 
remove all the lines that are hidden behind other surfaces when seen from your 
vantage point. Wire-frame models always appear transparent, because they have 
no surfaces. Surface models appear filled, with surfaces applied to all visible 
sides. 

• To specify the distance to pan: The displacement point indicates the distance you 
want to move the display. 

• To change the magnification: You can change the magnification by increasing or 
decreasing the size of entities in the current viewport. If the perspective is on, the 
Zoom adjusts the camera lens length, which changes the field of view and causes 
more or less of the drawing to be visible. The default lens length is 50mm, simu-
lating what you'd see with a 35mm camera and a 50mm lens. The lens length 
increasing is similar to switching to a telephoto lens. The lens length decreasing 
widens the field of view as with a wide-angle lens. If the perspective is off, the 
Zoom option dynamically increases or decreases the apparent size of objects in the 
current view.  
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Creating three-dimensional entities

AViCAD supports the following types of three-dimensional models:  

• Wire-frame models, which consist of lines and curves that define the edges of a 
three-dimensional entity. You can create a wire-frame model by drawing lines, 
arcs, polylines, and other two-dimensional entities anywhere in three-dimensional 
space. Wire-frame models have no surfaces; they always appear as outlines. 
Because you must individually draw and position each entity that makes up a 
wire-frame model, creating one can be exacting and time-consuming.

• Surface models, which consist of both edges and the surfaces between those 
edges. You can create a surface model by applying elevation and thickness to two-
dimensional planar entities or by using specific three-dimensional entity-creation 
commands. Surface models consist of individual planes forming a faceted, polyg-
onal mesh.

• 3D solids, which are three-dimensional ACIS entities that consist of faces and 
edges. 3D solids appear to have volume and are easier to work with than wire-
frame and surface models. AViCAD full version allow you to create and more 
completely edit 3D solids.

Applying elevation and thickness
By default, the program creates new two-dimensional entities with a zero elevation 
and thickness. The easiest way to create a surface is to change the thickness property 
of an existing two-dimensional entity. 

The elevation of an entity is its z-coordinate position in relation to the xy plane in 
which the entity is drawn. An elevation of 0 indicates that the entity is drawn on the 
xy plane of the current UCS. Positive elevations are above this plane; negative eleva-
tions are below it. 

The thickness of an entity is the distance it is extruded above or below its elevation. A 
positive thickness extrudes the entity upward in the positive z direction of the entity; 
a negative thickness extrudes it downward in the negative z direction. The thickness 
is applied uniformly to the entire entity. You can extrude any two-dimensional entity 
into a three-dimensional entity by changing the thickness of the entity to a nonzero 
value. For example, a circle becomes a cylinder, a line becomes a three-dimensional 
plane, and a rectangle becomes a box.  
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You can create three-dimensional entities using any of the following methods:

• Draw two-dimensional entities in three-dimensional space.    

• Convert two-dimensional planar entities into three-dimensional entities by 
applying elevation and thickness.

• Convert two-dimensional planar entities into three-dimensional entities by 
revolving or extruding.

• Create three-dimensional entities such as boxes, cylinders, cones, domes, spheres, 
and wedges.

NOTE Three-dimensional solids are drawn as true solids with full versions of 
AViCAD that include a license for the ACIS solids modeling system. Three-dimen-
sional solids include the following: box, cone, cylinder, dish, dome, pyramid, sphere, 
torus, and wedge.

You can change the default elevation and thickness values to create new entities with 
an elevation and thickness already applied.

To set the current elevation    

1 Display the current elevation setting by doing one of the following:

• Choose Format > Elevation.

• Type elevation and then press Enter.

2 Specify the New Current Value For Elevation, and then press Enter. 

To set the current thickness    

1 Display the current thickness setting by doing one of the following:

• Choose Format > Thickness.

• Type thickness and then press Enter.

2 Specify the New Current Value For Thickness, and then press Enter.

Two-dimensional entities. Two-dimensional entities with thickness added.
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To set the current elevation and thickness using a dialog box    

1 Display the Drawing Settings dialog box by doing one of the following:

• Choose Tools > Drawing Settings.

• Type settings and then press Enter.

2 Click the 3D Settings tab.

3 In the Change Settings For list, click Surfaces.

4 To change the current thickness, in the Current 3D Thickness box, type a new 
thickness value or click the arrows to select a new thickness.

5 To change the current elevation, in the Current 3D Elevation box, type a new ele-
vation value or click the arrows to select a new elevation.

6 Click OK.
  

A Type or select the current three-
dimensional thickness.

B Type or select the current three-
dimensional elevation.

A

B
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To change the thickness and elevation of an existing entity    

1 Type entprop and then press Enter.

2 Select the entity, and then press Enter.

AViCAD displays the Entity Properties dialog box. The exact appearance of the 
dialog box depends on the type of entity you select.

3 To change the thickness, in the Thickness box, type a new thickness value or click 
the arrows to select the new thickness.

4 To change the elevation, in the Z coordinate box, type a new elevation value or 
click the arrows to select the new elevation.    

5 Click OK.

NOTE When you change the thickness of an entity, you do not change the entity type. 
If you wish to extrude an entity and convert it to a three-dimensional solid, use the 
Extrude command.     

A Type or select the new thickness. B Type or select the new elevation.   

A

B
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Creating three-dimensional faces 
You can create a three-dimensional face, which consists of a section of a plane in 
three-dimensional space. You define a three-dimensional face by specifying the x,y,z 
coordinates of three or more corners. After you specify the fourth point, the program 
continues to prompt you for additional faces by alternating prompts for the third point 
and fourth point to allow you to build a complex three-dimensional entity. Each 
three- or four-sided plane is created as a separate three-dimensional face entity.    

To create a three-dimensional face 

Advanced experience level

1 Do one of the following:

• Choose Draw > Surfaces > 3D Face.

• On the Surfaces toolbar, click the 3D Face tool ( ).

2 Specify the first point of the three-dimensional face.

3 Specify the second, third, and fourth points.

4 Specify the third and fourth points for additional faces. 

5 To complete the command, press Enter.

NOTE Any or all edges of a three-dimensional face can be invisible to allow you to 
more accurately model entities with holes in them. As the program prompts you for 
the corner points, in the prompt box, choose Invisible Edge to make the next edge 
invisible.      

Creating rectangular meshes 
You can create a three-dimensional rectangular mesh consisting of four-sided poly-
gons. You determine the size of the mesh by specifying the number of vertices along 
the primary (M-direction) and secondary (N-direction) mesh axes and then specifying 
the coordinates for each vertex.    

An example of a three-dimensional model created using three-dimensional faces.
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To create a rectangular mesh    

Advanced experience level

1 Do one of the following:

• Choose Draw > Surfaces > 3D Mesh.

• On the Surfaces toolbar, click the 3D Mesh tool ( ).

• Type mesh and then press Enter.

2 Specify the number of vertices along the primary mesh axis.

3 Specify the number of vertices along the secondary mesh axis.

4 Specify the coordinates for each vertex.

Specifying the coordinates for the last vertex completes the mesh and ends the 
command. 

NOTE Although creating rectangular meshes manually can be exacting, they are 
useful for representing complex surfaces such as three-dimensional terrain models. 
The Mesh tool is most useful when combined with scripts or LISP programs that 
mathematically calculate the coordinates of the vertices.      

Creating polyface meshes  
You can create a polygon mesh consisting of faces connecting three or more vertices. 
You first determine the coordinates of each vertex and then define each face by enter-
ing the vertex numbers for all the vertices of that face. As you create each face, you 
can control the visibility and color of each edge and assign each edge to specific lay-
ers.    

An example of a three-dimensional terrain model created using rectangular meshes.
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To create a polyface mesh    

Advanced experience level

1 Do one of the following:  

• Choose Draw > Surfaces > Polymesh.

• Type pface and then press Enter.

2 Specify the coordinates of each vertex.

After each vertex that you specify, the next vertex number is displayed, and you 
are prompted for the coordinates of the vertex. Specify the coordinates, and then 
press Enter. Continue to specify the coordinates for each numbered vertex.

3 To finish specifying vertex coordinates, press Enter.

4 Specify the vertex numbers that define the first face. 

You specify the face by entering the vertex numbers that were defined when you 
specified coordinates in step 2. Each face can be composed of three or more num-
bered vertices.

5 To finish defining the first face, press Enter.

6 Specify the next face by entering its vertex numbers.

7 To complete the command, press Enter.

NOTE To make an edge invisible, type the vertex number as a negative value.    

Creating ruled surface meshes 
You can create a ruled surface, which is a three-dimensional polygon mesh that 
approximates the surface between two existing entities. You select the two entities 
that define the ruled surface. These entities can be arcs, circles, lines, points, or 
polylines.

To create a ruled surface mesh   

Advanced experience level

1 Do one of the following:

• Choose Draw > Surfaces > Ruled Surface.

• On the Surfaces toolbar, click the Ruled Surface tool ( ).

• Type rulesurf and then press Enter.

2 Select the first defining entity.

3 Select the second defining entity.
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.

NOTE To control the density of the mesh, change the values for the Number of M-
Direction Surfaces. Choose Tools > Drawing Settings, and then click the 3D Settings 
tab. Under Change Settings For, select Surfaces. Under Surface Settings, change the 
Number Of M-Direction Surfaces value.

Creating extruded surface meshes 
You can create an extruded surface, which is a three-dimensional polygon mesh that 
approximates the surface generated by extruding a path curve along a direction vec-
tor. You select the two entities that define the path curve and direction vector. The 
length of the direction vector determines the distance the path curve is moved along 
the direction vector. The extruded entity can be an arc, circle, line, or polyline. You 
can choose a line or open polyline as the direction vector. The resulting mesh consists 
of a series of parallel polygonal planes running along the specified path.

To create an  extruded surface mesh 

Advanced experience level

1 Do one of the following:

• Choose Draw > Surfaces > Tabulated Surface.

• On the Surfaces toolbar, click the Tabulated Surface tool ( ).

• Type tabsurf and then press Enter.

2 Select the entity to extrude.

3 Select the extrusion path.

Select the first (A) and second (B) defining entities. The resulting ruled surface mesh.

A

B
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NOTE To control the density of the mesh, change the values for the Number of M-
Direction Surfaces. Choose Tools > Drawing Settings, and then click the 3D Settings 
tab. Under Change Settings For, select Surfaces. Under Surface Settings, change the 
Number Of M-Direction Surfaces.

NOTE An extruded mesh is different from an extruded solid. If you wish to extrude 
an entity and convert it to a three-dimensional solid, use the Extrude command. 

Creating revolved surface meshes 
You can create a surface of revolution, which is a three-dimensional polygon mesh 
that approximates the surface generated by rotating a two-dimensional profile around 
an axis. You select the two entities that define the profile and the axis. You also spec-
ify the starting angle and the number of degrees to revolve the profile.

Revolving the profile 360 degrees creates a closed three-dimensional mesh. The 
Number Of M-Direction Surfaces value determines the mesh density (the number of 
mesh segments) in the M-direction (around the axis of revolution). The N-Direction 
Mesh Density value determines the mesh density (the number of mesh segments) in 
the N-direction (along the axis of revolution).

To create a revolved surface mesh    

Advanced experience level

1 Do one of the following:

• Choose Draw > Surfaces > Revolved Surface.

• On the Surfaces, click the Revolved Surface tool ( ).

• Type revsurf and then press Enter.

2 Select the entity to revolve.

3 Select the entity to be used as the axis of revolution.

4 Specify the starting angle.

Select the entity to extrude (A) and the  
extrusion path (B).

The resulting extruded  
surface mesh.

A B
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5 Specify the number of degrees to revolve the entity.

NOTE To control the density of the mesh, change the values for the Number Of M-
Direction Surfaces and N-Direction Mesh Density. Choose Tools > Drawing Set-
tings, and then click the 3D Settings tab. Under Change Settings For, select Surfaces. 
Under Surface Settings, change the Number Of M-Direction Surfaces and N-Direc-
tion Mesh Density values.

NOTE An revolved mesh is different from an revolved solid. If you wish to revolve 
an entity and convert it to a three-dimensional solid, use the Revolve command.

Creating edge-defined Coons surface patch meshes 
You can create a surface called a Coons surface patch, a mesh connecting four edges. 
You select the entities that define the edges. Edge entities can be arcs, lines, or 
polylines. The four edge entities must form a closed loop and share endpoints. A 
patch is a bicubic surface (one curve extends in the M-direction and the other in the 
N-direction) interpolated between the four adjoining edges. You can select the edges 
in any order. The first edge you select determines the M-direction of the mesh.

To create an edge-defined Coons surface patch mesh    

Advanced experience level

1 Do one of the following:

• Choose Draw > Surfaces > Edge Surface.

• On the Surfaces toolbar, click the Edge Surface tool ( ).

• Type edgesurf and then press Enter.

2 Select the first edge.

3 Select the second, third, and fourth edges.

Select the entity to be revolved (A) and the 
axis of revolution (B).

The resulting revolved surface  
mesh.

A

B



450   C H A P T E R  1 5

NOTE To control the density of the mesh, change the value for the Number of M-
Direction Surfaces and N-Direction Mesh Density. Choose Tools > Drawing Set-
tings, and then click the 3D Settings tab. Under Change Settings For, select Surfaces. 
Under Surface Settings, change the Number Of M-Direction Surfaces and N-Direc-
tion Mesh Density values.

Creating Surfaces

Creating boxes  
You can create rectangular boxes, or cubes. A box consists of six rectangular surface 
planes. The base of the box is always parallel with the xy plane of the current UCS. 
You position the box by specifying either a corner or the center of the box. You deter-
mine the size of the box by either specifying a second corner and the height; defining 
the box to be a cube and then providing its length; or specifying the length, width, and 
height.   

To create a box as a three-dimensional surface 

1 Do one of the following:

• Choose Draw > Surfaces > 3D Surface and than type Box.

• On the Surfaces toolbar, click the Box tool ( ).

• Type ai_box and then press Enter.

2 Specify the first corner of the base.

3 Specify the lenght of side of box. 

4 Specify the width of box. 

5 Specify the height. 

Select the entities to be used as the four 
edges (A, B, C, and D).

The resulting Coons surface patch mesh.

A
B

C

D
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.

Creating wedges
You can create three-dimensional wedges consisting of five surface planes. The base 
of the wedge is always parallel with the xy plane of the current UCS with the sloped 
face opposite the first corner. The height is always parallel with the z-axis. You posi-
tion the wedge by specifying either a corner or the center of the wedge. You deter-
mine the size of the wedge by either specifying a second corner and the height; 
defining the wedge based on a cube having a given length; or specifying the length, 
width, and height. 

To create a wedge as a three-dimensional surface 

1 Do one of the following:

• Choose Draw > Surfaces > 3D Surface and than type Wedge.

• On the Surfaces toolbar, click the Wedge tool ( ).

• Type ai_wedge and then press Enter.

2 Specify the first corner of the base.

3 Specify the opposite corner of the base.

4 Specify the height. 

First corner of the base (A), the opposite corner of the base (B), and the height (C).

First corner of the base (A), the opposite corner of the base (B), and the height (C).

A

C

B

A

C

B
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Creating cones
You can create three-dimensional cones defined by a circular base and tapering to a 
point perpendicular to the base. The base of the cone is always parallel with the xy 
plane of the current UCS; the height of the cone is always parallel with the z-axis. 
You position the cone by specifying the center of the base. You determine the size of 
the cone by specifying either the radius or the diameter of the base and the height.    

To create a cone as a three-dimensional surface 

1 Do one of the following:

• Choose Draw > Surfaces > 3D Surface and than type Cone.

• On the Surfaces toolbar, click the Cone tool ( ).

• Type ai_cone and then press Enter.

2 Specify the center of the base of the cone.

3 Specify the radius or diameter.

4 Specify the height.

5 Specify the number of longitudinal sections.

Creating pyramids
You can create tetrahedrons (three-sided pyramids) or four-sided pyramids. The sides 
of the resulting pyramid can meet at a point (the apex) or can form a three- or four-
edged top. The sides of a four-sided pyramid can also meet along a ridge defined by 
two points. The base of the pyramid is always parallel with the xy plane of the current 
UCS. You position the pyramid by specifying a corner of the base. You determine the 
size of the pyramid by specifying the base points and either the apex, the corners of 
the top surface, or the endpoints of the ridge.

Center of the base (A), the radius of the base (B), and the height (C).

A

C

B
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To create a tetrahedron    

1 Do one of the following:

• Choose Draw > Surfaces > 3D Surface and than type Pyramid.

• On the Surfaces toolbar, click the Pyramid tool ( ).

• Type ai_pyramid and then press Enter.

2 Specify the first point for the base of the pyramid.

3 Specify the second and third points.

4 In the prompt box, choose Tetrahedron.

5 Specify the apex of the tetrahedron.

To create a pyramid with a planar top  

1 Do one of the following: 

• Choose Draw > Surfaces > 3D Surface and than type Pyramid.

• On the Surfaces toolbar, click the Pyramid tool ( ).

• Type ai_pyramid and then press Enter.

2 Specify the first point for the base of the pyramid.

3 Specify the second, third, and fourth points.

4 In the prompt box, choose Top Surface.

5 Specify the first point on the top surface of the pyramid.

6 Specify the second, third, and fourth points

The first point (A), second point (B), and third point (C) of the base, and the apex (D).

A

B

C

D
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To create a pyramid as a three-dimensional  surface 

1 Do one of the following:

• Choose Draw > Surfaces > 3D Surface and than type Pyramid.

• On the Surfaces toolbar, click the Pyramid tool ( ).

• Type ai_pyramid and then press Enter.

2 Specify the points as described previously.

Creating cylinders
You can create cylinders defined by a circular base. The base of a cylinder is always 
parallel with the xy plane of the current UCS; the height of a cylinder is always paral-
lel with the z-axis. You position a cylinder by specifying the center of the base. You 
determine the size of a cylinder by specifying either the radius or diameter of the base 
and the height

To create a cylinder as a three-dimensional surface 

1 Do one of the following:

• Choose Draw > Surfaces > 3D Surface and than type Cylinder.

• Type ai_cylinder and then press Enter.

2 Specify the center of the base of the cylinder.

3 Specify the radius or diameter.

4 Specify the height.

5 Specify the number of longitudinal sections.

The first point (A), second point (B), third point (C), and fourth point (D) of the base, and the first point (E), 
second point (F), third point (G), and fourth point (H) of the top surface.

A

B

C

D

E

F
G

H
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Creating spheres
You can create spheres. The latitude lines of a sphere are always parallel with the xy 
plane of the current UCS; the central axis is always parallel with the z-axis. You posi-
tion a sphere by specifying its center point. You determine the size of a sphere by 
specifying either its radius or its diameter.

To create a sphere as a three-dimensional surface 

1 Do one of the following:

• Choose Draw > Surfaces > 3D Surface and than type Sphere

• On the Surfaces toolbar, click the Sphere tool ( ).

• Type ai_sphere and then press Enter.

2 Specify the center of the sphere.

3 Specify the radius or diameter.

4 Specify the number of longitudinal sections that are perpendicular to the xy plane.

5 Specify the number of latitudinal sections that are parallel to the xy plane.

Center of the base (A), radius of the base (B), and the height (C).

Center (A) and radius (B) of the sphere. The resulting sphere.

A

B

C

A

B
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Creating dishes
You can create a three-dimensional dish. The latitude lines of a dish are always paral-
lel with the xy plane of the current UCS; the central axis is always parallel with the z-
axis. You position a dish by specifying its center point. You determine the size of a 
dish by specifying either its radius or its diameter.

To create a dish as a three-dimensional surface 

1 Do one of the following:

• Choose Draw > Surfaces > 3D Surface and than type Dish.

• On the Surfaces toolbar, click the Dish tool ( ).

• Type ai_dish and then press Enter.

2 Specify the center of the dish.

3 Specify the radius or diameter.

4 Specify the number of divisions around the dish. 

5 Specify the number of top to bottom divisions.

Creating domes
You can create a three-dimensional dome. The latitude lines of a dome are always 
parallel with the xy plane of the current UCS; the central axis is always parallel with 
the z-axis. You position a dome by specifying its center point. You determine the size 
of a dome by specifying either its radius or its diameter.

To create a dome as a three-dimensional surface

1 Do one of the following:

• Choose Draw > Surfaces > 3D Surface and than type Dome.

• On the Surfaces toolbar, click the Dome tool ( ).

• Type ai_dome and then press Enter.

2 Specify the center of the dome.

3 Specify the radius or diameter.

Center (A) and radius (B) of the dish.

A

B
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4 Specify the number of divisions around the dome. 

5 Specify the number of top to bottom divisions.

Creating tori
You can create a three-dimensional donut or ring-shaped entity known as a torus. The 
diameter of a ring is always parallel with the xy plane of the current UCS. A torus is 
constructed by revolving a circle about a line drawn in the plane of the circle and par-
allel with the z-axis of the current UCS. You position a torus by specifying its center 
point. You determine the size of a torus by specifying its overall diameter or radius 
and the diameter or radius of the tube (the circle being revolved).

To create a torus as a three-dimensional surface 

1 Do one of the following:

• Choose Draw > Surfaces > 3D Surface and than type Torus.

• On the Surfaces, click the Torus tool ( ).

• Type ai_torus and then press Enter.

2 Specify the center of the whole torus.

3 Specify the radius or diameter of the whole torus.

4 Specify the radius or diameter of the body of the torus.

5 Specify the number of longitudinal sections that are perpendicular to the xy plane.

6 Specify the number of latitudinal sections that are parallel to the xy plane.

Center (A) and radius (B) of the dome.

A

B
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Creating Solids

Creating Boxes 

To create a box

1 Do one of the following:

• Choose Draw > 3D Entities > Box.

• On the Solids toolbar, click the Box tool ( ).

• Type box and then press Enter.

2 Specify the first corner of the base.

3 Specify the opposite corner of the base.

4 Specify the height.  

Center (A) and radius of the whole torus (B), and the radius of the body (C).

A

B C

First corner of the base (A), the opposite corner of the base (B), and the height (C).

A
B

C
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Creating Wedges 

To create a wedge

1 Do one of the following:

• Choose Draw > 3D Entities > Wedge.

• On the Solids toolbar, click the Wedge tool ( ).

• Type wedge and then press Enter.

2 Specify the first corner of the base.

3 Specify the opposite corner of the base.

4 Specify the height. 

Creating Cones 

To create a cone

1 Do one of the following:

• Choose Draw > 3D Entities > Cone.

• On the Solids toolbar, click the Cone tool ( ).

• Type cone and then press Enter.

2 Specify the center of the base of the cone.

3 Specify the radius or diameter.

4 Specify the height.

First corner of the base (A), the opposite corner of the base (B), and the height (C).

A

BC
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Creating Tetrahedrones 

To create a tetrahedron

1 Do one of the following:

• Choose Draw > 3D Entities > Pyramid.

• Type pyramid and then press Enter.

2 Specify the first point for the base of the pyramid.

3 Specify the second and third points.

4 In the prompt box, choose Tetrahedron.

5 Specify the apex of the tetrahedron.

Center of the base (A), the radius of the base (B), and the height (C).

The first point (A), second point (B), and third point (C) of the base, and the apex (D).

A

C

B

A

B

C

D
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Creating Pyramids 

To create a pyramid

1 Do one of the following:

• Choose Draw > 3D Entities > Pyramid.

• Type pyramid and then press Enter.

2 Specify the first point for the base of the pyramid.

3 Specify the second third and fourth points.

4 Specify the apex of the pyramid.

To create a pyramid with a planar top 

1 Do one of the following: 

• Choose Draw > 3D Entities > Pyramid.

• Type pyramid and then press Enter.

2 Specify the first point for the base of the pyramid.

3 Specify the second, third, and fourth points.

4 In the prompt box, choose Top Surface.

5 Specify the first point on the top surface of the pyramid.

6 Specify the second, third, and fourth points..

The first point (A), second point (B), third point (C), and fourth point (D) of the base, and the first point (E), 
second point (F), third point (G), and fourth point (H) of the top surface.

A

B

C

D

E

F
G

H
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Creating Cylinders 

To create a cylinder

1 Do one of the following:

• Choose Draw > 3D Entities > Cylinder.

• On the Solids toolbar, click the Cylinder tool ( ).

• Type cylinder and then press Enter.

2 Specify the center of the base of the cylinder.

3 Specify the radius or diameter.

4 Specify the height.

Creating Spheres 

To create a sphere

1 Do one of the following:

• Choose Draw > 3D Entities > Sphere.

• On the Solids toolbar, click the Sphere tool ( ).

• Type sphere and then press Enter.

2 Specify the center of the sphere.

3 Specify the radius or diameter.

Center of the base (A), radius of the base (B), and the height (C).

A

B

C
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Creating Dishs 

To create a dish

1 Do one of the following:

• Choose Draw > 3D Entities > Dish.

• Type dish and then press Enter.

2 Specify the center of the dish.

3 Specify the radius or diameter..

Creating Domes 

To create a dome

1 Do one of the following:

• Choose Draw > 3D Entities > Dome.

• Type dome and then press Enter.

2 Specify the center of the dome.

3 Specify the radius or diameter.

Center (A) and radius (B) of the sphere. The resulting sphere.

Center (A) and radius (B) of the dish.

A

B

A

B
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 Creating Tori 

To create a torus

1 Do one of the following:

• Choose Draw > 3D Entities > Torus.

• On the Solids toolbar, click the Torus tool ( ).

• Type torus and then press Enter.

2 Specify the center of the whole torus.

3 Specify the radius or diameter of the whole torus.

4 Specify the radius or diameter of the body of the torus.

Creating regions   
You can convert a closed entity into a two-dimensional region. After you create a 
region, you can modify it using the various three-dimensional tools. For example, you 
can create a region from a square, and then extrude the square to create a three-
dimensional cube.

Center (A) and radius (B) of the dome.

Center (A) and radius of the whole torus (B), and the radius of the body (C).

A

B

A

B C
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You can create regions from closed entities, such as polylines, polygons, circles, 
ellipses, closed splines, and donuts.        

Creating regions typically has no visible effect on a drawing. However, if the original 
entity had a width or lineweight, that information is lost when you create the region.    

To create a region

1 Do one of the following:

• Choose Modify > Region.

• On the Draw toolbar, click the Region tool ( ).

• Type region and then press Enter.

2 Select the entities to create the region.

3 Press Enter.

The command bar displays a message that describes how many regions were cre-
ated.

Creating extruded solids 
You can create three-dimensional solids by extruding closed objects, such as 
polylines, polygons, circles, ellipses, closed splines, donuts, and regions. You can 
extrude the object along a selected path, or you can specify its height and taper angle.

To create an extruded solid 

1 Do one of the following:

• Choose Draw > 3D Entities > Extrude.

• On the Solids toolbar, click the Extrude tool ( ).

• Type extrude and then press Enter.

2 Select the entity to extrude.

3 Select the extrusion path, or specify the height.

Select the entity to extrude (A) and the extrusion path 
(B).

The resulting extruded  
solid.

A B
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Creating revolved solids 
You can create three-dimensional solids by revolving closed objects, such as 
polylines, polygons, circles, ellipses, and regions. You can revolve the object about a 
defined axis, line, polyline, or two points

To create a revolved solid   

1 Do one of the following:

• Choose Draw > 3D Entities > Revolve.

• On the Solids toolbar, click the Revolve tool ( ).

• Type revolve and then press Enter.

2 Select the entity to revolve.

3 Do one of the following to define the axis of revolution:

• Specify a start point and an end point.

• Type o and press Enter to select an object that determines the axis.

• Type x and press Enter to select the x-axis.

• Type y and press Enter to select the y-axis.

4 Specify the angle of revolution.

Creating composite solids 
You can create composite three-dimensional solids by combining, subtracting, and 
finding the intersection of two or more solids

To combine solids

1 Do one of the following:

• Choose Modify > Solid Editing > Union

• On the Solids Editing toolbar, click the Union tool ( ).

• Type union and then press Enter.

2 Select the entities to combine.

Select the entity to revolve  (A) and the axis (B) about 
which to revolve it., followed by the angle of 
revolution.

The resulting revolved  
solid.
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To subtract solids    

1 Do one of the following:

• Choose Modify > Solid Editing > Subtract.

• On the Solids Editing toolbar, click the Subtract tool ( ).

• Type subtract and then press Enter.

2 Select the entities to subtract from one another.

To intersect solids

1 Do one of the following:

• Choose Modify > Solid Editing > Intersect.

• On the Solids Editing toolbar, click the Intersect tool ( ).

• Type intersect and then press Enter.

2 Select the entities to intersect

Select the entityies to combine (A and B). The resulting combined  
solid.

Select the entityies to subtract (A and B). The resulting   
solid.

A

B

A

B
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Editing in three dimensions

You can copy, move, rotate, array, mirror, and align two-dimensional and three-
dimensional entities in both two-dimensional and three-dimensional space. You can 
also  change and edit properties of three-dimensional entities much like you change 
and edit properties for two-dimensional entities. When you modify three-dimensional 
entities in two-dimensional space, you modify the entity in relation to the current 
UCS. 

Rotating in three dimensions
You can rotate selected entities about a specified axis in three-dimensional space. 
You select the entities to rotate and then define the axis of rotation either by specify-
ing two points; selecting an existing entity; aligning the axis with the x-, y-, or z-axis 
of the current UCS; or aligning the axis with the current view.

To rotate an entity about an axis in three dimensions 

1 Do one of the following:

• Choose Modify > 3D Operation > Rotate 3D.

• Type rotate3D and then press Enter.

2 Select the entities to rotate, and then press Enter.

3 Choose from one of the following options: Entity, Last, View, Xaxis, Yaxis, 
Zaxis.

4 Specify the rotation angle.

5 Specify the reference angle.

Select the entityies to combine (A and B). The resulting combined  
solid.
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Arraying in three dimensions
You can copy selected entities and arrange them in a three-dimensional rectangular or 
polar (circular) pattern. For a rectangular array, you control the number of copies in 
the array by specifying the number of rows and columns and the number of levels. 
You also specify the distance between each. For a polar array, you specify the axis 
around which to array the entities, the number of copies of the entities to create, and 
the angle subtended by the resulting array.

To create a three-dimensional rectangular array   

1 Do one of the following:

• Choose Modify > 3D Operation > 3D Array.

• Type 3Darray and then press Enter.

2 Select the entities, and then press Enter.

3 In the prompt box, choose Rectangular.

4 Type the number of rows in the array.

5 Type the number of columns.

6 Type the number of levels.

7 Specify the vertical distance between the rows.

8 Specify the horizontal distance between the columns.

9 Specify the depth between the levels.

Select the entities to rotate (A), specify the endpoints 
of the axis of rotation (B and C), and then specify the 
rotation angle (D).

Result after rotating the entities.

B

D
CA
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To create a three-dimensional polar array         

1 Do one of the following: 

• Choose Modify > 3D Operation > 3D Array.

• Type 3Darray and then press Enter.

2 Select the entities, and then press Enter.

3 In the prompt box, choose Polar.

4 Type the number of copies to make, including the original selection set.

5 Specify the angle the array is to fill, from 0 to 360 degrees.

The default setting for the angle is 360 degrees. Positive values create the array in 
a counterclockwise direction; negative values create the array in a clockwise 
direction.

6 In the prompt box, choose one of the following:

• Yes-Rotate Entities to rotate entities as they are arrayed.

• No-Do Not Rotate to retain the original orientation of each copy as it is arrayed.

7 Specify the center point of the array.

8 Specify a second point along the central axis of the array.

To create a three-dimensional rectangular array, select the entity to copy (A), type the 
number of rows, columns, and levels, and then specify the distance between each row (B), 
column (C), and level (D).

AB
C

D
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Mirroring in three dimensions
You can create a mirror image of selected entities in three-dimensional space. You 
mirror the entities about a mirror plane that you define by either specifying three 
points; selecting an existing two-dimensional planar entity; aligning the plane parallel 
with the xy, yz, or xz plane of the current UCS; or aligning the plane with the current 
view. You can delete or retain the original entities.

To mirror an entity about a three-dimensional plane     

1 Do one of the following:

• Choose Modify > 3D Operation > Mirror 3D.

• Type mirror3D and then press Enter.

2 Select the entities, and then press Enter.

3 In the prompt box, choose 3 Points, or press Enter to select the default.

4 Specify the first point on the mirror plane.

5 Specify the second and third points on the plane.

6 In the prompt box, choose one of the following:

• Yes-Delete Entities to delete the original entities.

• No-Keep Entities to retain the original entities.

To create a three-dimensional polar array, select the entity to copy (A), type the number of copies to make, 
specify the angle the array is to fill (B), and then specify the center point of the array (C) and a second point 
along the central axis of the array (D).

A
B

C

D
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Aligning in three dimensions
You can align selected entities with other entities in three-dimensional space. You 
select the entities you wish to align, and specify one, two or three pairs of points to 
align the selected entities.

To align an entity an entity with another     

1 Do one of the following:

• Choose Modify > 3D Operation > Align.

• Type align and then press Enter.

2 Select the entities, and then press Enter.

3 Specify the first source point.

4 Specify the first destination point.

5 Specify additional source and destination points if desired (up to three pairs).

Select the entity to mirror (A), and then specify 
the first point (B), second point (C), and third 
point (D) defining the mirror plane.

The resulting mirrored entity.

A
D C

B



D R A W I N G  I N  T H R E E  D I M E N S I O N S    473

Editing three-dimensional solids

You can edit three-dimensional solids in several unique ways, including: chamfer, fil-
let, section, and slice. You can also modify individual faces and edges of solids, as 
well as imprint, separate, shell, and check solids.

You can edit three-dimensional ACIS solids, including: boxes, cones, cylinders, 
dishes, domes, pyramids, spheres, tori, and wedges.

Chamfering and filleting solids 
You can chamfer or fillet a three-dimensional solid much like you chamfer or fillet a 
two-dimensional entity.

To chamfer a solid

1 Do one of the following:

• Choose Modify > Chamfer.

• On the Modify toolbar, click the Chamfer tool ( ).

• Type chamfer and then press Enter.

2 Select the edge of the base surface to chamfer. (One of two surfaces adjacent to 
the selected edge will be highlighted.)

Select the entities to align, and then specify the 
first source point (A), the first destination point 
(B), the second destination point (C), and the 
second destination point (D). You can specify up 
to three pairs of source/destination points.

The resulting mirrored entity.

C D

A

B
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3 Do one of the following:

• To select a different surface, type n and press Enter. 

• To use the current surface, press Enter.

4 Specify the base surface distance (measured from the selected edge to the base 
surface).

5 Specify the adjacent surface distance (measured from the selected edge to the 
adjacent surface).

6 Do one of the following:

• Specify the edges to chamfer.

• To select all edges around the base surface, type l and press Enter.

To fillet a solid

1 Do one of the following:

• Choose Modify > Fillet.

• On the Modify toolbar, click the Fillet tool ( ).

• Type fillet and then press Enter.

2 Select the edge of the solid to fillet.

3 Specify the fillet radius.

4 Select additional edges to fillet, and press Enter to fillet.

Sectioning and slicing solids 
You can section or slice a three-dimensional solid, region, or body (typically a sheet). 

When you section a solid, you obtain an “inside view” by creating a cross-section 
through the solid as a region or block. When you section a region or body, the result-
ing intersections are curves. 

When you slice a solid, region, or body, you create a new entity by cutting the origi-
nal entity and removing a specific side.

To section an entity 

1 Do one of the following:

• Choose Draw > 3D Entities > Section.

• On the Solids toolbar, click the Section tool ( ).

• Type section and then press Enter.

2 Select the entities to cross-section.

3 Do one of the following:

• Specify three points to define the cross-section plane. (The first point defines the 
origin, while the second point defines the x-axis and the third point defines the 
y-axis.)
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• Type o and press Enter to select an object that defines the cross-sectional plane.

• Specify an axis by typing the appropriate letter and pressing Enter.

To slice an entity 

1 Do one of the following:

• Choose Draw > 3D Entities > Slice.

• On the Solids toolbar, click the Slice tool ( ).

• Type slice and then press Enter.

2 Select the entities to slice.

3 Do one of the following:

• Specify three points to define the cross-section plane. (The first point defines the 
origin, while the second point defines the x-axis and the third point defines the 
y-axis.)

• Type o and press Enter to select an object that defines the cross-sectional plane.

• Specify an axis by typing the appropriate letter and pressing Enter.

4 Specify which side to retain, or type b to retain both sides.

Modifying faces

You can edit three-dimension solids by extruding, moving, rotating, offsetting, taper-
ing, deleting, or copying individual faces. You can also change the color of individual 
faces.

To extrude a solid face  

1 Do one of the following:

• Choose Modify > Solids Editing > Extrude Faces.

• On the Solids Editing toolbar, click the Extrude Face tool ( ).

2 Select the entity with the face you wish to extrude.

3 Select the face(s) to extrude, and press Enter.

4 Do one of the following:

• Specify the height of extrusion.

• Type p and press Enter to select a path for extrusion.

5 If you specified a height, specify a taper angle.
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To move a solid face   

1 Do one of the following:

• Choose Modify > Solids Editing > Move Faces.

• On the Solids Editing toolbar, click the Move Faces tool ( ).

2 Select the entity with the face you wish to move.

3 Select the face(s) to move, and press Enter.

4 Specify a base point.

5 Specify an end point.

Select the entitiy to extrude, and then specify 
the face(s) to extrude (A), and the height of 
extrusion or path.

The resulting entity with the face extruded to 
position (B).

Select the entitiy, and then specify the face(s) to 
move (A), the base point (B), and the end point 
(C).

The resulting entity with the face moved to the new 
position.
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To rotate a solid face  

1 Do one of the following:

• Choose Modify > Solids Editing > Rotate Faces.

• On the Solids Editing toolbar, click the Rotate Faces tool ( ).

2 Select the entity with the face you wish to rotate.

3 Select the face(s) to rotate, and press Enter.

4 Specify a base point.

5 Specify another point on the rotation axis.

6 Specify the rotation angle.

To offset a solid face 

1 Do one of the following:

• Choose Modify > Solids Editing > Offset Faces.

• On the Solids Editing toolbar, click the Offset Faces tool ( ).

2 Select the entity with the face you wish to offset.

3 Select the face(s) to offset, and press Enter.

4 Specify an offset distance.

Select the entitiy, and then specify the face(s) to 
rotate (A), the base point (B), a second point on 
the rotation axis (C),and a rotation angle.

The resulting entity with the face rotated to position 
(D).
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To taper a solid face 

1 Do one of the following:

• Choose Modify > Solids Editing > Taper Faces.

• On the Solids Editing toolbar, click the Taper Faces tool ( ).

2 Select the entity with the face you wish to taper.

3 Select the face(s) to taper, and press Enter.

4 Specify a base point.

5 Specify another point along the axis.

6 Specify a taper angle.

Select the entitiy, and then specify the face(s) 
to offset (A) and the distance to offset.

The resulting entity with the face offset to position 
(B).

Select the entitiy, and then specify the face(s) to 
taper (A), a base point, a second point along the 
taper axis, and a taper angle.

The resulting entity with the face tapered to position 
(D).
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To delete a solid face 

1 Do one of the following:

• Choose Modify > Solids Editing > Delete Faces.

• On the Solids Editing toolbar, click the Delete Faces tool ( ).

2 Select the entity with the face you wish to delete.

3 Select the face(s) to delete, and press Enter.

To copy a solid face 

1 Do one of the following:

• Choose Modify > Solids Editing > Copy Faces.

• On the Solids Editing toolbar, click the Copy Faces tool ( ).

2 Select the entity with the face you wish to copy.

3 Select the face(s) to copy, and press Enter.

4 Specify a base point.

5 Specify an end point.

Select the entitiy, and then specify the face(s) to 
delete (A).

The resulting entity with the face deleted.
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To color a face 

1 Do one of the following:

• Choose Modify > Solids Editing > Color Faces.

• On the Solids Editing toolbar, click the Color Faces tool ( ).

2 Select the entity with the face you wish to color.

3 Select the face(s) to color, and press Enter.

4 Specify a color.

Select the entitiy, and then specify the face(s) 
to copy (A), the base point (B), and the end 
point (C).

The resulting entity with the face copied.

Select the entitiy, and then specify the face(s) to 
color (A).

The resulting entity with the face colored.



D R A W I N G  I N  T H R E E  D I M E N S I O N S    481

Modifying edges
In addition to modifying faces of solids, you can modify individual edges. You can 
copy individual edges or change the color of individual edges.

To copy an edge 

1 Do one of the following:

• Choose Modify > Solids Editing > Copy Edges.

• On the Solids Editing toolbar, click the Copy Edges tool ( ).

2 Select the entity with the edge you wish to copy.

3 Select the edge(s) to copy, and press Enter.

4 Specify a base point.

5 Specify an end point.

To color an edge 

1 Do one of the following:

• Choose Modify > Solids Editing > Color Edges.

• On the Solids Editing toolbar, click the Color Edges tool ( ).

2 Select the entity with the edge you wish to color.

3 Select the edge(s) to color, and press Enter.

4 Specify a color.

Imprinting solids
You can modify the face of a solid by imprinting another entity on it. For example, 
you can imprint a line, arc, or polyline onto the face of a box.

Select the entitiy, and then specify the edge(s) 
to copy (A), the base point (B), and the end 
point (C).

The resulting entity with the edge copied.
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To imprint a solid object 

1 Do one of the following:

• Choose Modify > Solids Editing > Imprint.

• On the Solids Editing toolbar, click the Imprint tool ( ).

2 Select the solid entity you wish to imprint.

3 Select the entity you wish to imprint on the solid.

Separating solids
You can separate solids that have been combined. After you separate them, they are 
separated into individual solids.

To separate solids

1 Do one of the following:

• Choose Modify > Solids Editing > Separate.

• On the Solids Editing toolbar, click the Separate tool ( ).

2 Select the solid you wish to separate.

Shelling solids
You can create a shell or a hollow thin wall from your 3D solid object. AViCAD off-
sets existing faces to create new faces.

To shell a solid

1 Do one of the following:

• Choose Modify > Solids Editing > Shell.

• On the Solids Editing toolbar, click the Shell tool ( ).

2 Select the entity you wish to shell.

3 Remove any faces you don’t wish to include.

4 Specify an offset distance.
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Flattening solids
Using the SOLPROF command you create a flattened view of all 3d boundaries and 
solids of the current viewport. The resulting view is a block.

To create a 2D view of a 3D model

1 Determine a 3d model view. 

2 Do one of the following:

• Type solprof and then press Enter. 

• Choose Draw > 3D Entities > Profile ( ).

3 Select the desire entities. 

4 Choose if to place the hidden line on a separate layer. 

5 Choose where the profile is to be projected. 

6 Choose if delete tangential edges. 

Convert a solid to a surface
You can convert a solid to a surface,  the result will be a polyface mesh.

To convert a solid to a surface

1 Type 3dconvert and press Enter

2 Select the solids to convert

3 Press Enter.

Cleaning solids
You can remove redundant edges or vertices from solids when they are not needed.

Select the entitiy, and then select faces to 
remove (A)and (B), then specify an offset 
distance.

The resulting shelled entity.
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To clean a solid 

1 Do one of the following:

• Choose Modify > Solids Editing > Clean.

• On the Solids Editing toolbar, click the Clean tool ( ).

2 Select the entity you wish to clean.

Checking solids
You can check whether a selected solid object is a valid 3D ACIS solid object. If it is 
a valid 3D solid, you can modify the object; in not, you cannot edit the object. 

To check a solid

1 Do one of the following:

• Choose Modify > Solids Editing > Check.

• On the Solids Editing toolbar, click the Check tool ( ).

2 Select the entities to check.

Hiding, shading, and rendering

As you create three-dimensional entities, the program displays both wire-frame and 
surface models in wire-frame view, which makes it difficult to visualize your three-
dimensional models. To better visualize the model, you can remove all the lines that 
are hidden behind other entities or surfaces when seen from the current viewpoint.

Shading goes a step further by removing hidden lines and then assigning flat colors to 
the visible surfaces, making them appear solid. Shaded images are useful when you 
want to quickly visualize your model as a solid object, though they lack depth and 
definition.

Rendering provides an even more realistic image of your model, complete with light 
sources, shadows, surface material properties, and reflections, giving your model a 
photo-realistic look. As shown in the following illustrations, when you render a 
model, the program removes hidden lines and then shades the surfaces as though they 
were illuminated from imaginary light sources.  
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Creating hidden-line images
Creating a hidden-line view of your drawing removes all the lines that are hidden 
behind other surfaces when seen from your vantage point. When you remove hidden 
lines or shade a model, the program treats the entities differently, depending on how 
you created them. Wire-frame models always appear transparent, because they have 
no surfaces. Surface models appear filled, with surfaces applied to all visible sides. 

To create a hidden-line image

Do one of the following: 

• Choose View > Hide.

• On the Render toolbar, click the Hide tool ( ).

• Type hide and then press Enter. 

Creating shaded images
Creating a shaded image of your drawing removes hidden lines and then applies 
shading to the visible surfaces based on their entity color. Because they are intended 
to provide a quick visualization, shaded images do not have a light source and use 
continuous colors across surfaces, causing them to appear flat and unrealistic.   

To create a shaded image

Do one of the following: 

• Choose View > Shade and select shading mode do you want.

• On the Shade toolbar, click the Shade Highlighting Outline tool ( ).

Wire-frame model. Hidden-line image. Shaded image. Rendered image.

Before creating a hidden-line image. After removing hidden lines.
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• Type shade and then press Enter.

To control the appearance of the shaded image, choose Tools > Drawing Settings, 
and then click the 3D Settings tab and select the options you want. You can shade the 
surfaces and edges of the model in four ways: 

• Faces shaded; edges not highlighted. 

• Faces shaded; edges highlighted in the background color.

• Faces filled in the background color; edges drawn using the entity color (similar to 
a hidden-line view).

• Faces filled using the entity color; edges highlighted in the background color.

Creating rendered images
Creating a rendered image of your drawing removes hidden lines and then shades the 
surface as though it were illuminated from multiple light sources. 

Full rendering creates a photo-realistic image of your model, complete with light 
sources, shadows, surface material properties, and reflections. You can illuminate 
your image with spotlights, distant lighting to simulate sunshine, and ambient light. If 
you choose not to customize the light sources, the program generates default light 
sources for you.

Rays from these imaginary light sources are traced as they reflect off and refract 
through the surfaces of the model, a process called ray tracing. Ray tracing deter-
mines where shadows fall and how reflections on shiny materials such as metal and 
glass appear. You can modify the reflective properties of the materials that make up 
your model to control how the light rays reflect off its surfaces. 

Full rendering automatically creates a base on which your model is displayed, if you 
don’t already have one, so it does not appear suspended in space. A background is 
also automatically added to the image. A background such as a cloudy sky or an 
imported raster graphic such as a stone wall can also be added behind the image, 
making it even more realistic.

To create a quickly rendered image

Do one of the following: 

• Choose View > Render > Render.

• On the Render toolbar, click the Render tool ( ).

• Type render and then press Enter.

To create a fully rendered image

Do one of the following:    

• Choose View > Render > Full Render.

• On the Render toolbar, click the Full Render tool ( ).

• Type fullrender and then press Enter.  
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NOTE For more information, see Chapter 16, “Render” .  

Creating custom rendered images
AViCAD allows you to create custom rendered images by applying materials, 
backgrounds, and lighting (including shadows) to your drawing:

• Materials Specify materials for different surfaces and define how the materials 
map to those surfaces. Predefined materials are available in the materials library, 
which can be customized further using the built-in editor. You can choose to use 
procedural or bitmap materials.

• Backgrounds Specify the background or backdrop for a rendered image. Several 
predefined backgrounds are available. By default, no background is used and it 
appears black. The background is an infinite, planar surface and reflects off of any 
reflective surfaces in your model. The background is not affected by lighting how-
ever, so no shadows or highlights are seen on the background.

• Lighting Specify the placement of lights, light color, and light intensity to deter-
mine how your drawing or scene is lit, including shadows and reflections in the 
scene. Lights can be placed either outside the field of view or inside to illuminate 
different areas of the scene. Several predefined lighting controls are available, 
including ambient lighting, diffuse lighting, specular reflections, specular high-
lights, and transparency.  

    Fully rendered image.
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To apply materials, backgrounds, and lighting

1 Do one of the following: 

• Choose View > Render, and then choose Materials, Background, or Ligh.

• On the Render toolbar, click the Materials tool ( ), Background ( ), or 
Lights tool ( ).

• Type materials, backgrounds, or lighting and then press Enter.

2 Make your selections.

NOTE You can specify additional options by choosing View > Render > Preferences. 
For more information about creating custom rendered images, click Help in any of 
the Render dialog boxes.

Printing a rendered image
You cannot print a rendered image directly to a printer. Instead, you must first save 
the drawing to a different format — either a bitmap (.bmp), JPEG (.jpg), TIFF (.tif), 
TrueVision TGA (.tga), or Portable Network Graphic (.png). After you save a 
rendered image, you can print it from another graphics program. 

To save a rendered image of your drawing

1 Create a rendered image of the drawing.

2 Do one of the following:

• Choose View > Render > Preferences.

• On the Render toolbar, click the Render Preferences tool ( ).

• Type setrender and then press Enter.

3 On the Rendering tab, click Save Last Image.

4 Enter a file name and path.

5 In Save As Type, choose the file format.

6 Click Save.
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Getting Started 

The DaVinci Rendering Library is a tool for generating high-quality, "photo realistic" 
renderings or images of three-dimensional AViCAD drawings. The library extracts 
geometry information from your AViCAD drawing and then calculates how light will 
interact with the surfaces in the drawing to generate a realistic image.

The algorithm used to render the drawing is commonly called Ray Tracing. In the ray 
tracing algorithm, "rays" of light are traced backward from the viewer's eye, through 
the scene (i.e. the drawing), to the light sources. For each pixel, a ray (or set of rays 
when using anti-aliasing) is directed from the viewer's eye in the proper direction for 
that pixel. The software then determines which surface in the scene is "struck" first by 
the ray. The software then must determine if that spot on the surface is illuminated by 
the lights in the scene. If the surface is reflective, the software must also determine 
what light is bouncing off of other surfaces and hitting that spot. Similarly, if the sur-
face is transparent or partially transparent, the ray continues on through the surface to 
determine what can be seen through it. This process continues for each pixel in the 
image.

The commands to use the DaVinci Rendering Library are accessible from the top-
level View menu under the Render sub-menu as shown below.
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The set of entries control the rendering library include: Render, Full Render, Materi-
als..., Background..., Light..., and Preferences... .

Render Command

The Render command generates a lower-quality rendered image of the drawing 
using the lighting and materials options selected. Shadows, reflections, and transpar-
ency effects are not included to increase the speed of the rendering process. This 
command is useful for previewing the rendering output.

Full Render Command

The Full Render command generates a high-quality rendered image of the drawing 
using the lighting and materials options selected and also including shadows, reflec-
tions, and transparency effects. This command is used to generate a final rendered 
image.
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Materials... Command 

The Materials command allows you to select the "material" for each surface in the 
drawing. A number of material options are available and the material settings control 
the coloring of each surface, any pattern in the surface (tile or brick for example), as 
well as the surface finish (i.e. how the surface reflects light). If no material is speci-
fied for a surface, it defaults to a light gray color so that it will appear in the render-
ing.

Background... Command

The Background command allows you to select the background for the drawing. A 
wide variety of backgrounds can be selected. For example, you may wish to render an 
architectural drawing in front of a picture of the proposed site. In this case you can 
choose an image file for the background. If no background is specified, a black back-
ground is used.

Light... Command

The Light command is used to control the placement of lights in the drawing. Lights 
can be placed either outside the field of view or inside to illuminate different areas of 
the scene. Light placement controls shadows and reflections in the scene. If no lights 
are specified a default light is added to ensure that some part of the drawing will be 
scene when rendered.

Preferences... Command

The Preferences command brings up a window used to control various rendering 
options. In addition, rendered images can be exported to an image file through the 
render settings window or you can produce higher resolution rendered images and 
save them directly to a file. Settings that can be controlled include anti-aliasing, sur-
face smoothing, number of reflections considered, and rendering quality.

Render Command

Toolbar: Render > Render ( ).

Menu: View > Render > Render.

Keyboard: RENDER.

Alias: RR.
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The Render command starts the rendering process and generates a rendered image of 
the current drawing. The Render command generates a lower quality image than the 
Full Render command but is displayed more quickly. The Render command does not 
include shadow effects, transparency, or reflections, all of which are included with 
the Full Render command. The rendered image is displayed overtop the drawing win-
dow and is displayed incrementally while it is processed. At any time during the ren-
dering process, you can cancel the rendering by typing the escape (Esc) key. Once the 
image has been displayed, it will be overwritten if you zoom or pan the display or if 
another window is popped-up in front of the AViCAD window. The image can be 
redrawn (without the rendering delay) by using the "Redisplay Last Image" command 
on the Render Settings window. The rendered image can also be saved to a file from 
the Render Settings window.

Full Render Command  

Toolbar: Render > Full Render ( ).

Menu: View > Render >Full Render.

Keyboard: FULLRENDER.

The Full Render command starts the rendering process and generates a rendered 
image of the current drawing. The Full Render command generates the highest qual-
ity image and generally includes shadow effects, transparency, and reflections. The 
rendered image is displayed overtop the drawing window and is displayed incremen-
tally while it is processed. At any time during the rendering process, you can cancel 
the rendering by typing the escape (Esc) key. Once the image has been displayed, it 
will be overwritten if you zoom or pan the display or if another window is popped-up 
in front of the AViCAD window. The image can be redrawn (without the rendering 
delay) by using the "Redisplay Last Image" command on the Render Settings win-
dow. The rendered image can also be saved to a file from the Render Settings win-
dow.

Materials Command

Toolbar: Render > Materials ( ).

Menu: View > Render > Materials.

Keyboard: MATERIALS.
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Alias: RMAT.

The Material Assignment window allows you to specify the material that will be 
assigned to different surfaces in the drawing and how those materials will be mapped 
to the surface. A number of predefined materials are available that include different 
color patterns and surface finishes. In addition, a Materials Editor is available which 
allows you to modify the predefined materials or create new ones. 

Materials can be assigned to either individual drawing entities, to drawing layers, or 
to drawing colors. When rendering an entity, first material properties are retrieved for 
that entity if they exist. If no material assignment has been made for that entity, then 
material properties are retrieved for the layer on which that entity resides. If no mate-
rial assignment has been made for the layer, then material properties associated with 
the drawing color are used. Finally if no material properties have been assigned to 
that color, then the entity is rendered using the DEFAULT material properties and the 
drawing color that it has been assigned. 

The Material Assignment window includes two different tabbed worksheets and a 
preview area as illustrated below. The first tab is entitled Material Library and allows 
you to select from among a variety of predefined materials. The second tab is titled 
Material Mapping and controls how the material is mapped to the surfaces in the 
drawing. 
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After you issue the Materials command you will be prompted to choose whether 
you'd like to specify materials for a set of drawing entities, for a particular drawing 
layer, or for a particular drawing color. The prompt line, as shown below, will read 
"Assign materials to: <Selection>/Layer/Color/Browse:". You can either type in 
Selection, Layer, or Color; or you can click on the corresponding options on the 
popup menu that will appear (you can type the letters 's', 'l', or 'c' as shortcuts for 
selection, layer, or color). The default value is Selection, so if you would like that 
choice, you can just press enter. The Browse option allows you to look at and edit the 
materials library without affecting any material assignments.

 

To assign materials to a selection of drawing entities, you must designate to which 
entities you'd like to make the assignment. If any entities are already selected when 
you issue the materials command, the materials will be assigned to those entities and 
the Materials Properties window will appear immediately. If no entities are selected, 
then a prompt, "Select entities:", will appear and allow you to select an entity or 
group of entities. Once you have selected one or more enties, you can then type the 
"Enter" key to confirm your selection and then the Materials Properties window will 
appear. After you have made your material selection using the Materials Properties 
window and then click on the OK button, your material selections will be applied to 
all of the drawing entities selected.
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To assign materials to a layer, you must choose to which layer you'd like to make the 
assignment. A selection dialog box as shown below will appear and you can select a 
layer by clicking on the layer.

Once you have clicked on the layer of interest, the Materials Assignment window will 
appear and enable you to assign the desired material to the chosen layer. Once you've 
done that you will return to the Select Layer dialog again. When you have completed 
assigning materials to the various layers in the drawing, you can click the Done but-
ton to return to the drawing.

To assign materials to a drawing color, you must choose to which color you'd like to 
make the assigment. The color chooser, shown below, is similar to the normal 
AViCAD color selection dialog and allows you to click on one of the 256 different 
AViCAD drawing colors. 
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Once you have clicked on the color of interest, the Materials Properties window will 
appear. When you are finished assigning materials to the various colors you can click 
the Done button to return to the drawing.

In addition to the normal OK, Cancel, and Help buttons, a Clear Assignment button is 
provided at the bottom of the dialog box. This button will clear the material assign-
ment for the selected entities, layer, or color. This is useful for example if you have 
assigned a material to a particular entity, but then wish to have the entity drawn using 
the material selected for the layer. In this case you can select the entity, then issue the 
materials command to open the Material Assignment dialog and then click on the 
Clear Assignment button. The material selection will then be removed from that 
entity and the next time it is rendered it will use the material selection for the layer.

Material Library
The material library provides a selection of predefined materials that you can assign 
to the surfaces in your drawing. These predefined materials are shown in a file selec-
tion box on the left-hand side of the window. Folders in the file selection box can be 
opened or closed by clicking on the plus or minus sign to the left of the folder name. 
Individual materials can be selected by clicking on the name (ending in ".tex"). Once 
you click on the material name, a preview image will be shown in the right-hand-side 
area. The Brightness slider on the far right side next to the preview window adjusts 
the brightness of the preview image. Moving the slider tab up will increase the bright-
ness and moving it down will make the preview image darker. It does not in any way 
affect the rendering of the model.



498   C H A P T E R  1 6

The predefined materials listed in the Material Library are initially stored in files on 
your hard disk. When they are assigned to a surface in your drawing, a copy of the 
material definition is loaded and saved in the drawing file. This ensures that your 
drawing will render the same even if you later edit the material definitions on your 
hard disk. 

Above the file selection box on the left-hand side of the window, there are three 
option buttons that let you select whether you'd like to see the materials that are saved 
in the current drawing (the "Drawing" option), the materials that are stored in the 
library on your disk (the "Library" option), or all materials in the current drawing and 
in the library (the "All" option). If you make changes to a material in the library, you 
may want to reload that material in other drawings so that the changes you made will 
be effective in those drawing. The "Reload" buttons on the right side of the file selec-
tion box allow you to do this. The Reload button will reload the definition of the cur-
rently selected material from the library. If the selected material is not loaded this will 
have no effect. The Reload All button will reload the definitions of all of the currently 
selected materials. 

Above the Reload button is a Save button. If you receive a drawing from someone 
else, it may have materials loaded in the drawing that are not in your material library. 
The Save button will allow you to save those materials to your library so that you can 
reuse them in other drawings. 

Below the file selection box are three buttons that allow you to create new materials, 
edit existing materials, or remove unneeded materials. The New button will create a 
new material and load the Material Editor dialog so that you can define the material's 
characteristics. The Edit button will load the Material Editor dialog so that you can 
modify the selected material's characteristics. The Remove button will removed the 
selected material from the drawing and will also delete the associated file from your 
material library. Note that if you'd like to create a new material based on one of the 
existing materials, you can use the Edit button and then Rename the material before 
saving it as described on the Material Editor page.
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Material Mapping
The Material Mapping tab controls how materials are mapped to surfaces in the draw-
ing. Most of the procedural materials and bitmapped materials are 2D in nature, while 
the surfaces in the drawing are 3D. Therefore there must be some method of mapping 
the 3D coordinates of the surface to the 2D coordinates of the material. As shown 
below, the Material Mapping tab gives you a number of options to specify the way 
this is done.

Three different mapping or projection types are available for doing this, Planar, 
Cylindrical, and Spherical. The option buttons at the top left of the dialog allow you 
to control which projection type is used. The three different projection types are illus-
trated below with the Planar to the left, Cylindrical in the middle and Spherical to the 
right.

In each case, the 2D image is mapped to the specified geometric shape. Obviously 
many surfaces will not be planes, cylinders, or spheres so the material is projected 
from that simple geometric shape to the real surface shape. 
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Below the projection type options, there is another block of options for selecting 
Plane Normal Vector, the Cylinder Major Axis or the Sphere Major Axis depending 
on the projection type. The Plane Normal Vector defines the orientation of the projec-
tion plane and is perpendicular (or normal) to the plane itself. For example, if you 
would like the projection plane to be the X-Y plane, the normal vector would be the Z 
Axis. For a Cylindrical projection, this vector defines the axis of the cylinder. For a 
Spherical projection, the vector points to the north pole of the sphere. The first three 
options are the axis directions, X, Y, and Z. The fourth option is to specify the normal 
or axis vector directly using the entry boxes just below. The final option is to use the 
normal vector calculated for the drawing entity itself. This last option works best for 
entities that are nearly planar. The software will calculate the average normal vector 
for the entity and use it for the projection.

The box toward the bottom of the window provides entries where you can specify the 
Center vector, the Scale vector, the Rotation angle, and the Skew angle for the 
project. The Center vector defines where the center of the plane, cylinder, or sphere 
will be. If the Auto checkbox to the right of the entries is checked, the center of the 
drawing entities will be used. The Scale vector adjusts the size of the material as 
applied to the surface. For planar mapping, scale values of 1 will result in the image 
extending over a unit square (i.e., a square with width and height equal to one). If the 
scale values are greater than one, then the image will extend over a larger area. For 
example, if the x scale value (the first entry) is 2, then the image will extend over a 
rectangular area of width 2. If the y scale value (the second entry) is 3, then the image 
would extend over a rectangular area of height 3.

For cylindrical mapping, scale values of 1 will result in the image extending over a 
cyclinder of unit height and all the way around the cyclinder. The first/X component 
is mapped to the angle around the cylinder. The x value for cylindrical mapping will 
always lie in the range 0 to 1 around the circumference of the cyclinder. Thus x scale 
values greater than 1 will result in only part of the image being shown. The second/Y 
component is mapped to the height of the cylinder and the third/Z component is the 
distance from the centerline.

For spherical mapping, scale values of 1 will result in the image extending com-
pletely around the unit sphere. Note that the center of the image will be stretched 
around the "equator" of the sphere. The top and bottom of the image will be shrunk 
down to points at the "poles." The x and y values for spherical mapping will alway lie 
in the range from 0 to 1 around the sphere. Thus x or y scale values greater than 1 will 
result in only part of the image being shown. The x value is the azimuthal angle or 
longitude angle around the equator of the sphere. The y value is the elevation or lati-
tude angle on the sphere and the z value is the radial distance from the center of the 
sphere.

The rotation and skew angles control the angle at which the pattern is applied. For a 
planar mapping, the rotation angle and skew angle are applied the same way and are 
essentially added together to rotate the pattern on the plane. For a cylindrical and 
spherical mappings, the rotation angle controls where around the circumference of 
the cylinder the wrap line appears. The skew angle controls the angle of the pattern 
with respect to the axis of the cylinder. The illustration below illustrates the effect of 



R E N D E R    501

rotation and skew on an image mapped to the surface of a cylinder. The left hand 
image has a rotation and skew angle of zero degrees. The middle image has a rotation 
angle of -60 degrees. Note that the image has been rotated around the circumference 
of the cylinder. The right image has a skew angle of 45 degrees. The image has been 
skewed so that the image is no longer lined up with the axis of the cylinder.

Material Editor
The Material Editor window allows you to modify the properties of any of the materi-
als in the current drawing or in the material library. The window includes the name of 
the material at the top, three tabbed worksheets for editing the material properties, 
and a preview window on the right-hand side. The three tabbed worksheets are enti-
tled Surface Pattern, Color Map, and Surface Finish. The Surface Pattern worksheet 
allows you to choose the type of color pattern that will be displayed on surfaces in 
your drawing or as a background for your drawing. Fifteen different patterns (or pro-
cedural textures) are available and each has various parameters that control the look 
of the pattern. The Color Map worksheet allows you to choose the colors that will be 
used with the selected pattern. Finally, the Surface Finish worksheet allows you to 
specify how light will reflect off of the surface and the transparency of the surface.



502   C H A P T E R  1 6

The preview window on the right side of the dialog box enables you to see how the 
material will look. After you have made a change to the material, you can click on the 
Preview button and the image of the material in the preview window will be updated 
to reflect the current settings. The material is shown as a flat 2D surface 1 unit wide 
by 1 unit high. When you actually assign the material to a surface in your drawing, 
the Material Mapping worksheet will allow you to control how the 2D pattern is 
mapped to a three dimensional surface.

If you would like to rename the material, you can click on the Rename button and 
then modify the name of the material in the entry area at the top of the window. After 
you complete your changes and click on the Save button, you will then be asked to 
confirm that you want to remove the old material as shown below.

If you click Yes, the old material will be removed from the drawing and the library. If 
you click No, the old material will remain as well as the modified material. This is 
useful if you'd like to create a new material based on one of the existing ones.



R E N D E R    503

Surface Pattern
The Surface Pattern worksheet is part of the Material Editor dialog box. This work-
sheet allows you to choose the type of color pattern that will be displayed on surfaces 
in your drawing or as a background for your drawing. The simplest option is the Solid 
Color pattern option shown below. This option simply applies a solid color to the 
entire surface. For the Solid Color pattern you can select the color by clicking on the 
button labeled Pattern Color (colored white in the example below). 

Once you click on the Pattern Color button, a color chooser dialog box illustrated 
below.
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This dialog box will allow you to select which color you'd like to use for the drawing 
entity.

In addition to the Solid Color option, a number of other additional patterns are avail-
able as described in the table below. The appearance of the patterns can be further 
changed by modifying the way the material or texture is mapped to the drawing entity 
surface through the Material Mapping tab on the Material Assignment dialog.

Most of these patterns utilize the colors defined on the Color Map worksheet and sig-
nificant variations can be achieved by modifying the color map.

Pattern Description

Use Entity Color This selection is similar to the solid color option, but uses the color assigned to 
the drawing entity. This allows you to assign the same surface finish to several 
different entities or to a layer, but allow them to have different surface colors.

Image This pattern allows you to select an image file that will be used to color the 
drawing entities surface.

Gradient A linear gradient fill. The color map defines the way the color changes along the 
gradient direction.

Grit This pattern is a solid colors whose intensity varies in a psuedo-random manner 
to simulated a gritty appearance.

Marble A pattern simulating the color variations and striations appearing in marble.

Wood This pattern simulates the concentric growth rings seen in wood.

Checker A planar checkerboard type pattern.

Solid Checker A solid checkerboard type pattern. Not only do the colors alternate in one plane 
but also in the direction normal to the plane.

Agate A pattern simulating the color variations of agate.

Bozo The bozo pattern is commonly used to simulate the apperance of clouds.

Granite A pattern simulating the color variations of granite.

Onion A pattern simulating the concentric spherical layers of an onion.

Tile A regular geometric pattern simulating tiles or bricks in a "stacked bond" 
configuration. The tile color and morter/grout color is controlled by the colormap 
as well as the thickness of the morter/grout line. The size of the tiles or bricks is 
controlled by the scale parameters.

Brick A regular geometric pattern simulating tiles or bricks in a "running bond" 
configuration. The tile color and morter/grout color is controlled by the colormap 
as well as the thickness of the morter/grout line. The size of the tiles or bricks is 
controlled by the scale parameters.
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Agate Pattern

The agate pattern varies the color in a turbulent pattern that sim-
ulates the appearance of venis in various types of natural stone. 
The turbulence parameter controls the degree of irregularity in 
the pattern.

The parameters available to modify the pattern are described in 
the table below and an example of the Surface Pattern worksheet 
for agate is also shown. The colors associated with the agate pat-

tern are controlled by using the Color Map tab.

 

Parameter Description

Center The center vector includes three numbers (x, y, and z coordinates) that 
determine the center of the pattern. Changing this vector will offset the pattern 
in the direction specified.

Scale The scale value determines the size of the pattern in each of the three axis 
directions. Larger scale values will increase the overall size of pattern.

Noise Octaves The noise model used to for the agate pattern superimposes mulitple layers or 
octaves of pseudo-random variations. Each layer has a higher frequency and a 
lower magnitude. The superposition or fractal approach results in very complex 
and natural-looking patterns. The Noise Octaves parameters controls how 
many different layers or octaves of random variations are used in the noise 
computation.
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Bozo Pattern

The bozo pattern is typically used to simulate the appearance of 
clouds in the sky. The parameters available to modify the pattern 
are described in the table below and an example of the Surface 
Pattern worksheet for bozo is also shown. The colors associated 
with the bozo pattern are controlled by using the Color Map tab.

Fractal 
Dimension

The fractal dimension controls the magnitude of successive octaves of noise. 
For example, a value of 0.5 would result in each octave being one half the 
magnitude of the previous octave.

Lacunarity The lacunarity controls the relative size of successive octaves of noise. For 
example, a value of 2.0 would result in each octave have approximate twice the 
frequency of variation as the previous octave.

Turbulence Turbulence controls the magnitude of the random variations in the pattern. Zero 
turbulence would result in a regular geometric pattern. Larger values result in 
increasing amounts of pseudorandom variation. 

Parameter Description
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Brick Pattern

The brick pattern generates a regular geometric pattern simulat-
ing tiles or bricks in a "running bond" configuration where each 
row is offset from the row beneath it. The tile color and morter/
grout color as well as the thickness of the morter/grout line are 
controlled by using the Color Map tab. The size of the tiles or 
bricks is controlled by the scale parameters. The other parame-
ters are described in the table below.

Parameter Description

Center The center vector includes three numbers (x, y, and z coordinates) that 
determine the center of the pattern. Changing this vector will offset the pattern.

Scale The scale value determines the size of the pattern in each of the three axis 
directions. Larger scale values will increase the overall size of pattern.

Noise Octaves The noise model used to for the bozo pattern superimposes mulitple layers or 
octaves of pseudo-random variations. Each layer has a higher frequency and a 
lower magnitude. The superposition or fractal approach results in very complex 
and natural-looking patterns. The Noise Octaves parameters controls how 
many different layers or octaves of random variations are used in the noise 
computation.

Fractal 
Dimension

The fractal dimension controls the magnitude of successive octaves of noise. 
For example, a value of 0.5 would result in each octave being one half the 
magnitude of the previous octave.

Lacunarity The lacunarity controls the relative size of successive octaves of noise. For 
example, a value of 2.0 would result in each octave have approximate twice the 
frequency of variation as the previous octave.

Turbulence Turbulence controls the magnitude of the random variations in the pattern. Zero 
turbulence would result in a regular geometric pattern. Larger values result in 
increasing amounts of pseudorandom variation. 
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Checker Pattern

The checker pattern varies the surface color in an alternating 
checker-board pattern as shown above. The parameters available 
to modify the pattern are described in the table below and an 
example of the Surface Pattern worksheet is also shown.

Parameter Description

Center The center vector includes three numbers (x, y, and z coordinates) that 
determine the center of the pattern. Changing this vector will offset the pattern 
in the direction specified.

Scale The scale values determines the size of the bricks in each direction. The first 
value determines the width of the bricks (where width represents the length of 
the long side of a typical brick). The second value determines the height (top to 
bottom) of the brick and the third value determines the depth (front to back).
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Image Surface Pattern

The image surface pattern uses an image or bitmap file to color th e selected surface. 
This can be used to generate very sophisticated patterns and also to merge your CAD 
model with an existing scene or background. The Image Filename entry specifies the 
file to use for the pattern and the Center vector and Scale vector control the placement 
and size of the image on the surface. The meaning of each of these parameters is dis-
cussed in the table below.

Parameter Description

Center The center vector includes three numbers (x, y, and z coordinates) that 
determine the center of the pattern. Changing this vector will offset the pattern 
in the direction specified.

Scale The scale value determines the size of the pattern blocks in each direction.

Pattern Colors The two pattern color buttons are used to specify the two alternating colors of 
the checker pattern. Clicking on either of the two buttons will activate a color 
chooser window that will allow you to choose the colors of interest.
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Gradient Pattern

The gradient pattern provides a way to smoothly vary the color 
of a surface between two or more different colors. For example 
the sphere above used the gradient pattern to vary the color from 
blue at the top to red at the bottom.

As shown below, several parameters control the gradient effect, 
including the Center vector and Scale. The meaning of each of 
these parameters is discussed in the table below. The colors asso-

ciated with the gradient pattern are controlled by using the Color Map tab.

Parameter Description

Image Filename The image file parameter determines the name of the file used. Note that the 
file name is stored with the drawing. The image itself is not stored in the 
drawing. Consequently, if the image file location is moved, renamed, or deleted, 
the image will not be found during rendering and the surface will be colored 
black.
Note that if you put only the filename and not the full path here, then you can 
move the drawing file and image file together to different locations without 
breaking the association.

Center The center vector includes three numbers (x, y, and z coordinates) that 
determine the placement of the image during rendering.

Scale The scale vector determines how the width and height of the image is scaled. 
The first number controls the image width, and the second controls its height.
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Granite Pattern

The granite pattern varies the color in a turbulent pattern that 
simulates the appearance of veins in various types of natural 
stone. The parameters available to modify the pattern are 
described in the table below and an example of the Surface Pat-
tern worksheet for granite is also shown. The colors associated 
with the granite pattern are controlled by using the Color Map
tab.

Parameter Description

Center The center vector includes three numbers (x, y, and z coordinates) that 
determine the center of the gradient sweep. This point will be the midpoint of 
the sweep and will have a value of 0.5.

Scale The scale value determines the distance over which the gradient sweep takes 
place. This value represents the total distance from one extreme to the other 
along the direction vector specified by U Axis. 
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Parameter Description

Center The center vector includes three numbers (x, y, and z coordinates) that 
determine the center of the pattern. Changing this vector will offset the pattern 
in the direction specified.
If the checkbox labeled Auto to the right of the number entry blanks is checked, 
then the center vector will be automatically calculated as the centroid of each 
entity or block to which this pattern is applied. Since in the automatic mode the 
center vector is recalculated for each entity or block, there will be a discontinuity 
in the pattern between different entities or blocks that share the same pattern. 
You can avoid this discontinuity by manually setting the center vector to a 
common value for all of the entities or blocks that share the pattern.

Scale The scale value determines the size of the pattern in each of the three axis 
directions. Larger scale values will increase the overall size of pattern.

Noise Octaves The noise model used to for the granite pattern superimposes mulitple layers or 
octaves of pseudo-random variations. Each layer has a higher frequency and a 
lower magnitude. The superposition or fractal approach results in very complex 
and natural-looking patterns. The Noise Octaves parameters controls how 
many different layers or octaves of random variations are used in the noise 
computation.

Fractal 
Dimension

The fractal dimension controls the magnitude of successive octaves of noise. 
For example, a value of 0.5 would result in each octave being one half the 
magnitude of the previous octave.

Lacunarity The lacunarity controls the relative size of successive octaves of noise. For 
example, a value of 2.0 would result in each octave have approximate twice the 
frequency of variation as the previous octave.
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Grit Pattern

The grit pattern applies a slight pseudo random 
variation in the surface color that gives the 
appearance of a gritty texture. For example, the 
two spheres below have the same color applied, 
but the left sphere uses the Grit pattern and the 
right uses the Solid Color pattern.

The only parameter available for this pattern type 
is the color. To change the color click on the button labelled "Pattern Color." A color 
selection window will then appear and enable you to select the color of interest.

Marble Pattern

The marble pattern varies the color in a repeating wave pattern 
that simulates the appearance of veins in marble and other types 
of natural stone. The turbulence parameter controls the degree of 
irregularity in the pattern.

The parameters available to modify the pattern are described in 
the table below and an example of the Surface Pattern worksheet 
for marble is also shown. The colors associated with the marble 

pattern are controlled by using the Color Map tab.
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Parameter Description

Center The center vector includes three numbers (x, y, and z coordinates) that 
determine the center of the pattern. Changing this vector will offset the pattern 
in the direction specified.

Scale The scale value determines the size of the pattern in each of the three axis 
directions. Larger scale values will increase the overall size of pattern.

Noise Octaves The noise model used to for the marble pattern superimposes mulitple layers or 
octaves of pseudo-random variations. Each layer has a higher frequency and a 
lower magnitude. The superposition or fractal approach results in very complex 
and natural-looking patterns. The Noise Octaves parameters controls how 
many different layers or octaves of random variations are used in the noise 
computation. 

Fractal 
Dimension

The fractal dimension controls the magnitude of successive octaves of noise. 
For example, a value of 0.5 would result in each octave being one half the 
magnitude of the previous octave.

Lacunarity The lacunarity controls the relative size of successive octaves of noise. For 
example, a value of 2.0 would result in each octave have approximate twice the 
frequency of variation as the previous octave.

Turbulence Turbulence controls the magnitude of the random variations in the pattern. Zero 
turbulence would result in a regular geometric pattern. Larger values result in 
increasing amounts of pseudorandom variation. 
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Onion Pattern

The onion pattern varies the color in a series of concentric 
spheres around the center similar to the layers in an onion. It can 
be used to simulate a random ripple effect or wood burl. The 
parameters available to modify the pattern are described in the 
table below and an example of the Surface Pattern worksheet for 
onion is also shown. The colors associated with the onion pattern 
are controlled by using the Color Map tab.

Parameter Description

Center The center vector includes three numbers (x, y, and z coordinates) that 
determine the center of the pattern. Changing this vector will offset the pattern 
in the direction specified.

Scale The scale value determines the size of the pattern in each of the three axis 
directions. Larger scale values will increase the overall size of pattern.
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Solid Checker Pattern

The solid checker pattern varies the surface color in an alternat-
ing checker-board block pattern as shown above. This pattern 
differs from the checker pattern in that the blocks alternate in all 
three dimensions instead of just two dimensions. The parameters 
available to modify the pattern are described in the table below 
and an example of the Surface Pattern worksheet is also shown.

Noise Octaves The noise model used to for the onion pattern superimposes mulitple layers or 
octaves of pseudo-random variations. Each layer has a higher frequency and a 
lower magnitude. The superposition or fractal approach results in very complex 
and natural-looking patterns. The Noise Octaves parameters controls how 
many different layers or octaves of random variations are used in the noise 
computation. 

Fractal 
Dimension

The fractal dimension controls the magnitude of successive octaves of noise. 
For example, a value of 0.5 would result in each octave being one half the 
magnitude of the previous octave.

Lacunarity The lacunarity controls the relative size of successive octaves of noise. For 
example, a value of 2.0 would result in each octave have approximate twice the 
frequency of variation as the previous octave.

Parameter Description
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Tile Pattern

The tile pattern generates a regular geometric pattern simulating 
tiles or bricks in a "stacked bond" configuration. The tile color 
and morter/grout color is controlled by the colormap tab. The 
size of the tiles or bricks is controlled by the scale parameters. 
The other parameters are described in the table below.

Parameter Description

Center The center vector includes three numbers (x, y, and z coordinates) that 
determine the center of the pattern. Changing this vector will offset the pattern 
in the direction specified.

Scale The scale values determines the size of the pattern blocks in each direction. 

Pattern Colors The two pattern color buttons are used to specify the two alternating colors of 
the checker pattern. Clicking on either of the two buttons will activate a color 
chooser window that will allow you to choose the colors of interest.

Parameter Description

Center The center vector includes three numbers (x, y, and z coordinates) that 
determine the center of the pattern. Changing this vector will offset the pattern 
in the direction specified.

Scale The scale values determines the size of the tile blocks in each direction. 
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Wood Pattern

The wood pattern varies the color in a series of concentric rings 
that simulates the grain pattern in wood. The turbulence parame-
ter controls the degree of irregularity in the pattern.

The parameters available to modify the pattern are described in 
the table below and an example of the Surface Pattern worksheet 
for wood is also shown. The colors associated with the wood pat-
tern are controlled by using the Color Map tab.

Parameter Description

Center The center vector includes three numbers (x, y, and z coordinates) that 
determine the center of the pattern. Changing this vector will offset the pattern 
in the direction specified.

Scale The scale value determines the size of the pattern in each of the three axis 
directions. Larger scale values will increase the overall size of pattern.

Noise Octaves The noise model used to perturb the wood grain pattern superimposes mulitple 
layers or octaves of pseudo-random variations. Each layer has a higher 
frequency and a lower magnitude. The superposition or fractal approach results 
in very complex and natural-looking patterns. The Noise Octaves parameters 
controls how many different layers or octaves of random variations are used in 
the noise computation.
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Color Map 
The Color Map worksheet, illustrated below, is part of the Materials Editor dialog 
boxes. This worksheet allows you to choose the colors that will be used with the 
selected pattern on surfaces in your drawing or as a background for your drawing. 
The different surface patterns calculate a value between 0 and 1 for each point on the 
surface of the entity using a specific algorithm. For example, the gradient pattern cal-
culates the distance for each surface point from the specified origin along a specified 
direction. A scale factor is provided and the value is limited to lie within the range 0 
to 1. The Color Map worksheet allows you to control how those values are then 
mapped to colors for display in the rendered image.

The worksheet includes a colored slider bar across the top with five sliders and five 
corresponding color indicators at the bottom. The first slider is constrained to remain 
at the left side of the bar corresponding to a value of 0 (zero). The last slider is con-
strained to remain at the right side of the bar corresponding to a value of 1 (one). The 
other three sliders can be moved up or down to control the color map. The color rep-
reseted by each slider can be controlled by clicking on the color indicator buttons at 

Fractal 
Dimension

The fractal dimension controls the magnitude of successive octaves of noise. 
For example, a value of 0.5 would result in each octave being one half the 
magnitude of the previous octave.

Lacunarity The lacunarity controls the relative size of successive octaves of noise. For 
example, a value of 2.0 would result in each octave have approximate twice the 
frequency of variation as the previous octave.

Turbulence Turbulence controls the magnitude of the random variations in the pattern. Zero 
turbulence would result in a regular geometric pattern. Larger values result in 
increasing amounts of pseudorandom variation. 

Parameter Description
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the bottom of the worksheet. This will bring up a color selection dialog that will allow 
you to select the color of choice. The selected color will be used for values that are 
near the slider position. For values between slider positions, the color will be a mix-
ture of the color map colors above that value and below it. As you move the sliders or 
adjust the colors, the background of the slider bar will change to illustrate the color 
mapping.

For example, in the illustration above a brick pattern is used to simulate a red brick 
wall. Colormap values around 0 are a gray color representing the mortar. The body of 
the brick is represented by a red color from values of 0.05 to 1.0. 

Significantly different effects can be generated using the same pattern but modifying 
the color map. As you change the colors you can click on the Preview button to the 
right to observe the effect.

Surface Finish
The Surface Finish worksheet, illustrated below, is part of the Materials Editor dialog 
box. This worksheet allows you to specify how light will reflect off of the surface and 
the transparency of the surface. It includes one checkbox and 6 different sliders. For 
each of the sliders, the value can be adjusted by clicking on the slider tab and moving 
it up or down. The value is shown as the tab is moved and is also displayed to the 
right of the slider. All except the Light Reflection Size range from 0 to 1. The Light 
Reflection Size ranges from 0 to 500.
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Parameter Description

Metallic Finish This controls whether the surface is assumed to be metallic or not. When this is 
checked, light bouncing off of the surface takes on some of the color of the 
surface. For non-metallic surfaces, light bouncing off of the surface remains the 
same color as the light source.

Ambient Light Ambient light is used to model the small scale diffuse reflections that tend to fill 
in shadows and dark areas in real life scenes. Raytracing algorithms trace the 
major light reflections and shadows, but in a real-life scene there are many 
small scale reflections and refractions that cannot be modeled effectively with 
raytracing. For example, with raytracing areas that are in shadows tend to be 
very dark if not entirely black. In real life, shadows tend to be filled in by small 
scale or diffuse reflections off of other objects. Ambient light is a way to 
approximately model this effect. If the ambient light value is above 0 the surface 
will appear even if it is not lit by a light in the scene. Ambient light is equally 
distributed over the surface regardless of the angle of view.

Diffuse Light Diffuse light models the way light reflects off of a rough surface. When light 
shines off of a rough surface it is reflected in every direction by the surface. In 
contrast, a very smooth surface such as a mirror reflects the light primarily one 
direction (i.e. the specular direction). The intensity of diffuse lighting depends 
on the angle that the light hits the surface and not the angle that the viewer 
observes the surface. 

Specular 
Reflection

The specular reflection value controls the way other objects reflect off of the 
surface. If this value is greater than 0 then when a ray hits this surface, a 
reflection ray will be generated and traced. Consequently, the image of other 
surfaces will be reflected on this surface.

Light Reflection This parameter controls how light reflects off of the surface in specular 
highlights. Smooth surfaces reflect most of their light in the specular direction 
(imagine a ball bouncing off of a flat surface). In contrast, rougher surfaces will 
scatter the light in a diffuse reflection The light reflection parameter controls the 
magnitude of this specular highlight that occurs.

Light Reflection 
Size

The light reflection size parameter controls the size of the specular highlight 
that appears on an object. A value of one will produce a very diffuse reflection 
similar to the affect produced by the diffuse light parameter. Higher values of 
this parameter will produce smaller/tighter highlights on the surface.

Transparency Transparency controls the way light filters through the surface. If this parameter 
is greater than 0 then some portion of what lies behind the object will show 
through it. If this parameter is 1, then the object is totally transparent and will not 
be visible at all. 
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Background 

Toolbar: Render > Background ( ).

Menu: View > Render > Background.

Keyboard: BACKGROUNDS.

Alias: BACKGROUND.

The Background Properties window allows you to specify the background or back-
drop for your image. It is essentially identical to the Material Assignment window 
except that it applies to the background instead of surfaces in the drawing. The back-
ground is an infinite plane behind the rest of your drawing. A variety of background 
options are available as described below. By default, no background is used and the 
background will appear black. Note that the background is an infinite, planar surface 
and will reflect off of any reflective surfaces in your model. The background is not 
affected by lighting however, so no shadows or highlights will be seen on the back-
ground. 

You can access the Background Properties window using any of the toolbar, menu or 
keyboard commands shown above. The Background Properties window includes two 
different tabbed worksheets and a preview area as illustrated below. The first tab is 
entitled Material Library and allows you to select from among a variety of predefined 
materials for the background. This tab also includes buttons that allow you to create 
new materials or edit existing ones. The second tab is titled Material Mapping and is 
used to control the scaling and positioning of the material on the background.
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The quickest way to get started specifying a background is to select from among the 
predefined materials available on the Material Library tab. The available predefined 
materials are shown in a file selection box on the left-hand side of the window. Fold-
ers in the file selection box can be opened or closed by clicking on the plus or minus 
sign to the left of the folder name. Individual materials can be selected by clicking on 
the name (ending in ".tex"). Once you click on the material name, a preview image 
will be shown in the right-hand-side area, and the properties for that material will be 
loaded. You can then click on the "OK" button to accept the properties, or you can 
click on the Material Mapping tab to adjust the way the material is mapped to the sur-
face.

The Brightness slider on the far right side of the window adjusts the brightness of the 
image in the preview window. Moving the slider tab up will increase the brightness 
and moving it down will make the preview image darker. It does not in any way 
affect the rendering of the model.

The Clear Assignment button at the bottom left of the window allows you to remove 
the background material altogether. If this is done, the background will then be ren-
dered as black.

Background settings are stored in the drawing.

Light 

Toolbar: Render > Lights ( ).

Menu: View > Render > Light.

Keyboard: LIGHTING.

Alias: LIGHT.

The Lighting command activates the Lighting dialog box which allows you to specify 
how your drawing or scene is lit. You can control placement of the lights, light color, 
and light intensity. The Lighting dialog box, illustrated below, includes four buttons 
in the upper left corner of the window that allow you to select a preset lighting con-
figuration. To the right of those buttons is a list of all of the lights currently defined in 
the drawing and buttons that allow you to add or delete from the list of lights. The 
change the characteristics of a particular light in the drawing, you first click on the 
name of the light in the light list. In the upper right corner of the window, the name of 
the selected light will be shown, as well as the color of the light and the light type.
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Various other light parameters will be shown in the middle section of the window 
depending on the particular light type. Three types of lights are available to use in 
your drawing, Ambient light, Point lights, and Distant lights. An Ambient light 
illuminates the entire scene evenly (depending on the Ambient component of the 
Material finish). It does not cast shadows or change with viewing angle. A Point light 
represents light eminating from a single point in the drawing. Shadows will be cast by 
surfaces in the drawing and you will see highlights where the light reflects off of the 
surfaces. Point lights can also have a size or diameter to them so that they cast soft 
shadows. A Distant light represents a light from a large distance away from the sur-
faces in the drawing (e.g. the sun). All of the light rays are essentially parallel to each 
other so the shadows cast by the light have sharp edges.

The quickest way to specify a lighting configuration is to select one of the several 
preset light configurations provided including "Eye Light," "Side Light," "Sun 
Light," and "Back Light". All of these options add a small amount of ambient light 
and then a single point light. The Eye Light places the point light at the eye position 
for the scene. The Side Light option adds the point light at the upper right side of the 
scene. The Sun Light option adds a slightly yellowish light at a fixed point in the 
drawing coordinate system. The Back Light option adds the light behind and above 
the scene. Examples are shown below of the preset lighting on an example sphere.
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In addition to these preset lighting configurations, you can add individual lights by 
clicking on the "Add" button to the right of the list. You can delete lights by first 
clicking on the light in the list and then clicking on the "Delete" button to the right of 
the list. When you click on a light in the list it becomes selected and the parameters 
for that light are shown in the lower part of the window. Once you have selected the 
light of interest you can modify its parameters using the controls in the lower part of 
the window. 

Lighting settings are stored in the drawing.

Ambient Light
An ambient light illuminates the entire scene evenly and does not cast shadows or 
change with viewing angle. The parameters available for an ambient light are the 
light color and the light intensity. Ambient light can be used to fill in dark or shad-
owed areas of a drawing. It can also be used to make certain objects in a scene appear 
to glow. Note that too much ambient light will make the scene flat and lifeless since it 
flattens the shadows and highlights that provide depth cues.

Eye Light Side Light

Sun Light Back Light
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Point Light
A point light represents light eminating from a specific point in (or out of) the draw-
ing scene. Several additional parameters are available for the point light including its 
position, and its diameter. The diameter controls the size of the light source and hence 
the sharpness of the shadows cast by the light. A true point light source would have a 
diameter of zero and casts sharp-edged shadows. A larger diameter makes the light 
source into an area light source that will cast softer-edged shadows. Note that soft-
edged shadows require additional rendering time (please see the description of the 
Area Lights/Soft Shadows parameter on the Rendering Options dialog).

Control Description

Name The name field is an arbitrary name you can specify for the light to identify it in 
the Lights list at the top.

Color Clicking on the button in the color box will bring up a color selection dialog 
window that will allow you to specify the color for the light.

Intensity The light intensity is specified using this slider that ranges from 0 to 200. 100 is 
full intensity and 0 is completely dark. This allows you to adjust the brightness 
of the scene. Values above 100 will produce a brighter scene, but may 
oversaturate some areas.
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The position of the point light can be specified in several ways: in angles relative to 
the current view, in angles relative to the drawing World Coordinate System, or in 
drawing coordinates (X, Y & Z). If the "View" Coordinate System is selected as 
shown below, you will have the option to set the azimuth angle, elevation angle, and 
distance of the light relative to the current view. The azimuth angle is the angle in the 
horizontal plane relative to the scene center. Looking down from above, the camera 
position would be at zero degrees and the angle is measured clockwise. For example, 
90 degrees would be to the camera's left, 180 degrees would be behind the scene, and 
270 degrees would be to the camera's right. The elevation angle is the angle of the 
light above the viewing plane. An elevation angle of zero means that the light lies on 
the viewing plane, and an angle of 90 degrees means that it is straight above the scene 
center. The distance is the radial distance from the scene center to the light in drawing 
units. In this coordinate system, the light position will change relative to the drawing 
as you zoom, pan or rotate the view of the drawing. 

If the "World" Coordinate System is selected, the same azimuth angle, elevation 
angle and distance parameters are available. In this case however, the angles are mea-
sured relative to the drawing's World Coordinate System. The Azimuth angle is mea-
sured in the X-Y plane with zero degrees being in the +Y direction and 90 degrees 
being in the +X direction. The Elevation angle is measure above the X-Y plane. The 
distance is the distance from the light to the origin of the drawing World Coordinate 
System (0, 0, 0). 

If the "XYZ" Coordinate System is selected, the position of the light is specified 
using drawing coordinates (X, Y, Z) directly as shown below. These coordinates are 
relative to the drawing World Coordinate System.
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Detailed descriptions of each of the entries is presented in the table below.

Control Description

Name The name field is an arbitrary name you can specify for the light to identify it in 
the Lights list at the top.

Coordinate 
System

Point lights can be positioned anywhere in the scene either relative to the 
viewer or relative to the scene itself. If View is selected, the light is positioned 
relative to the viewer and as the view is modified by rotating or panning the 
drawing, then the light position will move as well. If World coordinates are 
selected, then the light will be placed at a fixed position relative to the drawing 
itself and the azimuth, elevation, and distance parameters are relative to the 
drawing origin (0, 0, 0). If XYZ coordinates are selected, then again the light will 
be placed at a fixed position relative to the drawing and you can enter the light 
X, Y, and Z coordinates directly. Lights placed in either the World or XYZ 
coordinate systems will not change position as you zoom or pan the drawing.

Color Clicking on the button in the color box will bring up a color selection dialog 
window that will allow you to specify the color for the light.

Intensity The light intensity is specified using this slider that ranges from 0 to 200. 100 is 
full intensity and 0 is completely dark. This allows you to adjust the brightness 
of the scene. Values above 100 will produce a brighter scene, but may 
oversaturate some areas.

Diameter The light diameter is specified using this slider that ranges from 0 to 1,000 
drawing units. Larger diameters will produce softer edged shadows. A diameter 
of zero will produce a hard edged shadow.
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Distant Light
A Distant light represents a light that is a large distance away from the surfaces in the 
drawing (e.g. the sun). All of the light rays are essentially parallel to each other so the 
shadows cast by the light have sharp edges. This option allows you to use a Sun Posi-
tion Calculator that will calculate the position of the sun at any time of the day or year 
at any point on the earth's surface. With this type of light, the light's position is always 
calculated in the drawing's World Coordinate System. The Azimuth angle measures 
the compass bearing in the X-Y plane to the light and the Elevation angle measures 
the angle of the light relative to the X-Y plane horizon. By default, an azimuth angle 
of 0 degrees is in the +Y direction. However, this can be altered by adjusting the Site 
Orientation parameter on the Site Location tab of the Render Settings dialog.

As shown in the image below, on the middle right side of the dialog box, a Sun Posi-
tion Calculator is available. This calculator enables you to calculate the position of 
the sun relative to any point on the earth's surface and any time. It contains entry 
blanks for the date and time. It also contains a button, "Edit Site Position", that will 
show the Site Location dialog and allow you to specify the latitude and longitude of 
the site represented by the drawing. Once you have set the site location, the date, and 
the time, you can press the button labeled "Calculate Azimuth and Elevation" and the 
software will calculate the sun position.

Azimut The azimuth slider allows you to position the light in the azimuthal direction. 
This is best envisioned as a compass heading. When working in World 
coordinates, the azimuth is measured by standing at the scene origin, with the 
compass N heading pointed in the +Y direction. The direction to the light is then 
read from the compass. For example, an azimuth setting of 90 deg would be in 
the easterly or +X direction. When working in View coordinates, the azimuth is 
measured by standing at the view center point with the compass N heading 
pointing at the eye position. An azimuth setting of 90 deg would then be to the 
viewer's left.

Distance This is the distance in drawing units to the light from the view center point (in 
View coordinates) or from the drawing origin (when using World coordinates).

Elevation This is the vertical angle between the horizon and the light. In World 
coordinates, this is measured from the X-Y plane through the origin to the light. 
In View coordinates, the horizon plane is the plane normal (perpendicular) to 
the view "up" direction. An elevation value of 0 is on the horizon and an 
elevation value of 90 degrees is straight up.

Light 
Coordinates

If the XYZ Coordinate system is selected, then lights can be placed using their 
X, Y, and Z coordinates directly. Text entry boxes will be displayed for each of 
the three coordinates.

Control Description
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Control Description

Name The name field is an arbitrary name you can specify for the light to identify it in 
the Lights list at the top.

Color Clicking on the button in the color box will bring up a color selection dialog 
window that will allow you to specify the color for the light.

Intensity The light intensity is specified using this slider that ranges from 0 to 200. 100 is 
full intensity and 0 is completely dark. This allows you to adjust the brightness 
of the scene. Values above 100 will produce a brighter scene, but may 
oversaturate some areas.

Azimut The azimuth slider allows you to position the light in the azimuthal direction. 
This is best envisioned as a compass heading. The azimuth is measured by 
standing at the drawing origin, with the compass N heading pointed in the +Y 
direction. The direction to the light is then read from the compass. For example, 
an azimuth setting of 90 deg would be in the easterly or +X direction.

Elevation This is the vertical angle between the horizon and the light. This is measured 
from the X-Y plane through the origin to the light. An elevation value of 0 is on 
the horizon and an elevation value of 90 degrees is straight up.

Date This is the date at which the sun position will be calculated. The sun position 
varies based on the day of year and also to a lesser extent the particular year.
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Preferences 

Toolbar: Render > Render Preferences ( ).

Menu: View > Render > Preferences.

Keyboard: SETRENDER.

Alias: RPREF.

The Render Preferences command allows you to control several aspects of the render-
ing system and the Render Settings dialog box is divided into five different work-
sheets entitled: Rendering, Shadows, Floor, Site, and Render to File.

• The first worksheet, entitled "Rendering" is used to control rendering quality, anti-
aliasing, and surface smoothing. It also provides buttons that allow you to save 
your rendered image to a file or to redisplay the last rendered image. 

• The second worksheet, entitled "Shadows" is used to control some of the aspects 
of the shadow computations in the rendering module.

• The third worksheet, entitled "Floor" is used to control the optional floor that can 
be placed beneath drawings when they are rendered.

• The fourth worksheet, entitled "Site" is used to set the location of the drawing on 
earth and the orientation of the drawing axes to true North. This information is 
used in calculating sun angles for lighting purposes.

• The fifth worksheet, entitled "Render to File" is used to rendering the drawing 
directly to a file on disk. This allows you to generate rendered images at any 
desired resolution independent of the screen resolution.

Each different worksheet can be accessed by clicking on the corresponding tab at the 
top of the dialog box.

Render settings are stored in the drawing.

Time This is the local time of day in the timezone specified on the Site Location 
dialog. Note that daylight savings time is not automatically included so standard 
times should be used.

Calculate 
Azimuth and 
Elevation

This button will cause the sun's azimuth and elevation to be calculated at the 
specified time and date.

Edit Site Position This button will show the Site Location dialog to allow you to adjust the site 
position (latitude and longitude), site time zone, and site orienation (relative to 
true north).

Control Description
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Rendering Worksheet 
The Rendering worksheet appears on the Render Settings Dialog box and is used to 
control rendering quality, antialiasing, surface smoothing, and shadow depth. It also 
provides buttons that allow you to save your rendered image to a file or to redisplay 
the last rendered image.

The Rendering worksheet is shown below and is followed by a table listing each of 
the available controls and their function.
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Control Description

Rendering 
Quality

The Rendering Quality pulldown menu allows you to control the quality of the 
rendered image and hence the time needed to compute it. Three options are 
available, "Low Quality," "Medium Quality," and "High Quality."
• Low Quality - Rendering is calculated without shadows, reflections, or trans-

parency.
• Medium Quality - Rendering is calculated without shadows.
• High Quality - Rendering is calculated with approximate shadows using a 

technique called "Adaptive Shadow Testing." This accelerates the rendering 
significantly when rendering scenes with multiple lights, but some artifacts 
and inaccuracies in the shadows may be noted in the image.

• Very High Quality - Rendering is calculated with detailed shadows, reflec-
tions, and transparency.

Redisplay Last 
Image

When a rendered image is computed and displayed on the screen, a copy is 
saved in memory for later use. After the image is displayed, it will be erased if 
you interact with the drawing or perform a redraw or regen of the drawing. The 
Redisplay Last Image button will redisplay the last rendered image onto the 
drawing window.
The image will be displayed exactly as it was seen before. Any changes to the 
drawing or drawing view will not be reflected. Moreover, the last rendered 
image could even be from a different drawing than the one currently displayed.

Save Last Image Once you have generated a rendered image that you would like to save, you 
can use the "Save Last Image" button to save the image to a file. Once you 
click on this button, you will have the opportunity to select a filename for the 
rendered image. Images can be saved in BMP, JPEG, TIFF, TGA, or PNG 
format. The saved image will be in 24 bit, full-color format at the same 
resolution as rendered on the screen.

Antialiasing In regions of the rendered image where the light intensity changes dramatically 
such as near surface edges, jagged edges may appear due to the sampling 
nature of the rendering process. Antialiasing attempts to aleviate these 
problems by taking multiple samples for each pixel in the rendered image and 
averaging the result. This can significantly improve the quality of the final 
image, but also significantly increases rendering time. By default, antialiasing is 
turned off. You may wish to active it for your final rendering step.

Surface 
Smoothing

AViCAD approximates curved surfaces by subdividing the surface into multiple 
flat polygons. The surface smoothing option smooths the transitions between 
individual faces on asurface so that curved surfaces will appear more rounded.

Double Sided Individual surfaces in the image are considered to have a front and a back face. 
This check box controls whether the renderer treats the front and back faces 
the same or not. If this box is not checked, then any light rays that hit the back 
face of a surface are essentially ignored (i.e. the back face is considered black 
and non reflective). If the box is checked, then the back face is treated the same 
as the front face.
Which face is considered front and which is considered back is controlled by the 
order of the vertices. Looking at the face, if the vertices proceed around the 
face in a counter-clockwise order, then the face is the front. If the vertices 
proceed around the face in a clockwise fashion, then you are looking at the 
back of the surface.
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Shadows Worksheet
The Shadows worksheet appears on the Render Settings Dialog box and is used to 
control some of the aspects of the shadow computations in the rendering module.

The Shadows worksheet is shown below and is followed by a table listing each of the 
available controls and their function.

Control Description

Area Lights/Soft 
Shadows

This option allows you to control the quality of the soft shadow computations. 
Soft shadows from area lights, that is lights that have some non-zero diameter, 
are calculated by taking multiple samples of the light at each point in the image. 
The higher this number the more accurate the lighting calculations will be, but 
the longer the rendering process will take.

Shadow Depth Shadow depth controls the number of light reflections or transmissions that are 
considered when generating the image. If your scene contained several 
mirrored surfaces that faced each other, the software could spend a 
considerable amount of time bouncing rays of light back and forth between the 
mirrored surfaces. The shadow depth option controls this by only allowing the 
renderer to consider a specified number of "bounces." Each time a light ray hits 
a surface and reflects off of it, or travels through it if the surface is transparent, 
the "depth" of the ray is increased. The number specified in this entry box will 
control how many reflections or transmissions the renderer considers.

Adaptive 
Shadow Testing

Adaptive Shadow Testing is an algorithm used to speed up the rendering 
process when rendering scenes with multiple light sources. This algorithm 
attempts to identify which light sources are most significant for each part of the 
scene and only directly samples those lights. The light cast by less significant 
light sources is estimated based on statistical techniques.
This slider controls the degree to which the technique will be applied. The 
higher the value set, the more rendering will accelerated, but the more 
approximate the lighting calculations. If the slider is set to 0, all of the light 
sources will be tested and shadows will be calculated exactly. If the slider is set 
to 1, only the strongest light source at each pixel will be tested and the 
contributions for other lights will be estimated. The Adaptive Shadow Testing 
algorithm is only used when Rendering Quality is set to High.
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Floor Worksheet
The Floor worksheet appears on the Render Settings Dialog box and controls whether 
or not a floor is displayed underneath the rest of the drawing during rendering. As an 
example, the drawing on the left below is shown without a floor and the drawing on 
the right is shown with the floor. The floor is drawn in the X-Y plane touching the 
lowest point (smallest Z value) on the drawing. The Z direction is assumed to be "up". 

The Floor worksheet is shown below and is followed by a table listing each of the 
available controls and their function. 

Control Description

Enable Floor This checkbox controls whether or not the floor is displayed. If the box is 
checked, then the floor is displayed. If the box is not checked then the floor is 
not displayed.

Edit Floor 
Material

This button opens the material selection dialog so that you can control the 
appearance of the floor. By default, a solid white/gray color floor is provided.

Floor Size This slider bar controls the size of the floor. If the slider is at the minimum 
position, then the floor will extend to the X and Y limits of the drawing. If the 
slider is moved to the right the size of the floor will increase.
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Site Settings
The Site tab of the Render Settings dialog allows you to specify the location and ori-
entation of the site where the drawing is located. This information is used in calculat-
ing the position of the sun for lighting purposes. The tab contains entries for the site 
latitude and longitude, the time zone, and site orientation relative to true north. In 
addition, it includes a pull-down menu containing a list of a number of major cities 
around the world. If your building site is in or near one of these cities you can choose 
that city and the latitude, longitude and time zone will be entered automatically. 

The site orientation represents the angle of true north relative to the drawing axes. By 
default, true north is assumed to be in the +Y direction. The site orientation value 
measures the angle from the +Y direction in drawing coordinates to true north. If the 
site orientation value is 90 degrees, then true north would be in the +X direction. If it 
is set to 180 degrees, then true north would be in the -Y direction.

Note that the Site Location parameters take effect the next time the sun position is 
calculated. The Site Orienation parameter will take effect when the next rendering is 
performed.

Render to File
The Render to File tab will allow you to produce a rendered image directly to a file on 
disk rather than to the AViCAD screen. The tab includes two entry blanks so that you 
can specify the desired width and height of the image in pixels. Once you have 
entered the desired values, you can click the button labeled "Render" to start the ren-
dering process. There is no preset limits on the width and height dimensions, how-
ever, the larger they are the longer the process will take and the more memory will be 
required. 
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After the rendering process has been started, you can interrupt it by pressing the 
Escape (Esc) button. You will not be able to use the AViCAD software until render-
ing processing is completed or cancelled.
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Google Earth

AViCAD add-on application for Google Earth is useful in viewing your CAD models 
in the Google Earth environment, rich in maps and satellite images. This tool allows 
you to import in the dwg file a Google Earth image that shows the location of your 
project and its geographical coordinates. It is also possible to publish your CAD 
model in Google Earth exporting a .kmz file.

Topics in this chapter

AViCAD Google Earth add-on .......................................................................... 540

Publishing 3D DWG Models to Google Earth ................................................... 542
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AViCAD Google Earth add-on

To publish your 3D model into Google Earth, you should know its position on the 
earth's surface. The easiest method to find it is firstly to import a Google Earth area 
view into AViCAD.

You can import the current Google Earth view into AViCAD and use this raster 
image as a background for a drawing or, that is more important, to give a geographi-
cal reference of your DWG model position on the earth’s surface.

Carrying out this command you have to bring an image into AViCAD, and adjust the 
image position according to your model until you see it is in the proper position on 
the earth's surface.

To publish a 3d model in Google Earth

1 Start Google Earth, and zoom to the location on the earth's surface where you want 
to put your model in.

2 Be sure you are looking perpendicular to the earth's surface (that is, the view 
doesn’t have any rotation.)

3 Zoom in to capture enough detail of the location area.

4 Keep Google Earth maximized. Do not minimize or close Google Earth applica-
tion.
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To import an image in AViCAD

1 Start AViCAD and open your file 3D in the plan view.

2 Select the button on the Google Earth toolbar or type importgeimage in the 
AViCAD Command Line

3 Set drawing units for picture scaling

4 After a few seconds, the current Google Earth’s view will be imported and placed 
at the point  0, 0  in the coordinate system of your drawing ( if you can’t see it, 
zoom extents to include all objects of the drawing). The image displayed in the 
drawing is a JPG file and it is stored in the same directory as the DWG file. 
Your display should look similar to this figure:  

The following suggestions may be of help:

• Once placed, you can use the AViCAD 'move' and 'rotate' commands to refine 
your model’s position relative to the image. Do not adjust the position of the Goo-
gle Earth’s image. For details, see Chapter 10, “Rearranging entities.” 

• Use the Draw Order command to send an image below. 

• The image is black and white – a current limitation imposed by Google Earth.
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To use Draw Order command

1 Do one of the following: 

• Choose Tools > Draw Order. 

• On the Tools toolbar, click the Draw Order tool

• Type draworder and then press Enter. 

2 Select the entity you want to reorder, and then press Enter. 

3 In the prompt box, specify the new drawing order, and then press Enter. 

4 If you are reordering above or under, select the entity you want the first entity to 
be above or below, and then press Enter. 

Publishing 3D DWG Models to Google Earth

To publish 3D DWG data to Google Earth

1 Do one of the following:

• choose Add-on > Google earth > publish kml

• type publishkml 

2 In the dialog box of the command, use the “Get georeference data from picture” 
button and select Google Earth’s image previously inserted to pick your Earth 
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position.If the position and rotation of a model relative to the image are correct, 
there’s no need to modify the orientation of the Y axis to North.

3 The output file name is given automatically from the DWG file name and direc-
tory. The Kmz file generated by export has the same name and it is stored in the 
same folder as the DWG file.

4 Select the option Export with Materials to get  a model with the materials pre-
assigned via O2C. 

5 When you have finished, click on Ok
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Working with other programs

AViCAD® offers great flexibility in its capability to be used with other programs. 
You can include an AViCAD drawing in a Microsoft Word document or insert a 
Microsoft Excel spreadsheet containing a parts list into an AViCAD drawing. To 
include AViCAD drawings in other programs and documents from other programs in 
AViCAD drawings, you either link or embed them. You can also save AViCAD 
drawings in other file formats that can be used directly with other programs or send 
AViCAD drawings to coworkers via e-mail.

This chapter explains how to:

• Save and view snapshots.

• Use object linking and embedding.

• Export AViCAD drawings to other file formats.

• Send drawing files via e-mail.

• Use AViCAD with the Internet.

Topics in this chapter

Saving and viewing snapshots.......................................................................... 546

Using data from other programs in AViCAD drawings ...................................... 547

Using AViCAD data in other programs.............................................................. 551

Using AViCAD with the Internet ........................................................................ 562

Other programs................................................................................................. 565
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Saving and viewing snapshots

You can save snapshots of a drawing to view later. A snapshot saves the current 
drawing in either *.emf, *.wmf, or *.sld format exactly as it appears on the screen. A 
snapshot is not a drawing file. You cannot edit or print the snapshot; you can only 
view it.

You can use snapshots in the following ways:

• Make presentations by showing snapshots of your drawings.

• Reference a snapshot of a drawing while working on a different drawing.

• Present a number of snapshots as a slide show by using scripts.

When you view a snapshot, it temporarily replaces the current drawing. When you 
refresh the display of the current drawing (by redrawing, panning, zooming, minimiz-
ing, maximizing, or tiling), the snapshot image disappears, and you are returned to 
the current drawing.

You create a snapshot by saving the current view as a snapshot. A snapshot does not 
include any entities on layers that are not currently visible. The contents of the snap-
shot also depend on the current drawing space. In model space, the snapshot shows 
only the current viewport. In paper space, the snapshot contains all visible viewports.

To create a snapshot 

1 Display the drawing exactly as you want to capture it as a snapshot.

• Choose Tools > Make Snapshot.

• Type msnapshot and then press Enter.

2 In the Create Snapshot dialog box, specify the name of the snapshot file you want 
to create.

3 From the Files Of Types list, choose either *.emf, *.wmf, or *.sld.

4 Click Save.

The current drawing remains on the screen, and the snapshot is saved to the directory 
that you specify. You can view previously saved snapshots, and you can also view 
snapshots created using AutoCAD.

To view a snapshot

1 Do one of the following: 

• Choose Tools > View Snapshot.

• Type vsnapshot and then press Enter.

2 In the View Snapshot dialog box, specify the name of the snapshot file you want 
to view.

3 Click Open.

AViCAD displays the snapshot in the current drawing window.
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Using data from other programs in AViCAD drawings

You can include data from other programs in AViCAD drawings by using either 
embedding or linking. The method you choose depends on the type of object or file 
you want to include in your AViCAD drawing and what you want to do with it after it 
is there.

Embedding objects into drawings
Embed an object into your AViCAD drawing when you want to keep all the data you 
work with in one file or if you want to transfer the file to other computers. You can 
embed data from programs that support object linking and embedding.

For example, if you want to distribute data about a department’s computer equipment 
along with an AViCAD drawing of the department’s floor plan, you can embed a 
Microsoft Excel spreadsheet into the floor plan.

When you embed data from another program, AViCAD becomes the container for 
that data. The object embedded in the AViCAD drawing becomes part of the 
AViCAD file. When you edit the data, you open its program from within the 
AViCAD drawing.

Any changes you make to the embedded data exist only in the AViCAD drawing, so 
it is not necessary to keep that data in a separate file. If the data does exist in a sepa-
rate file, the original file does not change when you modify the embedded object in 
AViCAD. Also, changes to the original file do not affect the embedded object in the 
AViCAD drawing.

To embed another program’s object into an AViCAD drawing

1 Open the file that contains the data you want.

2 In the file, select the data you want to embed in the AViCAD drawing.

3 Choose that program’s command to place data on the Clipboard.

Usually, you choose Edit > Copy.

4 In the AViCAD window, display the drawing in which you want to embed the 
object.

5 Choose Edit > Paste, or click the Paste tool ( ) on the Standard toolbar.

The data on the Clipboard is pasted into the drawing as an embedded object. The 
object appears in the center of the view, but you can select and move it by moving 
the cursor.
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To embed an object from an existing file within AViCAD      

1 Do one of the following:

• Choose Insert > OLE Object.

• On the Insert toolbar, click the OLE Object tool ( ).

• Type insertobj and then press Enter.

2 In the Insert Object dialog box, click Create From File.

3 Specify the file by doing one of the following:

• Type a path and file name in the File box.

• Click Browse to select a file.

4 Select Display As Icon if you want that program’s icon to appear in the drawing 
instead of the data.

5 Click OK.

The first page of the file appears in the AViCAD drawing, unless you chose to dis-
play it as an icon. You can select the object and drag to reposition it.

To create a new embedded object from within AViCAD

1 Do one of the following:

• Choose Insert > OLE Object.

• On the Insert toolbar, click the OLE Object tool ( ).

• Type insertobj and then press Enter.

2 In the Insert Object dialog box, click Create New.

3 From the Object Type list, select the type of object you want to create, and then 
click OK.

The program for creating that object opens within AViCAD. If the program is 
compatible with ActiveX, it opens in place (within the other program) in the 
AViCAD drawing; otherwise, the program opens in its full window.

4 Create the object in the other program.

5 If the program is running within the other document (in place), click anywhere 
outside the embedded object to close the program.

If the program is running in its full window, choose File > Exit.

Linking objects to drawings
If another program supports ActiveX, you can link its data to AViCAD drawings. 
Use linking when you want to include the same data in many files. When you update 
the data, all links to other files reflect the changes.

For example, if you created your company logo in an ActiveX-compatible drawing 
program, and you want to include it in the title block of every drawing you create 
with AViCAD, you can link it to each AViCAD drawing. When you change the orig-
inal logo in the drawing program, the AViCAD drawing updates automatically.
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When you link data from another program, the AViCAD drawing stores only a refer-
ence to the location of the file in which you created the data. You link data from a 
saved file, so AViCAD can find the data and display it.

Because linking adds only a reference to a file, the data does not significantly 
increase the file size of the AViCAD drawing. However, links require some mainte-
nance. If you move any of the linked files, you need to update the links. In addition, if 
you want to transport linked data, you must include all linked files.

You can update a linked object automatically every time you open the drawing, or 
you can do so only when you specify. Anytime a link is updated, changes made to the 
object in its original file also appear in the AViCAD drawing, and the changes also 
appear in the original file if they were made through AViCAD.

To link a file to an AViCAD drawing

1 Save the original file. 

Because a link consists of a reference to the original file, you must save the file 
before you can link to it.

2 In the original file, select the data you want in the AViCAD drawing.

3 Choose that program’s command to place data on the Clipboard.

Usually, you choose Edit > Copy.

4 Display the AViCAD drawing to which you want to link the file.

5 In AViCAD, choose Edit > Paste Special.

6 In the Paste Special dialog box, select Paste Link.

7 Click OK.

To create a linked object from within AViCAD   

1 Display the AViCAD drawing in which you want to display the linked object.

• Choose Insert > OLE Object.

• On the Insert toolbar, click the OLE Object tool ( ).

• Type insertobj and then press Enter.

2 In the Insert Object dialog box, click Create From File.

3 Specify the file by doing one of the following:

• Type a path and file name in the File box.

• Click Browse to select the file using a file dialog box.

4 Select the Link check box.

5 Select Display As Icon if you want that program’s icon to appear in the drawing 
instead of the data.

6 Click OK.

The first page appears in the AViCAD drawing, unless you chose to display it as 
an icon. To reposition the object, select and drag it.
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Editing an embedded or linked object from within AViCAD
You can modify an embedded or linked object in its original program from within 
AViCAD. When you modify an embedded object, you change the object only in 
AViCAD, not its original file (if you pasted the object from an existing file). When 
you modify a linked file, however, you open and change the original file.

Most programs include a submenu of actions you can perform on an embedded or 
linked ActiveX object. Usually, the commands for editing ActiveX objects are Edit 
and Open. If the object is embedded and its program supports in-place editing, the 
Edit command opens the object in place. The Open command opens the object in the 
full program window. In AViCAD, this command appears at the bottom of the Edit 
menu.

To edit an embedded or linked object 

• In the AViCAD drawing, double-click the object.

If the object is embedded and the program in which you created the object supports 
in-place editing, the object opens in place.

If the object is linked, or if its program does not support in-place editing, the other 
program opens in its full window and displays the object.

Importing files created in other formats
You can import the following files:

• Drawing Exchange Format files with a .dxf file extension. This file type is an 
ASCII or binary description of a drawing file.

• Design Web Format files with a .dwf file extension. DWF™ files are used to dis-
tribute a drawing for others to view in a Web browser, review, and edit using free 
Autodesk® software and tools.

• Drawing templates with a .dwt file extension. This file type contains predefined 
settings that you can reuse when you create new drawings.

• Three-dimensional entities saved with an .sat file extension. This file type contains 
three-dimensional ACIS solids saved as an .sat file. 

Importing a DXF, DWF, or DWT file
Importing DXF, DWF, and DWT files is similar to opening a standard drawing file.

To import a DXF, DWF, or DWT file 

1 Use one of the following methods: 

• Choose File > Open. 

• On the Standard toolbar, click the Open tool ( ).

• Type open and then press Enter. 

2 Choose the folder that contains the drawing. 

3 In Files of Type, choose the type of drawing you want to import. 
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4 Choose the file you want to open. 

5 Click Open.

Importing an ACIS file
An ACIS file contains three-dimensional solids, regions, or bodies that are saved as 
an ASCII .sat file. 

To import an ACIS file

1 Do one of the following:

• Choose File > Acis In.

• On the Insert toolbar, click the Acis File tool ( ).

• Type acisin, and then press Enter. 

2 Choose the directory containing the SAT file. 

3 Choose the SAT file you want to open. 

4 Click Open.

Using AViCAD data in other programs

You can use any of the following methods to include AViCAD data in a document 
created in another program:

• Embedding

• Linking

• Dragging

• Exporting

• E-mailing

The method you choose depends on the capabilities of the other program and how 
you want to work with the AViCAD data after you’ve placed it in the other 
document.

NOTE Each method except exporting uses ActiveX to integrate data from different 
programs. With ActiveX, you can open AViCAD drawings from within the other pro-
gram to modify the AViCAD drawings.

Embedding drawings
When you embed an AViCAD drawing, it becomes part of the other program’s docu-
ment file. When you edit the drawing, you edit only the version that is embedded in 
the other document.
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Embedding is useful when you don’t want to maintain a link to the AViCAD drawing 
for the data you include in the other document. Edits made to the new drawing do not 
affect the original drawing. To transfer the file to other computers, you can transfer 
all the data in one file, but embedded objects increase the file size.

From within a document in a program that supports ActiveX, such as Microsoft 
Word, you can either create a new embedded AViCAD drawing or embed an existing 
AViCAD drawing.

To create an AViCAD drawing in another document

1 In the document, choose Insert > OLE Object (or the equivalent command for that 
program).

2 In the dialog box, click the options for creating a new file. 

3 Under Object Type, choose AViCAD Drawing, and then click OK.

4 Create the AViCAD drawing.

5 If AViCAD is running in its own window, choose File > Exit.

If AViCAD is running within the other document (in place), click somewhere in 
the document outside the AViCAD drawing to close AViCAD.

6 To edit the AViCAD drawing from within the document, double-click the draw-
ing.

NOTE You can also embed an existing AViCAD drawing from within another docu-
ment. Follow step 1 in the preceding procedure, and then click the option for creating 
an object from an existing file.

To embed selected AViCAD entities

1 In AViCAD, select the entities you want to embed.

2 Choose Edit > Copy (or press Ctrl+C).

3 Open the document in which you want to embed the entities. 

4 Choose Edit > Paste (or the equivalent command).

To embed an entire AViCAD drawing

1 Open the document in which you want to embed the drawing.

2 Choose Insert > OLE Object.

3 Click Create From File.

4 Click Browse, and then choose the file you want to embed.

5 Click Insert, and then click OK.
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Editing an embedded AViCAD object in place
In many ActiveX-compatible programs you can edit an embedded AViCAD object 
without leaving the program (or container application). This is called in-place editing. 
A different set of AViCAD menus and toolbars temporarily replaces most of the 
menus and controls in the active window while you edit the AViCAD object.       

To edit an embedded AViCAD object in place

1 In the container application, double-click the embedded AViCAD object.

A different set of AViCAD menus and controls appears.

2 Edit the AViCAD drawing.

3 Click anywhere outside the drawing window to exit the in-place editing controls.

Linking drawings
When you link an AViCAD drawing to another document, the other document con-
tains only a reference to the AViCAD drawing file, rather than the actual drawing. 
You link data in a saved AViCAD file so that the other program can find the data and 
display it.     

Linking works well when you want to include the same AViCAD data in more than 
one document. When you update the data, you need update it in only one location. 
The versions that are linked to other documents reflect the changes automatically.

Linking an AViCAD file to another document does not increase the file size the way 
embedding an AViCAD object does. However, links require more maintenance. To 
transport the data, you must make sure to transfer all linked files to the other 
computer.

To link an AViCAD file to another document

1 Open the drawing you want to link.

NOTE Because a link is a reference to a file, you can link only files that are saved to 
a location on a disk. If you haven’t saved the drawing you want to link, choose  
File > Save.

2 In the other program, open the document in which you want to include the 
AViCAD drawing.

3 Choose that program’s command for inserting objects.

In Microsoft Office programs, choose Insert > OLE Object. In the Object dialog 
box, click the Create From File tab. Specify the name of the drawing file you want 
to link. Select the Link To File check box, and then click OK.

The drawing appears in the document, with a link to the original AViCAD file.
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Dragging AViCAD drawings into other programs
If the other program in which you want to include AViCAD drawings is compatible 
with ActiveX, an alternative to pasting drawings with menu commands is to drag 
drawing file icons from Windows Explorer into the other document. Dragging and 
dropping drawings does not use the Clipboard, so data on the Clipboard is not 
affected. 

When you drag an AViCAD drawing file from Windows Explorer, you link or embed 
the entire drawing in the other document. When you drag the file, the cursor changes 
in response to the action you take.

NOTE Before you drag a drawing, position the Windows Explorer window and the 
other program’s window so you can see the file icon and the document in which you 
want to drop it.

To drag and embed drawings into another document

• Select the icon for the drawing file, and then drag the drawing into the document.

Exporting drawings
You can save or export AViCAD drawings in a number of different formats for use 
with other programs. When you save a drawing in a different format, the program 
saves all the entities in the drawing to the new file. Or, you can choose which entities 
are included in the new file. 

How the cursor changes

Cursor appearance Action

Drag to embed the selected file to the other 
document. 

Cannot drop drawings in that document.

Export formats

Format File extension Details

AutoCAD Drawing DWG AutoCAD versions 2010, 2007, 2004, 2000, 
R14, R13, or R11/12,

ASCII AutoCAD Drawing 
Exchange Format

DXF AutoCAD versions 2010, 2007, 2004, 2000, 
R14, R13, R12, R11, R11, R10, R9, R2.6, 
R2.5,

Binary AutoCAD Drawing 
Exchange Format

DXF AutoCAD versions 2010, 2007, 2004, 2000, 
R14, R13, R12, R11, R11, R10, R9, R2.6, R2.

Bitmap BMP Graphics file

Enhanced Windows Metafile EMF Graphics file
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You can also export ACIS solids, regions, and surfaces to an ASCII file (*.sat) that 
you can use in other programs.

ATTENTION You can create PDF and JPG files with the print option in addiction to 
the formats previously listed. For more details, see Chapter 14, “Print a PDF or JPG 
file”. 

Exporting to a DWG, DXF, BMP, EMF, WMF,  or SVG file
Exporting to a file is similar to saving a standard drawing file.

To export a drawing to a DWG, DXF, BMP, EMF, WMF, or SVG file

1 Do one of the following:

• Choose File > Export.

• Type export and then press Enter.

2 Choose the file format.

3 Specify the name of the file you want to create.

4 Click Save.

5 If the selection prompt box displays, choose the entity-selection method, and then 
create the selection set. 

6 When you have finished selecting entities, press Enter.

Exporting to a PDF file
PDF files allow you to distribute your drawing to others for viewing in Adobe® 
Acrobat® Reader®, which is free software that users can download. PDF files can 
also be viewed, reviewed, and edited in Adobe® Acrobat.

Windows Metafile WMF Graphics file

3D DWF DWF DWF V06.01

Design Web Format DWF Distribute your drawing to others for using 
with Autodesk® software and tools

Scalable Vector Graphics SVG Graphics file format and Web development 
language

Export formats

Format File extension Details
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To export a drawing to a PDF file

1 Do one of the following: 

• Choose File > Export > Export PDF. 

• Type export, press Enter and choose Portable Document Format (pdf). 

2 Specify the name of the file you want to create. 

3 Click Save. 

4 Choose the entity-selection method, and then create a selection set that contains 
the entities you want to export. 

5 When you have finished selecting entities, press Enter. 

6 Choose the options for how you want to export to the PDF file. 

7 Click Export. 

Exporting to a DWF file
Exporting to a DWF file is similar to saving a standard drawing file, except you spec-
ify options for how you want to save the DWF file.

DWF files allow you to publish your drawings so they can be viewed on the Internet 
using a Web browser. AViCAD exports your drawing to a Design Web Format (.dwf) 
file, which can be viewed in a Web browser if Autodesk® DWF Viewer is also 
installed on the computer. DWF Viewer is a free tool from Autodesk®.

You can export your drawing to a 2D DWF file or a 3D DWF file. 2D DWF files 
have smaller file sizes, but cannot be viewed in three dimensions. 3D DWF files can 
be viewed in three dimensions using the Autodesk® DWF Viewer, but have larger 
file sizes.
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To export a drawing to a 2D DWF file

1 Do one of the following:

• Choose File > Export > Other formats.

• Type export and then press Enter.

2 In Save As Type, choose Design Web Format (dwf).

3 Specify the name of the file you want to create.

4 Click Save.

5 Choose how you want to export:

• DWF File Version – Choose the DWF file version you want. Version 4.2 can 
export entities on the Model tab only (no layouts). Version 5.5 can export the 
current layout only. Version 6.0 can export the current layout or all layouts.

• DWF File Format – Choose the desired file format. Compressed binary files 
have a smaller file size than uncompressed binary files. ASCII files have the 
largest file size.

• Layout to Export – Choose whether to export the current layout only, or all 
layouts in the drawing.

6 Click OK.

7 Choose the entity-selection method, and then create a selection set that contains 
the entities you want to export.

8 When you have finished selecting entities, press Enter.

To export a drawing to a 3D DWF file

1 Do one of the following:

• Choose File > Export > Other formats.

• Type export and then press Enter.

2 In Save As Type, choose 3D DWF.

3 Specify the name of the file you want to create.

4 Click Save.

5 Choose the entity-selection method, and then create a selection set that contains 
the entities you want to export.

6 When you have finished selecting entities, press Enter.
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Exporting to a 3DS, POV or LWO file

To export a drawing to a file 

1 Choose File > Export and choose a format 

2 In the Export Drawing As File dialog box specify the name of the file you want to 
create. 

3 Click Save. 

4 Select the entities to export. 

5 When you have finished selecting entities, press Enter.

NOTE: If the selected drawing has at least one ACIS solid, an alert message will 
appear suggesting that you convert it to a surface using the 3Dconvert command. For 
more details  see “Convert a solid to a surface” on page 483. 

Exporting ACIS files
You can export ACIS entities such as surfaces, regions, and solids to an ACIS file in 
ASCII (SAT) format. 

To export an ACIS file

1 Do one of the following:

• Choose File > Acis Out.

• Type acisout and then press Enter. 

2 Select the ACIS entities you wish to save. 

3 Specify the name of the file you want to create. 

4 Click Save. 

Etransmit
With the help of  eTransmit you can prepare a file package for Internet transmission. 
When sending drawing files to other users  it is necessary to attach even related 
dependent files such as xrefs and text fonts. In some cases the lack of these files 
makes it impossible for an addressee to use drawing files. Dependent files in eTrans-
mit are automatically included in the transmission package,  reducing eventual errors. 
It is possible to remove automatically added files or add manually files that you want 
to include in the transmission package.

Most common files that are included in the transmission package are immages, print 
styles, line types and text fonts.  

NOTE:  If you want to send only a .dwg file, you can use the Send command from the 
File menu.  
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To create a group of files for transmission

1 Do one of the following: 

• Select File > eTransmit

• Type etransmit and then press Enter.

2 In the dialog box Create Transmission you will see two tabs where you can view 
and change the files that are to be added to the transmission package.

• Files Tree. A list of files is presented in this tab. You can expand or fold each 
drawing file in the list to view related dependent files that are added automati-
cally in the transmission package. It is possible to remove the dependent files 
that you do not want to include in the transmission package.

• Files Table. There is a summary table presented in this tab with the files, paths 
of relative folders and files details. You can select or deselect each file obtaining 
thus a direct control over the contents of the transmission package.

3 Enter notes to include with this transmittal package. You can add notes and com-
ments for a person who receives the transmission package. Besides,  a .txt report 
file is generated  automatically and contains a list of the files present in the trans-
mission package. The contents of this report are displayed when you click on the 
View Report button. 

4 Choose files to add to the package and confirm them pressing the OK button.

Transmittal setups
The Transmittal Setups button allows to save settings of a transmission package.
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If you need to send transmission packages several times within one project it is better 
to save the Transmittal Setups. The Transmittal Setups dialog box shows you a list of 
saved settings that you can choose every time when you transmit a group of files. The 
default Transmittal Setup is Standard.

To create new Transmittal Setups

1  Press the New button…

 

2 Indicate some name for the new settings and press Continue

3 There will appear a dialog box with options of  Transmittal Setups
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4 Choose transmission options and press OK to confirm.

These settings allow to:

• Compress the transmission package in a ZIP file or in a folder that is copied to a 
specified location. 

• Specify if the folder structure of the transmission files should be organized accord-
ing to a logical hierarchy, inserted in a single folder, or copied to the addressee’s 
computer “as is”. If a FTP or http destination is specified, the transmission package 
uses the single folder option. 

• Include .shx fonts used in the drawing, add password protection to the transmis-
sion package, set the default printer to "none" and send automatically an email after 
the transmission package creation is completed.

To conclude the transmission package creation select Transmittal Setups in the main 
dialog box and press the OK button.
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After having created the transmission package you can make it available through the 
Internet or you can send it to other users in an email attachment. If you send the trans-
mission package via email, there is an option in the Modify Transmittal Setups dialog 
box that launches automatically the default system email application when selected. 
When the transmission package is created, it is automatically attached to a new email 
together with a transmission report file. 

NOTE:  Any fully specified (absolute) paths of dependent files are converted to rela-
tive paths or "no path" to ensure that the drawing file can identify the dependent files.

Sending drawings through e-mail
You can send an AViCAD drawing to another user via e-mail. AViCAD is compati-
ble with e-mail programs that support the Messaging Application Program Interface 
(MAPI) protocol.

To include a drawing file in an e-mail message

1 While the drawing file is open, choose File > Send.

If your mail program is not already running, it starts; a new e-mail message con-
taining the AViCAD icon and file name appears.

2 Address the e-mail, type a message, and send the e-mail message as you would 
any other message.

To view a AViCAD file sent by e-mail 

• Open the e-mail message, and then double-click the AViCAD icon.

NOTE AViCAD software must be installed on the computer used to open drawings 
in e-mail.

Using AViCAD with the Internet

You can use AViCAD to access the Internet and exchange drawing information and 
perform other tasks, including:

• Add hyperlinks to a drawing

• Publish drawings to the Internet

• Access the Internet during a drawing session.

NOTE You will need Microsoft Internet Explorer Version 5.0 or later and access to 
the Internet to fully use these features.



W O R K I N G  W I T H  O T H E R  P R O G R A M S    563

Add hyperlinks to a drawing 
In your AViCAD drawings, you can include hyperlinks, which are pointers that take 
you to another location, such as a Web address or a file on a particular computer. You 
can attach a hyperlink to any entity in your drawing. Then, when you select that 
entity, you can open the link and jump to the specific Web address or file location. 
You can create absolute hyperlinks, which store the full path to a file, or relative
hyperlinks, which store a partial path relative to a base folder or URL.

NOTE To open files associated with hyperlinks, the PICKFIRST system variable 
must be set to On. 

To create a hyperlink

1 Type hyperlink and then press Enter.

2 Select an entity or entities that you would like to associate with a hyperlink; then 
press Enter to display the Edit Hyperlink dialog box.

3 Do one of the following: 

• Click Browse to specify a file.

• In the Link to File or URL box, type a Web address.

4 If you wish to use a common path for all hyperlinks in the drawing, check the Use 
relative path for hyperlinks box. Relative paths provide flexibility if you move 
files to a different folder, since you can change multiple hyperlink paths at once, 
rather than change them all individually. 

5 Click OK to close the Edit Hyperlink dialog box.
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NOTE The HYPERLINKBASE system variable defines the relative path used for all 
hyperlinks in the current drawing. To use the default drawing path, leave the value 
blank by entering a period (".").

To remove a hyperlink

1 Type hyperlink and then press Enter.

2 Select an entity or entities with a hyperlink; then press Enter to display the Edit 
Hyperlink dialog box.

3 Click Remove Link. 

4 Click OK to close the Edit Hyperlink dialog box.

To access a hyperlink

1 Select an entity with a hyperlink.

2 Right-click anywhere in the drawing area.

3 In the pop-up menu, choose Open Link.

Publishing drawings to the Internet
You can publish your drawings so they can be viewed on the Internet using a Web 
browser. AViCAD exports your drawing to a Design Web Format (.dwf) file, which 
can be viewed in a Web browser if DWF Viewer is also installed on the computer. 
DWF Viewer is a free tool from Autodesk®.

For details about creating a DWF file, see “Click Export.” on page 556 in this chap-
ter. 

NOTE You can also export drawings as a Vector Markup Language (VML) files, 
which are high-quality graphic files that can be viewed and downloaded quickly on 
the Internet. In the command bar, type vmlout to export a drawing to a VML file with 
an .htm file extension, which can be viewed directly in a Web browser.

Inserting drawings from a Web site
Some Web sites are configured to allow you to drag drawings from the Web site 
directly into your drawing. You can drag-and-drop drawings from any Web site that 
supports the Autodesk® i-drop® technology. 

To insert a drawing from a Web site

1 Open your Web browser.

2 Navigate to a Web site that supports Autodesk® i-drop. 

3 Position the Web browser and AViCAD windows so they are both visible.

4 Click the drawing in your Web browser and drag it to your drawing in AViCAD.

The drawing file is downloaded and inserted into your drawing in AViCAD.



W O R K I N G  W I T H  O T H E R  P R O G R A M S    565

Accessing the AViCAD Web site during a drawing session
In addition to using hyperlinks to access the Internet, you can access the AViCAD 
Web site at any time using the Onweb command. At the Web site, you can obtain 
information about the AViCAD as well as product information and news. 

To access the AViCAD Web site

1 Do one of the following: 

• Choose Help > AViCAD on the Web.

• Type onweb and then press Enter.

2 Navigate to the section of your choice on the AViCAD Web site.

Other programs

AViCAD full version includes a special application that allows you to modify and 
view raster images. see Chapter 19, “Image”. 
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Image

AViCAD full version includes a special application that allows you to insert, modify 
and view raster images directly inside AViCAD. You can load, edit, and modify mul-
tiple images as overlays or underlays to your AViCAD drawings.

Topics in this chapter

Image overview................................................................................................. 568

Image commands ............................................................................................. 568
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Image overview

AViCAD supplies the tools that make the management of the images easier, making 
the job more simple and effective. The images can be inserted, loaded, downloaded, 
updated, correlated, georeferenced, trimmed or deleted from the drawing as desired.

These images are selected for the use with AViCAD commands through their frame 
that can be set as On or Off for selection or printing reasons. If the image isn’t 
required in the drawing anymore, it will be possible to remove it.

AViCAD Image manager allows selecting the color transparence to be able to view 
the ones under through the first images. The command Arrangement allows to easily 
put in first or second place the images in the drawings.

Among the image formats that can be managed in the drawing have been introduced 
ECW and JPG2000. The compression format ECW, acronyms of Enhanced Com-
pressed Wavelet, has a diffuse standard to compress high dimension images, used 
very much in the geomatic field and developed by ER Mapper.  The JPG2000 com-
pression format, also based on Wavelet technology, has an international ISO stan-
dard, developed by Joint Photographic Expert Group (JPEG).

Thanks to the compression technique used, the result is the equivalent of a pyramidal 
image (in which the datum is present with more resolutions) without the waste of 
space connected to the storage of additional data. The data reading time and the time 
for the extraction of a raster datum portion at the resolution wanted for a correct view, 
are basically independent from the dimension of the overall image. The compression 
of lossless data, not involving any data losses, allows recovering all the information 
and exactly remake the original datum starting from the compressed datum. This 
characteristic is essential in all those application where it’s important to keep 
unchanged the pixel values of the images.

Image commands 

Attaching images
When you attach an image to a drawing, the image displays in the drawing but is not 
saved in the drawing. The image file remains saved in its original location on your 
computer, network, or other media.

If you send or receive drawings that contain images, it is important to include with the 
drawing all of the image files attached to it. When you open a drawing that contains 
images, the source image files must be accessible for the images to display in the 
drawing.
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To attach an image

1 Do one of the following:

• Choose Image > Attach Raster Image.

• On the Reference toolbar, click the Image Attach tool ( ).

• Type imageattach and then press Enter.

2 Specify a file to attach, and then click Open.

3 In Image Path will be Saved As, enter a different image file location, if necessary. 
You can click [ > ] to choose how you want to save the image path:

• Full Path — The image is referenced using its full path, for example, c:\My 
Pictures\MyImage.jpg. Use this option if the image is saved in a folder unrelated 
to the current drawing folder.

• Relative Path — The image is referenced using a path relative to the current 
drawing folder, for example, ..\My Pictures\MyImage.jpg. Use this option if the 
image is stored in a subfolder of the current drawing folder.

• File Name Only — The image is referenced using its file name in the current 
drawing folder, for example, MyImage.jpg. Use this option if the image is saved 
in the same folder as the current drawing.

4 In the Attach Image dialog box, specify the position, scale, rotation, transparency, 
and clipping options, and then click OK. 
For the automatic insertion of georeferenced images, use a positioning File (.tfw) 
that contains all raster attributes like: scale, position and rotation angle. This file 
should have the same name as the raster file. If it is so and it’s placed in the same 
directory of the image file, it will be viewed in the Positioning File box. To use it 
in the insertion of the image, select the option Use positioning file. The same 
option can be used to select a .twf file that doesn’t have the same name of the 
image file or that is in a different path then the image one. With that setting acti-
vated, the mask gets updated to reflect the settings related to the tfw file.

NOTE Transparency works for images that support alpha transparency, that is, 
images that have at least one color that can be viewed as a transparent color.

5 In the drawing, specify an insertion point, scale, and rotation if you chose to spec-
ify those on the screen.
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TIP You can also attach images using the Image Manager. Choose Image > Image 
Management, and then click Attach to specify an image and then attach it, or if you 
want to quickly add another occurrence of an image already located in the drawing, 
select the image in the Image Manager and then click Add.

Modifying images
You can modify an image by changing its brightness, contrast, fade, size, rotation, or 
transparency. These changes affect the image in the drawing only — not the original 
image file.

A Enter a different image file location, if necessary.

B Choose to place the image automatically in the 
drawing using specifications located in a 
positioning file. Enter the TWF file associated 
with the image or click [...] to select it.

C Choose to specify the insertion point in the 
drawing upon insertion, or enter coordinates.

D Choose to specify the size of the image in the 
drawing upon insertion, or enter the size values.

E Choose whether to turn clipping display on or off 
for the image.

F Choose whether entities located under the image 
are visible (for images that support alpha 
transparency).

G Choose to specify rotation in the drawing upon 
insertion, or enter how many degrees to rotate 
the image to the left.

H Click to view image information, including color 
depth and resolution. 

I Choose to save the image path as its full path, 
relative path to the current drawing folder, or file 
name in the current drawing folder.

A

B

C

D

E
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In addition to modifying a single image or multiple images that you select, you can 
also modify all occurrences of an image within a drawing. For example, if your com-
pany logo appears in multiple locations throughout a drawing, you can use the Image 
Manager to specify the changes once and apply them to all occurrences of the logo.

You can use other AViCAD commands for typical modifications, such as Delete, 
Move, Layer, and more.

To modify images

1 Do one of the following:

• Choose Image > Image Management.

• On the Reference toolbar, click the Image tool ( ).

• Type image and then press Enter.

TIP You can also modify images by selecting one or more images in a drawing, 
and then choosing Modify > Properties.

2 In the Images list, select the image you want to modify. If there is more than one 
occurrence of the image in the drawing, do one of the following:

• To modify all occurrences of the image, select a top-level image in the list.

• To modify a single occurrence of the image, expand a top-level image in the list, 
and then select the individual image.

3 Adjust the Brightness, Contrast, and Fade by moving the slider to the setting you 
want or by entering an exact number. The image preview shows how your changes 
will affect the image.

TIP If you want to restore the image to the default brightness, contrast, and fade 
settings, click Reset.

4 Adjust the Size by making changes to the width (X) and height (Y) in drawing 
units. Mark Keep Aspect Ratio if you want the width and height to change 
together to retain the aspect ratio of the image.

5 Adjust the Rotation by entering the number of degrees you want to rotate the 
image to the left. Zero degrees indicates no rotation.

6 Mark Use Transparency if you want entities located under the image to be visible 
(for images that support alpha transparency, that is, images that have at least one 
color that can be viewed as a transparent color).

7 Mark Show Clipping Boundary if you want to show the image clipped, if a clip-
ping boundary is defined for the image. Unmarking this option displays the whole 
image, even if a clipping boundary is defined.

8 Click OK.
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Changing the display of images
You can change the following for how all images display in a drawing:

• Image quality — Images can display in high or low resolution.

• Image frames — Images can display with or without frames on their edges.

A Click a top-level image to modify all occurrences 
located in the drawing. Expand a top-level image and 
click an individual image to modify that occurrence 
only.

B Move the slider or enter an exact number for image 
brightness.

C Move the slider or enter an exact number for image 
contrast.

D Move the slider or enter an exact number for image 
fade, which fades the image without displaying entities 
located under the image.

E Click to return to the default brightness, contrast, and 
fade settings.

F Enter the width (X) and height (Y) in drawing units. 
Mark Keep Aspect Ratio to change width and height 
together.

G Choose whether to turn clipping display on or off for 
the image.

H Choose whether entities located under the image are 
visible (for images that support alpha transparency).

I Enter how many degrees to rotate the image to the left.

A

B
C
D
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Changing the display quality for all images
High quality displays images in high resolution and requires more system resources. 
Draft quality displays images in low resolution and consumes fewer system 
resources. Changing the quality setting affects all images in the drawing.

To change the display quality for all images

1 Do one of the following: 

• Choose Image > Image Quality.

• On the Reference toolbar, click the Image Quality tool ( ).

• Type imagequality and then press Enter.

2 Choose High or Draft.

Turning image frames on or off for all images
When an image border is set to 0 it will not be printed or visualized, setting to1, it will 
be printed and visualized while, setting to 2 it will be visualized but not printed . Each 
image frame dis-plays with the properties (layer, color, linetype, etc.) that are 
assigned to the image.

Turning image frames off may be helpful, for example, if the images are part of a 
background in the drawing.

To turn image frames on or off for all images

1 Do one of the following: 

• Choose Image > Display Image Frame.

• On the Reference toolbar, click the Image Frame tool ( ).

• Type imageframe and then press Enter.

2 Choose an option.

Clipping images
You can clip images so that only a portion of the image is visible in a drawing. The 
visible portion can be in the shape of a rectangle or polygon.

Image clipping can be turned on an off. If you turn off clipping for an image, the 
entire image is visible provided that the image is on a layer that is on and thawed. The 
clipping information is retained however, and you can turn clipping back on at any 
time. 

If you delete clipping from an image, the clipping is removed permanently but the 
image itself remains in the drawing.
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To clip an image in the shape of a rectangle

1 Make sure that image frames are turned on (option 1).

2 Do one of the following:

• Choose Image > Clip Image.

• On the Image toolbar, click the Image Clip tool ( ).

• Type imageclip and then press Enter.

3 Select the edge of the image you want to clip.

4 Choose New to create a new clipping boundary.

5 Choose Rectangle.

6 Define the first corner of the clipping rectangle.

7 Define the opposite corner of the clipping rectangle. 
Only the portion of the image located within the clipping rectangle is visible..
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To clip an image in the shape of a polygon

1 Make sure that image frames are turned on (option 1).

2 Do one of the following:

• Choose Image > Clip Image.

• On the Reference toolbar, click the Image Clip tool ( ).

• Type imageclip and then press Enter.

3 Select the edge of the image you want to clip.

4 Choose New to create a new clipping boundary.

5 Choose Polygonal.

6 Select the points for the polygon, and then press Enter to close the polygon. 
Only the portion of the image located within the clipping polygon is visible.

To turn clipping on or off for an image

1 Make sure that image frames are turned on (option 1).

2 Do one of the following:

• Choose Image > Clip Image.

• On the Reference toolbar, click the Image Clip tool ( ).

• Type imageclip and then press Enter.

3 Select the edge of the image for which you want to turn clipping on or off.

4 Choose On or Off.
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To remove clipping from an image

1 Make sure that image frames are turned on (option 1).

2 Do one of the following:

• Choose Image > Clip Image.

• On the Reference toolbar, click the Image Clip tool ( ).

• Type imageclip and then press Enter.

3 Select the edge of the image for which you want to remove clipping.

4 Choose Delete.

Unloading and reloading images
If you find that including an image affects system performance, you can unload it so 
only the image frame displays to mark its location. If you want an unloaded image to 
print, reload it before printing. You may also want to reload an image if the original 
file contains new content.

To unload and reload an image

1 Do one of the following: 

• Choose Image > Image Management.

• On the Reference toolbar, click the Image tool ( ).

• Type image and then press Enter.

2 In the Images list, select the desired image. If there is more than one occurrence of 
the image in the drawing, do one of the following:

• To unload or reload all occurrences of the image, select a top-level image in the 
list.

• To unload or reload a single occurrence of the image, expand a top-level image 
in the list, and then select the individual image.

3 Do one of the following: 

• To unload the image so only its outer edge displays, click Unload.

• To reload the image so its contents display and print, click Reload.

Changing the path for images
If the file associated with an image is renamed or moved to a different location, the 
program displays a message indicating that it cannot load the image. You can re-
establish the link to the file by changing the path for the image.
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To change the path for an image

1 Do one of the following: 

• Choose Image > Image Management.

• On the Reference toolbar, click the Image tool ( ).

• Type image and then press Enter.

2 In the Images list, select the desired image. If there is more than one occurrence of 
the image in the drawing, do one of the following:

• To change the path for all occurrences of the image, select a top-level image in 
the list.

• To change the path for a single occurrence of the image, expand a top-level 
image in the list, and then select the individual image.

3 Click the [...] button.

4 Select the file with its new name or in its new location, and then click Open.

5 Click Set Path.

Deleting images
Once an image is no longer required in the drawing, you can delete it from the draw-
ing. Deleting an image removes it from the drawing, and from the list of images in the 
Image Manager dialog box.

To delete an image

1 Do one of the following: 

• Choose Image > Image Management.

• On the Reference toolbar, click the Image tool ( ).

• Type image and then press Enter.

2 In the Images list, select the image you want to delete. If there is more than one 
occurrence of the image in the drawing, do one of the following:

• To delete all occurrences of the image, select a top-level image in the list.

• To delete a single occurrence of the image, expand a top-level image in the list, 
and then select the individual image.

3 Click Detach. 

Draw Order command

The draw order commands allow you to arrange the images and entities in your draw-
ing. When multiple entities overlap, you can change the order in which they are dis-
played and printed. You can move entities to the front, back, or on top or below of 
another entity.



578   C H A P T E R  1 9

To reorder entities

1 Do one of the following:

• Choose Image > Draw Order.

• Type draworder and then press Enter.

2 Select the entity you want to reorder, and then press Enter.

3 In the prompt box, specify the new drawing order, and then press Enter:

• Front, brings the selected image(s) to the front of the display. On the Draw 
Order toolbar, the Bring to Front tool ( ) .

• Back, sends the selected image(s) behind all other drawing elements. On the 
Draw Order toolbar, the Send to Back tool ( ) .

• Upper, select the object respect which it must be put as first.

• Down, select the object respect which it must be put as second.

Correlate Command
Create Correlation command applies a linear correlation to align a raster image to a 
vectorial drawing or another image, setting insert point, scale and rotation.

To adapt an image to a drawing pick two source points and two destination points; 
these are used as reference points to stretch the image corresponding to the drawing.

The next sample show as you can create a correlation between a vectorial drawing, a 
building plant and a raster image a map that shown the building context.
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To Create a Correlation

1 Do one of the following: 

• Choose Image  >  Image Correlate.

• On the Reference toolbar, click the Image Correlate tool ( ).

• Type imatch and then press Enter.

2 Select the raster image that you want to use for the corresponding.

3 Specify the reference points marked as 1 and 2 on the raster image.

4 Specify the source points marked as 1 and 2 on the vectorial image.
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Customizing AViCAD

You can customize AViCAD® in a number of ways. For example, you can change 
the appearance of many aspects of the program and modify the existing menus and 
toolbars or create new ones. This chapter explains how to: 

• Set the program’s preferences.

• Customize menus and toolbars.

• Customize the keyboard.

• Create aliases for frequently used commands.

• Customize entities.

• Create and use scripts.

• Use add-on programs with AViCAD.

• Use a digitizer tablet for menu selection and calibrated drawing.

Topics in this chapter

Setting and changing options............................................................................584

Customizing menus...........................................................................................602

Customizing toolbars.........................................................................................608

Customizing the keyboard.................................................................................618

Creating aliases ................................................................................................621

Customizing entities ..........................................................................................624

Creating and replaying scripts...........................................................................628

Programming AViCAD.......................................................................................630

Using a digitizer tablet .......................................................................................634
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Setting and changing options

You can change many of the options that control the program’s behavior and appear-
ance, such as setting the experience level, specifying file paths and default files, and 
configuring display features.

Changing the options on the General tab
In the Options dialog box, the General tab contains settings for experience level and 
save options. You can also set VBA security.

Setting the experience level You can control which menus and tools are available 
by setting the experience level. You can choose from the following experience levels: 

• Beginner Menus and toolbars display only basic commands. 

• Intermediate Menus and toolbars display most two-dimensional entity creation 
and modification commands.

• Advanced Menus and toolbars display all available commands. 

Saving your drawings automatically To avoid losing data in the event of a power 
failure or other system error, save your drawing files often. You can configure the 
program to periodically save your drawings automatically. The Minutes setting deter-
mines the interval between automatic saves. The program restarts this interval timer 
whenever you save the drawing file.        

When AutoSave is enabled, the program creates a copy of your drawing. The file is 
saved in the folder specified in Options > Paths/Files for Temporary Files, with the 
file extension specified in the AutoSave Drawing Extension box (by default, .SV$).

Setting the default Save As format You can control the default file format that you 
want to display in the Save Drawing As dialog box. For example, if you use the Save 
As command to save most of your drawings in a legacy file format, you can select 
that file format as the default so you don’t have to select it each time you save a draw-
ing using the Save As command.This setting has no effect on saving existing or new 
drawings using commands other than Save As — AViCAD always saves existing 
drawings in their current file format and saves new drawings with the most current 
file format.   

Setting how drawings are opened If you regularly open drawings that contain errors 
or damaged data, for example, if you are a new AViCAD user and your original 
drawings were created using different CAD software, you can enable Open Drawings 
using Recover. This option automatically checks all drawings for errors when using 
the Open command, and attempts recovery, as needed. Viewing warning messages 
when opening drawings allows you to know which files are being fixed by AViCAD
and what errors have occurred; however, you can also choose to hide the warnings.
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Disabling VBA CommonProject macros Each time you start AViCAD, macros are 
automatically loaded for the Visual Basic Application (VBA) CommonProject. If you 
do not plan to use VBA, disabling the macros may improve performance. In addition, 
disabling the macros can enhance security if you are running AViCAD at a low secu-
rity level.

To change the options on the General tab 

1 Do one of the following: 

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the General tab.

3 Under Experience level, select Beginner, Intermediate, or Advanced.

4 Under AutoSave, select the check box to enable the AutoSave feature, and select 
the frequency.

5 If you want to change the default extension assigned to your AutoSave files, type 
the new extension in AutoSave Drawing Extension.

6 Under Save As, select the default drawing format that displays when using the 
Save As command. You can always specify a different format in the Save Draw-
ing As dialog box.

7 If you want to use the Recover command automatically each time you use the 
Open command, mark the check box for Open Drawings using Recover. 

8 If you want to hide warnings when errors are found in a drawing, mark the check 
box for Hide Warnings when Opening Drawings using Recover. Errors will still 
be logged in an ASCII file with an .adt extension.

9 If you do not want the CommonProject macros to be loaded when you start 
AViCAD, under VBA Security, click the check box for Disable VBA Common-
Project Macros On Startup.

10 If you don't want to see the Start Wizard when you create a new drawing, deselect 
the Enable New Drawing Wizard check box.

11 If you don't want use the PPan acceleration, to improve the Pan command perfor-
mance, deselect the Enable PPan Acceleration check box.

12 To disable the automatic redraw after the command's execution, deselect the 
Enable AutoRedraw after command.

13 If you don't want the context menu when you have selected an entity, deselect 
Enable context menu on right click when the entity is selected.

14 If you don't want the context menu when no one entity is selected, deselect Enable 
context menu on right click with no entity selected.
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NOTE:  If you only want to repeat the last command with the right mouse button you 
must disable the options of the context menu

15 If you don't want to drag faster the entities, deselect Enable quick dragging of enti-
ties.

16 If you don't want the simplification of the text, an option that improves the perfor-
mance of the program by seeing only the outline of.

17 If you want see the text with the operation of the Zoom and Pan, deselect the box 
Semplify the text during the realtime operation.

18 If you don't want the simplification of hatching during the Pan and Zoom, an 
option that improves the performance of the program.

19 If you want see the hatching while using these commands, deselect Hide hatch 
during the realtime operation.

20 When you have finished, click OK.
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A Click to enable AutoSave feature. 

B Select the default file format  that displays when 
saving drawings using the Save As dialog box.

C Click to disable VBA CommonProject macros on 
startup. (Available if supported by your version of 
AViCAD.)

D Select to check all drawings for errors when 
using the Open command, and attempt recovery, 
as needed.

E Select to hide warning messages when opening 
drawings, if the check box Open Drawings using 
Recover is marked.

F Select to check New Drawing Wizard.

G Select to check PPan Accelleration.

H Select to check AutoRedraw after commands.

I Type the file extension for AutoSaved files.

J Enter frequency of AutoSave in minutes.

K Select the experience level.

L Select to enable Content menu on right click.

M Select to enable the context menu if no entities 
are selected.

N Select to enable the quick dragging.

O Select to enable the semplification of the text 
during the realtime commands.

P Select to hide the hatching during the realtime 
commands.

Q Select to enable VBA Events.
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Changing the options on the Paths/Files tab 

You can specify locations for various file types such as those used for drawings, 
fonts, and menus in the Options dialog box on the Paths/Files tab. You can even 
specify multiple paths for the same file type. In addition, you can change the names 
of the default system files that are used for functions such as font mapping and error 
logging.

Specifying the user paths 
You can enter paths to your AViCAD directories by typing them into a Location field 
in the Options dialog box. This feature includes directories for drawings, fonts, help, 
external references, menus, hatch patterns, blocks, print style tables, print output files, 
temporary files, templates and color books. AViCAD searches directories for support 
files in the following order:

• The AViCAD program directory.

• The current drawing directory.

• The Windows search path.

• The search path specified in the Options dialog box. 

You can enter multiple paths for each item. If, for example, the Drawings item has 
more than one directory associated with it, you can specify multiple paths by separat-
ing them with a semicolon. AViCAD searches the directories in the order in which 
they are listed.

To specify a user path

1 Do one of the following: 

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Paths/Files tab.

3 Under Location, click the item in the User Paths list whose path you want to spec-
ify, and type the path.

If you do not know the path or directory name, click Browse, and then browse to 
the location of the directory you want.

4 When you have finished, click OK.

Changing the default system files 
You can change the default system files, including the log file, default template, alter-
nate font, and font mapping file.

To change a default system file

1 Do one of the following: 

• Choose Tools > Options.

• Type config and then press Enter.
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2 Click the Paths/Files tab.

3 In the lower half of the dialog box, under File, click the file name for the default 
system file you want to change, and type in a new file name. 

If you don’t know the file name, click Browse, and then browse to the location of 
the file you want.

4 Type a new name.

5 When you have finished, click OK.

The following figure shows the Options dialog box with the User Paths and Sys-
tem Files sections identified.    

Changing the options on the Display tab
In the Options dialog box, the Display tab contains settings for displaying the 
command bar, AViCAD window, menus, and real-time view rotation.

Setting the command lines to track AViCAD tracks the commands and command 
prompts you used most recently. You can control the number of lines that the pro-
gram keeps in memory as you work. The default value is 256. You can display the 
commands in the Prompt History window. To display the Prompt History window, 
press F2. To close the window, press F2 again. 

A Click to select new default file.

B Select the default file to change.

C Click to select new default folder.

D Directory path specified by user.

A

B

C

D
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Displaying tabs and scroll bars Hiding window elements if you do not use them 
can help increase drawing space in the AViCAD window.

To show or hide the Model tab and Layout tabs, select the Show Tabs check box. You 
may want to hide the tabs if you only work on the Model tab or if you use the com-
mand bar and status bar to switch between tabs.

To show or hide the scroll bars that display on the right side and bottom of the 
AViCAD window or viewport, select the Show Scroll Bars check box. You may want 
to hide the scroll bars if you only use the Pan command to scroll drawings.

Enabling continuous view rotation  When you use the Real-Time Sphere command 
to rotate your view of entities, you typically move the mouse to rotate the view. If you 
want the rotation to continue after you release the mouse, turn on the Continuous 
Inertial Motion in Real Time check box. The rotation also continues when you use the 
Real-Time X, Real-Time Y, and Real-Time Z commands.

Changing the zoom direction of the mouse wheel By default when working in a 
drawing and using the mouse wheel, you spin the mouse wheel forward to zoom in 
and spin it backward to zoom out. If you want to reverse the zoom direction relative 
to the zoom wheel, that is, spin the wheel forward to zoom out and spin it backward 
to zoom in, enable the Reverse Mouse Wheel Zoom Direction check box. This can be 
especially helpful if you use the mouse with your left hand.

Setting the graphics screen color By default, drawings are displayed on a black 
background. You can change this color and specify the background screen color that 
you want. 

Displaying prompt boxes When a command offers several options, a prompt box is 
displayed with those options. If you prefer to select options by typing, you can turn 
off the prompt boxes by clearing the Display Prompt Boxes check box. 

Setting automatic menu loading The first time you start AViCAD, a default menu 
is loaded, and the Automatic Menu Loading check box in the Options dialog box is 
checked. The Automatic Menu Loading feature allows you to load drawings with 
associated menus without overwriting the default menu. You can turn off the Auto-
matic Menu Loading option.

Selection Area Effect When you create a selection window, by default, you are able to 
recognize it being identified with two colors: green and blue. In this part of the dialog 
box you are able to modify these colors, set their opacity or disable them.

Selection Preview When a command is active and you place the mouse cursor over an 
entity, this is highlighted. It is possible to set the selection options in a way that the 
elements are highlighted when there is not an active command or you can completely 
disable this functionality. With this last option selected the elements will not be high-
lighted.

Selection Preview Filtering When you activate any of the Preview Filtering options 
you can define which elements not to highlight, it is possible to chose among locked 
layers, external references (Xrefs), multiline text and hatches.
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To change the options on the Display tab

1 Do one of the following: 

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Display tab.

3 Select the options you want.

4 When you have finished, click OK. 

A Type or select the maximum number of 
command lines to track.

B Click to show or hide the Model and Layout 
tabs.

C Click to show or hide scroll bars.

D Click to select paper color.

E Click to show or hide prompt boxes.

F Click to toggle automatic menu loading on or off.

G  Click to select screen color

H Select to zoom out when spinning the mouse 
wheel forward and zoom in when spinning the 
mouse wheel backward.

I Select to continue rotating the view when using 
the Real-Time Sphere, Real-Time X, Real-Time 
Y, and Real-Time Z commands. 

J Select how the area that you select will appear

K Choose to see the selection preview when you 
pass the cursor over the objects if a command is 
active or not. You can also decide what objects 
not to see in the preview (xrefs, multiline text, 
hatch, ecc…) 

A
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D
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Changing the options on the Crosshairs tab
In the Options dialog box, on the Crosshairs tab, you can control how the crosshairs 
display. To help you differentiate the x-, y-, and z-axes, a different color is assigned 
to each. You can change the default axes colors to any color you want. In addition, 
you can specify the size of the crosshairs display, enable grips attraction for the cur-
sor, and you can elect to use crosshairs as the default pointer shape.   

To change the options on the Crosshairs tab

1 Do one of the following: 

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Crosshairs tab.

3 Select the options you want.

4 When you have finished, click OK

A For each axis, click Color and select an axis 
color from the palette.

B Select to always display the pointer as the 
crosshairs (instead of the small box).

C Select to move the crosshairs automatically to 
grips within a certain range. 

D Enter or scroll to a number for the grips attraction 
range. Higher points increase the range of the 
attraction.

E Enter or scroll to a number for the percentage of 
the screen to be used by the crosshairs cursor.

A

B

C D

E
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Changing the options on the Profiles tab
AViCAD allows you to customize the settings that control your drawing environ-
ment, and then save and restore those settings in a profile. For example, if you prefer 
working with custom menus and toolbars, you can save these settings as your own 
profile. 

Profiles can be helpful if you have multiple users with different preferences, or if you 
are a single user who works on various projects that require unique settings. You can 
even export your profile and bring it with you when you work on a different com-
puter. 

Understanding the settings saved in profiles
Profiles save many settings that control the drawing environment. Once you start 
using a profile, it automatically tracks and stores changes that you make to your 
drawing environment.

Some settings are saved immediately, but some require that you exit AViCAD and 
then start AViCAD again. This is because profiles save settings from your com-
puter’s registry and some settings are only saved to the registry when you exit 
AViCAD.  

Creating profiles
Create profiles if you want to save your custom drawing environment settings. This 
can be helpful if you have two or more drawing environments that you use regularly.

When you create a new profile, the current drawing environment settings are auto-
matically saved with the new profile.

Settings saved in profiles

Setting Location When saved

Toolbar settings Tools > Customize, Toolbars tab Exit and restart of AViCAD

Menu settings Tools > Customize, Menus tab Immediately

Keyboard settings Tools > Customize, Keyboard tab Immediately

Alias settings Tools > Customize, Aliases tab Immediately

Window elements on/off 
status and their various 
settings

View > Display > Command Bar
Tools > Options, Display tab
View > Display > Text Window
View > Display > Scroll Bars
View > Display > Status Bar

Exit and restart of AViCAD

Tablet configurations Tools > Tablet Immediately

User paths Tools > Options, Paths/Files tab Immediately

System variables Typed in command bar Varies — some saved immediately 
and some upon exit and restart of 
AViCAD
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To create a profile

1 Do one of the following:

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Profiles tab.

3 Click Create.

4 Enter a name, a description (optional), and then click OK.

5 In the Options dialog box, click OK.

6 Make changes to your drawing environment.

AViCAD automatically saves the settings to the new profile. 

NOTE In some cases, for example, with toolbars, you need to exit and restart 
AViCAD before the settings are saved with the profile. This is because profiles save 
settings from your computer’s registry and some settings are only saved to the regis-
try when you exit AViCAD. 
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Loading a profile
While you work in AViCAD, you can load the custom settings of any profile. The 
current profile when you exit AViCAD is automatically loaded when you start 
AViCAD again.

A Displays the name of the currently loaded profile.

B Select a profile to load it or modify it.

C Displays a description of the profile.

D Click to restore the selected profile to the system 
default settings.

E Click to open a profile stored in an .arg file.

F Click to save the selected profile in an .arg file.

G Click to delete the selected profile.

H Click to rename the selected profile.

I Click to make a copy of the selected profile.

J Click to load the selected profile and make it the 
active profile.

K Click to create a new profile.

A
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To load a profile

1 Do one of the following:

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Profiles tab.

3 Select the desired profile.

4 Click Set Current.

Restoring the default settings
At any time you can return to the default drawing environment settings that were 
installed with AViCAD. 

If the Default profile is unchanged, simply load it to restore the default settings. If the 
Default profile is deleted or changed, reset an existing profile (one that you no longer 
need) to replace its contents with the default settings.

To restore default settings using an unchanged Default profile

1 Do one of the following:

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Profiles tab.

3 Select the Default profile.

4 Click Set Current.

To restore default settings without using the Default profile

NOTE Resetting a profile erases all of the profile’s custom settings. Do this only if 
you are certain you no longer need the selected profile.

1 Do one of the following:

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Profiles tab.

3 Select a profile that you no longer need; all of it’s custom settings will be erased. 

If necessary, create or copy a profile to use for restoring the default settings.

4 Click Reset. 

Managing profiles
Once you start using profiles, you may need to rename, copy, or delete them. Copy-
ing a profile is a quick way to create a new profile based on an existing profile.
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To rename a profile

1 Do one of the following: 

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Profiles tab.

3 Select the profile you want to rename.

4 Click Rename.

5 Make any necessary changes to the name or description, and then click OK.

To copy a profile

1 Do one of the following: 

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Profiles tab.

3 Select the profile you want to copy.

4 Click Copy.

5 Enter a new name, a description (optional), and then click OK.

To delete a profile

1 Do one of the following: 

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Profiles tab.

3 Select the profile you want to delete.

4 Click Delete.

Working with profiles on multiple computers
If you use multiple computers and you like to work with our own drawing environ-
ment settings, save time by bringing your profile with you.

On your computer, export your profile to an .arg file. Bring the file with you to the 
other computer using a disk, E-mail, network, or some other method. When you start 
working at another computer, simply open and load your profile instead of recreating 
your preferred drawing environment.
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To export a profile to a file

1 Do one of the following: 

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Profiles tab.

3 Select the profile to export.

4 Click Export.

5 Specify a location and name for the exported file, and then click Save.

To open a profile from a file

1 Do one of the following: 

• Choose Tools > Options.

• Type config and then press Enter.

2 Click the Profiles tab.

3 Click Import.

4 Locate and select the profile (.arg file), and then click Open.

5 Make any necessary changes to the name or description, and then click OK.

6 (Optional) To load the imported profile, select it, and then click Set Current.

Changing the options on the Printing tab
In the Options dialog box, on the Printing tab, you can determine several printing set-
tings, including headers, footers, and print style tables.

Creating headers and footers You can include header and footer information such 
as a date and time stamp, your name and company name, or other information that 
you want to appear at the top or bottom of printed drawings. Header and footer set-
tings are set globally for all drawings.

Specifying print style settings Print styles change the appearance of your printed 
drawing without modifying the actual entities in your drawing. Use the Printing tab to 
specify initial print style settings for new drawings created without a template and for 
older drawings when opened (older drawings that were created before print styles 
were available, for example, before AutoCAD 2000). Drawings that are already open 
are not affected.

For more details about print styles and print style tables, see “Using print styles” on 
page 407. 
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To change the options on the Printing tab

1 Do one of the following: 

• Choose Tools > Options. 

• Type config and then press Enter.

2 Click the Printing tab.

3 Select the options you want.

4 When you have finished, click OK.

A Type the content for the header and footer, or 
select it from the lists.

B Select to use color-dependent or named print 
style tables for new drawings created without a 
template.

C Select a print style table to use with new 
drawings.

D For color-dependent tables, displays BYCOLOR 
(not selectable); for named tables, select the 
print style to assign to layer zero. 

E For color-dependent tables, displays BYCOLOR 
(not selectable); for named tables, select the 
print style to assign to new entities.

F Click to create or change print style tables that 
can be selected on the Printing tab or elsewhere 
in AViCAD.

A
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Changing the options on the Snapping tab
In the Options dialog box, on the Snapping tab, you can control how entity snaps 
work, including fly-over snapping. Fly-over snapping is a visual aid to help you 
see and use entity snaps more efficiently.

To change the options on the Snapping tab

1 Do one of the following: 

• Choose Tools > Options. 

• Type config and then press Enter.

• Choose Format > Entity Snap > Entity Snap Settings and click Flyover.

2 Click the Snapping tab.

3 Select the options you want.

4 When you have finished, click OK. 
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A Select to display an extra image on the cursor to 
show which entity snap is active. (Available even 
if fly-over snapping is turned off.)

B Select to turn on fly-over snapping.

C Select to turn on fly-over snap tooltips, which 
indicate the type of snap that was used to select 
the marked location.

D Select to turn on the fly-over snap aperture box. 
Entities found within the aperture box are 
available for selection, making it easier to find 
and select entity snap points.

E Type or scroll to the tolerance size for the fly-
over snap aperture box. Higher numbers 
increase the distance from the cursor in which 
entities are found.

F Type or scroll to the thickness of the fly-over 
snap marker.

G Type or scroll to the size of the fly-over snap 
marker.

H Click to choose the color of the fly-over snap 
marker.

I Select to turn on the display of fly-over snap 
markers in all views when you are using more 
than one viewport.

J Select to turn on fly-over snap markers, which 
mark snap points on entities.
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  Customizing menus

You can customize a current menu and save your changes as an AViCAD menu file. 
You can also load both existing AViCAD (*.icm) and AutoCAD (*.mnu, *.mns) 
menu files. You customize menus using the Customize dialog box.     

To display the Customize dialog box

1 Do one of the following: 

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Menus tab.  

A To make a menu item current, choose it from the 
list.

B Contains the command string assigned to the 
current menu item.

C Contains the text displayed in the status bar for 
the current menu item.

D Click to import an existing menu file from another 
source.

E Click to save the current menu to a different 
location.

F Click to display the Options dialog box for further 
customization options.

G Click to add the selected command to the current 
menu item.

H Click to rename the current menu item.

I Click to insert a Menu Item, a Menu Sub-Item, a 
Spacer, or Context Menu Item, or a Context 
Menu Sub-Item.
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Understanding menu compatibility
MNU files are menu files managed by all AutoCAD releases, and MNS files are 
included in AutoCAD Releases 13, 14, and 2000. AViCAD reads both file formats, 
even when menu macros include AutoLISP code. This feature allows you to continue 
using your existing AutoCAD menus.   

To see how AViCAD reads AutoCAD menu source files

1 Type menu and then press Enter. 

2 Under Files Of Type, select AutoCAD Menu File (mnu).

3 In the Open Menu dialog box, go to the AutoCAD Support folder and select the 
Acad.mnu file (or Acad.mns for Releases 13, 14, and 2000).

4 To load the AutoCAD menu file into AViCAD, click Open.

The AViCAD menu bar now looks identical to the AutoCAD menu bar.

5 To see how it works, choose a few commands from the menu bar, such as File > 
Open or Draw > Line.  

Creating new menus and commands
You can create a new menu by inserting a menu item at the top level of the Menu 
Tree. Then you can add commands to the new menu item. You can also add sub-
menus and modify existing menu names and commands by adding, deleting, and 
rearranging them. 

NOTE A green bullet in front of a menu item or command indicates that the menu 
item or command is available for you to use at the experience level you have set. A 
red bullet in front of a menu item or command indicates that the menu item or com-
mand is not available for you to use at the experience level you have set. To change 
your experience level, choose Tools > Options.

AViCAD support of specific sections in AutoCAD MNU and MNS files

Menu section Definition AViCAD support

***POP0 Cursor menu Supported

***POPn Pull-down menus Supported

***AUXn Auxiliary menus Not supported

***BUTTONn Button menus Not supported

***ICON Icon menus Not supported

***SCREEN Screen menus Not supported

***TABLETn Tablet menus Not supported
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To create a new menu 

1 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Menus tab.

3 In the Menu Tree, select the menu name above which you want to add a new 
menu.

4 Choose Insert > Menu Item.

5 Type a name for the new pull-down menu, and then press Enter.

6 Click Close.

To see the new menu, you must perform the following steps for adding a command to 
the menu.

To add a command to a menu 

1 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Menus tab.

3 In the Menu Tree, select the menu to which you want to add the new command.

4 Choose Insert > Menu Sub-Item.

5 Type a name for the new command, and then press Enter.

6 Assign a command string to the command you added by doing one of the 
following:

• In the Available Commands list, choose the command, and then click Add 
Command.

• In the Command box, type the command string, and then click Add Command.

7 In the Help String box, type the text to be displayed in the status bar when the cur-
sor is positioned over the new command.

8 To add another command, repeat steps 3 through 7.

9 When you have finished, click Close.

NOTE When you type a name for a new command, you can specify an access key by 
including an ampersand (&) immediately preceding the letter you want to use as the 
access key. Be sure not to assign the same access key to more than one menu or com-
mand within a menu. For example, if you add a command named Quick Line to the 
Insert menu, including an ampersand immediately preceding the letter Q causes that 
letter to appear underlined in the menu. You can then select that command by dis-
playing the menu and pressing the Q key. 
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To rename a menu item 

1 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Menus tab.

3 In the Menu Tree, select the menu item you want to rename.

4 Click Rename.

5 Type a new name for the menu item by typing over the highlighted name, and then 
press Enter.

6 Click Close.

To delete a menu item 

1 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Menus tab.

3 In the Menu Tree, select the menu item you want to delete.

4 Click Delete.

5 In the Confirmation dialog box, click Yes to delete the menu item.

6 Click Close.

NOTE Deleting a menu item that has sub-items below it in the Menu Tree also 
deletes all those sub-items.

Setting the experience levels for menus
You can set the experience levels for menu items you create, and you can change the 
experience levels for existing commands.

To set the experience levels for a command 

1 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Menus tab.

3 In the Menu Tree, select the command.

4 Click Options.

5 In the Menu Customization Options dialog box, under Experience Level, select 
the experience levels that you want for the command.

6 Click OK.
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7 Click Close.

NOTE Select all the experience levels above the lowest level you want to use. Com-
mands appear in the menu only at the experience levels you specify. If you select 
Intermediate without also selecting Advanced, the commands will appear only when 
you set the experience level to Intermediate.

Saving menu files
AViCAD automatically saves any changes you make to the current menu. You can 
also create and save your custom menus. The program automatically saves all menu 
files with the *.icm file extension. 

To save the current menu to a file

1 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Menus tab.

3 Click Export.

4 In the Select Menu File dialog box, specify the directory and file name you want 
to use to save the menu file.

5 Click Save.

6 Click Close.

NOTE Saving a menu does not save any toolbars that you created or modified.

Loading menu files
You can replace the current menu file with other custom menus. The program loads 
both AutoCAD (*.mnu, *.mns) and AViCAD (*.icm) menu files. 

To load a menu file

1 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Menus tab.

3 Click Import.

4 From the Files Of Type list, choose either *.icm, *.mnu, or *.mns.

5 Select the menu to load.

6 Click Open.

7 Click Close.
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NOTE Loading a new menu replaces only the menu. It does not replace any custom 
toolbars you may have defined.

Creating custom shortcut menus
With AViCAD, you can create a custom shortcut menu for commands you want to 
use frequently. You access the shortcut menu by holding down the Shift key and 
clicking the right mouse button or by clicking the mouse wheel (if you have one). 
Using any ASCII text editor, you construct the menu to conform to the Custom short-
cut menu syntax and definitions as shown here:

***MENUGROUP=group_name 
***POP0 
**menu_name 
[menu_name] 
ID_item_name [item_string]command

***HELPSTRINGS 
ID_item_name[help_string]

To create a custom shortcut menu 

The following example describes how to build a custom menu that includes line, 
hatch, dtext, circle, and erase commands.

1 Open any ASCII text editor.

2 Type the following characters exactly as shown here:

***MENUGROUP=example 
***POP0 
**AViCAD 
[AViCAD] 
ID_Line [Line]^C^C_line 
ID_Hatch [Hatch]^C^C_hatch 

Shortcut menu syntax and explanations

Item Explanation

group_name Menu group name.

menu_name Shortcut menu name.

item_name Menu item name.

item_string Menu item string (typically, the command name). The menu item string 
appears in the shortcut menu. To specify an access key for a command, insert 
an ampersand (&) immediately before the letter you want to use as the access 
key. Do not assign the same access key to more than one command.

command Command string. Begin the command string with "^C^C" (e.g., ̂ C^C_LINE) 
unless the command is transparent.

help_string Help string. The text in the help string appears in the status bar when you 
place the cursor over the menu item.
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ID_Dtext [Dtext]^C^C_dtext 
ID_0 [Circle Rad]^C^C_circle 
ID_Erase [erase]^C^C_erase

***HELPSTRINGS 
ID_LINE [Draws a line] 
ID_HATCH [Fills an enclosed area with a nonassociative hatch pattern] 
ID_DTEXT [Displays text on screen as it is entered] 
ID_CIRCLE [Creates a circle] 
ID_ERASE [Removes objects from a drawing]

3 Save the file as example.mnu to the AViCAD folder.

To use the custom shortcut menu

1 Open AViCAD.

2 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and press Enter.

3 Click the Menus tab.

4 Click Import.

5 Select the custom shortcut menu file.

6 Select the Append To Current Menu check box, and then click Open. 

If you don’t select this box, the custom shortcut menu deletes all current menus.

7 Click Close.

8 Select an entity in your drawing, and then hold down Shift and click the right 
mouse button.

9 Click the shortcut command that you want.

Customizing toolbars

AViCAD provides toolbars so that you can access frequently used commands. You 
can customize these toolbars by adding or removing tools or by rearranging the orga-
nization of tools. You can also create custom toolbars. Toolbars are saved as integral 
parts of the program. Although you cannot export custom toolbars for use by others, 
you can load toolbars created as part of AutoCAD menus. You customize toolbars 
using the Customize dialog box and clicking the Toolbars tab.  
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To display the Customize dialog box

1 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and then press Enter. 

2 Click the Toolbars tab.

3 Customize the toolbars using the procedures that follow the illustration here. 

Creating a new toolbar
You can create a new toolbar by dragging a tool from the Customize dialog box and 
dropping it anywhere except on another toolbar. AViCAD immediately creates a new 
toolbar and assigns it a default name. Then you can add tools to the new toolbar. You 
can also add, delete, or modify tools on any existing toolbar. 

When you create a toolbar using tools from the Buttons area of the Customize dialog 
box, the ToolTip, Help String, and Command fields are filled in automatically with 
default information. You can edit this information for each tool. 

A  The Categories list shows available toolbar 
categories.

B Contains the string displayed as a ToolTip for the 
current tool.

C Contains the text displayed in the status bar for 
the current tool.

D Contains the command string assigned to the 
current tool.

E  Displays the available tools for the selected 
category.

A

B

C
D

E
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To create a new toolbar

1 Do one of the following: 

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Toolbars tab.

3 In the Categories list, choose a category to display its associated tools.

4 Click and drag a tool outside the Customize dialog box and onto an open area of 
the screen.

5 Modify the ToolTip, Help String, and Command fields as needed.

6 Click Close.

To add a tool to a toolbar 

1 Make sure the toolbar you want to modify is visible.

2 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

3 Click the Toolbars tab.

4 In the Categories list, choose a category to display its associated tools.

5 Click and drag a tool onto the toolbar.

6 Modify the ToolTip, Help String, and Command fields as needed.

7 To add another tool, repeat steps 3 through 5.

8 Click Close.

To delete a tool from a toolbar

Make sure the toolbar you want to modify is visible.

1 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Toolbars tab.

3 Drag the tool you want to delete off of the toolbar.

4 Click Close.
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To add space between tools on a toolbar 

Make sure the toolbar you want to modify is visible.

1 Do one of the following: 

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Toolbars tab.

3 On the toolbar, drag the tool away from the tool beside it.

To avoid accidentally deleting a tool, do not drag a tool more than halfway past 
the edge of the toolbar.

4 Click Close.

Naming toolbars
When you create a toolbar, the program assigns it an arbitrary name, such as 
ToolBar1, ToolBar2, and so on. The toolbar name is displayed on the title bar when 
the toolbar is floating. You can rename a toolbar at any time.

In the Select Toolbars dialog box, you can rename toolbars, turn the display of tool-
bars on and off, choose to display large or small tools, choose to display toolbar tools 
in color or black and white, and control the display of ToolTips. 

To rename a toolbar 

1 Do one of the following:

• Choose Tools > Customize > Toolbar.

• Type tbconfig and then press Enter.

2 From the Toolbars list, choose the toolbar that you want to rename. 

3 In the Toolbar Name field, replace the current name with the new toolbar name.

4 Click OK.



612   C H A P T E R  2 0

  

Creating flyouts
A flyout displays a set of additional tools under a single toolbar tool. AViCAD uses 
flyouts to organize related tools and to conserve space on toolbars. A flyout is indi-
cated by a small triangle in the lower right corner of a tool. When you click a flyout 
tool, the other tools on the flyout extend from the original tool so you can select one 
of them. The flyout tool you select then becomes the default tool on the toolbar. You 
can add your own flyouts to toolbars. 

To add a flyout to a toolbar

1 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Toolbars tab.

3 Select the Insert As Flyout check box.

4 In the Categories list, choose a toolbar name to display its associated tools in the 
Buttons area.

5 From the Buttons area, click and drag a tool onto a toolbar outside the Customize 
dialog box.

6 Modify the ToolTip, Help String, and Command fields as needed.

7 To add another flyout tool, repeat steps 4 through 6.

8 Click Close. 

A Select to display a toolbar. 

B Choose the toolbar that you want to rename.

C Type a new name.

D Select to display large tools; clear to display 
small tools. 

E Select to display color tools; clear to display 
black and white tools.

F Select to display ToolTips; clear to not display 
ToolTips.

G Click to customize the toolbars.

A
B

C

D
E
F

G
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Setting the experience levels for tools
You can set the experience levels for toolbar tools you create, and you can change the 
experience levels for existing tools.

To set the experience levels for a tool 

1 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Toolbars tab.

3 Go outside the Customize dialog box to a toolbar, and click a tool to select it.

4 Go back to the Customize dialog box, and click Options.

5 Under User Level, select the experience levels you want for that tool.

6 Click OK.

7 Click Close.

NOTE Select all the experience levels above the lowest level you want to use. Tools 
appear in toolbars only at the experience levels you specify. If you select Intermediate 
without also selecting Advanced, the tool will appear only when you set the 
experience level to Intermediate.

Creating custom toolbar tools
AViCAD provides tools for most of the available AViCAD commands. These tools 
appear on the Toolbars tab of the Customize dialog box. You can also create your 
own custom tools and incorporate them into your custom toolbars. To add a custom 
tool to a toolbar, you must first add one of the program’s standard tools and then 
replace it on the toolbar with your custom tool. 

You create custom tools as bitmap (*.bmp) files using any paint or illustration pro-
gram capable of saving to a bitmap. Because you can configure toolbars to display 
either large or small tools and to display tools either in color or monochrome, create 
four different versions of each custom tool. Create custom tools using the following 
dimensions: 

• Small tools: 16 x 15 pixels. 

• Large tools: 24 x 22 pixels. 

NOTE If you attempt to use bitmaps that do not match these dimensions, the pro-
gram will stretch or shrink (rather than crop) the bitmaps to fit the specified size. The 
resulting tools may not appear as originally intended.
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To add a custom tool to a toolbar

Make sure the toolbar you want to modify is visible.

1 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Toolbars tab.

3 Go outside the Customize dialog box to a toolbar, and click a tool in the toolbar to 
select it.

4 Go back to the Customize dialog box, and click Options.

5 In the Toolbar Customization Options dialog box, under Button Bitmaps, click the 
browse tool (indicated by an ellipsis) adjacent to the Small, Color Button list to 
display the Select Bitmap dialog box.

6 Select the bitmap you want to use for the small color tool.

7 Click Open.

8 Repeat steps 5 through 7 for the Large Color Button, Small Black and White But-
ton, and Large Black and White Button versions of your custom tool.

9 When you have finished, click OK.

10 Click Close.
 

The Toolbar Customization Options dialog box.
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Importing toolbars
Toolbars are saved as integral parts of AViCAD. In AViCAD, you can load toolbars 
created as part of AutoCAD (*.mnu, *.mns) menus. Importing an AutoCAD menu 
file from the Toolbars tab of the Customize dialog box loads only the toolbar section 
of the menu file. 

To import a menu file

1 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Toolbars tab.

3 Click Import.

4 Select the menu you want to load.

5 Click Open.

6 Click Close.

NOTE Importing an AutoCAD menu file from the Toolbars tab of the Customize dia-
log box replaces any custom toolbars you may have defined. Importing the menu file 
in this way, however, does not affect the current menu.

Creating toolbars that you can share as files
With AViCAD, you can manually create toolbars that you can share as files with 
other AViCAD users. You create the toolbar files using any ASCII text editor and the 
toolbar syntax and definitions shown here:

***MENUGROUP=group_name 
 
***TOOLBARS 
**toolbar_name 
ID_toolbar_name [_Toolbar ("toolbar_name", orient, visible, xval, yval, 

rows)] 
ID_button_name [_Button ("button_name", id_small, id_large)]command 
 
***HELPSTRINGS 
ID_button_name [help_string]

Toolbar syntax and explanations

Item Explanation

group_name Menu group name.

toolbar_name Toolbar name.

orient Orientation. Select Floating, Top, Bottom, Left, and Right (not case 
sensitive).

visible Visibility. Select Show or Hide (not case sensitive).
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To create a toolbar that you can share

1 Open any ASCII text editor.

2 Type the following characters exactly as shown here:

***MENUGROUP=example 
 
***TOOLBARS 
**NewDraw 
ID_ NewDraw [_Toolbar("NewDraw ", _Bottom, _Show, 200, 200, 1)] 
ID_Line_0 [_Button("Line", Iline.bmp, IL_line.bmp)]^C^C_line 
ID_Hatch [_Button("Hatch", Ihatch.bmp, IL_hatch.bmp)]^C^C_hatch 
ID_Dtext [_Button("Dtext", Idtext.bmp, IL_dtext.bmp)]^C^C_dtext 
ID__0 [_Button("Circle Rad", Icirad.bmp, IL_cirad.bmp)]^C^Ccircle; 
ID_Erase [_Button("Erase", Ierase.bmp, IL_erase.bmp)]^C^Cerase; 
 
***HELPSTRINGS 
ID_Line_0 [Creates straight line segments] 
ID_Hatch [Fills an enclosed area with a nonassociative hatch pattern] 
ID_Dtext [Displays text on screen as it is entered] 
ID__0 [Allows user to draw a circle with a radius value] 
ID_Erase [Removes objects from a drawing]

3 Save the file to the AViCAD folder with a *.mnu extension.

xval x coordinate, designated in pixels from left edge of screen. Suggested 
value: 200.

yval y coordinate, designated in pixels from top edge of screen. Suggested 
value: 200.

rows Number of rows

button_name Tool name. Appears as a ToolTip when user places cursor over button.

id_small Name of small (16 x 15 pixels) icon bitmap (BMP) file. This file must be 
located in the AViCAD folder.

id_large Name of large (24 x 22 pixels) icon bitmap (BMP) file. This file must be 
located in the AViCAD folder.

command Command string (Example: ^C^C_LINE).

help_string Help string. Appears in the status bar when cursor passes over the button.

Toolbar syntax and explanations

Item Explanation
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To copy an existing toolbar

Make sure the toolbar you want to copy is visible.

1 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and press Enter.

2 Click the Toolbars tab.

3 Go outside the Customize dialog box and select a tool on the existing toolbar that 
you want to copy. 

4 Copy the information from the ToolTip, Help String, and Command boxes and 
paste it into the corresponding lines in the text file. 

5 Save the file to the AViCAD folder with a *.mnu extension.

To open the toolbar file on another computer

1 Copy the toolbar (MNU) file and all related custom bitmap (*.bmp) files to the 
AViCAD folder on the other computer.

2 Open AViCAD.

3 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and press Enter.

4 Click the Toolbars tab.

5 Click Import.

6 Select the new toolbar file.

7 Select the Append To Current Menu check box, and then click Open.

If you don’t select this box, the custom shortcut menu deletes all current menus. 

8 Click Close. 
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Customizing the keyboard

AViCAD provides keyboard shortcuts so you can access frequently used commands. 
You can customize these shortcuts and add new shortcuts using the Customize dialog 
box. 

To customize the keyboard

1 Do one of the following: 

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Keyboard tab.

3 To define a new shortcut key, enter the shortcut in the Press New Shortcut Key 
box.

4 To define a new command string, enter the command string in the Command box.

5 To import an existing keyboard shortcut file, click Import.

6 To save a keyboard shortcut to a file, click Export.

7 To add a command selected in the Available Commands pane to the shortcuts, 
click Add Command.

8 To insert a new keyboard shortcut, click New. 

A Shows shortcuts already defined.

B Displays the shortcut key combination when 
adding a new shortcut.

C Contains the command string assigned to the 
shortcut.

A

B

C
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Creating a keyboard shortcut
You can assign macros to special keys and certain combinations of keys to create a 
keyboard shortcut. A macro consists of one or more commands that are displayed on 
the status bar as follows: 

• A single command, such as QSAVE.

• A command with options, such as ARC;\A;\\.

• More than one command, such as ^C^C^CZOOM;E;QSAVE;QPRINT.

Keyboard shortcuts are more powerful than aliases. An alias lets you abbreviate a sin-
gle command name; a keyboard shortcut contains one or more macros. To activate a 
macro, you press the shortcut key; you do not need to press Enter as you do with an 
alias. A shortcut consists of the following keys: the function and the cursor control 
keys, as well as alphanumeric keys pressed in combination with the Ctrl, Alt, and 
Shift keys. The Shift key must be used in conjunction with the Ctrl, Alt, and/or func-
tion keys. 

• Alphanumeric keys are those labeled A through Z and 1 though 0. 

• The cursor keys are the up, down, left, and right arrows and the Page Up, Page 
Down, Home, End, Insert, and Delete keys. 

• The function keys are those labeled F1 through F12.

To create a keyboard shortcut 

1 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Keyboard tab.

3 Click New.

4 In the Press New Shortcut Key field, press Alt+A.

The program adds Alt+A to its list of Defined Keys.

5 In the Available Commands list, select Arc Center-Start-Angle.

6 Click Add Command.

The program adds the command to the Command field and enters the complete 
syntax for you:

^C^C^_CARC;C;\ \A; 

7 To save your changes and close the dialog box, click Close. 

8 To activate the Arc command with the center, start, and angle options, press 
Alt+A.
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To redefine an existing keyboard shortcut

1 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Keyboard tab.

3 In the Defined Keys list, select the shortcut you want to change.

4 In the Command field, change the command string assigned to the keyboard short-
cut by doing one of the following:

• Use the text cursor to delete the current command string, choose a new 
command in the Available Commands list, and then click Add Command.

• Edit the command string in the Command field.

5 Click Close.

To delete an existing keyboard shortcut 

1 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Keyboard tab.

3 In the Defined Keys list, select the shortcut you want to delete.

4 Click Delete.

5 Click Close.

Saving keyboard shortcut files
AViCAD automatically saves any changes you make to the current keyboard short-
cuts. You can also create and save your own keyboard shortcut files. The program 
saves keyboard shortcut files with the *.ick file extension. 

To save the current keyboard shortcuts to a file

1 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Keyboard tab.

3 Click Export.

4 Specify the directory and file name you want to use to save the keyboard shortcut 
file.

5 Click Save.

6 Click Close.



C U S T O M I Z I N G  A V I C A D    621

Loading keyboard shortcut files
You can replace the current keyboard shortcut file with other custom keyboard short-
cut files.

To load a keyboard shortcut file

1 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Keyboard tab.

3 Click Import.

4 Select the file to load.

5 Click Open.

6 Click Close.

Creating aliases

AViCAD provides aliases for many commands. You can use aliases to issue fre-
quently used commands by entering one or two letters rather than the entire command 
name. 

The program also uses aliases to maintain command-name compatibility with 
AutoCAD. You can use the same aliases and keyboard shortcuts used by AutoCAD. 
In addition, AViCAD has enhanced several AutoCAD commands. For example, 
AViCAD added two useful options to the rectangle command: you can draw a 
rectangle as a square, and you can rotate a rectangle at an angle.

You can customize aliases, and you can add new aliases. You customize aliases using 
the Customize dialog box.

To display the Customize dialog box

1 Do one of the following: 

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Aliases tab.
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Creating, redefining, and deleting aliases
To create a new command alias, you first define the alias and then assign it one of the 
available AViCAD commands. 

To create a new alias 

1 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Aliases tab.

3 Click New.

4 In the Alias field, type the new alias.

5 In the Available Commands list, select the command you want to assign to the 
alias.

6 Click Assign.

7 Click Close.

A Shows aliases already defined.

B Contains the current alias.

C Displays the command assigned to the current 
alias. 

A

B C



C U S T O M I Z I N G  A V I C A D    623

To redefine an existing alias 

1 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Aliases tab.

3 In the Aliases list, select the alias you want to change.

4 In the Available Commands list, select the command you want to assign to the 
alias.

5 Click Assign.

6 Click Close.

To delete an existing alias 

1 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Aliases tab.

3 In the Aliases list, select the alias you want to delete.

4 Click Delete.

5 Click Close.

Saving alias files
AViCAD automatically saves any changes you make to the current aliases. You can 
also create and save your own alias files. The program saves alias files with the *.ica 
file extension. You can also save alias files for use with AutoCAD by saving the files 
with the *.pgp file extension. 

To save the current aliases to a file

1 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Aliases tab.

3 Click Export.

4 From the Save As Type list, choose either *.ica or *.pgp.

5 Specify the directory and file name you want to use to save the alias file.

6 Click Save.

7 Click Close.
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Loading alias files
You can replace the current alias file with other custom alias files. The program loads 
both AutoCAD (*.pgp) and AViCAD (*.ica) alias files.

To load an alias file

1 Do one of the following:

• Choose Tools > Customize > Menu.

• Type customize and then press Enter.

2 Click the Aliases tab.

3 Click Import.

4 From the Files Of Type list, choose either *.ica or *.pgp.

5 Select the alias file to load.

6 Click Open.

7 Click Close.

Customizing entities

AViCAD provides ways to customize entities beyond common formats, dimensions, 
and layers. Further customization includes using custom audio notes and using cus-
tom shape files.

Working with audio notes
In AViCAD you can record and attach audio notes, which are sound clips attached to 
entities and available for playback at any time. For example, audio notes in a factory 
floor plan can describe maintenance activities for specific areas of the factory and 
employees can play the audio notes to hear instructions.

When you include audio notes in your drawing, they are saved in the drawing file — 
not in a separate audio file. Note that this can increase the file size of your drawing. 
Audio notes created from an existing *.wav file are also saved in the drawing file and 
the separate *.wav file remains unchanged. 

NOTE You can play audio notes in AViCAD only. 
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Attaching audio notes
Audio notes can be created from existing *.wav files. You can also record an audio 
note using any microphone that works with your computer. Many computers have a 
built-in microphone. If you do not have a microphone and you record an audio note, 
the audio note will contain no sound.

An audio note icon displays on entities that have attached audio notes. The icon is for 
display only and cannot be selected.

To record and attach an audio note to entities

1 Do one of the following:    

• Choose Tools > Audio Note.

• Type audionote and then press Enter.

2 Select the desired entities, and then press Enter.

3 Choose Record.

4 Click Record to begin the audio note, and then speak into the microphone.

5 Click Stop to end the audio note.

6 To test the audio note, click Test, and then use Pause and Stop in the Test Audio 
Note area.

7 If necessary, you can record the audio note again. This overwrites the previous 
audio note for the entities you selected in Step 2.

8 Click Attach.

TIP To modify an audio note after you attach it to an entity, select the entity and re-
record the audio note using the previous steps.

To attach an audio note to entities using a .wav file

1 Do one of the following: 

• Choose Tools > Audio Note.

• Type audionote and then press Enter.

2 Select the desired entities, and then press Enter.

3 Choose Attach.

4 Select the desired *.wav file, and then click Open.

Selecting audio notes
Audio notes themselves cannot be selected. Instead, you select the entity that corre-
sponds to the desired audio note.

An audio note icon displays on entities that have attached audio notes. The icon is for 
display only and cannot be selected.
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To select audio notes

1 Do one of the following: 

• Choose Tools > Audio Note.

• Type audionote and then press Enter.

2 Select the entity that is attached to the desired audio note, and then press Enter.

You cannot select the audio note icon that displays on the entity.

3 Choose an option to continue working with audio notes.

TIP You can change the appearance of audio note icons using the AUDIOICON, 
AUDIOICONCOLOR, and AUDIOICONSCALE system variables.

Playing audio notes

To play audio notes

1 Do one of the following:

• Choose Tools > Audio Note.

• Type audionote and then press Enter.

2 Select the entity that has the audio note you want to play, and then press Enter.

3 Choose Playback.

4 In the Playback dialog box, do the following:

• Click Play to begin playback.

• To pause the audio note temporarily, click Pause and then click Resume to 
continue.

• Click Stop to end playback.

5 Click OK.

An audio note icon displays on an entity, signifying that an audio note 
is attached to the entity.
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Deleting audio notes
You can remove audio notes from selected entities. In some cases, you may want to 
remove extra audio notes to reduce the drawing file size. 

NOTE When you remove an audio note from an entity, the audio note is removed 
permanently and cannot be recovered. However, if the audio note was created using 
an existing *.wav file, that *.wav file is not removed.

To delete audio notes

1 Do one of the following: 

• Choose Tools > Audio Note.

• Type audionote and then press Enter.

2 Select entities that have the audio notes you want to delete, and then press Enter. 

3 Choose Delete.

 Using shape files
Shapes are objects that you define for use as drawing symbols and text fonts. You can 
specify the scale and rotation to use for each shape as you add it. 

To use shape files, you first load the compiled shape file that defines the shape. Then 
you use insert shapes from the file into your drawing. 

To load a shape file

1 Type load and then press Enter.

2 In the Load Shape File dialog box, select a shape file.

3 Click OK to close the Load Shape File dialog box.

To use a shape file

1 Type shape and then press Enter.

2 Choose the Shape-Object or press ? to list the available Shape-Objects.

3 Specify an insertion point.

4 Specify a height.

5 Specify a rotation angle.
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Creating and replaying scripts

AViCAD can record anything you type on the keyboard and any points you select in 
a drawing. You can save all of these actions to a script file (with the *.scr extension) 
and then repeat them by replaying the script. You can use scripts for successively 
repeating commands, showing snapshots in a slide show, or batch plotting. You can 
also load and run script files created for use with AutoCAD. 

AViCAD supports most AutoCAD customization files, including menus, script files, 
and LISP routines. AViCAD uses compatible linetypes, hatch patterns, units transla-
tion, and command aliases, but you can also substitute your own files for these. This 
feature allows you to continue to work with your favorite customized drafting envi-
ronment. 

A script is a form of text file. A script file contains one line of text or other data for 
each action. For example, when you type a command and press Enter, it is recorded 
on a line in the script file. When you select a point in a drawing, the coordinate of that 
point is recorded on a line in the script file. You can also create script files outside 
AViCAD using a text editor (such as Microsoft Notepad or Microsoft WordPad) or a 
word-processing program (such as Microsoft Word) that saves the file in ASCII for-
mat. The file type must be .scr.

Script files can contain comments. Any line that begins with a semicolon is consid-
ered a comment. The program ignores these lines when replaying the script. The 
Undo feature reverses the last command performed by the script. 

AViCAD improves on scripts, AutoLISP, and ADS by providing additional func-
tions. For scripts, AViCAD includes a Script Recorder that records both command 
line entries and screen picks you make with your mouse. 

After you activate the Script Recorder, every keyboard entry you make and any 
points you select in a drawing are recorded until you stop the Script Recorder. You 
can play back your script at any time.

CAUTION The Script Recorder does not record your use of toolbars, menus, or dia-
log boxes. Using these elements while recording a script causes unpredictable 
results.
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To record a script 

1 Do one of the following:

• Choose Tools > Record Script.

• Type recscript and then press Enter.

2 Specify the name of the script file you want to create.

3 Click Save.

4 Type commands on the keyboard.

The Script Recorder records all keyboard entries and all points you select in the 
drawing, saving everything to the script file.

To stop recording 

1 Type stopscript and then press Enter.

To replay a script

1 Do one of the following:

• Choose Tools > Run Script.

• Type script and then press Enter.

2 In the Run Script dialog box, specify the name of the script file you want to run.

3 Click Open.

The program immediately runs the script, performing all the actions originally 
recorded.

To append to a script 

1 Do one of the following:

• Choose Tools > Record Script.

• Type recscript and then press Enter.

2 In the Record Script dialog box, select the Append To Script check box.

3 Select the existing script file to append.

4 Click Save.

5 Click Yes to the prompt asking whether you want to replace the existing script.

6 Repeat the procedure to enter additional commands and steps.

NOTE To invoke a script automatically when you load AViCAD, in Windows 
Explorer, double-click a script file. 
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Programming AViCAD

Another way you can customize AViCAD is to add custom programs written in any 
of several programming languages that run within AViCAD, including the following:

• LISP

• Visual Basic for Applications (VBA)

• ADS

• DIESEL

In AViCAD, you can run many programs originally created for use with AutoCAD. 
Specifically, you can use programs written entirely in AutoLISP with no modifica-
tion. In addition, you can run many ADS programs originally written for use with 
AutoCAD after first recompiling them using the AViCAD run-time libraries. Many 
AutoCAD third-party programs are compatible with AViCAD. 

NOTE Creating custom programs for use with AViCAD is beyond the scope of this 
manual. For information about programming for AViCAD, see the online Help for 
the AViCAD Developer’s Reference.

Using LISP routines 
AViCAD supports the LISP programming language and is compatible with 
AutoLISP, the implementation of the LISP language in AutoCAD. This means that 
you can load and run any AutoLISP program written for use with AutoCAD.

To load a LISP routine 

Advanced experience level

1 Do one of the following:

• Choose Tools > Load LISP or SDS Application.

• Type appload and then press Enter.

• Drag and drop the LISP file into AViCAD.

2 In the Load Application Files dialog box, click Add File.

3 Select the LISP file that you want to load, and then click Open.

4 Click OK.    
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NOTE You can also load a LISP routine by typing (load “d:/path/routine.lsp”) in the 
command bar (you must include the parentheses and the quotation marks), where d:/
path is the drive and path where the LISP routine is located on your computer, and 
routine.lsp is the LISP routine file name. 

To run a LISP routine 

Advanced experience level

1 Do one of the following:

• Choose Tools > Load LISP or SDS Application.

• Type appload and then press Enter.

2 In the Load Application Files dialog box, choose the routine you want to run 
(make sure that it is the only one selected), and then click Load.

Some LISP routines are created in such a way that you can run them by simply typing 
the name of the routine, or by typing a keyword, directly in the command bar. If noth-
ing happens when you attempt to run the LISP routine from within the Load Applica-
tion Files dialog box, turn on the display of the command bar or Prompt History 
window by choosing View > Command Bar or View > Prompt History Window, and 
look for an entry that is similar to the following: 

Loading D:\path\routine.lsp

C:KEYWORD

A Lists the names of LISP and SDS files already 
loaded. 

B Click to add a LISP or SDS file.

C Click to remove the highlighted file.

D Click to load the highlighted file.

E Click to unload the highlighted file.

F Select to save the current list to the icadload.dfs 
file when you click Load, Unload, or OK. 

A

B

C D

E

F
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where D:\path\routine.lsp is the complete drive, path, and file name of the LISP rou-
tine. You may need to scroll back several lines in the command bar or Prompt History 
window to find the lines indicating where the LISP routine was loaded. You can run 
the LISP routine by typing the name of the routine or keyword appearing after the C 
drive designation. 

For example, if you loaded a LISP routine named drawbox.lsp and see the designa-
tion C:DRAWBOX in the command bar or Prompt History window, you can run the 
LISP routine by typing drawbox in the command bar.    

Using ADS applications 
To write AutoCAD applications in C or C++, Autodesk uses the ADS (AutoCAD 
Development System). This is an API (applications programming interface) that pro-
vides a library to access AutoCAD-specific functions and drawing data. 

The equivalent in AViCAD is called SDS™, the Solutions Development System™. 
SDS is a C/C++ language interface compatible with the ADS interface in AutoCAD. 
Like scripts and AutoLISP, you can run your existing ADS applications in AViCAD. 
Simply recompile the source code using the SDS libraries provided on the AViCAD
CD-ROM, or, if you use an AutoCAD program written by a third-party vendor, 
contact that vendor for the AViCAD version.

AViCAD provides the Sds.H file, which redefines ADS function names to their SDS 
equivalents. SDS supports the AutoCAD dialog control language (DCL), which is 
used by ADS to define the look of a dialog box. You can use all DCL files unmodi-
fied within SDS. 

Understanding ADS compatibility
The primary difference between ADS and SDS is that all SDS functions have an sds_ 
prefix, and ADS functions have a variety of prefixes, such as ads_, acad_, and acrx_. 
The exception is dialog-related SDS functions, which have a dlg_ prefix. AViCAD
accepts either prefix. Other differences include the additional SDS functions listed in 
the following table. 

SDS functions with no ADS equivalent

SDS function name Description

sds_grclear Clears all graphics from the drawing window; similar to the LISP 
(grclear) function.

sds_name_clear Clears the entity name or selection set.

sds_name_equal Verifies whether two entity names or selection sets are equal.

sds_name_nil Verifies whether the entity name or selection set has been 
cleared. 

sds_name_set Copies one entity name or selection set to another drawing.

sds_pmtssget Similar to the ads_ssget function, but allows you to display a 
prompt appropriate for the specific command, rather than the 
generic “Select object” prompt.
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Some ADS functions are not supported in SDS, including: ads__msize, ads_ssgetx, 
a d s _ s s n a m e x ,  a d s _ t a b l e t ,  a d s _ s s G e t K w o r d C a l l b a c k P t r ,  
ads_ssGetOtherCallbackPtr, and adsw_acadDocWnd. 

For more information

• Read the online documentation for SDS functions. 

• See the \AViCAD ...\Api\Sds folder, which contains the SDS include, header, and 
library files.

• See the \AViCAD ...\Api\Dcl folder, which contains the core DCL files.

Using DCL with AViCAD
AViCAD completely supports the AutoCAD DCL (dialog control language). DCL is 
used by AutoLISP functions to define the look of dialog boxes. You can use all DCL 
files unmodified within AViCAD.

Using VBA
AViCAD can be customized using Visual Basic for Applications (VBA) through an 
integrated interface, available from the AViCAD menu. AViCAD features a broad 
range of objects, giving you the power to write your own custom applications that can 
run within AViCAD. 

To run a VBA macro        

Advanced experience level

1 Do one of the following:

• Choose Tools > Macro > Macros.

• Type vbarun and then press Enter.

2 In the Run AViCAD VBA Macro dialog box, enter the name of an existing VBA 
macro, and then click Run.

You can also create, delete, and edit VBA macros from this dialog box.

sds_point_set Copies a point from one variable to another.

sds_progresspercent Displays the percentage done in a progress bar.

sds_progressstart Starts the progress bar.

sds_progressstop Ends the progress bar.

sds_readaliasfile Loads the PGP file into AViCAD.

sds_sendmessage Sends a message to the AViCAD command line.

sds_swapscreen Flips the off-screen device context to the display.

SDS functions with no ADS equivalent

SDS function name Description
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To edit a VBA macro      

Advanced experience level

1 Do one of the following:

• Choose Tools > Macro > Visual Basic Editor.

• Type vba and then press Enter.

2 Use the Microsoft Visual Basic Editor to write or debug VBA macros.

For more information

• Read the online documentation for VBA, available both from the VBA Editor 
Help and from the AViCAD Help. 

• Many publications are available that explain how to program in Visual Basic and 
how to use VBA.

Using DIESEL with IntelliCAD
IntelliCAD supports AutoCAD DIESEL (Direct Interactively Evaluated String

Expression Language). DIESEL is a separate interpretive programming language that

allows you to customize the following:

• Status bar

• Menus

• LISP functions

For more information

• Read the online documentation for DIESEL, available from the IntelliCAD Help.

• Several publications and tutorials are available online that explain how to use

DIESEL.

Using a digitizer tablet

AViCAD supports tablets compatible with the TabletWorks driver and has its own 
tablet overlay. For instructions on installing the tablet driver and using the buttons on 
your pointing device, refer to your hardware documentation. 

Three options are available with the Tablet command: 

• Configure Maps the tablet overlay to the tablet itself. Configure the tablet if you 
plan to select AViCAD tools from the tablet overlay.
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• Calibrate Maps points on the tablet, in absolute coordinates, to points on a draw-
ing. Calibrate the tablet if you intend to digitize points. This process is convenient 
for tracing paper drawings.

• Tablet ON/OFF Turns tablet calibration (digitizer mode) on and off. Use this to 
switch between tool selection and digitizer input. To use the tablet for tool selec-
tion, tablet mode must be turned off. 

Configuring the tablet
Before you begin to configure the tablet, slip the tablet overlay underneath the tab-
let’s plastic cover, and align it in accordance with the directions for your tablet. If 
your tablet does not have a plastic cover, align the overlay holes with the pegs on 
your tablet. 

AViCAD provides a default configuration for tablets measuring 12" by 12". If you 
choose to accept the default, be sure to verify that the commands in the grid are acti-
vated correctly. If the default alignment does not work for your tablet, you’ll need to 
begin the configuration process again and align the tablet yourself.

To configure the tablet for menu input

1 Do one of the following:

• Choose Tools > Tablet > Configure.

• Type tablet, choose Configure, and then press Enter.

2 In response to the prompt to align the tablet, do one of the following:

• If your tablet is 12" by 12", choose No to accept the default alignment and 
conclude the configuration process. 

• To align the tablet yourself, choose Yes, and then continue with step 3.

3 Click the tablet pointer on the upper left alignment point of the overlay ( ). 

4 Click the tablet pointer on the lower left alignment point of the overlay ( ).

5 Click the tablet pointer on the lower right alignment point of the overlay ( ).

6 Click the tablet pointer on the lower left alignment point of the Workspace area of 
the overlay ( ).

7 Click the tablet pointer on the upper right alignment of the Workspace area of the 
overlay ( ).
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To turn tablet mode on or off

1 Do one of the following:

• Choose Tools > Tablet > Tablet On (or Tablet Off).

• Type tablet, choose On or Off, and then press Enter.

• Press the F4 key to toggle tablet mode on or off.

• On the status bar, double-click TABLET to turn tablet mode on or off. 

Calibrating the tablet
You must specify at least two points for tablet calibration. However, the more points 
you specify, the more accurate the transformation between the tablet and the screen 
points. Specifying additional points is particularly useful if you plan to trace a paper 
drawing that is not orthogonal, such as an aerial photograph. 

Understanding transformation types
Depending on the number of points specified, you have a choice of transformation 
types to use, along with the type recommended for AViCAD. 

Transformation refers to the calculation of the points on the screen that correspond to 
points you digitize on the tablet.

• Orthogonal Preserves all angles between lines, preserves all relative distances, 
and, in general, preserves shapes. If you specify only two points, an orthogonal 
transformation is automatically generated. The orthogonal transformation type 
yields the most precise mapping between the digitized points on the tablet and the 
corresponding points on the screen.

Click points in the order shown to configure your tablet for menu input.

5

1

2

4

3
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• Affine Preserves parallel lines, but not necessarily the angles between intersect-
ing lines. If you specified three points, AViCAD can no longer represent this map-
ping as an exact orthogonal transformation. Therefore, you have a choice of an 
exact affine transformation or a “best fit” orthogonal transformation.

• Projective Does not preserve parallel lines or angles. If you specify exactly four 
points, you have a choice of an exact projective transformation or a “best fit” 
orthogonal or affine transformation. 

Choose the recommended type unless you know it will not be appropriate for what 
you are digitizing. The most appropriate type is not always the one with the least 
error; for example, you might digitize three points and select the orthogonal transfor-
mation, even though the affine transformation would yield a closer representation of 
your calibration entries.    

Recommended and “best fit” transformation types

Number of points specified
Transformation type 
recommended “Best fit” (approximate)

2 Orthogonal None

3 Affine Orthogonal

4 Projective Orthogonal, Affine

5-10 None Orthogonal, Affine

Digitizing by selecting points (1, 2, 3, and 4) on the tablet. Corresponding screen coordinates:

1 Coordinate specification X0, Y0, Z0

2 Coordinate specification X0, Y5, Z0

3 Coordinate specification X5, Y5, Z0

4 Coordinate specification X5, Y0, Z0

2

1 4

3

3

4

2

1
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To calibrate your tablet for digitizing points

1 Do one of the following:

• Choose Tools > Tablet > Calibrate.

• Type tablet, choose Calibrate, and then press Enter.

2 Click a point on the tablet to define as the first calibration point.

3 Specify a point within the AViCAD drawing window to correspond to the point 
you digitized on the tablet, or enter coordinate values in the command bar. 

4 Click a point on the tablet to define as the second calibration point.

Specify a point within the AViCAD drawing window to correspond to the point 
you digitized on the tablet, or enter coordinate values in the command bar. To 
specify more than the two points required, click a point on the tablet to define as 
the third calibration point. You can enter up to 10 points.

5 Choose the transformation type, and then press Enter.

Customizing the tablet interface
You can customize the digitizer tablet interface by using the LISP commands 
integrated with AViCAD, even if you are not familiar with LISP. For instructions, see 
“Customizing the Tablet Interface” in the AViCAD online Help.

Screen result of orthogonal transformation after 
tracing polyline on tablet.

Screen result of affine transformation  
after tracing polyline on tablet.

Screen result of projective transformation after 
tracing polyline on tablet.
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Understanding AutoCAD compatibility

AViCAD® was designed to interface with AutoCAD as seamlessly as possible. 
There are, however, some differences for which those accustomed to working in 
AutoCAD may need to adjust. This appendix provides information specifically for 
that audience. 
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Using enhanced AutoCAD commands in AViCAD

AViCAD enhances several AutoCAD commands by providing more options. For 
example, if you hold down the Shift key, AViCAD is placed temporarily in 
orthogonal mode, which you will find to be a useful feature for drawing at right 
angles. The following table lists examples of other commands with enhanced options.    

Enhanced AViCAD commands

Command
Enhanced  
option name Explanation

circle Arc Converts an arc to a circle.

donut 2point Determines the outside diameter of a donut by 
two pick points.

donut 3point Determines the outside diameter of a donut by 
three pick points.

donut RadTanTan Determines the outside diameter of a donut by 
tangent points.

line Angle Types an angle, followed by a length.

line Length Types a length, followed by an angle.

msnapshot (mslide) and 
vsnapshot (vslide) 

EMF Saves and views screen images in enhanced 
metafile format.

msnapshot (mslide) and 
vsnapshot (vslide)

WMF Saves and views screen images in Windows 
metafile format.

parallel (offset) Both sides Copies an entity parallel on both sides.

parallel (offset) Wrap Follows a complex polyline path.

plane (solid) Rectangle Draws a rectangular solid at any angle.

plane (solid) Square Draws a square solid at any angle.

plane (solid) Triangle Draws an equilateral solid at any angle.

rectangle Square Draws a square rectangle.

rectangle Rotated Draws a rotated rectangle.
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Using additional selection sets

AViCAD has additional selection-set options not found in AutoCAD. In particular, in 
the circle selection set, the Crossing Circle (CC), Outside Circle (OC), and Window 
Circle (WC) options select all entities relative to the same distance (radius) of a 
central pick point.

The following table lists and describes the additional selection sets in AViCAD.    

Using additional AViCAD commands 

Although you can use the AutoCAD command structure with AViCAD, the program 
has its own set of commands. AViCAD has numerous command names not found in 
AutoCAD, although many of these commands have an equivalent function in 
AutoCAD. When you type the AutoCAD equivalent, the AViCAD alias system 
activates the correct command. 

The following table lists optional AViCAD command names that you can use in 
place of AutoCAD command names to perform the equivalent AutoCAD function.    

Additional selection set options

Selection mode Description

CC Crossing Circle: Selects all entities within and crossing a circular area.

D Selection method: Displays the Drawing Settings dialog box.

O Outside Window: Selects all entities outside a rectangular area; this is the 
inverse of the Crossing Circle option.

OC Outside Circle: Selects all entities outside a circular area.

OP Outside Polygon: Selects all entities outside a polygonal area; this is the 
inverse of the CP (Crossing Polygon) and WP (Window Polygon) options. 

PRO Properties: Selects all entities with specific properties, such as area, color, 
and layer.

WC Window Circle: Selects all entities within a circular area.

Command differences in AViCAD

AViCAD command AutoCAD 2008 command AutoCAD 2000/R14 command Action in AViCAD

audionote No equivalent No equivalent Creates and plays audio notes attached to 
entities.

cmdbar No equivalent No equivalent Positions the command window.

coordinate Ctrl+D or F6 Ctrl+D or F6 Changes the display of coordinates on the 
status line.

copyedata No equivalent No equivalent Copies extended entity data from one 
entity to another.
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customize toolbar toolbar Displays the Customize dialog box.

deledata No equivalent No equivalent Deletes extended entity data from an 
entity.

delete erase erase Removes entities from the drawing.

dimension dim dim Switches to dimension mode.

editedata No equivalent No equivalent Edits extended entity data found in an 
entity.

editlen lengthen lengthen Changes the length of open entities.

editpline pedit pedit Edits polylines and polymeshes.

entprop ddmodify and ddchprop ddmodify and ddchprop Displays the Entity Properties dialog box.

esnap -osnap -osnap Sets entity snaps from the command line.

expblocks ddinsert ddinsert Displays the AViCAD Explorer - Blocks.

expdimstyles ddim ddim Displays the AViCAD Explorer - 
Dimension Styles.

expfonts style ddstyle Displays the AViCAD Explorer - Styles.

explayers layer layer Displays the AViCAD Explorer - Layers.

expltypes linetype linetype Displays the AViCAD Explorer - Linetypes.

expucs dducs dducs Displays the AViCAD Explorer - UCS.

expviews ddview ddview Displays the AViCAD Explorer - Views.

face 3dface 3dface Draws three-dimensional faces with three 
or four vertices.

flatten No equivalent No equivalent Sets thickness to zero at user-specified 
elevation.

font -style -style Displays the Text Style dialog box.

freehand sketch sketch Allows freehand sketching.

infline xline xline Draws a line of infinite length.

mesh 3dmesh 3dmesh Draws a surface mesh.

moveedata No equivalent No equivalent Moves extended entity data from one 
entity to another.

msnapshot mslide mslide Makes an SLD, EMF, or WMF file of the 
current view.

orthogonal ortho ortho Toggles orthogonal mode.

parallel offset offset Copies an entity by a parallel offset 
distance.

plane solid solid Draws a two-dimensional solid plane.

pmthist F2 F2 Switches between the Prompt History 
window and the graphics screen.

polyline pline pline Draws a polyline.

Command differences in AViCAD

AViCAD command AutoCAD 2008 command AutoCAD 2000/R14 command Action in AViCAD
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ppreview preview preview Previews the plot.

print plot plot Prints the drawing.

printstyle plotstyle printstyle (not applicable before 
AutoCAD 2000)

Assign a print style.

psetup No equivalent No equivalent Displays the Print Setup dialog box.

qprint No equivalent No equivalent Quickly prints the current viewport 
(window) with no options.

reassocapp No equivalent No equivalent Reassociates extended entity data with an 
application.

recscript No equivalent No equivalent Starts the Script Recorder.

rtrot 3dorbit No equivalent Rotates the view of entities.

rtrotx No equivalent No equivalent Rotates the view of entities while 
maintaining the x-axis.

rtroty No equivalent No equivalent Rotates the view of entities while 
maintaining the y-axis.

rtrotz No equivalent No equivalent Rotates the view of entities while 
maintaining the z-axis.

saveall No equivalent No equivalent Saves all currently open drawings.

setcolor ddcolor ddcolor Displays the Color dialog box.

setdim ddim ddim Displays the Dimension Settings dialog 
box.

setesnap osnap osnap Displays the Drawing Settings dialog box 
with the Coordinate Input tab displayed.

setlayer ai_molc ai_molc Sets the current layer based on the 
selected entity’s layer.

settings No equivalent No equivalent Displays the Drawing Settings dialog box.

setucs dducs dducs Displays the User Coordinate Systems 
dialog box.

setvpoint No equivalent No equivalent Displays the Preset Viewpoints dialog box.

stopscript No equivalent No equivalent Stops running the script.

tipofday No equivalent No equivalent Displays the Tip of the Day.

undelete oops oops Restores the last deleted entity.

vba vbaide vbaide Opens the Microsoft Visual Basic 
Applications editor.

vbarun vbarun vbarun Runs a VBA application.

Command differences in AViCAD

AViCAD command AutoCAD 2008 command AutoCAD 2000/R14 command Action in AViCAD
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Recognizing subtle command differences

The commands listed in the following table function slightly differently in AViCAD 
than in AutoCAD.    

Identifying what does not display

When a drawing containing AutoCAD entities that will not display it is loaded into 
AViCAD, the program displays the following message: “This drawing contains one 
or more entities that will not display. These entities WILL be stored and saved back 
into the drawing.” 

The following table identifies which AutoCAD objects are not displayed in 
AViCAD. 

viewctl ddvpoint ddvpoint Sets the three-dimensional viewing 
direction via an interactive dialog box.

viewpoint vpoint vpoint Sets the three-dimensional viewing 
direction via the command line.

vsnapshot vslide vslide Displays an SLD, EMF, or WMF file in the 
current viewport.

Command differences in AViCAD

AViCAD command AutoCAD 2008 command AutoCAD 2000/R14 command Action in AViCAD

Command function differences

AViCAD 
command

AutoCAD 
command Function in AViCAD

cal cal Displays the Windows calculator.

pan -pan Performs a vector pan instead of a real-time pan.

zoom -zoom Performs a stepped zoom instead of a real-time zoom.

AutoCAD objects not displayed in AViCAD

AutoCAD object Description

Arc aligned text Text that is aligned along the curve of an arc.

Camera Point at which a camera is inserted into a drawing.

Light Point at which a light is inserted into a drawing.

Read text Dynamically linked text that displays in a drawing but resides in an 
external file.

Tables Tables display as anonymous blocks but cannot be edited.
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Moreover you can choose:

•   View the proxy entities without editing them

•   Convert them in blocks

•   Convert only the proxy entities text

Supporting AutoCAD customization

The following table lists and describes the ways AViCAD supports the AutoCAD 
customization files.  

AViCAD support of AutoCAD customization files

File extension Description

LIN Supported: Linetypes and complex linetypes with text and shapes. 

MNU and MNS Supported: Toolbar and menu macros. 
Supported: ***POP0, ***POPn, and ***TOOLBAR sections. 
Not supported: ***TABLET, ***BUTTONS, ***SCREEN, ***AUX, and ***ICON 
sections.

MIN Not supported: The multiline definition file is used by the AutoCAD mline 
command.

PAT Supported: Hatch patterns.

PGP Supported: Command aliases. 
Not supported: External commands.

PSF Not supported: PostScript fill pattern file is used by the AutoCAD psfill 
command.
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Understanding menu compatibility

MNU files are menu files created by all AutoCAD releases, and MNS files are 
included in AutoCAD Releases 13, 14, and 2000. AViCAD reads both file formats, 
even when menu macros include AutoLISP code. This feature allows you to continue 
using your existing AutoCAD menus. 

SHP and SHX Supported: Text fonts and shapes.

SLD Supported: Slide files.

UNT Supported: Unit translation file used by the LISP (cvunit) and SDS sds_cvunit 
functions to translate values from one unit of measurement to another.

AViCAD support of AutoCAD customization files

File extension Description

AViCAD support of specific sections in AutoCAD MNU and MNS files

Menu section Definition AViCAD support

***POP0 Cursor menu Supported

***POPn Pull-down menus Supported

***AUXn Auxiliary menus Not supported

***BUTTONn Button menus Not supported

***ICON Icon menus Not supported

***SCREEN Screen menus Not supported

***TABLETn Tablet menus Not supported
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Importing and exporting customization files

You can continue using aliases and menu files from AutoCAD by importing the 
appropriate file. You can import AutoCAD customization files and export AViCAD 
formats using the Customize dialog box. All of the files listed in the following table 
are in ASCII format, which means you can view and edit them with a text editor, such 
as Notepad. 

NOTE You can manually add toolbar customizations to a MNU file, see Chapter 20, 
“Customizing toolbars.” for more information.

Programming AViCAD

AViCAD supports more AutoCAD application programming interfaces (APIs) than 
any other software, but not all of the AutoCAD APIs are available in AViCAD. The 
following table summarizes the AutoCAD APIs AViCAD supports.  

Customizing files

Customization Import file formats Export file formats

Aliases PGP: AutoCAD aliases 
ICA: AViCAD aliases

PGP: AutoCAD aliases

Keyboard ICK: AViCAD keyboard ICK: AViCAD keyboard

Menus MNU: All AutoCAD menus 
MNS: AutoCAD R13, R14 and 2000 
menus 
ICM: AViCAD menu

ICM: AViCAD menu

Toolbars MNU: All AutoCAD menus None

AViCAD support of the AutoCAD programming interface

AutoCAD programming interface AViCAD support

Scripts (SCR files) Supported

AutoLISP (LSP files) Supported

Dialog Control Language (DCL files) Supported

AutoCAD Development System (ADS) Supported; source code must be 
recompiled

Visual Basic Applications (VBA) Supported, depending on your version 
of AViCAD

Direct Interactively Evaluated String Expression 
Language (Diesel)

Supported
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Understanding AutoLISP compatibility 
AViCAD adds LISP functionality that you will find useful. The following table lists 
functions that are unique to AViCAD LISP.  

Not all AViCAD LISP functions are completely compatible with AutoLISP 
functions. The following table identifies AViCAD LISP functions that are partially 
compatible with AutoLISP functions.

AutoCAD SQL Interface (ASI) Not supported

Autodesk Threaded Language Application System Toolkit 
(Atlast)

Not needed

AutoCAD Runtime Extension (ARx) Not supported

Additional AViCAD LISP functions

Unique LISP function Definition

(log10) Returns log base 10.

(lpad) Pads a text string with spaces to the left.

(rpad) Pads a text string with spaces to the right.

(tan) Returns the tangent.

(trim) Trims spaces from a string.

Partially compatible LISP functions

LISP function Description

(menucmd) Supports P0 (cursor menu) and P1 through P16 (the pull-down 
menus) and M (diesel expressions), but does not support A (aux 
menus), B (button menus), I (icon menus), M (diesel expressions), S 
(screen menu), or T (tablet menus).

(osnap) Supports an additional entity snap, pla, for planview (two-dimensional 
intersection).

(print1) Does not support Unicode characters, such as \U+00B0 (the degree 
symbol) and M+Nxxxx (multibyte Unicode sequences).

(ssget) and (ssadd) Supports additional selection modes: 
CC = Crossing Circle 
O = Outside 
OC = Outside Circle 
OP = Outside Polygon 
PO = POint

AViCAD support of the AutoCAD programming interface

AutoCAD programming interface AViCAD support
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AViCAD-AutoCAD list of terms

List of terms

AViCAD term Meaning for AutoCAD users

command bar command prompt area

edit length lengthen

entity object

entity snap object snap

entity snap precision aperture

fixed attribute constant attribute

follow continue

freehand sketch

hidden attribute invisible attribute

infinite line XLine

insert draw

orthogonal ortho

parallel offset

plane solid (2D)

predefined attribute preset attribute

print plot

print style plot style

prompt box context menu

Prompt History window text screen

reference grid grid

point snap node snap

snapshot slide (SLD)

validate attribute verify attribute
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Glossary

2D  Two-dimensional locations defined by x- and y-coordinates.

3D  Three-dimensional locations defined by x-, y-, and z-coordinates.

3D DWF  Acronym for Three-Dimensional Design Web Format, which is a type of 
file that can be viewed in three dimensions using a Web browser, if Autodesk® DWF 
Viewer is also installed on the computer.

3D solids  Three-dimensional ACIS entity.

absolute coordinates  Coordinates defined in relation to the origin point of the current 
user coordinate system. See also coordinate system, coordinates, origin, relative 
coordinates, user coordinate system, and World Coordinate System.

ActiveX  A mechanism for exchanging information between different programs 
whereby a copy of a source document is embedded or a pointer to a source document 
is linked to a target document. See also embed and link.

acute angles  Angles of fewer than 90 degrees.

alias  An abbreviation or alternative word for an AViCAD® command.

aligned dimension  A dimension aligned parallel to an entity or measuring the distance 
between two points at any angle.

angle  The difference in direction between two nonparallel linear entities, measured in 
degrees or radians.

angular dimension  A dimension measuring the angle between two lines or subtended 
by an arc.

angular unit  The unit of measurement for angles. Angular units can be measured in 
decimal degrees, degrees/minutes/seconds, grads, and radians.

annotation  Any text, dimensions, tolerances, or notes added to a drawing.

ANSI  Acronym for American National Standards Institute. In the context of text, a 
standard character set defined by ANSI used in computer-aided drafting.

arc  A segment of a circle or ellipse.

area  Measurement of a planar region or the calculated space within an entity. 

array  Multiple copies of selected entities in a circular or rectangular pattern.
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ASCII  Acronym for American Standard Code for Information Interchange, a com-
monly used system for assigning numbers to printable alphanumeric characters, 
punctuation, and symbols.

attribute  A component of a block containing specific text or numeric information. 
You can copy the information contained in an attribute from the drawing to an exter-
nal database.

attribute definition  An entity composed of a name, prompt for information, display 
characteristics, and default text that, when incorporated into a block, creates an 
attribute when the block is inserted into a drawing.

attribute name  Text that identifies an attribute within a block.

attribute text  The text containing an attribute’s information within a block.

B-spline curve  See spline. 

base point  A point on an entity that serves as its reference or insertion point. A point 
of reference when specifying relative distances.    

baseline  The line on which text characters appear to sit. The descenders of individual 
characters drop below the baseline.

baseline dimension  Multiple parallel dimensions measured from the same baseline 
origin.

bind  To convert an externally referenced drawing into a standard block definition.

blips  Temporary screen markers displayed in a drawing when you select a point. 
Also called marker blips.

block  One or more entities grouped together to create a single entity. See also nested 
block.

block definition  The name, base point, and entities grouped together when creating a 
block.

boundary polyline  A selected area bounded by a single closed entity or by multiple 
entities that intersect.

BYBLOCK  A property whereby an entity inherits the color or linetype of any block 
that contains it.

BYLAYER  A property whereby an entity inherits the color or linetype of its associated 
layer. 

CAD  Acronym for computer-aided design.

Cartesian coordinates  Coordinates defined using three perpendicular axes (x, y, and 
z) to define locations in three-dimensional space. See also cylindrical coordinates, 
polar coordinates, and spherical coordinates.

center line  A line used to indicate the center of a circle or an arc, usually consisting of 
a center mark and lines extending slightly beyond the diameter of the circle or the arc.
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center mark  A cross marking the center of a circle or an arc.

chamfer  A beveled edge between two lines.

chord  A line connecting two points on a circle or an arc.

circumference  The measurement of the distance around a circle.

closed  A condition whereby the start point and endpoint of an entity are the same.

comma-delimited  Data that is separated by a comma to represent the end of a field.

command bar  A dockable window in which you type AViCAD commands and view 
prompts and other program messages.

cone  A three-dimensional entity where a vertex exists above or below the circular 
shape and where a surface has been applied between the vertex and the circular shape.

contiguous  Connected, unbroken, or uninterrupted. Entities that share the same end-
point.

continued dimension  A dimension measured from the previous extension line of an 
existing dimension, resulting in two or more dimensions positioned end to end. 

control point  A point used to define a spline.

Coons patch  A surface interpolated among three or four boundary curves.

coordinate filter  A function that extracts individual x-, y-, and z-coordinate values 
from different points to create a new composite point.

coordinate system  A system of points that represents the drawing space in relation to 
an origin (0,0,0) and a set of axes that intersect at the origin. In two dimensions, the x- 
and y-axes represent horizontal and vertical directions, respectively. In three dimen-
sions, the z-axis represents locations above and below the two-dimensional xy plane. 
Locations in the drawing can be represented using two-dimensional and three-dimen-
sional rectangular (Cartesian) coordinates, two-dimensional polar coordinates, three-
dimensional polar (cylindrical) coordinates, and three-dimensional spherical coordi-
nates. See also polar coordinates, relative coordinates, spherical coordinates,
user coordinate system, and World Coordinate System.

coordinates  A set of values that determines a location in two-dimensional or three-
dimensional space. See also absolute coordinates, Cartesian coordinates, polar 
coordinates, relative coordinates, and spherical coordinates.

coplanar  Lying within the same plane.

crosshairs  A cursor that consists of two or three lines that intersect at the cursor loca-
tion.

crosshatch  To fill an area with a pattern of evenly spaced perpendicular lines. See 
also hatch.

crossing circle  An entity-selection method that selects entities contained within or 
crossing the boundary of a circular selection window. 
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crossing polygon  An entity-selection method that selects entities contained within or 
crossing the boundary of a polygon selection window. 

crossing window  An entity-selection method that selects entities contained within or 
crossing the boundary of a rectangular selection window. 

cube  A boxed, three-dimensional, geometric shape where length, width, and height 
are equal.

cursor  The insertion-point symbol on the screen. The appearance of the cursor 
changes based on the current task.

curve  A smooth, continuous path made up of linear and arc segments. Curve types 
include arcs, splines, circles, and ellipses. 

cylindrical coordinates  Coordinates describing a point in three-dimensional space 
based on its distance from the origin, its angle in the xy plane, and its z-coordinate 
value. See also polar coordinates and spherical coordinates.

datum-line dimensioning  See ordinate dimension.

default  An initial or predefined setting.

detach  To remove an external reference from a drawing. See also external refer-
ence.  diameter  The distance across a circle or sphere.

digitizer tablet  A hardware input device that incorporates an electronic pad and a 
hand-held pointer similar to a mouse. A digitizer tablet serves two purposes: (1) You 
can select tools from paper representations attached to the pad (called an overlay), 
providing access to all tools at once while freeing your screen space; and (2) you can 
input digital points into the computer that correspond to points on a paper drawing, 
photograph, or blueprint attached to the pad.

dimension  A measurement, as in height or width. In the context of drafting, a set of 
lines, arrowheads, and text used to indicate a measurement. 

dimension style  A named group of dimension variable settings that determines the 
appearance of the dimension. You can save multiple dimension styles for reuse.

dimension text  The measurement value. Dimension text can include prefixes, suf-
fixes, tolerances, and other annotations.

dimension text rotation  The angle in degrees between the x-axis and the dimen-sion 
text baseline.

dimension tolerance  A value specifying the allowed variation of a dimension (+ or – 
n).

dish  The lower half of a sphere. See also dome.

displacement point  The point to which a base, or reference, point will be relocated 
when moving or copying entities.

distance  The measure of space between two points.
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dock  To position a toolbar or the command bar at the edge of the drawing window, 
where it locks into place. See also float.

dome  The upper half of a sphere. See also dish.

donut  A filled circle or flat ring created as a polyline.       

drawing extents  See extents.

drawing limits  See limits.

drawing unit  The linear measurement system used in a drawing. The user determines 
what a drawing unit represents, such as one inch, one centimeter, one foot, or one 
meter.

.dwg  A standard format used by CAD programs to store drawing files.

DXF  Acronym for Drawing Exchange Format, a standard ASCII or binary file format 
for importing and exporting files between most CAD programs.

elevation  The z value measured from the xy plane. Positive values are above the xy 
plane; negative values are below the xy plane.

embed  A technique for exchanging information between different programs whereby 
a copy of the source document is stored in the target document. See also ActiveX and 
link.

EMF  Acronym for Enhanced Metafile, a file format with the type and extension of 
.emf. It is a native internal file format of Windows 95, Windows 98, and Windows 
NT. EMF supports both raster and vector information and 24-bit RGB color. Most 
Windows-based programs support this format.

endpoint  The point at which a line or curve ends.

entity  Any single basic item in a drawing. Entities include arcs, attributes, blocks, cir-
cles, dimensions, ellipses, elliptical arcs, infinite lines, lines, polylines, rays, and text.      

entity data  Any of a variety of additional information, such as text, numbers, and dis-
tances, that can be attached to drawing entities.

entity snap  A technique for accurately locating and specifying key geometric points 
on entities, such as endpoints and midpoints of lines, and center points and tangents 
of arcs and circles.

entity snap override  To disable or change an entity snap mode for a single input. See 
also entity snap and running entity snap.

Esnap  See entity snap.

explode  The conversion of a complex entity into its basic entities.

extension lines  Lines extending away from an entity being dimensioned so that you 
can place the dimension line away from the entity. Also called projection lines.

extents  The smallest rectangle that can contain all the entities in a drawing. Infinite 
lines and rays do not affect a drawing’s extents. See also limits.



656   G L O S S A R Y

external reference  A drawing that is linked to another drawing.

extrude  The process of converting a two-dimensional entity into a three-dimensional 
entity by stretching (extruding) the two-dimensional entity along a straight path. 
Changing the thickness of a two-dimensional entity effectively extrudes it along its z-
axis. See also tabulated surface.

face  A planar surface defined by three or four points.

fence  An entity-selection method that selects entities crossing a multisegmented line.

fillet  An arc that smoothly connects the end of one line to another.

float  To position a toolbar or the command bar away from the edges of the drawing 
window where it can be moved independently. See also dock.

freeze  To suppress the display of, and ignore the entities on, a specified layer when 
regenerating a drawing, thus accelerating the display of the drawing. See also thaw.

grid  An adjustable, regularly spaced pattern of dots on the screen, used as an aid in 
drawing and aligning entities. The grid is not plotted.

grip  A small square displayed at key positions on an entity when the entity is selected 
that can be used to modify the entity by clicking and dragging.

halfwidth  The distance from the center of a wide polyline to its edge.

hatch  To fill a selected area either with lines, crosshatching, or a hatch pattern. See 
also crosshatch.

hatch pattern  A pattern, often representing a material such as steel, wood, or sand, for 
filling selected areas.

hidden-line removal  A visualization technique in which all lines that are hidden 
behind other entities or surfaces from your viewpoint are clipped or removed, giving 
the image the appearance of a solid object.

horizontal dimension  A linear dimension measuring a horizontal distance.

infinite line  A line extending infinitely in both directions.  

insertion point  The point where you place an entity into a particular space. A refer-
ence point by which an entity is inserted in a drawing. 

intersection  The point where two entities meet or cross.

isometric drawing  A drawing aligned with an isometric plane.

isometric plane  One of three planes representing the left, right, or top sides of an 
implied three-dimensional, orthogonal entity. Snap and grid points are aligned with 
the plane to constrain drawings.

layer  The computer equivalent of overlays used in manual drafting. A tool by which 
drawing components can be organized into related sets, such as plumbing, framing, 
and electrical systems of a house, each being drawn on its own layer.
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leader  A line leading from a feature of a drawing to an annotation.

limits  The user-defined boundary of a drawing, defined by its lower left and upper 
right corner coordinates. See also extents.

limits tolerance  Dimension text in which the measured dimension is replaced by the 
largest and smallest dimensions allowed, with the upper limit displayed above the 
lower limit. See also tolerance and variance tolerance.

linetype  The appearance of a line, defined as a solid (continuous) line or as a pattern 
of dashes, dots, and blank spaces.

link  A technique for exchanging information between different programs whereby 
the target document maintains a pointer to the original source document. Any 
changes to the source document are reflected in all target documents containing links 
to the source. See also ActiveX and embed.

LISP  Acronym for List Processing Language, a computer language invented in the 
late 1950s by John McCarthy for use in artificial intelligence. Because it is inter-
preted rather than compiled, and is relatively straightforward, it is a convenient lan-
guage for users to write routines to extend the set of commands and functionality of 
AViCAD.

lock  Prevents unauthorized access to drawing layers.

M direction  In a polygon mesh, the direction from the first to the second row. See also
N direction.

macro  In menus and toolbars, several commands grouped together as one. Also 
Microsoft Visual Basic for Applications code.

major axis  The longest distance across an ellipse, from one end to the other. See also
minor axis.

marker blips  Temporary screen markers displayed in a drawing when you select a 
point. Also called blips.

MDI  Acronym for multiple-document interface. See multiple-document interface.

mesh  A set of connected polygon faces approximating a curved surface.

minor axis  The shortest distance across an ellipse, from one side to the other. See also
major axis.

mirror  To create a reverse-image copy of selected entities by reflecting the entities 
symmetrically about a line or plane.

model space  The primary drawing workspace in which you create entities. See also
paper space. 

multiple-document interface  The ability to view and work with different drawings 
simultaneously.

N direction  In a polygon mesh, the direction from the first to the second column. See 
also M direction.
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named view  A saved view that can be recalled at a later time by specifying its name.

nested block  A block contained as part of the definition of another block. See also
block.

nonassociative hatch  A hatch that is not associated with or linked to an entity.

oblique  Geometric lines or planes that are not parallel or perpendicular.

offset  See parallel.

OLE  Acronym for Object Linking and Embedding. See ActiveX.

ordinate dimension  A measurement of the horizontal (x-ordinate) or vertical (y-ordi-
nate) distance from an established reference base point or datum.

origin  The intersection point of the coordinate system axes. In a Cartesian coordinate 
system, the origin is the point at which the x-, y-, and z-axes intersect (the 0,0,0 coor-
dinate).

orthogonal  Having perpendicular slopes or tangents at the point of intersection.

orthogonal mode (ortho)  A drawing mode in which the entity creation is constrained 
to parallel the horizontal and vertical axes relative to the current snap angle.

orthographic projection  A drafting technique by which a three-dimensional item is 
described in two dimensions by showing it from various directions, most commonly 
front, top, and side views.

outside circle  An entity-selection method that selects entities falling completely out-
side a circular selection window. 

outside polygon  An entity-selection method that selects entities falling completely 
outside a polygon selection window. 

outside window  An entity-selection method that selects entities falling completely 
outside a rectangular selection window. 

pan  To shift the displayed view of a drawing without changing the magnification. 
See also zoom.

paper space  A two-dimensional workspace analogous to a sheet of paper, in which 
you can arrange different views of your drawing as floating model space viewports. 
See also model space.

parallel  Two or more coplanar lines that never intersect one another.

parallel dimension  See baseline dimension.

PDF  Acronym for Portable Document Format. PDF files can be viewed using 
Adobe® Acrobat Reader, which is free software that users can download; they can 
also be viewed, reviewed, and edited using Adobe® Acrobat.

perimeter  The distance around the boundary of an entity.

perpendicular  Entities at right angles to one another.
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planar  Entities whose extents are situated entirely within a plane.

plane  Two-dimensional surface.

plan view  A view of the drawing from above, looking down the z-axis perpendicular 
to the xy plane of the current UCS.

point  A location in space specified by its x-, y-, and z-coordinates. A drawing entity 
consisting of a single x,y,z-coordinate location and represented by one of several 
symbols.        

point filter  See coordinate filter.

polar array  Multiple copies of selected entities in a circular pattern.

polar coordinates  Coordinates describing a two-dimensional point on a two-dimen-
sional plane based on the point’s distance from the origin and its angle in the plane. 
See also Cartesian coordinates, coordinates, cylindrical coordinates, relative 
coordinates, and spherical coordinates.

polygon  A closed single entity with three or more sides.  

polyline  A drawing entity composed of one or more connected line or arc segments 
treated as a single entity. 

projection lines  See extension lines.

prompt box  A list of options displayed when a command or tool provides several 
choices.

Prompt History window  A window containing a history of the most recent commands 
and prompts issued since you started the current session of AViCAD.

quadrant  One-fourth of a circle, arc, or ellipse entity. In the context of entity snaps, 
the option that snaps to points on a circle, arc, or ellipse at each quadrant.

radial dimension  A dimension that measures the radius of a circle or arc.

radian  A unit of angular measurement; 360 degrees equals 6.283185 or 2pi radians.

radius  The distance from the center of a circle or sphere to its periphery.

ray  A line that starts at a designated point and runs infinitely.

ray tracing  A visualization technique in which rays from imaginary light sources are 
traced as they refract off the surfaces of a model, determining where shadows fall and 
how reflections on shiny materials such as metal and glass appear.

rectangle  A four-sided, closed entity whereby opposite sides are equal in length.

rectangular array  Multiple copies of selected entities in a rectangular pattern consist-
ing of a specified number of columns and rows.

redo  To reverse the effect of previous undo commands. See also undo.

redraw  To quickly update or refresh the drawing screen display. See also regenerate.
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regenerate  To update or refresh the drawing screen display by recalculating the draw-
ing from its database. See also redraw. 

relative coordinates  Coordinates expressed in relation to a previous coordinate. See 
also absolute coordinates. 

render  A visualization technique in which all surfaces of a model are shaded as 
though they were illuminated from an imaginary light source located behind you as 
you face the screen. Rendered images are photo-realistic, having depth, shadow, 
reflection, and texture. 

revolve  Creating a three-dimensional surface entity by rotating a two-dimensional 
profile around an axis.

right-hand rule  A visual aid for remembering the relative directions of the positive x-, 
y-, and z-axes of a Cartesian coordinate system and the positive rotation direction 
about an axis.

rotate  To change the orientation of an entity, without modifying it, by repositioning it 
equidistant from, but at a new angle with respect to, a point or axis.

rotation angle  The angle by which an entity is displaced from its original location 
when rotating it about a point or axis.

rubber-band line  A ghosted image line that stretches dynamically on the screen with 
the movement of the cursor. The line extends between a fixed point and the cursor 
position to provide dynamic feedback.

ruled surface  A three-dimensional polygon mesh that approximates a smooth surface 
between two entities.

running entity snap  Setting an entity snap so that it continues for subsequent selec-
tions. See also entity snap and entity snap override.

scale  To resize an entity. To draw according to the proportions of an entity.

script  A set of commands stored in an ASCII script file and replayed in sequence by 
running the script.

SDS  Acronym for Solutions Development System, a C programming interface for 
developing specialized programs to run inside AViCAD.

segment  Any part of an entity bounded by two points.

selection set  One or more drawing entities selected on which one can operate as a sin-
gle unit.

shade  To fill planar entities with solid colors for easier visualization.

snap angle  The angle around which the snap grid is rotated.

snap grid  An invisible grid that locks entity creation to a specified alignment and 
snap increment when Snap is enabled.

snap resolution  The spacing between points on the snap grid.
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snapshot  A raster representation of the current view of one’s drawing.

spherical coordinates  Coordinates describing a point in three-dimensional space 
based on its distance from the origin, its angle in the xy plane, and its angle up from 
the xy plane. See also Cartesian coordinates, coordinates, cylindrical coordinates, 
and polar coordinates.

spline  A curve generated along the path of three or more control points. The curve 
passes through the start point and endpoint, but does not necessarily pass through the 
intermediate control points. 

status bar  The bar at the bottom of the AViCAD window that displays information 
about the selected command or tool as well as the cursor coordinates, the name of the 
current layer, mode settings, and other information about drawing settings.

surface model  A three-dimensional model consisting of both edges and the surfaces 
between those edges. See also wire-frame model.

surface of revolution  A three-dimensional polygon mesh that approximates the sur-
face generated by rotating a two-dimensional profile around an axis.

system variable  A setting or value that stores operating environment and command 
information (such as the drawing limits or global linetype scale factor).

tabulated surface  A three-dimensional polygon mesh that approximates the surface 
generated by extruding a curve along a vector. See also extrude.

tangent  A line that passes through a single point on a curve.

template  A drawing with preset layers, linetypes, and other settings (and entities) that 
can be used as the basis for creating a new drawing.

text style  A named, saved collection of format settings that determines the appear-
ance of text.  

thaw  To redisplay a layer that was frozen. See also freeze.

thickness  An entity’s depth, as measured along its z-axis. The distance an entity is 
extruded above or below its elevation. See also elevation and extrude.

through point  In creating a parallel entity, a point through which the new entity 
passes.

tolerance  Dimension text indicating how much the actual dimension of a manufac-
tured component can vary from the specified dimension. See also limits tolerance
and variance tolerance.

tolerance command  A command that creates a feature-control frame used in mechan-
ical geometric dimensioning and tolerancing.

toolbar  A collection of tools arranged on a palette that can be moved and resized any-
where on the screen.

torus  A donut-shaped, three-dimensional entity.
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transparent command  A command started while another command is already active. 
You can use a command transparently by preceding it with an apostrophe.

true color  Colors defined using 24-bit color. There are more than 16 million true col-
ors from which you can choose.

UCS  Acronym for user coordinate system. See user coordinate system.

UCS icon  A user coordinate system icon that shows the orientation of the coordinate 
axes, the location of the coordinate system origin, and the viewing direction relative 
to the xy plane.

undo  To reverse the effect of previous commands. See also redo.

unit  See drawing unit.

unlock  Free access to layers in a drawing that would be otherwise locked, thus pro-
hibiting them from being viewed or edited by another user.

user coordinate system  A Cartesian coordinate system with origins and orientation 
defined by the user. See also World Coordinate System.

variance tolerance  Dimension text in which a plus/minus value is appended to the 
specified dimension to indicate how much the actual dimension of a manufactured 
component can vary from the specified dimension. See also limits tolerance and tol-
erance.

VBA  Acronym for Visual Basic for Applications, a macro programming language 
embedded in programs that allows the user to customize the program.

vector  A means of describing a displacement using magnitude and orientation. For 
example, you can create a line entity, or move an entity, by specifying an initial point, 
a direction, and a distance.

vertex  The point of intersection of the sides of an angle. The start points or endpoints 
of a line or arc segment in a polyline.

vertical dimension  A linear dimension measuring a vertical distance.

view  A representation of a drawing or portion of a drawing from a specific viewpoint 
in three-dimensional space.

viewpoint  A location in three-dimensional space for viewing one’s drafting.

viewport  A window that displays all or a portion of a drawing’s model space. See also
model space and paper space.             

viewport configuration  A named arrangement of windows that can be saved and 
restored.

WCS  Acronym for World Coordinate System. See World Coordinate System.

wedge  A three-dimensional entity that resembles a box divided along one side from 
one corner to the opposite corner; for example, a doorstop or a ramp.
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window circle  An entity-selection method that selects entities contained entirely 
within a circular selection window. 

window inside  An entity-selection method that selects entities contained entirely 
within a rectangular selection window. 

window polygon  An entity-selection method that selects entities contained entirely 
within a polygon selection window. 

wipeout  An entity that displays with the current background color, so the details 
behind it do not display or print.

wire-frame model  A three-dimensional model consisting of lines and curves that 
define the edges of a three-dimensional entity. See also surface model.

WMF  Acronym for Windows metafile, a format containing vector and color informa-
tion to render entities.

workspace  A space for representing and working with drawing information; types of 
workspaces are model space and paper space.

World Coordinate System  The fixed Cartesian coordinate system used as the basis for 
defining other coordinate systems. See also user coordinate system.

xref  See external reference.

zoom  To increase or decrease the magnification of the display of a drawing. See also
pan.   
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